linux-pci.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Lukas Wunner <lukas@wunner.de>
To: Bjorn Helgaas <helgaas@kernel.org>
Cc: Sinan Kaya <okaya@kernel.org>,
	linux-pci@vger.kernel.org,
	Mika Westerberg <mika.westerberg@linux.intel.com>,
	Keith Busch <keith.busch@intel.com>
Subject: Re: [PATCH 4/9] PCI: pciehp: Unify controller and slot structs
Date: Thu, 6 Sep 2018 09:38:26 +0200	[thread overview]
Message-ID: <20180906073826.43xonlbyoahji7hr@wunner.de> (raw)
In-Reply-To: <20180905223016.GA214747@bhelgaas-glaptop.roam.corp.google.com>

On Wed, Sep 05, 2018 at 05:30:16PM -0500, Bjorn Helgaas wrote:
> > > > On 8/19/2018 10:29 AM, Lukas Wunner wrote:
> > > > > Simplify the driver by merging struct slot into struct controller.
> > > > > Merge the slot constructor pcie_init_slot() and the destructor
> > > > > pcie_cleanup_slot() into the controller counterparts.
> > > > > Rename the slot struct's "lock" member to "state_lock" and rename
> > > > > "work" to "button_work" for clarity.
> 
> Could the rename be done in a separate patch before the unification?
> If so, that would be nice.

Okay, I've already reworked my internal development branch to do the
unification first, then the rename, but can easily turn the order around,
no problem at all.

The preceding patches 1 to 3 of this series could be merged independently,
or would you prefer me to resend them?  The first one is also included in
Keith's error handling rework series (posted yesterday):

[1/9] PCI: Simplify disconnected marking
      https://patchwork.ozlabs.org/patch/959373/
[2/9] PCI: pciehp: Drop unnecessary includes
      https://patchwork.ozlabs.org/patch/959376/
[3/9] [3/9] PCI: pciehp: Drop hotplug_slot_ops wrappers
      https://patchwork.ozlabs.org/patch/959377/

Important side note:  Keith's series includes a pciehp fix which should
probably go into 4.19:

[PATCHv2,15/20] PCI/pciehp: Fix powerfault detection order
https://patchwork.ozlabs.org/patch/966678/

Now, if that patch goes into, say, 4.19-rc3, the pci/hotplug branch would
have to be rebased on top of 4.19-rc3 to avoid conflicts during the 4.20
merge window.

The problem with unification of the controller and slot structs in pciehp
is that it's a fairly intrusive patch.  Any pciehp patches that are pending
now would need to be rebased on top of it.  Right now the only pending
pciehp patches are Keith's series posted yesterday and this patch from me
(which would be 4.20 material):

PCI: pciehp: Tolerate Presence Detect hardwired to zero diffmboxseries
https://patchwork.ozlabs.org/patch/961860/

I can rebase all the patches as often as necessary, no problem.
Just let me know when it is most convenient for you to merge what
and I'll accommodate.  I'm sorry for the somewhat complicated
merging situation.

Thanks,

Lukas

  reply	other threads:[~2018-09-06  7:38 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-08-19 14:29 [PATCH 0/9] PCI hotplug diet Lukas Wunner
2018-08-19 14:29 ` [PATCH 1/9] PCI: Simplify disconnected marking Lukas Wunner
2018-08-19 21:56   ` Sinan Kaya
2018-08-19 14:29 ` [PATCH 7/9] PCI: hotplug: Drop hotplug_slot_info Lukas Wunner
2018-08-20  8:14   ` Rafael J. Wysocki
2018-08-21  0:41   ` Tyrel Datwyler
2018-09-03 17:52   ` Sebastian Ott
2018-08-19 14:29 ` [PATCH 3/9] PCI: pciehp: Drop hotplug_slot_ops wrappers Lukas Wunner
2018-08-19 22:01   ` Sinan Kaya
2018-08-19 14:29 ` [PATCH 8/9] PCI: hotplug: Embed hotplug_slot Lukas Wunner
2018-08-20  8:17   ` Rafael J. Wysocki
2018-08-21  0:43   ` Tyrel Datwyler
2018-09-03 17:54   ` Sebastian Ott
2018-08-19 14:29 ` [PATCH 6/9] PCI: hotplug: Constify hotplug_slot_ops Lukas Wunner
2018-08-20  8:10   ` Rafael J. Wysocki
2018-08-21  0:38   ` Tyrel Datwyler
2018-08-19 14:29 ` [PATCH 4/9] PCI: pciehp: Unify controller and slot structs Lukas Wunner
2018-08-19 21:59   ` Sinan Kaya
2018-08-20  9:09     ` Lukas Wunner
2018-08-20 17:34       ` Sinan Kaya
2018-09-05 22:30         ` Bjorn Helgaas
2018-09-06  7:38           ` Lukas Wunner [this message]
2018-09-06 18:54             ` Bjorn Helgaas
2018-09-17 22:37             ` Bjorn Helgaas
2018-09-18 19:46               ` Lukas Wunner
2018-09-18 19:46                 ` Lukas Wunner
2018-08-19 14:29 ` [PATCH 9/9] PCI: hotplug: Document TODOs Lukas Wunner
2018-08-19 14:29 ` [PATCH 2/9] PCI: pciehp: Drop unnecessary includes Lukas Wunner
2018-08-19 14:29 ` [PATCH 5/9] PCI: pciehp: Reshuffle controller struct for clarity Lukas Wunner
2018-08-30  8:50 ` [PATCH 0/9] PCI hotplug diet Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20180906073826.43xonlbyoahji7hr@wunner.de \
    --to=lukas@wunner.de \
    --cc=helgaas@kernel.org \
    --cc=keith.busch@intel.com \
    --cc=linux-pci@vger.kernel.org \
    --cc=mika.westerberg@linux.intel.com \
    --cc=okaya@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).