linux-pci.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Chocron, Jonathan" <jonnyc@amazon.com>
To: "jingoohan1@gmail.com" <jingoohan1@gmail.com>,
	"mark.rutland@arm.com" <mark.rutland@arm.com>,
	"lorenzo.pieralisi@arm.com" <lorenzo.pieralisi@arm.com>,
	"Gustavo.Pimentel@synopsys.com" <Gustavo.Pimentel@synopsys.com>,
	"bhelgaas@google.com" <bhelgaas@google.com>,
	"robh+dt@kernel.org" <robh+dt@kernel.org>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"Woodhouse, David" <dwmw@amazon.co.uk>,
	"Hanoch, Uri" <hanochu@amazon.com>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	"Wasserstrom, Barak" <barakw@amazon.com>,
	"Saidi, Ali" <alisaidi@amazon.com>,
	"Hawa, Hanna" <hhhawa@amazon.com>,
	"Shenhar, Talel" <talel@amazon.com>,
	"Krupnik, Ronen" <ronenk@amazon.com>,
	"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
	"benh@kernel.crashing.org" <benh@kernel.crashing.org>,
	"Chocron, Jonathan" <jonnyc@amazon.com>
Subject: Re: [PATCH v2 6/8] PCI: al: Add support for DW based driver type
Date: Mon, 22 Jul 2019 15:38:46 +0000	[thread overview]
Message-ID: <27d8e8a8bba4aeb845d6c953f3a07a29875fef02.camel@amazon.com> (raw)
In-Reply-To: <DM6PR12MB40101465C6D032B025473EFADAC40@DM6PR12MB4010.namprd12.prod.outlook.com>

On Mon, 2019-07-22 at 08:54 +0000, Gustavo Pimentel wrote:
> 
> > 
> > > > +static inline void al_pcie_target_bus_set(struct al_pcie
> > > > *pcie,
> > > > +					  u8 target_bus,
> > > > +					  u8 mask_target_bus)
> > > > +{
> > > > +	void __iomem *cfg_control_addr;
> > > > +	u32 reg;
> > > > +
> > > > +	reg = FIELD_PREP(CFG_TARGET_BUS_MASK_MASK,
> > > > mask_target_bus) |
> > > > +	      FIELD_PREP(CFG_TARGET_BUS_BUSNUM_MASK,
> > > > target_bus);
> > > > +
> > > > +	cfg_control_addr = (void __iomem *)((uintptr_t)pcie-
> > > > > controller_base +
> > > > 
> > > > +			   AXI_BASE_OFFSET + pcie-
> > > > >reg_offsets.ob_ctrl
> > > > +
> > > > +			   CFG_TARGET_BUS);
> > > > +
> > > > +	writel(reg, cfg_control_addr);
> > > 
> > > From what I'm seeing you commonly use writel() and readl() with a
> > > common 
> > > base address, such as pcie->controller_base + AXI_BASE_OFFSET.
> > > I'd suggest to creating a writel and readl with that offset
> > > built-in.
> > > 
> > 
> > I prefer to keep it generic, since in future revisions we might
> > want to
> > access regs which are not in the AXI region. You think I should add
> > wrappers which simply hide the pcie->controller_base part?
> 
> I and other developers typically do that, but it's a suggestion. IMHO
> it 
> helps to keep the code cleaner and more readable.
> 

Added al_pcie_controller_readl/writel wrappers.

-- 
Thanks,
   Jonathan

  reply	other threads:[~2019-07-22 15:38 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-18  9:45 [PATCH v2 0/8] Amazon's Annapurna Labs DT-based PCIe host controller driver Jonathan Chocron
2019-07-18  9:45 ` [PATCH v2 1/8] PCI: Add Amazon's Annapurna Labs vendor ID Jonathan Chocron
2019-07-18  9:45 ` [PATCH v2 2/8] PCI: Add ACS quirk for Amazon Annapurna Labs root ports Jonathan Chocron
2019-07-19  8:25   ` Gustavo Pimentel
2019-07-18  9:45 ` [PATCH v2 3/8] PCI/VPD: Add VPD release quirk for Amazon's Annapurna Labs Root Port Jonathan Chocron
2019-07-19  8:24   ` Gustavo Pimentel
2019-07-18  9:45 ` [PATCH v2 4/8] PCI: Add quirk to disable MSI-X support " Jonathan Chocron
2019-07-19  9:17   ` Gustavo Pimentel
2019-07-18  9:47 ` [PATCH v2 5/8] dt-bindings: PCI: Add Amazon's Annapurna Labs PCIe host bridge binding Jonathan Chocron
2019-07-18  9:47 ` [PATCH v2 6/8] PCI: al: Add support for DW based driver type Jonathan Chocron
2019-07-19  8:55   ` Gustavo Pimentel
2019-07-21 15:08     ` Chocron, Jonathan
2019-07-22  0:47       ` Benjamin Herrenschmidt
2019-07-22  8:54       ` Gustavo Pimentel
2019-07-22 15:38         ` Chocron, Jonathan [this message]
2019-07-22 21:15       ` Bjorn Helgaas
2019-07-18  9:47 ` [PATCH v2 7/8] PCI: dw: Add validation that PCIe core is set to correct mode Jonathan Chocron
2019-07-19  9:15   ` Gustavo Pimentel
2019-07-18  9:47 ` [PATCH v2 8/8] PCI: dw: Add support for PCI_PROBE_ONLY/PCI_REASSIGN_ALL_BUS flags Jonathan Chocron

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=27d8e8a8bba4aeb845d6c953f3a07a29875fef02.camel@amazon.com \
    --to=jonnyc@amazon.com \
    --cc=Gustavo.Pimentel@synopsys.com \
    --cc=alisaidi@amazon.com \
    --cc=barakw@amazon.com \
    --cc=benh@kernel.crashing.org \
    --cc=bhelgaas@google.com \
    --cc=devicetree@vger.kernel.org \
    --cc=dwmw@amazon.co.uk \
    --cc=hanochu@amazon.com \
    --cc=hhhawa@amazon.com \
    --cc=jingoohan1@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lorenzo.pieralisi@arm.com \
    --cc=mark.rutland@arm.com \
    --cc=robh+dt@kernel.org \
    --cc=ronenk@amazon.com \
    --cc=talel@amazon.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).