linux-pci.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Sean V Kelley" <sean.v.kelley@intel.com>
To: "Jonathan Cameron" <Jonathan.Cameron@Huawei.com>
Cc: "Sean V Kelley" <seanvk.dev@oregontracks.org>,
	bhelgaas@google.com, rafael.j.wysocki@intel.com,
	ashok.raj@intel.com, tony.luck@intel.com,
	sathyanarayanan.kuppuswamy@intel.com, qiuxu.zhuo@intel.com,
	linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v7 05/13] PCI/ERR: Use "bridge" for clarity in pcie_do_recovery()
Date: Thu, 01 Oct 2020 14:04:49 -0700	[thread overview]
Message-ID: <42394E6B-6BD6-4628-BF1F-E1F14F6A86F1@intel.com> (raw)
In-Reply-To: <20201001090657.00003fe4@Huawei.com>

On 1 Oct 2020, at 2:06, Jonathan Cameron wrote:

> On Wed, 30 Sep 2020 14:58:12 -0700
> Sean V Kelley <seanvk.dev@oregontracks.org> wrote:
>
>> From: Sean V Kelley <sean.v.kelley@intel.com>
>>
>> The term "dev" is being applied to root ports, switch
>> upstream ports, switch downstream ports, and the upstream
>> ports on endpoints. While endpoint upstream ports don't have
>> subordinate buses, a generic term such as "bridge" may be used
>
> This sentence is a bit confusing.  The bit before the comma
> seems only slightly connected. Perhaps 2 sentences?

I agree.  Will reword.
>
>> for something with a subordinate bus. The current conditional
>> logic in pcie_do_recovery() would also benefit from some
>> simplification with use of pci_upstream_bridge() in place of
>> dev->bus->self. Reverse the pcie_do_recovery() conditional logic
>> and replace use of "dev" with "bridge" for greater clarity.
>>
>> Suggested-by: Bjorn Helgaas <bhelgaas@google.com>
>> Signed-off-by: Sean V Kelley <sean.v.kelley@intel.com>
>
> Acked-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>

Thanks,

Sean

>
>> ---
>>  drivers/pci/pcie/err.c | 20 +++++++++++++-------
>>  1 file changed, 13 insertions(+), 7 deletions(-)
>>
>> diff --git a/drivers/pci/pcie/err.c b/drivers/pci/pcie/err.c
>> index 950612342f1c..c6922c099c76 100644
>> --- a/drivers/pci/pcie/err.c
>> +++ b/drivers/pci/pcie/err.c
>> @@ -152,16 +152,22 @@ pci_ers_result_t pcie_do_recovery(struct 
>> pci_dev *dev,
>>  {
>>  	pci_ers_result_t status = PCI_ERS_RESULT_CAN_RECOVER;
>>  	struct pci_bus *bus;
>> +	struct pci_dev *bridge;
>> +	int type;
>>
>>  	/*
>> -	 * Error recovery runs on all subordinates of the first downstream 
>> port.
>> -	 * If the downstream port detected the error, it is cleared at the 
>> end.
>> +	 * Error recovery runs on all subordinates of the first downstream
>> +	 * bridge. If the downstream bridge detected the error, it is
>> +	 * cleared at the end.
>>  	 */
>> -	if (!(pci_pcie_type(dev) == PCI_EXP_TYPE_ROOT_PORT ||
>> -	      pci_pcie_type(dev) == PCI_EXP_TYPE_DOWNSTREAM))
>> -		dev = dev->bus->self;
>> -	bus = dev->subordinate;
>> -
>> +	type = pci_pcie_type(dev);
>> +	if (type == PCI_EXP_TYPE_ROOT_PORT ||
>> +	    type == PCI_EXP_TYPE_DOWNSTREAM)
>> +		bridge = dev;
>> +	else
>> +		bridge = pci_upstream_bridge(dev);
>> +
>> +	bus = bridge->subordinate;
>>  	pci_dbg(dev, "broadcast error_detected message\n");
>>  	if (state == pci_channel_io_frozen) {
>>  		pci_walk_bus(bus, report_frozen_detected, &status);

  reply	other threads:[~2020-10-01 21:04 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-30 21:58 [PATCH v7 00/13] Add RCEC handling to PCI/AER Sean V Kelley
2020-09-30 21:58 ` [PATCH v7 01/13] PCI/RCEC: Add RCEC class code and extended capability Sean V Kelley
2020-09-30 21:58 ` [PATCH v7 02/13] PCI/RCEC: Bind RCEC devices to the Root Port driver Sean V Kelley
2020-09-30 21:58 ` [PATCH v7 03/13] PCI/RCEC: Cache RCEC capabilities in pci_init_capabilities() Sean V Kelley
2020-09-30 22:15   ` Sean V Kelley
2020-10-01  9:02   ` Jonathan Cameron
2020-09-30 21:58 ` [PATCH v7 04/13] PCI/ERR: Rename reset_link() to reset_subordinate_device() Sean V Kelley
2020-10-01  9:03   ` Jonathan Cameron
2020-09-30 21:58 ` [PATCH v7 05/13] PCI/ERR: Use "bridge" for clarity in pcie_do_recovery() Sean V Kelley
2020-10-01  9:06   ` Jonathan Cameron
2020-10-01 21:04     ` Sean V Kelley [this message]
2020-09-30 21:58 ` [PATCH v7 06/13] PCI/ERR: Limit AER resets " Sean V Kelley
2020-10-01 10:00   ` Jonathan Cameron
2020-09-30 21:58 ` [PATCH v7 07/13] PCI/AER: Extend AER error handling to RCECs Sean V Kelley
2020-10-01 23:14   ` Bjorn Helgaas
2020-10-02  4:15     ` Sean V Kelley
2020-09-30 21:58 ` [PATCH v7 08/13] PCI/AER: Apply function level reset to RCiEP on fatal error Sean V Kelley
2020-09-30 21:58 ` [PATCH v7 09/13] PCI/RCEC: Add pcie_link_rcec() to associate RCiEPs Sean V Kelley
2020-09-30 21:58 ` [PATCH v7 10/13] PCI/RCEC: Add RCiEP's linked RCEC to AER/ERR Sean V Kelley
2020-09-30 21:58 ` [PATCH v7 11/13] PCI/AER: Add pcie_walk_rcec() to RCEC AER handling Sean V Kelley
2020-09-30 21:58 ` [PATCH v7 12/13] PCI/PME: Add pcie_walk_rcec() to RCEC PME handling Sean V Kelley
2020-09-30 21:58 ` [PATCH v7 13/13] PCI/AER: Add RCEC AER error injection support Sean V Kelley
2020-10-01 10:16 ` [PATCH v7 00/13] Add RCEC handling to PCI/AER Jonathan Cameron
2020-10-01 21:01   ` Sean V Kelley

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=42394E6B-6BD6-4628-BF1F-E1F14F6A86F1@intel.com \
    --to=sean.v.kelley@intel.com \
    --cc=Jonathan.Cameron@Huawei.com \
    --cc=ashok.raj@intel.com \
    --cc=bhelgaas@google.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=qiuxu.zhuo@intel.com \
    --cc=rafael.j.wysocki@intel.com \
    --cc=sathyanarayanan.kuppuswamy@intel.com \
    --cc=seanvk.dev@oregontracks.org \
    --cc=tony.luck@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).