linux-pci.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Kuppuswamy, Sathyanarayanan"  <sathyanarayanan.kuppuswamy@linux.intel.com>
To: Sean V Kelley <sean.v.kelley@intel.com>,
	bhelgaas@google.com, Jonathan.Cameron@huawei.com,
	xerces.zhao@gmail.com, rafael.j.wysocki@intel.com,
	ashok.raj@intel.com, tony.luck@intel.com,
	sathyanarayanan.kuppuswamy@intel.com, qiuxu.zhuo@intel.com
Cc: linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v11 02/16] PCI/RCEC: Add RCEC class code and extended capability
Date: Tue, 17 Nov 2020 12:07:30 -0800	[thread overview]
Message-ID: <f90fcafa-3aea-758a-b3ef-636aeaf0ee4b@linux.intel.com> (raw)
In-Reply-To: <20201117191954.1322844-3-sean.v.kelley@intel.com>

Hi,

On 11/17/20 11:19 AM, Sean V Kelley wrote:
> From: Qiuxu Zhuo <qiuxu.zhuo@intel.com>
> 
> A PCIe Root Complex Event Collector (RCEC) has base class 0x08, sub-class
> 0x07, and programming interface 0x00.  Add the class code 0x0807 to
> identify RCEC devices and add #defines for the RCEC Endpoint Association
> Extended Capability.
> 
> See PCIe r5.0, sec 1.3.4 ("Root Complex Event Collector") and sec 7.9.10
> ("Root Complex Event Collector Endpoint Association Extended Capability").
Why not merge this change with usage patch ? Keeping changes together will help
in case of reverting the code.
> 
> Link: https://lore.kernel.org/r/20201002184735.1229220-2-seanvk.dev@oregontracks.org
> Signed-off-by: Qiuxu Zhuo <qiuxu.zhuo@intel.com>
> Signed-off-by: Bjorn Helgaas <bhelgaas@google.com>
> Reviewed-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
> ---
>   include/linux/pci_ids.h       | 1 +
>   include/uapi/linux/pci_regs.h | 7 +++++++
>   2 files changed, 8 insertions(+)
> 
> diff --git a/include/linux/pci_ids.h b/include/linux/pci_ids.h
> index 1ab1e24bcbce..d8156a5dbee8 100644
> --- a/include/linux/pci_ids.h
> +++ b/include/linux/pci_ids.h
> @@ -81,6 +81,7 @@
>   #define PCI_CLASS_SYSTEM_RTC		0x0803
>   #define PCI_CLASS_SYSTEM_PCI_HOTPLUG	0x0804
>   #define PCI_CLASS_SYSTEM_SDHCI		0x0805
> +#define PCI_CLASS_SYSTEM_RCEC		0x0807
>   #define PCI_CLASS_SYSTEM_OTHER		0x0880
>   
>   #define PCI_BASE_CLASS_INPUT		0x09
> diff --git a/include/uapi/linux/pci_regs.h b/include/uapi/linux/pci_regs.h
> index a95d55f9f257..bccd3e35cb65 100644
> --- a/include/uapi/linux/pci_regs.h
> +++ b/include/uapi/linux/pci_regs.h
> @@ -831,6 +831,13 @@
>   #define  PCI_PWR_CAP_BUDGET(x)	((x) & 1)	/* Included in system budget */
>   #define PCI_EXT_CAP_PWR_SIZEOF	16
>   
> +/* Root Complex Event Collector Endpoint Association  */
> +#define PCI_RCEC_RCIEP_BITMAP	4	/* Associated Bitmap for RCiEPs */
> +#define PCI_RCEC_BUSN		8	/* RCEC Associated Bus Numbers */
> +#define  PCI_RCEC_BUSN_REG_VER	0x02	/* Least version with BUSN present */
> +#define  PCI_RCEC_BUSN_NEXT(x)	(((x) >> 8) & 0xff)
> +#define  PCI_RCEC_BUSN_LAST(x)	(((x) >> 16) & 0xff)
> +
>   /* Vendor-Specific (VSEC, PCI_EXT_CAP_ID_VNDR) */
>   #define PCI_VNDR_HEADER		4	/* Vendor-Specific Header */
>   #define  PCI_VNDR_HEADER_ID(x)	((x) & 0xffff)
> 

-- 
Sathyanarayanan Kuppuswamy
Linux Kernel Developer

  reply	other threads:[~2020-11-17 20:07 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-17 19:19 [PATCH v11 00/16] Add RCEC handling to PCI/AER Sean V Kelley
2020-11-17 19:19 ` [PATCH v11 01/16] AER: aer_root_reset() non-native handling Sean V Kelley
2020-11-17 20:04   ` Kuppuswamy, Sathyanarayanan
2020-11-17 19:19 ` [PATCH v11 02/16] PCI/RCEC: Add RCEC class code and extended capability Sean V Kelley
2020-11-17 20:07   ` Kuppuswamy, Sathyanarayanan [this message]
2020-11-17 22:39     ` Kelley, Sean V
2020-11-17 19:19 ` [PATCH v11 03/16] PCI/RCEC: Bind RCEC devices to the Root Port driver Sean V Kelley
2020-11-17 20:09   ` Kuppuswamy, Sathyanarayanan
2020-11-17 19:19 ` [PATCH v11 04/16] PCI/RCEC: Cache RCEC capabilities in pci_init_capabilities() Sean V Kelley
2020-11-17 19:19 ` [PATCH v11 05/16] PCI/ERR: Rename reset_link() to reset_subordinates() Sean V Kelley
2020-11-17 20:10   ` Kuppuswamy, Sathyanarayanan
2020-11-17 19:19 ` [PATCH v11 06/16] PCI/ERR: Simplify by using pci_upstream_bridge() Sean V Kelley
2020-11-17 20:11   ` Kuppuswamy, Sathyanarayanan
2020-11-17 19:19 ` [PATCH v11 07/16] PCI/ERR: Simplify by computing pci_pcie_type() once Sean V Kelley
2020-11-17 21:58   ` Kuppuswamy, Sathyanarayanan
2020-11-17 22:47     ` Kelley, Sean V
2020-11-17 19:19 ` [PATCH v11 08/16] PCI/ERR: Use "bridge" for clarity in pcie_do_recovery() Sean V Kelley
2020-11-17 21:59   ` Kuppuswamy, Sathyanarayanan
2020-11-17 19:19 ` [PATCH v11 09/16] PCI/ERR: Avoid negated conditional for clarity Sean V Kelley
2020-11-17 22:00   ` Kuppuswamy, Sathyanarayanan
2020-11-17 19:19 ` [PATCH v11 10/16] PCI/ERR: Add pci_walk_bridge() to pcie_do_recovery() Sean V Kelley
2020-11-17 19:19 ` [PATCH v11 11/16] PCI/ERR: Limit AER resets in pcie_do_recovery() Sean V Kelley
2020-11-17 19:19 ` [PATCH v11 12/16] PCI/RCEC: Add pcie_link_rcec() to associate RCiEPs Sean V Kelley
2020-11-17 19:19 ` [PATCH v11 13/16] PCI/RCEC: Add RCiEP's linked RCEC to AER/ERR Sean V Kelley
2020-11-17 19:19 ` [PATCH v11 14/16] PCI/AER: Add pcie_walk_rcec() to RCEC AER handling Sean V Kelley
2020-11-18  6:04   ` Kuppuswamy, Sathyanarayanan
2020-11-17 19:19 ` [PATCH v11 15/16] PCI/PME: Add pcie_walk_rcec() to RCEC PME handling Sean V Kelley
2020-11-18  6:03   ` Kuppuswamy, Sathyanarayanan
2020-11-18 16:11     ` Kelley, Sean V
2020-11-17 19:19 ` [PATCH v11 16/16] PCI/AER: Add RCEC AER error injection support Sean V Kelley
2020-11-18  6:02   ` Kuppuswamy, Sathyanarayanan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f90fcafa-3aea-758a-b3ef-636aeaf0ee4b@linux.intel.com \
    --to=sathyanarayanan.kuppuswamy@linux.intel.com \
    --cc=Jonathan.Cameron@huawei.com \
    --cc=ashok.raj@intel.com \
    --cc=bhelgaas@google.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=qiuxu.zhuo@intel.com \
    --cc=rafael.j.wysocki@intel.com \
    --cc=sathyanarayanan.kuppuswamy@intel.com \
    --cc=sean.v.kelley@intel.com \
    --cc=tony.luck@intel.com \
    --cc=xerces.zhao@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).