From mboxrd@z Thu Jan 1 00:00:00 1970 From: Lukasz Majewski Subject: Re: [PATCH 1/5] cpufreq: Define cpufreq_set_drv_attr_files() to add per CPU sysfs attributes Date: Thu, 06 Jun 2013 10:58:14 +0200 Message-ID: <20130606105814.3495e3a9@amdc308.digital.local> References: <1370502472-7249-1-git-send-email-l.majewski@samsung.com> <1370502472-7249-2-git-send-email-l.majewski@samsung.com> Mime-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Return-path: In-reply-to: Sender: linux-kernel-owner@vger.kernel.org To: Viresh Kumar Cc: "Rafael J. Wysocky" , "cpufreq@vger.kernel.org" , Linux PM list , Vincent Guittot , Jonghwa Lee , Myungjoo Ham , linux-kernel , Lukasz Majewski , Andre Przywara , Daniel Lezcano , Lists linaro-kernel List-Id: linux-pm@vger.kernel.org Hi Viresh, > On 6 June 2013 12:37, Lukasz Majewski wrote: > > > Subject: cpufreq: Define cpufreq_set_drv_attr_files() to add per > > CPU sysfs attributes > > Its not per-cpu. We just add it for policy->cpu and other routines > actually create links. > > > The cpufreq_set_drv_attr_files() function creates sysfs file entry > > for each available CPU. With it in place it is possible to add > > different set of attributes without code duplication. > > Not for each available cpu but are linked to a policy->kobj and so > shows up on each policy->cpus. Yes, you are right here. Thanks for detailed explanation. Being "per-cpu" comes from kobj embedded at policy, which has information about cpus affected. > > > Signed-off-by: Lukasz Majewski > > Signed-off-by: Myungjoo Ham > > --- > > drivers/cpufreq/cpufreq.c | 23 +++++++++++++++-------- > > 1 file changed, 15 insertions(+), 8 deletions(-) > > > > diff --git a/drivers/cpufreq/cpufreq.c b/drivers/cpufreq/cpufreq.c > > index 1b8a48e..ca74e27 100644 > > --- a/drivers/cpufreq/cpufreq.c > > +++ b/drivers/cpufreq/cpufreq.c > > @@ -730,12 +730,23 @@ static int cpufreq_add_dev_symlink(unsigned > > int cpu, return ret; > > } > > > > +static int cpufreq_set_drv_attr_files(struct cpufreq_policy > > *policy, > > + struct freq_attr **drv_attr) > > +{ > > + while ((drv_attr) && (*drv_attr)) { > > + if (sysfs_create_file(&policy->kobj, > > &((*drv_attr)->attr))) > > + return 1; > > You are changing the semantics here. We used to return error > value from sysfs_create_file() and you are returning 1. Yes, correct. The ret from sysfs_create_file shall be returned. Returning 1 causes information lost. > > > + drv_attr++; > > If drv_attr was valid initially, then drv_attr++ can't make it NULL. > So, we don't need to check validity of drv_attr for every loop. I'm confused here. So you want to check dev_attr for NULL just after: drv_attr = cpufreq_driver->attr; if (!drv_attr) goto error; and skip the check at the while loop: while ((drv_attr) && (*drv_attr)) to while ((*drv_attr)) Am I correct? -- Best regards, Lukasz Majewski Samsung R&D Institute Poland (SRPOL) | Linux Platform Group