linux-raid.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-09-01 15:59:50 to 2020-09-10 19:18:49 UTC [more...]

bdi cleanups v4
 2020-09-10 14:48 UTC  (3+ messages)
` [PATCH 03/12] drbd: remove RB_CONGESTED_REMOTE
` [PATCH 11/12] bdi: invert BDI_CAP_NO_ACCT_WB

rework check_disk_change() v2
 2020-09-10 15:54 UTC  (44+ messages)
` [PATCH 01/19] block: add a bdev_check_media_change helper
` [PATCH 02/19] amiflop: use bdev_check_media_change
` [PATCH 03/19] ataflop: "
` [PATCH 04/19] floppy: "
` [PATCH 05/19] swim: "
` [PATCH 06/19] swim: simplify media change handling
` [PATCH 07/19] swim3: use bdev_check_media_changed
` [PATCH 08/19] xsysace: use bdev_check_media_change
` [PATCH 09/19] xsysace: simplify media change handling
` [PATCH 10/19] paride/pcd: use bdev_check_media_change
` [PATCH 11/19] gdrom: "
` [PATCH 12/19] ide-cd: use bdev_check_media_changed
` [PATCH 13/19] ide-cd: remove idecd_revalidate_disk
` [PATCH 14/19] ide-gd: stop using the disk events mechanism
` [PATCH 15/19] md: use bdev_check_media_change
` [PATCH 16/19] sd: "
` [PATCH 17/19] sr: "
` [PATCH 18/19] sr: simplify sr_block_revalidate_disk
` [PATCH 19/19] block: remove check_disk_change

bdi cleanups v3
 2020-09-10 17:15 UTC  (7+ messages)
` [PATCH 06/14] block: lift setting the readahead size into the block layer

[PATCH 0/4] mdmonitor improvements
 2020-09-09  8:31 UTC  (3+ messages)
` [PATCH 3/4] mdmonitor: set small delay once
` [PATCH 4/4] Check if other Monitor instance running before fork

[PATCH V4 1/3] percpu_ref: add percpu_ref_is_initialized for MD
 2020-09-09  7:18 UTC 

[PATCH V3 1/3] percpu_ref: add percpu_ref_inited() for MD
 2020-09-09  6:04 UTC  (4+ messages)

clean up is partition checks
 2020-09-09  0:55 UTC  (14+ messages)
` [PATCH 1/9] Documentation/hdio: fix up obscure bd_contains references
` [PATCH 2/9] block: add a bdev_is_partition helper
` [PATCH 3/9] md: compare bd_disk instead of bd_contains
` [PATCH 4/9] md: don't detour through bd_contains for the gendisk
` [PATCH 5/9] drbd: "
` [PATCH 6/9] drbd: don't set ->bd_contains
` [PATCH 7/9] target/iblock: fix holder printing in iblock_show_configfs_dev_params
` [PATCH 8/9] block: use bd_partno in bdevname
` [PATCH 9/9] vsprintf: use bd_partno in bdev_name

rework check_disk_change()
 2020-09-08 14:37 UTC  (45+ messages)
` [PATCH 01/19] block: add a bdev_check_media_change helper
` [PATCH 02/19] amiflop: use bdev_check_media_change
` [PATCH 03/19] ataflop: "
` [PATCH 04/19] floppy: "
` [PATCH 05/19] swim: "
` [PATCH 06/19] swim: simplify media change handling
` [PATCH 07/19] swim3: use bdev_check_media_changed
` [PATCH 08/19] xsysace: use bdev_check_media_change
` [PATCH 09/19] xsysace: simplify media change handling
` [PATCH 10/19] paride/pcd: use bdev_check_media_change
` [PATCH 11/19] gdrom: "
` [PATCH 12/19] ide-cd: use bdev_check_media_changed
` [PATCH 13/19] ide-cd: remove idecd_revalidate_disk
` [PATCH 14/19] ide-gd: stop using the disk events mechanism
` [PATCH 15/19] md: use bdev_check_media_change
` [PATCH 16/19] sd: "
` [PATCH 17/19] sr: "
` [PATCH 18/19] sr: simplify sr_block_revalidate_disk
` [PATCH 19/19] block: remove check_disk_change

Linux raid-like idea
 2020-09-05 22:42 UTC  (4+ messages)

[PATCH 21/23] init: add an init_stat helper
 2020-09-04 16:04 UTC  (3+ messages)
` [PATCH] init: fix error check in clean_path()

💥 PANICKED: Test report for kernel 5.9.0-rc3-020ad03.cki (block)
 2020-09-04 15:06 UTC  (4+ messages)

simplify gendisk lookup and remove struct block_device aliases v3
 2020-09-04 10:30 UTC  (40+ messages)
` [PATCH 01/19] char_dev: replace cdev_map with an xarray
` [PATCH 02/19] block: merge drivers/base/map.c into block/genhd.c
` [PATCH 03/19] block: cleanup del_gendisk a bit
` [PATCH 04/19] block: split block_class_lock
` [PATCH 05/19] block: rework requesting modules for unclaimed devices
` [PATCH 06/19] block: add an optional probe callback to major_names
` [PATCH 07/19] ide: remove ide_{,un}register_region
` [PATCH 08/19] swim: don't call blk_register_region
` [PATCH 09/19] sd: use __register_blkdev to avoid a modprobe for an unregistered dev_t
` [PATCH 10/19] brd: use __register_blkdev to allocate devices on demand
` [PATCH 11/19] loop: "
` [PATCH 12/19] md: "
` [PATCH 13/19] ide: switch to __register_blkdev for command set probing
` [PATCH 14/19] floppy: use a separate gendisk for each media format
` [PATCH 15/19] amiflop: use separate gendisks for Amiga vs MS-DOS mode
` [PATCH 16/19] ataflop: use a separate gendisk for each media format
` [PATCH 17/19] z2ram: reindent
` [PATCH 18/19] z2ram: use separate gendisk for the different modes
` [PATCH 19/19] block: switch gendisk lookup to a simple xarray

Config option for removing bbl on assembly?
 2020-09-04  7:45 UTC 

Feature request: Remove the badblocks list
 2020-09-02 19:45 UTC  (11+ messages)

Best way to add caching to a new raid setup
 2020-09-02 18:17 UTC  (11+ messages)

remove revalidate_disk()
 2020-09-02 14:02 UTC  (20+ messages)
` [PATCH 1/9] Documentation/filesystems/locking.rst: remove an incorrect sentence
` [PATCH 2/9] block: don't clear bd_invalidated in check_disk_size_change
` [PATCH 3/9] block: rename bd_invalidated
` [PATCH 4/9] block: add a new revalidate_disk_size helper
` [PATCH 5/9] block: use revalidate_disk_size in set_capacity_revalidate_and_notify
` [PATCH 6/9] nvme: opencode revalidate_disk in nvme_validate_ns
` [PATCH 7/9] sd: open code revalidate_disk
` [PATCH 9/9] block: remove revalidate_disk()

[PATCH V6 0/3] md/raid10: Improve handling raid10 discard request
 2020-09-02 12:04 UTC  (5+ messages)
` [PATCH V6 1/3] md: calculate discard start address and size in specific raid type
` [PATCH V6 2/3] md/raid10: improve raid10 discard request
` [PATCH V6 3/3] md/raid10: improve discard request for far layout


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).