linux-rdma.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Jason Gunthorpe <jgg@ziepe.ca>
To: linux-mm@kvack.org, Daniel Vetter <daniel.vetter@ffwll.ch>,
	Jerome Glisse <jglisse@redhat.com>,
	Ralph Campbell <rcampbell@nvidia.com>
Cc: linux-rdma@vger.kernel.org, Jason Gunthorpe <jgg@mellanox.com>
Subject: [PATCH 0/3] Rename variables in mmu_notifier.c
Date: Thu, 16 Jan 2020 12:39:42 -0400	[thread overview]
Message-ID: <20200116163945.26956-1-jgg@ziepe.ca> (raw)

From: Jason Gunthorpe <jgg@mellanox.com>

Linus has observed that the variable names here do not make a lot of sense,
revise them as discussed so the file has better readability.

The new names are:

  struct mmu_notifier_mm -> struct mmu_notifier_subscriptions
  mmu_notifier_mm or mmn_mm -> subscriptions
   The per mm_struct memory that holds all the notifier subscription list
   heads and interval tree

  mn -> subscription (of type struct mmu_notifier)
   A list based subscription to notifications

  mni -> interval_sub (of type struct mmu_interval_notifier)
   A VA interval based subscription to notifications

I had originaly thought to also change the struct names, and while they are
not ideal, it seems that the resulting tree wide churn is probably not
worthwhile considering the size.

This is intended to have no functional change.

Jason Gunthorpe (3):
  mm/mmu_notifier: Rename struct mmu_notifier_mm to
    mmu_notifier_subscriptions
  mm/mmu_notifiers: Use 'subscription' as the variable name for
    mmu_notifier
  mm/mmu_notifiers: Use 'interval_sub' as the variable for
    mmu_interval_notifier

 Documentation/vm/hmm.rst     |  20 +-
 include/linux/mm_types.h     |   2 +-
 include/linux/mmu_notifier.h |  86 ++---
 kernel/fork.c                |   4 +-
 mm/debug.c                   |   4 +-
 mm/mmu_notifier.c            | 585 +++++++++++++++++++----------------
 6 files changed, 375 insertions(+), 326 deletions(-)

-- 
2.24.1


             reply	other threads:[~2020-01-16 16:39 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-16 16:39 Jason Gunthorpe [this message]
2020-01-16 16:39 ` [PATCH 1/3] mm/mmu_notifier: Rename struct mmu_notifier_mm to mmu_notifier_subscriptions Jason Gunthorpe
2020-01-16 16:39 ` [PATCH 2/3] mm/mmu_notifiers: Use 'subscription' as the variable name for mmu_notifier Jason Gunthorpe
2020-01-16 16:39 ` [PATCH 3/3] mm/mmu_notifiers: Use 'interval_sub' as the variable for mmu_interval_notifier Jason Gunthorpe
2020-01-27 20:52 ` [PATCH 0/3] Rename variables in mmu_notifier.c Jason Gunthorpe

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200116163945.26956-1-jgg@ziepe.ca \
    --to=jgg@ziepe.ca \
    --cc=daniel.vetter@ffwll.ch \
    --cc=jgg@mellanox.com \
    --cc=jglisse@redhat.com \
    --cc=linux-mm@kvack.org \
    --cc=linux-rdma@vger.kernel.org \
    --cc=rcampbell@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).