linux-rdma.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH rdma-core] redhat: Fix the condition for pyverbs enablement on Fedora 32 and up
@ 2020-06-28 14:50 Alaa Hleihel
  2020-06-29 10:58 ` Honggang LI
  2020-06-30 10:31 ` Leon Romanovsky
  0 siblings, 2 replies; 3+ messages in thread
From: Alaa Hleihel @ 2020-06-28 14:50 UTC (permalink / raw)
  To: jgg; +Cc: linux-rdma, Alaa Hleihel, Leon Romanovsky, Edward Srouji, Honggang Li

The cited commit enabled pyverbs build by default for Fedora 32 and up.
However, it broke enalbing pyverbs build when passing '--with pyverbs' flag.

Fix the condition so that now the behavior for Fedora 32 and up will be:
 * Default: pyverbs enabled.
 * --with pyverbs: pyverbs enabled.
 * --without pyverbs: pyverbs disabled.

Fixes: 07b304b75186 ("redhat: Build pyverbs for Fedora greater than release 31")
Signed-off-by: Alaa Hleihel <alaa@mellanox.com>
Reviewed-by: Leon Romanovsky <leonro@mellanox.com>
Tested-by: Edward Srouji <edwards@mellanox.com>
CC: Honggang Li <honli@redhat.com>
---
 redhat/rdma-core.spec | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/redhat/rdma-core.spec b/redhat/rdma-core.spec
index 7ff33b3ca8b8..76549e5cb61f 100644
--- a/redhat/rdma-core.spec
+++ b/redhat/rdma-core.spec
@@ -28,7 +28,7 @@ BuildRequires: valgrind-devel
 BuildRequires: systemd
 BuildRequires: systemd-devel
 %if 0%{?fedora} >= 32
-%define with_pyverbs %{?_with_pyverbs: 0} %{?!_with_pyverbs: 1}
+%define with_pyverbs %{?_with_pyverbs: 1} %{?!_with_pyverbs: %{?!_without_pyverbs: 1} %{?_without_pyverbs: 0}}
 %else
 %define with_pyverbs %{?_with_pyverbs: 1} %{?!_with_pyverbs: 0}
 %endif
-- 
2.26.2


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH rdma-core] redhat: Fix the condition for pyverbs enablement on Fedora 32 and up
  2020-06-28 14:50 [PATCH rdma-core] redhat: Fix the condition for pyverbs enablement on Fedora 32 and up Alaa Hleihel
@ 2020-06-29 10:58 ` Honggang LI
  2020-06-30 10:31 ` Leon Romanovsky
  1 sibling, 0 replies; 3+ messages in thread
From: Honggang LI @ 2020-06-29 10:58 UTC (permalink / raw)
  To: Alaa Hleihel; +Cc: jgg, linux-rdma, Leon Romanovsky, Edward Srouji

On Sun, Jun 28, 2020 at 05:50:03PM +0300, Alaa Hleihel wrote:
> The cited commit enabled pyverbs build by default for Fedora 32 and up.
> However, it broke enalbing pyverbs build when passing '--with pyverbs' flag.
> 
> Fix the condition so that now the behavior for Fedora 32 and up will be:
>  * Default: pyverbs enabled.

Confirmed this patch works for me. Thanks!

Acked-by: Honggang Li <honli@redhat.com>

>  * --with pyverbs: pyverbs enabled.
>  * --without pyverbs: pyverbs disabled.
> 
> Fixes: 07b304b75186 ("redhat: Build pyverbs for Fedora greater than release 31")
> Signed-off-by: Alaa Hleihel <alaa@mellanox.com>
> Reviewed-by: Leon Romanovsky <leonro@mellanox.com>
> Tested-by: Edward Srouji <edwards@mellanox.com>
> CC: Honggang Li <honli@redhat.com>
> ---
>  redhat/rdma-core.spec | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/redhat/rdma-core.spec b/redhat/rdma-core.spec
> index 7ff33b3ca8b8..76549e5cb61f 100644
> --- a/redhat/rdma-core.spec
> +++ b/redhat/rdma-core.spec
> @@ -28,7 +28,7 @@ BuildRequires: valgrind-devel
>  BuildRequires: systemd
>  BuildRequires: systemd-devel
>  %if 0%{?fedora} >= 32
> -%define with_pyverbs %{?_with_pyverbs: 0} %{?!_with_pyverbs: 1}
> +%define with_pyverbs %{?_with_pyverbs: 1} %{?!_with_pyverbs: %{?!_without_pyverbs: 1} %{?_without_pyverbs: 0}}
>  %else
>  %define with_pyverbs %{?_with_pyverbs: 1} %{?!_with_pyverbs: 0}
>  %endif
> -- 
> 2.26.2
> 


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH rdma-core] redhat: Fix the condition for pyverbs enablement on Fedora 32 and up
  2020-06-28 14:50 [PATCH rdma-core] redhat: Fix the condition for pyverbs enablement on Fedora 32 and up Alaa Hleihel
  2020-06-29 10:58 ` Honggang LI
@ 2020-06-30 10:31 ` Leon Romanovsky
  1 sibling, 0 replies; 3+ messages in thread
From: Leon Romanovsky @ 2020-06-30 10:31 UTC (permalink / raw)
  To: Alaa Hleihel; +Cc: jgg, linux-rdma, Edward Srouji, Honggang Li

On Sun, Jun 28, 2020 at 05:50:03PM +0300, Alaa Hleihel wrote:
> The cited commit enabled pyverbs build by default for Fedora 32 and up.
> However, it broke enalbing pyverbs build when passing '--with pyverbs' flag.
>
> Fix the condition so that now the behavior for Fedora 32 and up will be:
>  * Default: pyverbs enabled.
>  * --with pyverbs: pyverbs enabled.
>  * --without pyverbs: pyverbs disabled.
>
> Fixes: 07b304b75186 ("redhat: Build pyverbs for Fedora greater than release 31")
> Signed-off-by: Alaa Hleihel <alaa@mellanox.com>
> Reviewed-by: Leon Romanovsky <leonro@mellanox.com>
> Tested-by: Edward Srouji <edwards@mellanox.com>
> CC: Honggang Li <honli@redhat.com>
> ---
>  redhat/rdma-core.spec | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)


I'll wait for the results of this PR and merge it.
https://github.com/linux-rdma/rdma-core/pull/784

Thanks

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2020-06-30 10:31 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-06-28 14:50 [PATCH rdma-core] redhat: Fix the condition for pyverbs enablement on Fedora 32 and up Alaa Hleihel
2020-06-29 10:58 ` Honggang LI
2020-06-30 10:31 ` Leon Romanovsky

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).