linux-rdma.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-01-03 13:48:32 to 2020-01-10 02:17:11 UTC [more...]

[GIT PULL] Please pull RDMA subsystem changes
 2020-01-10  2:16 UTC 

[PATCH v5 0/2] mm/hmm/test: add self tests for HMM
 2020-01-09 23:25 UTC  (5+ messages)
` [PATCH v5 1/2] mm/mmu_notifier: make interval notifier updates safe

[PATCH v12 00/22] mm/gup: prereqs to track dma-pinned pages: FOLL_PIN
 2020-01-09 22:07 UTC  (24+ messages)
` [PATCH v12 01/22] mm/gup: factor out duplicate code from four routines
` [PATCH v12 02/22] mm/gup: move try_get_compound_head() to top, fix minor issues
` [PATCH v12 03/22] mm: Cleanup __put_devmap_managed_page() vs ->page_free()
` [PATCH v12 04/22] mm: devmap: refactor 1-based refcounting for ZONE_DEVICE pages
` [PATCH v12 05/22] goldish_pipe: rename local pin_user_pages() routine
` [PATCH v12 06/22] mm: fix get_user_pages_remote()'s handling of FOLL_LONGTERM
` [PATCH v12 07/22] vfio: fix FOLL_LONGTERM use, simplify get_user_pages_remote() call
` [PATCH v12 08/22] mm/gup: allow FOLL_FORCE for get_user_pages_fast()
` [PATCH v12 09/22] IB/umem: use get_user_pages_fast() to pin DMA pages
` [PATCH v12 10/22] media/v4l2-core: set pages dirty upon releasing DMA buffers
` [PATCH v12 11/22] mm/gup: introduce pin_user_pages*() and FOLL_PIN
` [PATCH v12 12/22] goldish_pipe: convert to pin_user_pages() and put_user_page()
` [PATCH v12 13/22] IB/{core,hw,umem}: set FOLL_PIN via pin_user_pages*(), fix up ODP
` [PATCH v12 14/22] mm/process_vm_access: set FOLL_PIN via pin_user_pages_remote()
` [PATCH v12 15/22] drm/via: set FOLL_PIN via pin_user_pages_fast()
` [PATCH v12 16/22] fs/io_uring: set FOLL_PIN via pin_user_pages()
` [PATCH v12 17/22] net/xdp: "
` [PATCH v12 18/22] media/v4l2-core: pin_user_pages (FOLL_PIN) and put_user_page() conversion
` [PATCH v12 19/22] vfio, mm: "
` [PATCH v12 20/22] powerpc: book3s64: convert to pin_user_pages() and put_user_page()
` [PATCH v12 21/22] mm/gup_benchmark: use proper FOLL_WRITE flags instead of hard-coding "1"
` [PATCH v12 22/22] mm, tree-wide: rename put_user_page*() to unpin_user_page*()

[PATCH 1/3] infiniband: hw: hfi1: verbs.c: Use built-in RCU list checking
 2020-01-09 18:10 UTC  (3+ messages)

[PATCH] IB/core: Fix build failure without hugepages
 2020-01-09 16:00 UTC  (2+ messages)

[PATCH rdma-core 0/7] verbs: Relaxed ordering memory regions
 2020-01-09 14:04 UTC  (8+ messages)
` [PATCH rdma-core 1/7] Update kernel headers
` [PATCH rdma-core 2/7] verbs: Move free_context from verbs_device_ops to verbs_context_ops
` [PATCH rdma-core 3/7] verbs: Move alloc_context to ioctl
` [PATCH rdma-core 4/7] verbs: Relaxed ordering memory regions
` [PATCH rdma-core 5/7] mlx5: Add optional access flags range to DM
` [PATCH rdma-core 6/7] pyverbs: Add relaxed ordering access flag
` [PATCH rdma-core 7/7] tests: Add relaxed ordering access test

[PATCH] RDMA/core: remove err in iw_query_port
 2020-01-09 13:40 UTC 

[PATCH v4 for-next] RDMA/hns: Add support for reporting wc as software mode
 2020-01-09 12:20 UTC 

[PATCH for-next] RDMA/hns: Bugfix for posting a wqe with sge
 2020-01-09 12:10 UTC 

[PATCH rdma-next 00/10] Relaxed ordering memory regions
 2020-01-09  9:38 UTC  (12+ messages)
` [PATCH rdma-next 01/10] net/mlx5: Expose relaxed ordering bits
` [PATCH rdma-next 02/10] RDMA/core: Add UVERBS_METHOD_ASYNC_EVENT_ALLOC
` [PATCH rdma-next 03/10] RDMA/core: Remove ucontext_lock from the uverbs_destry_ufile_hw() path
` [PATCH rdma-next 04/10] RDMA/uverbs: Add ioctl command to get a device context
` [PATCH rdma-next 05/10] RDMA/uverbs: Verify MR access flags
` [PATCH rdma-next 06/10] RDMA/core: Add optional access flags range
` [PATCH rdma-next 07/10] RDMA/efa: Allow passing of optional access flags for MR registration
` [PATCH rdma-next 08/10] RDMA/uverbs: Add new relaxed ordering memory region access flag
` [PATCH rdma-next 09/10] RDMA/core: Add the core support field to METHOD_GET_CONTEXT
` [PATCH rdma-next 10/10] RDMA/mlx5: Set relaxed ordering when requested

[PATCH rdma-next 00/14] Refactoring FD usage
 2020-01-08 17:22 UTC  (15+ messages)
` [PATCH rdma-next 01/14] RDMA/mlx5: Use RCU and direct refcounts to keep memory alive
` [PATCH rdma-next 02/14] RDMA/core: Simplify destruction of FD uobjects
` [PATCH rdma-next 03/14] RDMA/mlx5: Simplify devx async commands
` [PATCH rdma-next 04/14] RDMA/core: Do not allow alloc_commit to fail
` [PATCH rdma-next 05/14] RDMA/core: Make ib_ucq_object use ib_uevent_object
` [PATCH rdma-next 06/14] RDMA/core: Do not erase the type of ib_cq.uobject
` [PATCH rdma-next 07/14] RDMA/core: Do not erase the type of ib_qp.uobject
` [PATCH rdma-next 08/14] RDMA/core: Do not erase the type of ib_srq.uobject
` [PATCH rdma-next 09/14] RDMA/core: Do not erase the type of ib_wq.uobject
` [PATCH rdma-next 10/14] RDMA/core: Simplify type usage for ib_uverbs_async_handler()
` [PATCH rdma-next 11/14] RDMA/core: Fix locking in ib_uverbs_event_read
` [PATCH rdma-next 12/14] RDMA/core: Remove the ufile arg from rdma_alloc_begin_uobject
` [PATCH rdma-next 13/14] RDMA/core: Make ib_uverbs_async_event_file into a uobject
` [PATCH rdma-next 14/14] RDMA/core: Use READ_ONCE for ib_ufile.async_file

[PATCH v6 00/25] RTRS (former IBTRS) rdma transport library and RNBD (former IBNBD) rdma network block device
 2020-01-08 16:51 UTC  (57+ messages)
` [PATCH v6 03/25] rtrs: private headers with rtrs protocol structs and helpers
` [PATCH v6 04/25] rtrs: core: lib functions shared between client and server modules
` [PATCH v6 05/25] rtrs: client: private header with client structs and functions
` [PATCH v6 06/25] rtrs: client: main functionality
` [PATCH v6 07/25] rtrs: client: statistics functions
` [PATCH v6 08/25] rtrs: client: sysfs interface functions
` [PATCH v6 09/25] rtrs: server: private header with server structs and functions
` [PATCH v6 10/25] rtrs: server: main functionality
` [PATCH v6 11/25] rtrs: server: statistics functions
` [PATCH v6 12/25] rtrs: server: sysfs interface functions
` [PATCH v6 13/25] rtrs: include client and server modules into kernel compilation
` [PATCH v6 14/25] rtrs: a bit of documentation
` [PATCH v6 15/25] rnbd: private headers with rnbd protocol structs and helpers
` [PATCH v6 16/25] rnbd: client: private header with client structs and functions
` [PATCH v6 17/25] rnbd: client: main functionality
` [PATCH v6 18/25] rnbd: client: sysfs interface functions

Recent trace observed in target code during iSer testing
 2020-01-08 16:18 UTC  (3+ messages)

[PATCH rdma-rc 0/3] ODP Fixes
 2020-01-08 15:24 UTC  (4+ messages)
` [PATCH rdma-rc 3/3] IB/core: Fix ODP with IB_ACCESS_HUGETLB handling

[RFC v2] RoCE v2.0 Entropy - IPv6 Flow Label and UDP Source Port
 2020-01-08 14:26 UTC 

[PATCH RDMA/uverbs] RDMA/uverbs: Protect list_empty() by lock
 2020-01-08 14:23 UTC  (3+ messages)

[PATCH rdma-next v1 0/4] Let IB core distribute cache update events
 2020-01-08 11:42 UTC  (6+ messages)
` [PATCH rdma-next v1 2/4] IB/core: "

[PATCH rdma-next 0/5] VIRTIO_NET Emulation Offload
 2020-01-08  8:12 UTC  (5+ messages)
` [PATCH rdma-next 4/5] IB/mlx5: Introduce VAR object and its alloc/destroy methods

[PATCH for-next 0/7] RDMA/hns: Various cleanups
 2020-01-08  1:42 UTC  (11+ messages)
` [PATCH for-next 1/7] RDMA/hns: Avoid printing address of mtt page
` [PATCH for-next 2/7] RDMA/hns: Remove unused function hns_roce_init_eq_table()
` [PATCH for-next 3/7] RDMA/hns: Update the value of qp type
` [PATCH for-next 4/7] RDMA/hns: Delete unnessary parameters in hns_roce_v2_qp_modify()
` [PATCH for-next 5/7] RDMA/hns: Remove redundant print information
` [PATCH for-next 6/7] RDMA/hns: Replace custom macros HNS_ROCE_ALIGN_UP
` [PATCH for-next 7/7] RDMA/hns: Fix coding style issues

[PATCH v10 0/3] Proposed trace points for RDMA/core
 2020-01-07 20:23 UTC  (3+ messages)

[PATCH 3/3] infiniband: sw: rdmavt: mcast.c: Use built-in RCU list checking
 2020-01-07 19:31 UTC 

[PATCH 2/3] infiniband: hw: qib: qib_verbs: Use built-in RCU list checking
 2020-01-07 19:30 UTC 

[PATCH rdma-rc] i40iw: Remove setting of VMA private data and use rdma_user_mmap_io
 2020-01-07 19:14 UTC  (2+ messages)

[PATCH rdma-rc v2 00/48] Organize code according to IBTA layout
 2020-01-07 18:40 UTC  (6+ messages)
` [PATCH rdma-rc v2 04/48] RDMA/cm: Add SET/GET implementations to hide IBA wire format
` [PATCH rdma-rc v2 05/48] RDMA/cm: Request For Communication (REQ) message definitions

[PATCH 1/3] infiniband: hw: hfi1: verbs.c: Use built-in RCU list checking
 2020-01-07 18:26 UTC  (4+ messages)
` [PATCH 2/3] infiniband: hw: qib: qib_verbs: "
` [PATCH 3/3] infiniband: sw: rdmavt: mcast.c: "

[PATCH v9 0/3] Proposed trace points for RDMA/core
 2020-01-07 14:39 UTC  (6+ messages)

[PATCH v5 00/25] RTRS (former IBTRS) rdma transport library and the corresponding RNBD (former IBNBD) rdma network block device
 2020-01-07 10:56 UTC  (6+ messages)

[PATCH v4] infiniband: i40iw: fix a potential NULL pointer dereference
 2020-01-07  2:08 UTC  (3+ messages)

[PATCH v11 00/25] mm/gup: track dma-pinned pages: FOLL_PIN
 2020-01-07  1:26 UTC  (12+ messages)

[PATCH v2] net: mlx5: Use iowriteXbe() to ring doorbell and remove reduntant wmb()
 2020-01-06 22:05 UTC  (4+ messages)

[PATCH] mlx5: work around high stack usage with gcc
 2020-01-06 21:59 UTC  (3+ messages)

[PATCH rdma-core 0/2] pyverbs: Support CQ events properly
 2020-01-06 15:01 UTC  (3+ messages)
` [PATCH rdma-core 1/2] pyverbs: Handle "
` [PATCH rdma-core 2/2] tests: Add a test for completion events

[PATCH for-next 0/9] Clean ups, refactror, additions
 2020-01-06 13:44 UTC  (11+ messages)
` [PATCH for-next 1/9] IB/hfi1: Move chip specific functions to chip.c
` [PATCH for-next 2/9] IB/hfi1: Add fast and slow handlers for receive context
` [PATCH for-next 3/9] IB/hfi1: Move common receive IRQ code to function
` [PATCH for-next 4/9] IB/hfi1: IB/hfi1: Add an API to handle special case drop
` [PATCH for-next 5/9] IB/hfi1: Create API for auto activate
` [PATCH for-next 6/9] IB/hfi1: Decouple IRQ name from type
` [PATCH for-next 7/9] IB/hfi1: Return void in packet receiving functions
` [PATCH for-next 8/9] IB/hfi1: Add software counter for ctxt0 seq drop
` [PATCH for-next 9/9] IB/hfi1: Add RcvShortLengthErrCnt to hfi1stats

[PATCH for-next v2] RDMA/siw: Simplify QP representation
 2020-01-04 17:26 UTC  (3+ messages)
`  "

[PATCH 0/5] RDMA: use true,false for bool variable
 2020-01-04 17:25 UTC  (3+ messages)

[PATCH for-next] RDMA/hns: Simplify the calculation and usage of wqe idx for post verbs
 2020-01-04  5:57 UTC  (3+ messages)

[PATCH] RDMA/rxe: Fix error type of mmap_offset
 2020-01-03 23:45 UTC  (2+ messages)

[PATCH for-next] RDMA/core: Fix storing node_desc
 2020-01-03 23:12 UTC  (2+ messages)

[PATCH rdma-rc v1 0/3] ODP Fixes
 2020-01-03 21:07 UTC  (2+ messages)

[PATCH for-rc] IB/hfi1: Adjust flow PSN with the correct resync_psn
 2020-01-03 20:50 UTC  (2+ messages)

[PATCH for-rc 0/4] Patches for 5.5 rc
 2020-01-03 20:47 UTC  (2+ messages)

[PATCH rdma-next] RDMA/mlx4: Redo TX checksum offload in line with docs
 2020-01-03 20:39 UTC  (2+ messages)

[PATCH rdma-next] RDMA/cm: Use RCU synchronization mechanism to protect cm_id_private xa_load()
 2020-01-03 20:36 UTC  (2+ messages)

[PATCH v2] scsi: RDMA/srpt: remove unnecessary assertion in srpt_queue_response
 2020-01-03 20:23 UTC  (2+ messages)

[PATCH RDMA/netlink v2] RDMA/netlink: Adhere to returning zero on success
 2020-01-03 20:10 UTC  (2+ messages)

[PATCH] IB/mlx5: Fix outstanding_pi index for GSI qps
 2020-01-03 20:01 UTC  (2+ messages)

[PATCH for-next v2 02/11] IB/hfi1: List all receive contexts from debugfs
 2020-01-03 19:48 UTC  (3+ messages)
` [PATCH for-next v3] "

[PATCH for-next 0/6] RDMA/bnxt_re driver update
 2020-01-03 19:46 UTC  (8+ messages)
` [PATCH for-next 4/6] RDMA/bnxt_re: Refactor device add/remove functionalities
` [PATCH for-next 5/6] RDMA/bnxt_re: Use driver_unregister and unregistration API
` [PATCH for-next 6/6] RDMA/bnxt_re: Report more number of completion vectors

[PATCH v2 rdma-next] RDMA/qedr: Add kernel capability flags for dpm enabled mode
 2020-01-03 19:18 UTC  (2+ messages)

[PATCH] net: mlx5: Use writeX() to ring doorbell and remove reduntant wmb()
 2020-01-03 19:06 UTC  (11+ messages)

[PATCH v1 0/9] NFS/RDMA client patches for v5.6
 2020-01-03 16:57 UTC  (10+ messages)
` [PATCH v1 1/9] xprtrdma: Eliminate ri_max_send_sges
` [PATCH v1 2/9] xprtrdma: Make sendctx queue lifetime the same as connection lifetime
` [PATCH v1 3/9] xprtrdma: Refactor initialization of ep->rep_max_requests
` [PATCH v1 4/9] xprtrdma: Eliminate per-transport "max pages"
` [PATCH v1 5/9] xprtrdma: Refactor frwr_is_supported
` [PATCH v1 6/9] xprtrdma: Allocate and map transport header buffers at connect time
` [PATCH v1 7/9] xprtrdma: Destroy rpcrdma_rep when Receive is flushed
` [PATCH v1 8/9] xprtrdma: Destroy reps from previous connection instance
` [PATCH v1 9/9] xprtrdma: DMA map rr_rdma_buf as each rpcrdma_rep is created


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).