linux-rdma.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-01-07 22:47:17 to 2020-01-15 15:30:45 UTC [more...]

[PATCH v12 00/22] mm/gup: prereqs to track dma-pinned pages: FOLL_PIN
 2020-01-15 15:30 UTC  (27+ messages)
` [PATCH v12 02/22] mm/gup: move try_get_compound_head() to top, fix minor issues
` [PATCH v12 03/22] mm: Cleanup __put_devmap_managed_page() vs ->page_free()
` [PATCH v12 04/22] mm: devmap: refactor 1-based refcounting for ZONE_DEVICE pages
` [PATCH v12 05/22] goldish_pipe: rename local pin_user_pages() routine
` [PATCH v12 06/22] mm: fix get_user_pages_remote()'s handling of FOLL_LONGTERM
` [PATCH v12 07/22] vfio: fix FOLL_LONGTERM use, simplify get_user_pages_remote() call
` [PATCH v12 08/22] mm/gup: allow FOLL_FORCE for get_user_pages_fast()
` [PATCH v12 10/22] media/v4l2-core: set pages dirty upon releasing DMA buffers
` [PATCH v12 11/22] mm/gup: introduce pin_user_pages*() and FOLL_PIN
` [PATCH v12 12/22] goldish_pipe: convert to pin_user_pages() and put_user_page()
` [PATCH v12 13/22] IB/{core,hw,umem}: set FOLL_PIN via pin_user_pages*(), fix up ODP
` [PATCH v12 15/22] drm/via: set FOLL_PIN via pin_user_pages_fast()
` [PATCH v12 17/22] net/xdp: set FOLL_PIN via pin_user_pages()
` [PATCH v12 18/22] media/v4l2-core: pin_user_pages (FOLL_PIN) and put_user_page() conversion
` [PATCH v12 19/22] vfio, mm: "
` [PATCH v12 20/22] powerpc: book3s64: convert to pin_user_pages() and put_user_page()
` [PATCH v12 22/22] mm, tree-wide: rename put_user_page*() to unpin_user_page*()

[PATCH bpf-next v2 00/10] tools: Use consistent libbpf include paths everywhere
 2020-01-15 15:21 UTC  (13+ messages)
` [PATCH bpf-next v2 01/10] samples/bpf: Don't try to remove user's homedir on clean
` [PATCH bpf-next v2 02/10] tools/bpf/runqslower: Fix override option for VMLINUX_BTF
` [PATCH bpf-next v2 03/10] tools/runqslower: Use consistent include paths for libbpf
` [PATCH bpf-next v2 04/10] selftests: "
` [PATCH bpf-next v2 05/10] bpftool: "
` [PATCH bpf-next v2 06/10] perf: "
` [PATCH bpf-next v2 07/10] samples/bpf: "
` [PATCH bpf-next v2 08/10] libbpf: Fix include of bpf_helpers.h when libbpf is installed on system
` [PATCH bpf-next v2 09/10] selftests: Remove tools/lib/bpf from include path
` [PATCH bpf-next v2 10/10] tools/runqslower: "

[PATCH rdma-next 0/2] RoCE accelerator counters
 2020-01-15 14:54 UTC  (3+ messages)
` [PATCH mlx5-next 1/2] net/mlx5: Add "
` [PATCH rdma-next 2/2] IB/mlx5: Expose "

[PATCH] IB/srp: Never use immediate data if it is disabled by a user
 2020-01-15 13:30 UTC 

[PATCH mlx5-next 00/10] Use ODP MRs for kernel ULPs
 2020-01-15 12:43 UTC  (11+ messages)
` [PATCH mlx5-next 01/10] IB: Allow calls to ib_umem_get from "
` [PATCH mlx5-next 02/10] IB/core: Introduce ib_reg_user_mr
` [PATCH mlx5-next 03/10] IB/core: Add interface to advise_mr for kernel users
` [PATCH mlx5-next 04/10] IB/mlx5: Add ODP WQE handlers for kernel QPs
` [PATCH mlx5-next 05/10] RDMA/mlx5: Don't fake udata for kernel path
` [PATCH mlx5-next 06/10] IB/mlx5: Mask out unsupported ODP capabilities for kernel QPs
` [PATCH mlx5-next 07/10] RDMA/mlx5: Fix handling of IOVA != user_va in ODP paths
` [PATCH mlx5-next 08/10] net/rds: Detect need of On-Demand-Paging memory registration
` [PATCH mlx5-next 09/10] net/rds: Handle ODP mr registration/unregistration
` [PATCH mlx5-next 10/10] net/rds: Use prefetch for On-Demand-Paging MR

[PATCH v7 for-next 0/2] RDMA/hns: Add the workqueue framework for flush cqe handler
 2020-01-15  9:49 UTC  (3+ messages)
` [PATCH v7 for-next 1/2] "
` [PATCH v7 for-next 2/2] RDMA/hns: Delayed flush cqe process with workqueue

[RFC v2] RoCE v2.0 Entropy - IPv6 Flow Label and UDP Source Port
 2020-01-15  9:48 UTC  (2+ messages)

[PATCH v5 for-next 0/2] RDMA/hns: Add the workqueue framework for flush cqe handler
 2020-01-15  9:39 UTC  (8+ messages)
` [PATCH v5 for-next 1/2] "

[PATCH rdma-rc] IB/mlx4: Fix memory leak in add_gid error flow
 2020-01-15  8:50 UTC 

[rdma:wip/jgg-for-next] BUILD INCOMPLETE 3f59b6c3e600f9665dcf5b8e566cd7b778f03045
 2020-01-15  4:50 UTC 

[PATCH for-next] RDMA/hns: Add support for extended atomic in userspace
 2020-01-15  1:42 UTC 

[PATCH for-next] RDMA/hns: Add support for extended atomic
 2020-01-15  1:30 UTC  (7+ messages)

[PATCH net-next] mlx5: Use proper logging and tracing line terminations
 2020-01-14 20:30 UTC  (2+ messages)

[PATCH 1/3] infiniband: hw: hfi1: verbs.c: Use built-in RCU list checking
 2020-01-14 19:46 UTC  (7+ messages)

[PATCH 3/3] infiniband: sw: rdmavt: mcast.c: Use built-in RCU list checking
 2020-01-14 16:25 UTC 

[PATCH 2/3] infiniband: hw: qib: qib_verbs: Use built-in RCU list checking
 2020-01-14 16:25 UTC 

[PATCH v6 0/6] mm/hmm/test: add self tests for HMM
 2020-01-14 13:00 UTC  (9+ messages)
` [PATCH v6 1/6] mm/mmu_notifier: add mmu_interval_notifier_insert_safe()
` [PATCH v6 2/6] mm/mmu_notifier: add mmu_interval_notifier_put()
` [PATCH v6 3/6] mm/notifier: add mmu_interval_notifier_update()
` [PATCH v6 4/6] mm/mmu_notifier: add mmu_interval_notifier_find()
` [PATCH v6 5/6] nouveau: use new mmu interval notifiers
` [PATCH v6 6/6] mm/hmm/test: add self tests for HMM

[PATCH v5 0/2] mm/hmm/test: add self tests for HMM
 2020-01-14 12:45 UTC  (7+ messages)
` [PATCH v5 1/2] mm/mmu_notifier: make interval notifier updates safe

[PATCH for-next 0/6] EFA updates 2020-01-14
 2020-01-14  8:57 UTC  (7+ messages)
` [PATCH for-next 1/6] RDMA/efa: Unified getters/setters for device structs bitmask access
` [PATCH for-next 2/6] RDMA/efa: Properly document the interrupt mask register
` [PATCH for-next 3/6] RDMA/efa: Device definitions documentation updates
` [PATCH for-next 4/6] RDMA/efa: Remove {} brackets from single statement if
` [PATCH for-next 5/6] RDMA/efa: Remove unused ucontext parameter from efa_qp_user_mmap_entries_remove
` [PATCH for-next 6/6] RDMA/efa: Do not delay freeing of DMA pages

[PATCH for-next V2] RDMA/core: Fix storing node description
 2020-01-14  8:14 UTC 

[PATCH for-next] RDMA/core: Fix storing node description
 2020-01-14  8:12 UTC  (3+ messages)

[PATCH v3 0/2] rxe should use same buffer size for SGE's and inline data
 2020-01-14  0:41 UTC  (3+ messages)
` [PATCH v3 1/2] Introduce maximum WQE size to check limits
` [PATCH v3 2/2] SGE buffer and max_inline data must have same size

[PATCH rdma-next 00/14] Refactoring FD usage
 2020-01-13 20:37 UTC  (17+ messages)
` [PATCH rdma-next 01/14] RDMA/mlx5: Use RCU and direct refcounts to keep memory alive
` [PATCH rdma-next 02/14] RDMA/core: Simplify destruction of FD uobjects
` [PATCH rdma-next 03/14] RDMA/mlx5: Simplify devx async commands
` [PATCH rdma-next 04/14] RDMA/core: Do not allow alloc_commit to fail
` [PATCH rdma-next 05/14] RDMA/core: Make ib_ucq_object use ib_uevent_object
` [PATCH rdma-next 06/14] RDMA/core: Do not erase the type of ib_cq.uobject
` [PATCH rdma-next 07/14] RDMA/core: Do not erase the type of ib_qp.uobject
` [PATCH rdma-next 08/14] RDMA/core: Do not erase the type of ib_srq.uobject
` [PATCH rdma-next 09/14] RDMA/core: Do not erase the type of ib_wq.uobject
` [PATCH rdma-next 10/14] RDMA/core: Simplify type usage for ib_uverbs_async_handler()
` [PATCH rdma-next 11/14] RDMA/core: Fix locking in ib_uverbs_event_read
` [PATCH rdma-next 12/14] RDMA/core: Remove the ufile arg from rdma_alloc_begin_uobject
` [PATCH rdma-next 13/14] RDMA/core: Make ib_uverbs_async_event_file into a uobject
` [PATCH rdma-next 14/14] RDMA/core: Use READ_ONCE for ib_ufile.async_file

[PATCH] RDMA/uverbs: Remove needs_kfree_rcu from uverbs_obj_type_class
 2020-01-13 20:37 UTC  (2+ messages)

[PATCH v2 0/2] rxe should use same buffer size for SGE's and inline data
 2020-01-13 19:16 UTC  (12+ messages)
` [PATCH v2 1/2] Introduce maximum WQE size to check limits

[PATCH] net: mellanox: prevent resource leak on htbl
 2020-01-13 17:25 UTC  (3+ messages)

[PATCH v6 for-next 0/2] RDMA/hns: Add the workqueue framework for flush cqe handler
 2020-01-13 11:44 UTC  (3+ messages)
` [PATCH v6 for-next 1/2] "
` [PATCH v6 for-next 2/2] RDMA/hns: Delayed flush cqe process with workqueue

[PATCH rdma-next 0/5] VIRTIO_NET Emulation Offload
 2020-01-12 23:54 UTC  (7+ messages)
` [PATCH rdma-next 4/5] IB/mlx5: Introduce VAR object and its alloc/destroy methods

[PATCH for-next] RDMA/core: Fix storing node_desc
 2020-01-12 20:02 UTC  (3+ messages)

Investment opportunity
 2020-01-12  5:00 UTC 

[GIT PULL] Please pull RDMA subsystem changes
 2020-01-11 14:45 UTC  (2+ messages)

[PATCH for-next 0/3] RDMA/hns: Get pf capabilities from firmware
 2020-01-11 10:32 UTC  (4+ messages)
` [PATCH for-next 1/3] RDMA/hns: Remove some redundant variables related to capabilities
` [PATCH for-next 2/3] RDMA/hns: Add interfaces to get pf capabilities from firmware
` [PATCH for-next 3/3] RDMA/hns: Get "

[Discussion] can ROCE protocol work with NAT (Network Address Translation)?
 2020-01-10 19:00 UTC  (2+ messages)

[PATCH v6 00/25] RTRS (former IBTRS) rdma transport library and RNBD (former IBNBD) rdma network block device
 2020-01-10 17:38 UTC  (23+ messages)
` [PATCH v6 09/25] rtrs: server: private header with server structs and functions
` [PATCH v6 10/25] rtrs: server: main functionality
` [PATCH v6 11/25] rtrs: server: statistics functions
` [PATCH v6 17/25] rnbd: client: main functionality
` [PATCH v6 18/25] rnbd: client: sysfs interface functions

[RFC PATCH] RDMA/core: avoid potential memory leak in add_one_compat_dev
 2020-01-10 15:55 UTC  (2+ messages)

[PATCH 1/3] infiniband: hw: hfi1: verbs.c: Use built-in RCU list checking
 2020-01-10 15:54 UTC  (4+ messages)

[PATCH] RDMA/core: remove err in iw_query_port
 2020-01-10 15:23 UTC  (2+ messages)

[PATCH v4 for-next] RDMA/hns: Add support for reporting wc as software mode
 2020-01-10 15:18 UTC  (2+ messages)

[PATCH for-next] RDMA/hns: Bugfix for posting a wqe with sge
 2020-01-10 15:18 UTC  (2+ messages)

[PATCH for-next 0/9] Clean ups, refactror, additions
 2020-01-10 15:15 UTC  (2+ messages)

[PATCH] IB/core: Fix build failure without hugepages
 2020-01-09 16:00 UTC  (2+ messages)

[PATCH rdma-core 0/7] verbs: Relaxed ordering memory regions
 2020-01-09 14:04 UTC  (8+ messages)
` [PATCH rdma-core 1/7] Update kernel headers
` [PATCH rdma-core 2/7] verbs: Move free_context from verbs_device_ops to verbs_context_ops
` [PATCH rdma-core 3/7] verbs: Move alloc_context to ioctl
` [PATCH rdma-core 4/7] verbs: Relaxed ordering memory regions
` [PATCH rdma-core 5/7] mlx5: Add optional access flags range to DM
` [PATCH rdma-core 6/7] pyverbs: Add relaxed ordering access flag
` [PATCH rdma-core 7/7] tests: Add relaxed ordering access test

[PATCH rdma-next 00/10] Relaxed ordering memory regions
 2020-01-09  9:38 UTC  (12+ messages)
` [PATCH rdma-next 01/10] net/mlx5: Expose relaxed ordering bits
` [PATCH rdma-next 02/10] RDMA/core: Add UVERBS_METHOD_ASYNC_EVENT_ALLOC
` [PATCH rdma-next 03/10] RDMA/core: Remove ucontext_lock from the uverbs_destry_ufile_hw() path
` [PATCH rdma-next 04/10] RDMA/uverbs: Add ioctl command to get a device context
` [PATCH rdma-next 05/10] RDMA/uverbs: Verify MR access flags
` [PATCH rdma-next 06/10] RDMA/core: Add optional access flags range
` [PATCH rdma-next 07/10] RDMA/efa: Allow passing of optional access flags for MR registration
` [PATCH rdma-next 08/10] RDMA/uverbs: Add new relaxed ordering memory region access flag
` [PATCH rdma-next 09/10] RDMA/core: Add the core support field to METHOD_GET_CONTEXT
` [PATCH rdma-next 10/10] RDMA/mlx5: Set relaxed ordering when requested

Recent trace observed in target code during iSer testing
 2020-01-08 16:18 UTC  (3+ messages)

[PATCH rdma-rc 0/3] ODP Fixes
 2020-01-08 15:24 UTC  (4+ messages)
` [PATCH rdma-rc 3/3] IB/core: Fix ODP with IB_ACCESS_HUGETLB handling

[PATCH RDMA/uverbs] RDMA/uverbs: Protect list_empty() by lock
 2020-01-08 14:23 UTC  (3+ messages)

[PATCH rdma-next v1 0/4] Let IB core distribute cache update events
 2020-01-08 11:42 UTC  (6+ messages)
` [PATCH rdma-next v1 2/4] IB/core: "

[PATCH for-next 0/7] RDMA/hns: Various cleanups
 2020-01-08  1:42 UTC  (4+ messages)
` [PATCH for-next 7/7] RDMA/hns: Fix coding style issues


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).