linux-rdma.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-04-24 15:24:34 to 2020-04-28 20:40:18 UTC [more...]

[GIT PULL] Please pull RDMA subsystem changes
 2020-04-28 20:40 UTC  (2+ messages)

[PATCH v6 00/12] mm/gup: track FOLL_PIN pages
 2020-04-28 20:12 UTC  (11+ messages)
` [PATCH v6 06/12] "
  ` [regression] "
          ` [regression?] "

[PATCH 00/16] Add support to get xmit slave
 2020-04-28 20:04 UTC  (23+ messages)
` [PATCH V6 mlx5-next 01/16] net/core: Introduce netdev_get_xmit_slave
` [PATCH V6 mlx5-next 02/16] bonding: Export skip slave logic to function
` [PATCH V6 mlx5-next 03/16] bonding: Rename slave_arr to usable_slaves
` [PATCH V6 mlx5-next 04/16] bonding/alb: Add helper functions to get the xmit slave
` [PATCH 05/16] bonding: Add helper function to get the xmit slave based on hash
` [PATCH V6 mlx5-next 06/16] bonding: Add helper function to get the xmit slave in rr mode
` [PATCH V6 mlx5-next 07/16] bonding: Add function to get the xmit slave in active-backup mode
` [PATCH V6 mlx5-next 08/16] bonding: Add array of all slaves
` [PATCH V6 mlx5-next 09/16] bonding: Implement ndo_get_xmit_slave
` [PATCH V6 mlx5-next 10/16] RDMA: Group create AH arguments in struct
` [PATCH V6 mlx5-next 11/16] RDMA/core: Add LAG functionality
` [PATCH V6 mlx5-next 12/16] RDMA/core: Get xmit slave for LAG
` [PATCH V6 mlx5-next 13/16] net/mlx5: Change lag mutex lock to spin lock
` [PATCH V6 mlx5-next 14/16] net/mlx5: Add support to get lag physical port
` [PATCH V6 mlx5-next 15/16] RDMA/mlx5: Refactor affinity related code
` [PATCH V6 mlx5-next 16/16] RDMA/mlx5: Set lag tx affinity according to slave

[RFC PATCH] RDMA/siw: Experimental e2e negotiation of GSO usage
 2020-04-28 20:00 UTC  (3+ messages)

[PATCH] net/mlx5e: Remove unneeded semicolon
 2020-04-28 19:49 UTC  (2+ messages)

[PATCH mlx5-next 0/9] Mellanox, mlx5-next updates 2020-04-24
 2020-04-28 19:47 UTC  (14+ messages)
` [PATCH mlx5-next 1/9] net/mlx5: Add support for COPY steering action
` [PATCH mlx5-next 2/9] net/mlx5: Introduce IPsec Connect-X offload hardware bits and structures
` [PATCH mlx5-next 3/9] net/mlx5: Use aligned variable while allocating ICM memory
` [PATCH mlx5-next 4/9] net/mlx5: Refactor imm_inval_pkey field in cqe struct
` [PATCH mlx5-next 5/9] net/mlx5: Add structure layout and defines for MFRL register
` [PATCH mlx5-next 6/9] net/mlx5: Add structure and defines for pci sync for fw update event
` [PATCH mlx5-next 7/9] net/mlx5: Introduce TLS RX offload hardware bits
` [PATCH mlx5-next 8/9] net/mlx5: Add release all pages capability bit
` [PATCH mlx5-next 9/9] net/mlx5: TX WQE Add trailer insertion field

[PATCH v13 00/25] RTRS (former IBTRS) RDMA Transport Library and RNBD (former IBNBD) RDMA Network Block Device
 2020-04-28 18:01 UTC  (27+ messages)
` [PATCH v13 01/25] sysfs: export sysfs_remove_file_self()
` [PATCH v13 02/25] RDMA/rtrs: public interface header to establish RDMA connections
` [PATCH v13 03/25] RDMA/rtrs: private headers with rtrs protocol structs and helpers
` [PATCH v13 04/25] RDMA/rtrs: core: lib functions shared between client and server modules
` [PATCH v13 05/25] RDMA/rtrs: client: private header with client structs and functions
` [PATCH v13 06/25] RDMA/rtrs: client: main functionality
` [PATCH v13 07/25] RDMA/rtrs: client: statistics functions
` [PATCH v13 08/25] RDMA/rtrs: client: sysfs interface functions
` [PATCH v13 09/25] RDMA/rtrs: server: private header with server structs and functions
` [PATCH v13 10/25] RDMA/rtrs: server: main functionality
` [PATCH v13 11/25] RDMA/rtrs: server: statistics functions
` [PATCH v13 12/25] RDMA/rtrs: server: sysfs interface functions
` [PATCH v13 13/25] RDMA/rtrs: include client and server modules into kernel compilation
` [PATCH v13 14/25] RDMA/rtrs: a bit of documentation
` [PATCH v13 15/25] block/rnbd: private headers with rnbd protocol structs and helpers
` [PATCH v13 16/25] block/rnbd: client: private header with client structs and functions
` [PATCH v13 17/25] block/rnbd: client: main functionality
` [PATCH v13 18/25] block/rnbd: client: sysfs interface functions
` [PATCH v13 19/25] block/rnbd: server: private header with server structs and functions
` [PATCH v13 20/25] block/rnbd: server: main functionality
` [PATCH v13 21/25] block/rnbd: server: functionality for IO submitting to block dev
` [PATCH v13 22/25] block/rnbd: server: sysfs interface functions
` [PATCH v13 23/25] block/rnbd: include client and server modules into kernel compilation
` [PATCH v13 24/25] block/rnbd: a bit of documentation
` [PATCH v13 25/25] MAINTAINERS: Add maintainers for RNBD/RTRS modules

[PATCH 1/1] i40iw: remove bogus call to netdev_master_upper_dev_get
 2020-04-28 13:15 UTC 

[PATCH v12 00/25] RTRS (former IBTRS) RDMA Transport Library and RNBD (former IBNBD) RDMA Network Block Device
 2020-04-28 12:41 UTC  (4+ messages)

[PATCH for-next] RDMA/core: Assign the name of device when allocating ib_device
 2020-04-28 12:39 UTC  (15+ messages)

WARNING in ib_unregister_device_queued
 2020-04-28 12:31 UTC  (3+ messages)

[PATCH v3 for-next 0/5] RDMA/hns: Refactor process of buffer allocation and calculation
 2020-04-28 12:28 UTC  (11+ messages)
` [PATCH v3 for-next 1/5] RDMA/hns: Optimize PBL buffer allocation process
  ` [RFC PATCH] RDMA/hns: hns_roce_mr_free() can be static
` [PATCH v3 for-next 2/5] RDMA/hns: Remove unused MTT functions
` [PATCH v3 for-next 3/5] RDMA/hns: Optimize WQE buffer size calculating process
` [PATCH v3 for-next 4/5] RDMA/hns: Move SRQ code to the reasonable place
` [PATCH v3 for-next 5/5] RDMA/hns: Optimize SRQ buffer size calculating process

[PATCH v4 for-next 0/5] RDMA/hns: Optimize PBL buffer allocation process
 2020-04-28 11:03 UTC  (6+ messages)
` [PATCH v4 for-next 1/5] "
` [PATCH v4 for-next 2/5] RDMA/hns: Remove unused MTT functions
` [PATCH v4 for-next 3/5] RDMA/hns: Optimize WQE buffer size calculating process
` [PATCH v4 for-next 4/5] RDMA/hns: Move SRQ code to the reasonable place
` [PATCH v4 for-next 5/5] RDMA/hns: Optimize SRQ buffer size calculating process

[PATCH 00/17 V5] nvme-rdma/nvmet-rdma: Add metadata/T10-PI support
 2020-04-28  9:18 UTC  (25+ messages)
` [PATCH 05/17] nvme-fabrics: Allow user enabling "
` [PATCH 08/17] nvme-rdma: add "
` [PATCH 14/17] nvmet: Add "

[RFC PATCH v5 01/16] RDMA/irdma: Add driver framework definitions
 2020-04-28  0:03 UTC  (13+ messages)

[PATCH] i40iw: Fix error handling in i40iw_manage_arp_cache()
 2020-04-27 17:54 UTC  (3+ messages)

[PATCH rdma-next v1 00/36] Refactor mlx5_ib_create_qp
 2020-04-27 15:46 UTC  (37+ messages)
` [PATCH rdma-next v1 01/36] RDMA/mlx5: Organize QP types checks in one place
` [PATCH rdma-next v1 02/36] RDMA/mlx5: Delete impossible GSI port check
` [PATCH rdma-next v1 03/36] RDMA/mlx5: Perform check if QP creation flow is valid
` [PATCH rdma-next v1 04/36] RDMA/mlx5: Prepare QP allocation for future removal
` [PATCH rdma-next v1 05/36] RDMA/mlx5: Avoid setting redundant NULL for XRC QPs
` [PATCH rdma-next v1 06/36] RDMA/mlx5: Set QP subtype immediately when it is known
` [PATCH rdma-next v1 07/36] RDMA/mlx5: Separate create QP flows to be based on type
` [PATCH rdma-next v1 08/36] RDMA/mlx5: Split scatter CQE configuration for DCT QP
` [PATCH rdma-next v1 09/36] RDMA/mlx5: Update all DRIVER QP places to use QP subtype
` [PATCH rdma-next v1 10/36] RDMA/mlx5: Move DRIVER QP flags check into separate function
` [PATCH rdma-next v1 11/36] RDMA/mlx5: Remove second copy from user for non RSS RAW QPs
` [PATCH rdma-next v1 12/36] RDMA/mlx5: Initial separation of RAW_PACKET QP from common flow
` [PATCH rdma-next v1 13/36] RDMA/mlx5: Delete create QP flags obfuscation
` [PATCH rdma-next v1 14/36] RDMA/mlx5: Process create QP flags in one place
` [PATCH rdma-next v1 15/36] RDMA/mlx5: Use flags_en mechanism to mark QP created with WQE signature
` [PATCH rdma-next v1 16/36] RDMA/mlx5: Change scatter CQE flag to be set like other vendor flags
` [PATCH rdma-next v1 17/36] RDMA/mlx5: Return all configured create flags through query QP
` [PATCH rdma-next v1 18/36] RDMA/mlx5: Process all vendor flags in one place
` [PATCH rdma-next v1 19/36] RDMA/mlx5: Delete unsupported QP types
` [PATCH rdma-next v1 20/36] RDMA/mlx5: Store QP type in the vendor QP structure
` [PATCH rdma-next v1 21/36] RDMA/mlx5: Promote RSS RAW QP attribute check in higher level
` [PATCH rdma-next v1 22/36] RDMA/mlx5: Combine copy of create QP command in RSS RAW QP
` [PATCH rdma-next v1 23/36] RDMA/mlx5: Remove second user copy in create_user_qp
` [PATCH rdma-next v1 24/36] RDMA/mlx5: Rely on existence of udata to separate kernel/user flows
` [PATCH rdma-next v1 25/36] RDMA/mlx5: Delete impossible inlen check
` [PATCH rdma-next v1 26/36] RDMA/mlx5: Globally parse DEVX UID
` [PATCH rdma-next v1 27/36] RDMA/mlx5: Separate XRC_TGT QP creation from common flow
` [PATCH rdma-next v1 28/36] RDMA/mlx5: Separate to user/kernel create QP flows
` [PATCH rdma-next v1 29/36] RDMA/mlx5: Reduce amount of duplication in QP destroy
` [PATCH rdma-next v1 30/36] RDMA/mlx5: Group all create QP parameters to simplify in-kernel interfaces
` [PATCH rdma-next v1 31/36] RDMA/mlx5: Promote RSS RAW QP flags check to higher level
` [PATCH rdma-next v1 32/36] RDMA/mlx5: Handle udate outlen checks in one place
` [PATCH rdma-next v1 33/36] RDMA/mlx5: Copy response to the user "
` [PATCH rdma-next v1 34/36] RDMA/mlx5: Remove redundant destroy QP call
` [PATCH rdma-next v1 35/36] RDMA/mlx5: Consolidate into special function all create QP calls
` [PATCH rdma-next v1 36/36] RDMA/mlx5: Verify that QP is created with RQ or SQ

[PATCH v2] RDMA/rxe: check for error
 2020-04-27  2:34 UTC  (2+ messages)

Purchase Order
 2020-04-26 23:44 UTC 

[PATCH rdma-next] RDMA/mlx5: Add support for drop action in DV steering
 2020-04-26 16:23 UTC  (3+ messages)

[PATCH for-next 0/3] EFA statistics minor updates
 2020-04-26 14:17 UTC  (8+ messages)
` [PATCH for-next 2/3] RDMA/efa: Count mmap failures

[PATCH rdma-rc] IB/mlx4: Test return value of calls to ib_get_cached_pkey
 2020-04-26  7:59 UTC 

[PATCH rdma-rc] IB/core: Fix potential NULL pointer dereference in pkey cache
 2020-04-26  7:58 UTC 

[PATCH v2 for-next 0/5] RDMA/hns: Refactor process of buffer allocation and calculation
 2020-04-26  6:37 UTC  (2+ messages)

[PATCH -next] net/mlx4_core: Add missing iounmap() in error path
 2020-04-26  3:44 UTC  (3+ messages)

[rdma:wip/jgg-for-next] BUILD SUCCESS a97bf49f824e357f1cc5d292e247d05271d32afe
 2020-04-26  0:58 UTC 

[rdma:wip/jgg-for-rc] BUILD SUCCESS f0abc761bbb9418876cc4d1ebc473e4ea6352e42
 2020-04-26  0:56 UTC 

[rdma:for-rc] BUILD SUCCESS 47c370c1a5eea9b2f6f026d49e060c3748c89667
 2020-04-26  0:54 UTC 

[PATCH V5 mlx5-next 00/15] Add support to get xmit slave
 2020-04-25 22:40 UTC  (5+ messages)
` [PATCH V5 mlx5-next 01/16] net/core: Introduce netdev_get_xmit_slave
` [PATCH V5 mlx5-next 10/16] RDMA: Group create AH arguments in struct

[GIT PULL] Please pull NFSoRDMA Client Bugfixes for Linux 5.7
 2020-04-24 21:19 UTC 

[PATCH rdma-next 00/18] Refactor mlx5_ib_create_qp (Part I)
 2020-04-24 20:26 UTC  (6+ messages)
` [PATCH rdma-next 14/18] RDMA/mlx5: Process create QP flags in one place

[PATCH rdma-rc] RDMA/core: Fix race between destroy and release FD object
 2020-04-24 18:58 UTC  (2+ messages)

[PATCH v3] IB/rdmavt: return proper error code
 2020-04-24 18:33 UTC  (2+ messages)

[PATCH] RDMA/rxe: check for error
 2020-04-24 18:30 UTC  (2+ messages)

Request for feedback : Possible use-after-free in routing SA query via netlink
 2020-04-24 18:22 UTC  (2+ messages)

[PATCH v2] IB/rdmavt: return proper error code
 2020-04-24 16:59 UTC  (2+ messages)

remaining flexible-array conversions
 2020-04-24 15:36 UTC  (5+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).