linux-rdma.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-09-03 00:20:53 to 2020-09-08 20:13:05 UTC [more...]

[PATCH rdma-next v1 0/3] Fix in-kernel active_speed type
 2020-09-08 17:21 UTC  (9+ messages)
` [PATCH rdma-next v1 3/3] RDMA: Fix link active_speed size

[PATCH rdma-next 0/4] scatterlist: add sg_alloc_table_append function
 2020-09-08 16:13 UTC  (18+ messages)
` [PATCH rdma-next 2/4] lib/scatterlist: Add support in dynamically allocation of SG entries
` [PATCH rdma-next 3/4] lib/scatterlist: Add support in dynamic allocation of SG table from pages
` [PATCH rdma-next 4/4] RDMA/umem: Move to allocate "
` [PATCH rdma-next 1/4] lib/scatterlist: Refactor sg_alloc_table_from_pages

mcast bugs
 2020-09-08 19:34 UTC 

[PATCH v2 00/17] RDMA: Improve use of umem in DMA drivers
 2020-09-08 13:48 UTC  (24+ messages)
` [PATCH v2 01/17] RDMA/umem: Fix ib_umem_find_best_pgsz() for mappings that cross a page boundary
` [PATCH v2 02/17] RDMA/umem: Prevent small pages from being returned by ib_umem_find_best_pgsz()
` [PATCH v2 03/17] RDMA/umem: Use simpler logic for ib_umem_find_best_pgsz()
` [PATCH v2 04/17] RDMA/umem: Add rdma_umem_for_each_dma_block()
` [PATCH v2 05/17] RDMA/umem: Replace for_each_sg_dma_page with rdma_umem_for_each_dma_block
` [PATCH v2 06/17] RDMA/umem: Split ib_umem_num_pages() into ib_umem_num_dma_blocks()
` [PATCH v2 07/17] RDMA/efa: Use ib_umem_num_dma_pages()
` [PATCH v2 08/17] RDMA/i40iw: "
` [PATCH v2 09/17] RDMA/qedr: Use rdma_umem_for_each_dma_block() instead of open-coding
` [PATCH v2 10/17] RDMA/qedr: Use ib_umem_num_dma_blocks() instead of ib_umem_page_count()
` [PATCH v2 11/17] RDMA/bnxt: Do not use ib_umem_page_count() or ib_umem_num_pages()
` [PATCH v2 12/17] RDMA/hns: Use ib_umem_num_dma_blocks() instead of opencoding
` [PATCH v2 13/17] RDMA/ocrdma: Use ib_umem_num_dma_blocks() instead of ib_umem_page_count()
` [PATCH v2 14/17] RDMA/pvrdma: "
` [PATCH v2 15/17] RDMA/mlx4: Use ib_umem_num_dma_blocks()
` [PATCH v2 16/17] RDMA/qedr: Remove fbo and zbva from the MR
  ` [EXT] "
` [PATCH v2 17/17] RDMA/ocrdma: Remove fbo from MR

[PATCH rdma-next v2 0/9] Restore failure of destroy commands
 2020-09-08 18:56 UTC  (13+ messages)
` [PATCH rdma-next v2 1/9] RDMA: Restore ability to fail on PD deallocate
` [PATCH rdma-next v2 2/9] RDMA: Restore ability to fail on AH destroy
` [PATCH rdma-next v2 3/9] RDMA/mlx5: Issue FW command to destroy SRQ on reentry
` [PATCH rdma-next v2 4/9] RDMA: Restore ability to fail on SRQ destroy
` [PATCH rdma-next v2 5/9] RDMA/core: Delete function indirection for alloc/free kernel CQ
` [PATCH rdma-next v2 6/9] RDMA: Allow fail of destroy CQ
` [PATCH rdma-next v2 7/9] RDMA: Change XRCD destroy return value
` [PATCH rdma-next v2 8/9] RDMA: Restore ability to return error for destroy WQ
` [PATCH rdma-next v2 9/9] RDMA: Make counters destroy symmetrical

[IB/srpt] c804af2c1d: last_state.test.blktests.exit_code.143
 2020-09-08 18:22 UTC  (8+ messages)

[PATCH for-next] RDMA/hns: Avoid unncessary initialization
 2020-09-08  6:52 UTC 

[PATCH net-next] mlx4: make sure to always set the port type
 2020-09-07 17:51 UTC  (11+ messages)

[PATCH v2] RDMA/rtrs-srv: Set .release function for rtrs srv device during device init
 2020-09-07 12:12 UTC  (3+ messages)

[PATCH rdma-next v2 00/14] Track memory allocation with restrack DB help
 2020-09-07 12:21 UTC  (15+ messages)
` [PATCH rdma-next v2 01/14] RDMA/cma: Delete from restrack DB after successful destroy
` [PATCH rdma-next v2 02/14] RDMA/mlx5: Don't call to restrack recursively
` [PATCH rdma-next v2 03/14] RDMA/mlx4: Provide port number for special QPs
` [PATCH rdma-next v2 04/14] RDMA/restrack: Count references to the verbs objects
` [PATCH rdma-next v2 05/14] RDMA/restrack: Simplify restrack tracking in kernel flows
` [PATCH rdma-next v2 06/14] RDMA/restrack: Improve readability in task name management
` [PATCH rdma-next v2 07/14] RDMA/cma: Be strict with attaching to CMA device
` [PATCH rdma-next v2 08/14] RDMA/core: Allow drivers to disable restrack DB
` [PATCH rdma-next v2 09/14] RDMA/counter: Combine allocation and bind logic
` [PATCH rdma-next v2 10/14] RDMA/restrack: Store all special QPs in restrack DB
` [PATCH rdma-next v2 11/14] RDMA/restrack: Make restrack DB mandatory for IB objects
` [PATCH rdma-next v2 12/14] RDMA/restrack: Support all QP types
` [PATCH rdma-next v2 13/14] RDMA/core: Track device memory MRs
` [PATCH rdma-next v2 14/14] RDMA/restrack: Drop valid restrack field as source of ambiguity

[PATCH for-next 0/9] RDMA/hns: Misc Updates
 2020-09-07 13:36 UTC  (10+ messages)
` [PATCH for-next 1/9] RDMA/hns: Refactor process about opcode in post_send()
` [PATCH for-next 2/9] RDMA/hns: Add type check in get/set hw field
` [PATCH for-next 3/9] RDMA/hns: Add interception for resizing SRQs
` [PATCH for-next 4/9] RDMA/hns: Correct typo of hns_roce_create_cq()
` [PATCH for-next 5/9] RDMA/hns: Add check for the validity of sl configuration
` [PATCH for-next 6/9] RDMA/hns: Solve the overflow of the calc_pg_sz()
` [PATCH for-next 7/9] RDMA/hns: Fix the wrong value of rnr_retry when querying qp
` [PATCH for-next 8/9] RDMA/hns: Fix configuration of ack_req_freq in QPC
` [PATCH for-next 9/9] RDMA/hns: Fix missing sq_sig_type when querying QP

Finding the namespace of a struct ib_device
 2020-09-07 13:48 UTC  (13+ messages)

[PATCH v4] RDMA/rtrs-srv: Incorporate ib_register_client into rtrs server init
 2020-09-07 10:36 UTC  (2+ messages)

[PATCH rdma-next v1 00/13] Track memory allocation with restrack DB help
 2020-09-06 15:24 UTC  (12+ messages)
` [PATCH rdma-next v1 01/13] RDMA/cma: Delete from restrack DB after successful destroy
` [PATCH rdma-next v1 07/13] RDMA/core: Allow drivers to disable restrack DB
` [PATCH rdma-next v1 13/13] RDMA/restrack: Drop valid restrack field as source of ambiguity

[PATCH] RDMA/rtrs-srv: Set .release function for rtrs srv device during device init
 2020-09-06 14:02 UTC  (3+ messages)

[PATCH -next] RDMA/bnxt_re: Remove set but not used variable 'qplib_ctx'
 2020-09-06  7:37 UTC  (2+ messages)

[PATCH 00/14] RDMA: Improve use of umem in DMA drivers
 2020-09-04 22:32 UTC  (20+ messages)
` [PATCH 01/14] RDMA/umem: Fix ib_umem_find_best_pgsz() for mappings that cross a page boundary
` [PATCH 02/14] RDMA/umem: Prevent small pages from being returned by ib_umem_find_best_pgsz()
` [PATCH 04/14] RDMA/umem: Add rdma_umem_for_each_dma_block()
` [PATCH 06/14] RDMA/umem: Split ib_umem_num_pages() into ib_umem_num_dma_blocks()
` [PATCH 09/14] RDMA/bnxt: Do not use ib_umem_page_count() or ib_umem_num_pages()
` [PATCH 13/14] RDMA/mlx5: Use ib_umem_num_dma_blocks()
` [PATCH 14/14] RDMA/umem: Rename ib_umem_offset() to ib_umem_dma_offset()

[PATCH v3] IB/isert: fix unaligned immediate-data handling
 2020-09-04 19:50 UTC 

pyverbs testing on rxe
 2020-09-04 18:20 UTC  (2+ messages)

[RFC] Reliable Multicast on top of RTRS
 2020-09-04 15:33 UTC  (5+ messages)

[rdma:wip/jgg-for-next] BUILD SUCCESS 00b3c11879d790f51cac6477abe870936a2323ae
 2020-09-04  4:20 UTC 

[PATCH v4 for-next 0/7] rdma_rxe: add memory windows to rxe
 2020-09-03 22:40 UTC  (8+ messages)
` [PATCH v4 for-next 1/7] ib_user_verbs.h: Added missing WR and WC opcodes
` [PATCH v4 for-next 2/7] rdma_rxe: Separated MEM into MR and MW objects
` [PATCH v4 for-next 3/7] rdma_rxe: enabled "
` [PATCH v4 for-next 4/7] rdma_rxe: Let pools support both keys and indices
` [PATCH v4 for-next 5/7] rdma_rxe: Added alloc_mw and dealloc_mw verbs
` [PATCH v4 for-next 6/7] rdma_rxe: added bind_mw and invalidate_mw verbs
` [PATCH v4 for-next 7/7] rdma_rxe: add memory access through MWs

[PATCH v2] IB/isert: fix unaligned immediate-data handling
 2020-09-03 21:49 UTC  (6+ messages)

[PATCH rdma-next v1 00/10] Restore failure of destroy commands
 2020-09-03 13:42 UTC  (19+ messages)
` [PATCH rdma-next v1 03/10] RDMA/mlx5: Issue FW command to destroy SRQ on reentry
` [PATCH rdma-next v1 04/10] RDMA/mlx5: Fix potential race between destroy and CQE poll
` [PATCH rdma-next v1 05/10] RDMA: Restore ability to fail on SRQ destroy
` [PATCH rdma-next v1 06/10] RDMA/core: Delete function indirection for alloc/free kernel CQ

[PATCH v2 0/5] RDMA: convert tasklets to use new
 2020-09-03 15:06 UTC  (7+ messages)
` [PATCH v2 1/5] RDMA/bnxt_re: convert tasklets to use new tasklet_setup() API
` [PATCH v2 2/5] IB/hfi1: "
` [PATCH v2 3/5] RDMA/i40iw: "
` [PATCH v2 4/5] RDMA/qib: "
` [PATCH v2 5/5] RDMA/rxe: "

[PATCH v3 for-next 0/4] RDMA/hns: Extend some capabilities for HIP09
 2020-09-03 13:16 UTC  (5+ messages)
` [PATCH v3 for-next 1/4] RDMA/hns: Add support for EQE in size of 64 Bytes
` [PATCH v3 for-next 2/4] RDMA/hns: Add support for CQE "
` [PATCH v3 for-next 3/4] RDMA/hns: Add support for QPC in size of 512 Bytes
` [PATCH v3 for-next 4/4] RDMA/hns: Add support for SCCC in size of 64 Bytes

[PATCH] net/mlx5e: kTLS, Fix GFP_KERNEL in spinlock context
 2020-09-03 12:38 UTC  (2+ messages)

[rdma:wip/jgg-for-next] BUILD SUCCESS 4f680cb9f1bb6c2b5cd3574533702334709e50ad
 2020-09-03 12:39 UTC 

[PATCH] RDMA/ucma: Fix resource leak on error path
 2020-09-03  9:35 UTC  (5+ messages)

[rdma:wip/jgg-for-rc] BUILD SUCCESS 28b0865714b315e318ac45c4fc9156f3d4649646
 2020-09-03  9:32 UTC 

[PATCH rdma-next 0/3] Extend mlx5_ib software steering interface
 2020-09-03  7:38 UTC  (4+ messages)
` [PATCH mlx5-next 1/3] RDMA/mlx5: Add sw_owner_v2 bit capability
` [PATCH rdma-next 2/3] RDMA/mlx5: Allow DM allocation for sw_owner_v2 enabled devices
` [PATCH rdma-next 3/3] RDMA/mlx5: Expose TIR and QP ICM address for sw_owner_v2 devices

[PATCH rdma-next] qedr: Add support for user mode XRC-SRQ's
 2020-09-03  7:13 UTC  (3+ messages)
  ` [EXT] "


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).