linux-rdma.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-09-04 22:42:18 to 2020-09-11 13:40:46 UTC [more...]

[PATCH v2 00/17] RDMA: Improve use of umem in DMA drivers
 2020-09-11 13:21 UTC  (27+ messages)
` [PATCH v2 01/17] RDMA/umem: Fix ib_umem_find_best_pgsz() for mappings that cross a page boundary
` [PATCH v2 02/17] RDMA/umem: Prevent small pages from being returned by ib_umem_find_best_pgsz()
` [PATCH v2 04/17] RDMA/umem: Add rdma_umem_for_each_dma_block()
` [PATCH v2 05/17] RDMA/umem: Replace for_each_sg_dma_page with rdma_umem_for_each_dma_block
` [PATCH v2 06/17] RDMA/umem: Split ib_umem_num_pages() into ib_umem_num_dma_blocks()
` [PATCH v2 07/17] RDMA/efa: Use ib_umem_num_dma_pages()
` [PATCH v2 08/17] RDMA/i40iw: "
` [PATCH v2 09/17] RDMA/qedr: Use rdma_umem_for_each_dma_block() instead of open-coding
` [PATCH v2 10/17] RDMA/qedr: Use ib_umem_num_dma_blocks() instead of ib_umem_page_count()
` [PATCH v2 11/17] RDMA/bnxt: Do not use ib_umem_page_count() or ib_umem_num_pages()
` [PATCH v2 12/17] RDMA/hns: Use ib_umem_num_dma_blocks() instead of opencoding
` [PATCH v2 13/17] RDMA/ocrdma: Use ib_umem_num_dma_blocks() instead of ib_umem_page_count()
` [PATCH v2 14/17] RDMA/pvrdma: "
` [PATCH v2 15/17] RDMA/mlx4: Use ib_umem_num_dma_blocks()
` [PATCH v2 16/17] RDMA/qedr: Remove fbo and zbva from the MR
  ` [EXT] "
` [PATCH v2 17/17] RDMA/ocrdma: Remove fbo from MR

KASAN: use-after-free Read in ucma_close (2)
 2020-09-11 12:02 UTC  (3+ messages)

[Spam] We are still waiting for your email
 2020-09-09  8:49 UTC 

[trivial PATCH] treewide: Convert switch/case fallthrough; to break;
 2020-09-11  4:19 UTC  (14+ messages)

[GIT PULL] Please pull RDMA subsystem changes
 2020-09-10 23:38 UTC 

[PATCH rdma-next v1 0/4] scatterlist: add sg_alloc_table_append function
 2020-09-10 13:42 UTC  (5+ messages)
` [PATCH rdma-next v1 1/4] lib/scatterlist: Refactor sg_alloc_table_from_pages
` [PATCH rdma-next v1 2/4] lib/scatterlist: Add support in dynamically allocation of SG entries
` [PATCH rdma-next v1 3/4] lib/scatterlist: Add support in dynamic allocation of SG table from pages
` [PATCH rdma-next v1 4/4] RDMA/umem: Move to allocate "

[PATCH rdma-next 00/10] Prepare drivers to move QP allocation to ib_core
 2020-09-10 14:30 UTC  (12+ messages)
` [PATCH rdma-next 01/10] RDMA/mlx5: Embed GSI QP into general mlx5_ib QP
` [PATCH rdma-next 02/10] RDMA/mlx5: Reuse existing fields in parent QP storage object
` [PATCH rdma-next 03/10] RDMA/mlx5: Change GSI QP to have same creation flow like other QPs
` [PATCH rdma-next 04/10] RDMA/mlx5: Delete not needed GSI QP signature QP type
` [PATCH rdma-next 05/10] RDMA/mlx4: Embed GSI QP into general mlx4_ib QP
` [PATCH rdma-next 06/10] RDMA/mlx4: Prepare QP allocation to remove from the driver
` [PATCH rdma-next 07/10] RDMA/core: Align write and ioctl checks of QP types
` [PATCH rdma-next 08/10] RDMA/drivers: Remove udata check from special QP
` [PATCH rdma-next 09/10] RDMA/mthca: Combine special QP struct with mthca QP
` [PATCH rdma-next 10/10] RDMA/i40iw: Remove intermediate pointer that points to the same struct

[PATCH rdma-next 0/4] Query GID table API
 2020-09-10 14:22 UTC  (5+ messages)
` [PATCH rdma-next 1/4] RDMA/core: Change rdma_get_gid_attr returned error code
` [PATCH rdma-next 2/4] RDMA/core: Modify enum ib_gid_type and enum rdma_network_type
` [PATCH rdma-next 3/4] RDMA/core: Introduce new GID table query API
` [PATCH rdma-next 4/4] RDMA/uverbs: Expose the new GID query API to user space

[PATCH] RDMA/iw_cxgb4: disable delayed ack by default
 2020-09-10 19:14 UTC  (4+ messages)

[PATCH] qedr: fix resource leak in qedr_create_qp
 2020-09-10 16:34 UTC  (2+ messages)
  ` [PATCH v2] "

[PATCH for-next] RDMA/hns: Support inline data in extented sge space for RC
 2020-09-10 13:21 UTC 

[PATCH rdma-next v2 0/9] Restore failure of destroy commands
 2020-09-10 12:24 UTC  (15+ messages)
` [PATCH rdma-next v2 1/9] RDMA: Restore ability to fail on PD deallocate
` [PATCH rdma-next v2 2/9] RDMA: Restore ability to fail on AH destroy
` [PATCH rdma-next v2 3/9] RDMA/mlx5: Issue FW command to destroy SRQ on reentry
` [PATCH rdma-next v2 4/9] RDMA: Restore ability to fail on SRQ destroy
` [PATCH rdma-next v2 5/9] RDMA/core: Delete function indirection for alloc/free kernel CQ
` [PATCH rdma-next v2 6/9] RDMA: Allow fail of destroy CQ
` [PATCH rdma-next v2 7/9] RDMA: Change XRCD destroy return value
` [PATCH rdma-next v2 8/9] RDMA: Restore ability to return error for destroy WQ
` [PATCH rdma-next v2 9/9] RDMA: Make counters destroy symmetrical

[rdma:wip/jgg-for-rc] BUILD SUCCESS 7bf5d303007cd3cc835966bc03a8b1949a59c823
 2020-09-10 10:51 UTC 

[PATCH rdma-next 0/8] RDMA/qedr: various fixes
 2020-09-10  6:29 UTC  (3+ messages)
  ` [EXT] "

[PATCH v4 for-next 0/7] rdma_rxe: add memory windows to rxe
 2020-09-09 18:45 UTC  (3+ messages)
` [PATCH v4 for-next 1/7] ib_user_verbs.h: Added missing WR and WC opcodes

[Bug 209213] New: ib_srp: Already connected to target port with
 2020-09-09 17:21 UTC 

[PATCH for-next] RDMA/iw_cxgb4: disable delayed ack by default
 2020-09-09 15:37 UTC 

[PATCH] qedr: fix resource leak in qedr_create_qp
 2020-09-09 16:55 UTC 

Bug report: in-place build exposes fixup headers, breaking static_assert
 2020-09-09 16:06 UTC  (2+ messages)

[PATCH v3] IB/isert: fix unaligned immediate-data handling
 2020-09-09 16:49 UTC  (2+ messages)

[PATCH] RDMA: error code handling
 2020-09-09 16:38 UTC  (2+ messages)

[PATCH v4] RDMA/rtrs-srv: Incorporate ib_register_client into rtrs server init
 2020-09-09 16:35 UTC  (3+ messages)

[PATCH v2] RDMA/rtrs-srv: Set .release function for rtrs srv device during device init
 2020-09-09 16:28 UTC  (4+ messages)

[PATCH for-next] RDMA/hns: Avoid unncessary initialization
 2020-09-09 16:24 UTC  (2+ messages)

[PATCH -next] RDMA/bnxt_re: Remove set but not used variable 'qplib_ctx'
 2020-09-09 16:21 UTC  (3+ messages)

[PATCH rdma-next] RDMA/core: Change how failing destroy is handled during uobj abort
 2020-09-09 16:19 UTC  (2+ messages)

[RFC] Reliable Multicast on top of RTRS
 2020-09-09 11:42 UTC  (5+ messages)

[PATCH for-next] RDMA/hns: Create QP/CQ with selected QPN/CQN for bank load balance
 2020-09-09  9:09 UTC 

[PATCH v2 for-next 0/9] RDMA/hns: Misc Updates
 2020-09-09  8:57 UTC  (10+ messages)
` [PATCH v2 for-next 1/9] RDMA/hns: Refactor process about opcode in post_send()
` [PATCH v2 for-next 2/9] RDMA/hns: Add type check in get/set hw field
` [PATCH v2 for-next 3/9] RDMA/hns: Add interception for resizing SRQs
` [PATCH v2 for-next 4/9] RDMA/hns: Correct typo of hns_roce_create_cq()
` [PATCH v2 for-next 5/9] RDMA/hns: Add check for the validity of sl configuration
` [PATCH v2 for-next 6/9] RDMA/hns: Solve the overflow of the calc_pg_sz()
` [PATCH v2 for-next 7/9] RDMA/hns: Fix the wrong value of rnr_retry when querying qp
` [PATCH v2 for-next 8/9] RDMA/hns: Fix configuration of ack_req_freq in QPC
` [PATCH v2 for-next 9/9] RDMA/hns: Fix missing sq_sig_type when querying QP

[PATCH for-next 0/9] RDMA/hns: Misc Updates
 2020-09-09  3:41 UTC  (12+ messages)
` [PATCH for-next 1/9] RDMA/hns: Refactor process about opcode in post_send()
` [PATCH for-next 2/9] RDMA/hns: Add type check in get/set hw field
` [PATCH for-next 3/9] RDMA/hns: Add interception for resizing SRQs
` [PATCH for-next 4/9] RDMA/hns: Correct typo of hns_roce_create_cq()
` [PATCH for-next 5/9] RDMA/hns: Add check for the validity of sl configuration
` [PATCH for-next 6/9] RDMA/hns: Solve the overflow of the calc_pg_sz()
` [PATCH for-next 7/9] RDMA/hns: Fix the wrong value of rnr_retry when querying qp
` [PATCH for-next 8/9] RDMA/hns: Fix configuration of ack_req_freq in QPC
` [PATCH for-next 9/9] RDMA/hns: Fix missing sq_sig_type when querying QP

[IB/srpt] c804af2c1d: last_state.test.blktests.exit_code.143
 2020-09-09  2:01 UTC  (9+ messages)

[PATCH rdma-next v1 0/3] Fix in-kernel active_speed type
 2020-09-08 17:21 UTC  (9+ messages)
` [PATCH rdma-next v1 3/3] RDMA: Fix link active_speed size

[PATCH rdma-next 0/4] scatterlist: add sg_alloc_table_append function
 2020-09-08 16:13 UTC  (16+ messages)
` [PATCH rdma-next 2/4] lib/scatterlist: Add support in dynamically allocation of SG entries
` [PATCH rdma-next 3/4] lib/scatterlist: Add support in dynamic allocation of SG table from pages
` [PATCH rdma-next 4/4] RDMA/umem: Move to allocate "
` [PATCH rdma-next 1/4] lib/scatterlist: Refactor sg_alloc_table_from_pages

mcast bugs
 2020-09-08 19:34 UTC 

[PATCH net-next] mlx4: make sure to always set the port type
 2020-09-07 17:51 UTC  (11+ messages)

[PATCH rdma-next v2 00/14] Track memory allocation with restrack DB help
 2020-09-07 12:21 UTC  (15+ messages)
` [PATCH rdma-next v2 01/14] RDMA/cma: Delete from restrack DB after successful destroy
` [PATCH rdma-next v2 02/14] RDMA/mlx5: Don't call to restrack recursively
` [PATCH rdma-next v2 03/14] RDMA/mlx4: Provide port number for special QPs
` [PATCH rdma-next v2 04/14] RDMA/restrack: Count references to the verbs objects
` [PATCH rdma-next v2 05/14] RDMA/restrack: Simplify restrack tracking in kernel flows
` [PATCH rdma-next v2 06/14] RDMA/restrack: Improve readability in task name management
` [PATCH rdma-next v2 07/14] RDMA/cma: Be strict with attaching to CMA device
` [PATCH rdma-next v2 08/14] RDMA/core: Allow drivers to disable restrack DB
` [PATCH rdma-next v2 09/14] RDMA/counter: Combine allocation and bind logic
` [PATCH rdma-next v2 10/14] RDMA/restrack: Store all special QPs in restrack DB
` [PATCH rdma-next v2 11/14] RDMA/restrack: Make restrack DB mandatory for IB objects
` [PATCH rdma-next v2 12/14] RDMA/restrack: Support all QP types
` [PATCH rdma-next v2 13/14] RDMA/core: Track device memory MRs
` [PATCH rdma-next v2 14/14] RDMA/restrack: Drop valid restrack field as source of ambiguity

Finding the namespace of a struct ib_device
 2020-09-07 13:48 UTC  (13+ messages)

[PATCH rdma-next v1 00/13] Track memory allocation with restrack DB help
 2020-09-06 15:24 UTC  (12+ messages)
` [PATCH rdma-next v1 01/13] RDMA/cma: Delete from restrack DB after successful destroy
` [PATCH rdma-next v1 07/13] RDMA/core: Allow drivers to disable restrack DB
` [PATCH rdma-next v1 13/13] RDMA/restrack: Drop valid restrack field as source of ambiguity

[PATCH] RDMA/rtrs-srv: Set .release function for rtrs srv device during device init
 2020-09-06 14:02 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).