linux-rdma.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Tariq Toukan <ttoukan.linux@gmail.com>
To: Eric Dumazet <eric.dumazet@gmail.com>,
	"Gustavo A. R. Silva" <gustavoars@kernel.org>,
	Tariq Toukan <tariqt@nvidia.com>,
	"David S. Miller" <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>
Cc: netdev@vger.kernel.org, linux-rdma@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-hardening@vger.kernel.org
Subject: Re: [PATCH][net-next] net/mlx4: Use array_size() helper in copy_to_user()
Date: Wed, 29 Sep 2021 20:45:17 +0300	[thread overview]
Message-ID: <e2f72429-91c5-7140-c13d-35d4623092de@gmail.com> (raw)
In-Reply-To: <16ae2d2d-3aba-82b2-0bd8-90f7d0367a62@gmail.com>



On 9/29/2021 8:21 PM, Eric Dumazet wrote:
> 
> 
> On 9/29/21 3:24 AM, Tariq Toukan wrote:
>>
>>
>> On 9/28/2021 11:17 PM, Gustavo A. R. Silva wrote:
>>> Use array_size() helper instead of the open-coded version in
>>> copy_to_user(). These sorts of multiplication factors need
>>> to be wrapped in array_size().
>>>
>>> Link: https://github.com/KSPP/linux/issues/160
>>> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
>>> ---
>>>    drivers/net/ethernet/mellanox/mlx4/cq.c | 3 ++-
>>>    1 file changed, 2 insertions(+), 1 deletion(-)
>>>
>>> diff --git a/drivers/net/ethernet/mellanox/mlx4/cq.c b/drivers/net/ethernet/mellanox/mlx4/cq.c
>>> index f7053a74e6a8..4d4f9cf9facb 100644
>>> --- a/drivers/net/ethernet/mellanox/mlx4/cq.c
>>> +++ b/drivers/net/ethernet/mellanox/mlx4/cq.c
>>> @@ -314,7 +314,8 @@ static int mlx4_init_user_cqes(void *buf, int entries, int cqe_size)
>>>                buf += PAGE_SIZE;
>>>            }
>>>        } else {
>>> -        err = copy_to_user((void __user *)buf, init_ents, entries * cqe_size) ?
>>> +        err = copy_to_user((void __user *)buf, init_ents,
>>> +                   array_size(entries, cqe_size)) ?
>>>                -EFAULT : 0;
>>>        }
>>>   
>>
>> Thanks for your patch.
>> Reviewed-by: Tariq Toukan <tariqt@nvidia.com>
> 
> Not sure why avoiding size_t overflows would make this code safer.
> init_ents contains PAGE_SIZE bytes...
> 
> BTW
> 
> Is @entries guaranteed to be a power of two ?

Yes.

> 
> This function seems to either copy one chunk ( <= PAGE_SIZE),
> or a number of full pages.
> 

Exactly. No remainder handling is needed, for the reason you mentioned 
above.

      reply	other threads:[~2021-09-29 17:45 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-09-28 20:17 [PATCH][net-next] net/mlx4: Use array_size() helper in copy_to_user() Gustavo A. R. Silva
2021-09-29 10:24 ` Tariq Toukan
2021-09-29 17:21   ` Eric Dumazet
2021-09-29 17:45     ` Tariq Toukan [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e2f72429-91c5-7140-c13d-35d4623092de@gmail.com \
    --to=ttoukan.linux@gmail.com \
    --cc=davem@davemloft.net \
    --cc=eric.dumazet@gmail.com \
    --cc=gustavoars@kernel.org \
    --cc=kuba@kernel.org \
    --cc=linux-hardening@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rdma@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=tariqt@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).