linux-rockchip.lists.infradead.org archive mirror
 help / color / mirror / Atom feed
From: Kever Yang <kever.yang@rock-chips.com>
To: Yifeng Zhao <yifeng.zhao@rock-chips.com>,
	miquel.raynal@bootlin.com, richard@nod.at, vigneshr@ti.com,
	robh+dt@kernel.org
Cc: devicetree@vger.kernel.org, heiko@sntech.de,
	linux-kernel@vger.kernel.org, linux-rockchip@lists.infradead.org,
	linux-mtd@lists.infradead.org,
	linux-arm-kernel@lists.infradead.org
Subject: Re: [PATCH v10 0/8] Add Rockchip NFC drivers for RK3308 and others
Date: Wed, 14 Oct 2020 08:35:51 +0800	[thread overview]
Message-ID: <5288a031-5dbe-e32d-f706-a70a8109110d@rock-chips.com> (raw)
In-Reply-To: <20200930020710.7394-1-yifeng.zhao@rock-chips.com>

Hi Miquel and maintainers,

     This patch set seems ready for upstream, could you pick and merge 
to linux-mtd?


Thanks,

- Kever

On 2020/9/30 上午10:07, Yifeng Zhao wrote:
> Rockchp's NFC(Nand Flash Controller) has four versions: V600, V622, V800 and
> V900.This series patch can support all four versions.
>
>
> Changes in v10:
> - Fix compile error on master v5.9-rc7
>
> Changes in v9:
> - The nfc->buffer will realloc while the page size of the second mtd
>    is large than the first one
> - Fix coding style.
> - Remove struct rk_nfc_clk.
> - Prepend some function with rk_nfc_.
> - Replace function readl_poll_timeout_atomic with readl_relaxed_poll_timeout.
> - Remove function rk_nfc_read_byte and rk_nfc_write_byte.
> - Don't select the die if 'check_only == true' in function rk_nfc_exec_op.
> - Modify function rk_nfc_write_page and rk_nfc_write_page_raw.
>
> Changes in v8:
> - Fix make dt_binding_check error
>
> Changes in v7:
> - Fix some wrong define
> - Rebase to linux-next.
> - Fix coding style.
> - Reserved 4 bytes at the beginning of the oob area.
> - Page raw read and write included ecc data.
>
> Changes in v6:
> - Fix some wrong define
> - Modified the definition of compatible
> - The mtd->name set by NAND label property.
> - Add some comments.
> - Fix compile error.
>
> Changes in v5:
> - Fix some wrong define.
> - Add boot-medium define.
> - Remove some compatible define.
> - Add boot blocks support  with different ECC for bootROM.
> - Rename rockchip-nand.c to rockchip-nand-controller.c.
> - Unification of other variable names.
> - Remove some compatible define.
>
> Changes in v4:
> - The compatible define with rkxx_nfc.
> - Add assigned-clocks.
> - Fix some wrong defineChanges in.
> - Define platform data structure for the register offsets.
> - The compatible define with rkxx_nfc.
> - Use SET_SYSTEM_SLEEP_PM_OPS to define PM_OPS.
> - Use exec_op instead of legacy hooks.
>
> Changes in v3:
> - Change the title for the dt-bindings.
>
> Changes in v2:
> - Fix compile error.
> - Include header files sorted by file name.
>
> Yifeng Zhao (8):
>    dt-bindings: mtd: Describe Rockchip RK3xxx NAND flash controller
>    mtd: rawnand: rockchip: NFC drivers for RK3308, RK2928 and others
>    MAINTAINERS: add maintainers to ROCKCHIP NFC
>    arm64: dts: rockchip: Add NFC node for RK3308 SoC
>    arm64: dts: rockchip: Add NFC node for PX30 SoC
>    arm: dts: rockchip: Add NFC node for RV1108 SoC
>    arm: dts: rockchip: Add NFC node for RK2928 and other SoCs
>    arm: dts: rockchip: Add NFC node for RK3036 SoC
>
>   .../mtd/rockchip,nand-controller.yaml         |  162 ++
>   MAINTAINERS                                   |    4 +-
>   arch/arm/boot/dts/rk3036.dtsi                 |   52 +
>   arch/arm/boot/dts/rk3xxx.dtsi                 |    9 +
>   arch/arm/boot/dts/rv1108.dtsi                 |   11 +
>   arch/arm64/boot/dts/rockchip/px30.dtsi        |   15 +
>   arch/arm64/boot/dts/rockchip/rk3308.dtsi      |   15 +
>   drivers/mtd/nand/raw/Kconfig                  |   12 +
>   drivers/mtd/nand/raw/Makefile                 |    1 +
>   .../mtd/nand/raw/rockchip-nand-controller.c   | 1455 +++++++++++++++++
>   10 files changed, 1734 insertions(+), 2 deletions(-)
>   create mode 100644 Documentation/devicetree/bindings/mtd/rockchip,nand-controller.yaml
>   create mode 100644 drivers/mtd/nand/raw/rockchip-nand-controller.c
>



_______________________________________________
Linux-rockchip mailing list
Linux-rockchip@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-rockchip

      parent reply	other threads:[~2020-10-14  0:36 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-09-30  2:07 [PATCH v10 0/8] Add Rockchip NFC drivers for RK3308 and others Yifeng Zhao
2020-09-30  2:07 ` [PATCH v10 1/8] dt-bindings: mtd: Describe Rockchip RK3xxx NAND flash controller Yifeng Zhao
2020-10-05 14:41   ` Rob Herring
2020-10-14  0:25   ` Kever Yang
2020-09-30  2:07 ` [PATCH v10 2/8] mtd: rawnand: rockchip: NFC drivers for RK3308, RK2928 and others Yifeng Zhao
2020-10-14  0:26   ` Kever Yang
2020-09-30  2:07 ` [PATCH v10 3/8] MAINTAINERS: add maintainers to ROCKCHIP NFC Yifeng Zhao
2020-10-14  0:26   ` Kever Yang
2020-09-30  2:07 ` [PATCH v10 4/8] arm64: dts: rockchip: Add NFC node for RK3308 SoC Yifeng Zhao
2020-10-14  0:26   ` Kever Yang
2020-09-30  2:08 ` [PATCH v10 5/8] arm64: dts: rockchip: Add NFC node for PX30 SoC Yifeng Zhao
2020-09-30  2:09   ` [PATCH v10 6/8] arm: dts: rockchip: Add NFC node for RV1108 SoC Yifeng Zhao
2020-10-14  0:27     ` Kever Yang
2020-09-30  2:09   ` [PATCH v10 7/8] arm: dts: rockchip: Add NFC node for RK2928 and other SoCs Yifeng Zhao
2020-10-14  0:27     ` Kever Yang
2020-09-30  2:09   ` [PATCH v10 8/8] arm: dts: rockchip: Add NFC node for RK3036 SoC Yifeng Zhao
2020-10-14  0:28     ` Kever Yang
2020-10-14  0:27   ` [PATCH v10 5/8] arm64: dts: rockchip: Add NFC node for PX30 SoC Kever Yang
2020-10-14  0:35 ` Kever Yang [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5288a031-5dbe-e32d-f706-a70a8109110d@rock-chips.com \
    --to=kever.yang@rock-chips.com \
    --cc=devicetree@vger.kernel.org \
    --cc=heiko@sntech.de \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=linux-rockchip@lists.infradead.org \
    --cc=miquel.raynal@bootlin.com \
    --cc=richard@nod.at \
    --cc=robh+dt@kernel.org \
    --cc=vigneshr@ti.com \
    --cc=yifeng.zhao@rock-chips.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).