linux-scsi.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Alim Akhtar <alim.akhtar@gmail.com>
To: Bart Van Assche <bvanassche@acm.org>
Cc: "Martin K . Petersen" <martin.petersen@oracle.com>,
	"James E . J . Bottomley" <jejb@linux.vnet.ibm.com>,
	linux-scsi@vger.kernel.org, Bean Huo <beanhuo@micron.com>,
	Can Guo <cang@codeaurora.org>, Avri Altman <avri.altman@wdc.com>,
	Stanley Chu <stanley.chu@mediatek.com>,
	Tomas Winkler <tomas.winkler@intel.com>,
	Alim Akhtar <alim.akhtar@samsung.com>
Subject: Re: [PATCH 2/6] ufs: Make ufshcd_add_command_trace() easier to read
Date: Fri, 27 Dec 2019 06:47:35 +0530	[thread overview]
Message-ID: <CAGOxZ52yTEa9c-pYZxW6R4QppqR543ksnep7v521=AcjQFiA0g@mail.gmail.com> (raw)
In-Reply-To: <20191224220248.30138-3-bvanassche@acm.org>

On Wed, Dec 25, 2019 at 3:34 AM Bart Van Assche <bvanassche@acm.org> wrote:
>
> Since the lrbp->cmd expression occurs multiple times, introduce a new
> local variable to hold that pointer. This patch does not change any
> functionality.
>
FYMI, Any Advantage of doing this? or it just we don't want to fetch
cmd from lrbp every time? I mean in terms of execution speed.

> Cc: Bean Huo <beanhuo@micron.com>
> Cc: Can Guo <cang@codeaurora.org>
> Cc: Avri Altman <avri.altman@wdc.com>
> Cc: Stanley Chu <stanley.chu@mediatek.com>
> Cc: Tomas Winkler <tomas.winkler@intel.com>
> Signed-off-by: Bart Van Assche <bvanassche@acm.org>
> ---
Reviewed-by: Alim Akhtar <alim.akhtar@samsung.com>
>  drivers/scsi/ufs/ufshcd.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/scsi/ufs/ufshcd.c b/drivers/scsi/ufs/ufshcd.c
> index 48f2f94d51bc..acc84e964e8f 100644
> --- a/drivers/scsi/ufs/ufshcd.c
> +++ b/drivers/scsi/ufs/ufshcd.c
> @@ -327,27 +327,27 @@ static void ufshcd_add_command_trace(struct ufs_hba *hba,
>         u8 opcode = 0;
>         u32 intr, doorbell;
>         struct ufshcd_lrb *lrbp = &hba->lrb[tag];
> +       struct scsi_cmnd *cmd = lrbp->cmd;
>         int transfer_len = -1;
>
>         if (!trace_ufshcd_command_enabled()) {
>                 /* trace UPIU W/O tracing command */
> -               if (lrbp->cmd)
> +               if (cmd)
>                         ufshcd_add_cmd_upiu_trace(hba, tag, str);
>                 return;
>         }
>
> -       if (lrbp->cmd) { /* data phase exists */
> +       if (cmd) { /* data phase exists */
>                 /* trace UPIU also */
>                 ufshcd_add_cmd_upiu_trace(hba, tag, str);
> -               opcode = (u8)(*lrbp->cmd->cmnd);
> +               opcode = cmd->cmnd[0];
>                 if ((opcode == READ_10) || (opcode == WRITE_10)) {
>                         /*
>                          * Currently we only fully trace read(10) and write(10)
>                          * commands
>                          */
> -                       if (lrbp->cmd->request && lrbp->cmd->request->bio)
> -                               lba =
> -                                 lrbp->cmd->request->bio->bi_iter.bi_sector;
> +                       if (cmd->request && cmd->request->bio)
> +                               lba = cmd->request->bio->bi_iter.bi_sector;
>                         transfer_len = be32_to_cpu(
>                                 lrbp->ucd_req_ptr->sc.exp_data_transfer_len);
>                 }



-- 
Regards,
Alim

  parent reply	other threads:[~2019-12-27  1:18 UTC|newest]

Thread overview: 28+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-24 22:02 [PATCH 0/6] Six UFS patches Bart Van Assche
2019-12-24 22:02 ` [PATCH 1/6] ufs: Fix indentation in ufshcd_query_attr_retry() Bart Van Assche
2019-12-25  7:16   ` Stanley Chu
2019-12-25  8:17   ` Can Guo
2019-12-27  1:13   ` Alim Akhtar
2019-12-24 22:02 ` [PATCH 2/6] ufs: Make ufshcd_add_command_trace() easier to read Bart Van Assche
2019-12-25  7:16   ` Stanley Chu
2019-12-25  8:17   ` Can Guo
2019-12-27  1:17   ` Alim Akhtar [this message]
2019-12-24 22:02 ` [PATCH 3/6] ufs: Make ufshcd_prepare_utp_scsi_cmd_upiu() " Bart Van Assche
2019-12-25  7:17   ` Stanley Chu
2019-12-25  8:18   ` Can Guo
2019-12-24 22:02 ` [PATCH 4/6] ufs: Fix a race condition in the tracing code Bart Van Assche
2019-12-25 10:59   ` Can Guo
2019-12-26 17:35     ` Bart Van Assche
2019-12-27  5:50       ` Can Guo
2019-12-27  1:21   ` Alim Akhtar
2019-12-24 22:02 ` [PATCH 5/6] ufs: Remove superfluous memory barriers Bart Van Assche
2019-12-25 10:31   ` Can Guo
2019-12-26 17:36     ` Bart Van Assche
2019-12-24 22:02 ` [PATCH 6/6] ufs: Remove the SCSI timeout handler Bart Van Assche
2019-12-25 11:02   ` Can Guo
2019-12-27  1:24   ` Alim Akhtar
2020-05-28  9:47   ` Can Guo
2020-05-28 16:12     ` Bart Van Assche
2020-05-29  1:39       ` Can Guo
2020-05-29  3:56         ` Bart Van Assche
2020-01-03  2:58 ` [PATCH 0/6] Six UFS patches Martin K. Petersen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAGOxZ52yTEa9c-pYZxW6R4QppqR543ksnep7v521=AcjQFiA0g@mail.gmail.com' \
    --to=alim.akhtar@gmail.com \
    --cc=alim.akhtar@samsung.com \
    --cc=avri.altman@wdc.com \
    --cc=beanhuo@micron.com \
    --cc=bvanassche@acm.org \
    --cc=cang@codeaurora.org \
    --cc=jejb@linux.vnet.ibm.com \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=stanley.chu@mediatek.com \
    --cc=tomas.winkler@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).