linux-scsi.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Finn Thain <fthain@telegraphics.com.au>
To: Daniel Wagner <dwagner@suse.de>
Cc: Bart Van Assche <bvanassche@acm.org>,
	"Martin K. Petersen" <martin.petersen@oracle.com>,
	"James E. J. Bottomley" <jejb@linux.vnet.ibm.com>,
	linux-scsi@vger.kernel.org, Hannes Reinecke <hare@suse.de>,
	Arun Easi <aeasi@marvell.com>,
	Himanshu Madhani <himanshu.madhani@oracle.com>,
	Nilesh Javali <njavali@marvell.com>,
	Quinn Tran <qutran@marvell.com>, Martin Wilck <mwilck@suse.com>,
	Roman Bolshakov <r.bolshakov@yadro.com>
Subject: Re: [PATCH v7 15/15] qla2xxx: Fix endianness annotations in source files
Date: Wed, 20 May 2020 17:39:55 +1000 (AEST)	[thread overview]
Message-ID: <alpine.LNX.2.22.394.2005201726250.8@nippy.intranet> (raw)
In-Reply-To: <20200519152401.oh6cewdru3fu7ogd@beryllium.lan>

Hi Daniel,

On Tue, 19 May 2020, Daniel Wagner wrote:

> 
> I tried to figure out if with the patch the compiler generates different 
> object code. Looking through the filtered diff between the two versions 
> I haven't really found any relevant changes. All looks good.
> 
> In case someone wants to look at the diffs:
> 
> https://monom.org/data/qla2xxx/qla2xxx-endianness-annotations.diff 
> https://monom.org/data/qla2xxx/qla2xxx-endianness-annotations-filtered.diff
> 

I agree. qla2xxx-endianness-annotations.diff seems to be noise.

The differences in the __bug_table sections and ql_dbg() call sites are 
presumably caused by line break changes. Perhaps they can be squelched by 
inserting blank lines at the appropriate places (for either build). That 
could probably be automated.

Once the comments are stripped from the .s files, we are left with 
differences like this,

@@ -21204,75 +21205,75 @@
        .quad   .LC146
        .quad   .LC146
        .quad   .LC272
+       .local  __key.63281
+       .comm   __key.63281,0,1
        .local  __key.63280
        .comm   __key.63280,0,1
-       .local  __key.63279
-       .comm   __key.63279,0,1
        .align 16
-       .type   __func__.63244, @object
-       .size   __func__.63244, 22
-__func__.63244:
+       .type   __func__.63245, @object
+       .size   __func__.63245, 22
+__func__.63245:
        .string "qlt_24xx_config_rings"
        .align 16
        .type   __func__.61306, @object
        .size   __func__.61306, 26

...

@@ -2571,7 +2571,7 @@
        .pushsection __jump_table,  "aw" 
         .balign 8 
        .long 1b - ., .L218 - .         #
-        .quad __UNIQUE_ID_ddebug285.63134+40 + 0 - .   #,
+        .quad __UNIQUE_ID_ddebug285.63135+40 + 0 - .   #,
        .popsection 
        
 # 0 "" 2

It would be nice to know how these symbols end up with different numbering 
between builds because it makes a real mess of the diff.

I wonder whether the Reproducible Builds project has developed any 
techniques that could be applied here.
https://reproducible-builds.org/

  reply	other threads:[~2020-05-20  7:39 UTC|newest]

Thread overview: 24+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-05-18 21:16 [PATCH v7 00/15] Fix qla2xxx endianness annotations Bart Van Assche
2020-05-18 21:16 ` [PATCH v7 01/15] qla2xxx: Fix spelling of a variable name Bart Van Assche
2020-05-18 21:16 ` [PATCH v7 02/15] qla2xxx: Suppress two recently introduced compiler warnings Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 03/15] qla2xxx: Simplify the functions for dumping firmware Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 04/15] qla2xxx: Sort BUILD_BUG_ON() statements alphabetically Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 05/15] qla2xxx: Add more BUILD_BUG_ON() statements Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 06/15] qla2xxx: Make a gap in struct qla2xxx_offld_chain explicit Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 07/15] qla2xxx: Increase the size of struct qla_fcp_prio_cfg to FCP_PRIO_CFG_SIZE Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 08/15] qla2xxx: Change two hardcoded constants into offsetof() / sizeof() expressions Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 09/15] qla2xxx: Use register names instead of register offsets Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 10/15] qla2xxx: Fix the code that reads from mailbox registers Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 11/15] qla2xxx: Change {RD,WRT}_REG_*() function names from upper case into lower case Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 12/15] qla2xxx: Cast explicitly to uint16_t / uint32_t Bart Van Assche
2020-05-19 15:29   ` Daniel Wagner
2020-05-18 21:17 ` [PATCH v7 13/15] qla2xxx: Use make_handle() instead of open-coding it Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 14/15] qla2xxx: Fix endianness annotations in header files Bart Van Assche
2020-05-18 21:17 ` [PATCH v7 15/15] qla2xxx: Fix endianness annotations in source files Bart Van Assche
2020-05-19 15:24   ` Daniel Wagner
2020-05-20  7:39     ` Finn Thain [this message]
2020-05-20  8:56       ` Daniel Wagner
2020-05-24  4:28         ` Finn Thain
2020-05-24 15:50           ` Bart Van Assche
2020-05-24 23:45             ` Finn Thain
2020-05-20  2:30 ` [PATCH v7 00/15] Fix qla2xxx endianness annotations Martin K. Petersen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LNX.2.22.394.2005201726250.8@nippy.intranet \
    --to=fthain@telegraphics.com.au \
    --cc=aeasi@marvell.com \
    --cc=bvanassche@acm.org \
    --cc=dwagner@suse.de \
    --cc=hare@suse.de \
    --cc=himanshu.madhani@oracle.com \
    --cc=jejb@linux.vnet.ibm.com \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=mwilck@suse.com \
    --cc=njavali@marvell.com \
    --cc=qutran@marvell.com \
    --cc=r.bolshakov@yadro.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).