linux-security-module.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] ima: Fix function name error in comment.
@ 2021-04-06  2:12 Jiele Zhao
  2021-04-09  1:20 ` Jiele Zhao
  2021-04-09 18:50 ` Mimi Zohar
  0 siblings, 2 replies; 3+ messages in thread
From: Jiele Zhao @ 2021-04-06  2:12 UTC (permalink / raw)
  To: zohar, jmorris; +Cc: linux-security-module, linux-kernel, Jiele Zhao

The original function name was ima_path_check().  The policy parsing
still supports PATH_CHECK.   Commit 9bbb6cad0173 ("ima: rename
ima_path_check to ima_file_check") renamed the function to
ima_file_check(), but missed modifying the function name in the
comment.

Fixes: 9bbb6cad0173 ("ima: rename ima_path_check to ima_file_check").

Signed-off-by: Jiele Zhao <unclexiaole@gmail.com>
---
 security/integrity/ima/ima_main.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c
index 9ef748ea829f..03bef720ab44 100644
--- a/security/integrity/ima/ima_main.c
+++ b/security/integrity/ima/ima_main.c
@@ -482,7 +482,7 @@ int ima_bprm_check(struct linux_binprm *bprm)
 }
 
 /**
- * ima_path_check - based on policy, collect/store measurement.
+ * ima_file_check - based on policy, collect/store measurement.
  * @file: pointer to the file to be measured
  * @mask: contains MAY_READ, MAY_WRITE, MAY_EXEC or MAY_APPEND
  *
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH v2] ima: Fix function name error in comment.
  2021-04-06  2:12 [PATCH v2] ima: Fix function name error in comment Jiele Zhao
@ 2021-04-09  1:20 ` Jiele Zhao
  2021-04-09 18:50 ` Mimi Zohar
  1 sibling, 0 replies; 3+ messages in thread
From: Jiele Zhao @ 2021-04-09  1:20 UTC (permalink / raw)
  To: zohar, jmorris; +Cc: linux-security-module, linux-kernel

Hi Mimi,

On 2021/4/6 10:12, Jiele Zhao wrote:
> The original function name was ima_path_check().  The policy parsing
> still supports PATH_CHECK.   Commit 9bbb6cad0173 ("ima: rename
> ima_path_check to ima_file_check") renamed the function to
> ima_file_check(), but missed modifying the function name in the
> comment.
>
> Fixes: 9bbb6cad0173 ("ima: rename ima_path_check to ima_file_check").
>
> Signed-off-by: Jiele Zhao <unclexiaole@gmail.com>
> ---
>   security/integrity/ima/ima_main.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/security/integrity/ima/ima_main.c b/security/integrity/ima/ima_main.c
> index 9ef748ea829f..03bef720ab44 100644
> --- a/security/integrity/ima/ima_main.c
> +++ b/security/integrity/ima/ima_main.c
> @@ -482,7 +482,7 @@ int ima_bprm_check(struct linux_binprm *bprm)
>   }
>   
>   /**
> - * ima_path_check - based on policy, collect/store measurement.
> + * ima_file_check - based on policy, collect/store measurement.
>    * @file: pointer to the file to be measured
>    * @mask: contains MAY_READ, MAY_WRITE, MAY_EXEC or MAY_APPEND
>    *

This is the [patch v2] based on your suggestion. Does this meet the 
requirements ?



^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v2] ima: Fix function name error in comment.
  2021-04-06  2:12 [PATCH v2] ima: Fix function name error in comment Jiele Zhao
  2021-04-09  1:20 ` Jiele Zhao
@ 2021-04-09 18:50 ` Mimi Zohar
  1 sibling, 0 replies; 3+ messages in thread
From: Mimi Zohar @ 2021-04-09 18:50 UTC (permalink / raw)
  To: Jiele Zhao, jmorris; +Cc: linux-security-module, linux-kernel

On Tue, 2021-04-06 at 02:12 +0000, Jiele Zhao wrote:
> The original function name was ima_path_check().  The policy parsing
> still supports PATH_CHECK.   Commit 9bbb6cad0173 ("ima: rename
> ima_path_check to ima_file_check") renamed the function to
> ima_file_check(), but missed modifying the function name in the
> comment.
> 
> Fixes: 9bbb6cad0173 ("ima: rename ima_path_check to ima_file_check").
> 
> Signed-off-by: Jiele Zhao <unclexiaole@gmail.com>

Thanks, Jiele.

Applied to
git://git.kernel.org/pub/scm/linux/kernel/git/zohar/linux-integrity.git 
next-integrity

Mimi


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2021-04-09 18:50 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-04-06  2:12 [PATCH v2] ima: Fix function name error in comment Jiele Zhao
2021-04-09  1:20 ` Jiele Zhao
2021-04-09 18:50 ` Mimi Zohar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).