linux-sparse.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-10-20 21:10:45 to 2020-11-27 22:46:45 UTC [more...]

[PATCH 0/7] simplify logical negation
 2020-11-27 22:44 UTC  (22+ messages)
` [PATCH 1/7] not: add testcases for canonicalization & simplification of negations
        ` [PATCH 0/6] 'bits translation' simplification
          ` [PATCH 1/6] add testscases for 'bits translation' optimization
          ` [PATCH 2/6] factorize SEL(x, OP(y,z), y) into OP(SEL(x, z, 0), y)
          ` [PATCH 3/6] add helper is_power_of_2()
          ` [PATCH 4/6] add helper is_pow2()
          ` [PATCH 5/6] add log base 2 function: log2_exact()
          ` [PATCH 6/6] convert SEL(x & BIT1, BIT2, 0) into SHIFT(x & BIT1, S)
          ` [PATCH 7/7] move up instructions blocking if-conversion
` [PATCH 2/7] canon: put PSEUDO_ARGs in canonical order too
` [PATCH 3/7] canon: put PSEUDO_REGs "
` [PATCH 4/7] canon: simplify calculation of canonical order
` [PATCH 5/7] opcode: add helpers opcode_negate() & opcode_swap()
` [PATCH 6/7] not: simplify (~x {&,|,^} x) --> {0,~0,~0}
` [PATCH 7/7] not: simplify ((x cmp y) {&,|,^} (x !cmp y)) --> {0,1,1}

[PATCH 0/8] factorization of distributive operations
 2020-11-27 16:49 UTC  (9+ messages)
` [PATCH 1/8] add testscases for some "
` [PATCH 2/8] reassoc: add helper can_move_to()
` [PATCH 3/8] add helper make_insn_pair() & swap_insn()
` [PATCH 4/8] add helper replace_binop()
` [PATCH 5/8] refactor simplify_add() to avoid code duplication (preparation)
` [PATCH 6/8] refactor simplify_add() to avoid code duplication
` [PATCH 7/8] factorize (x OP1 z) OP2 (y OP1 z) into (x OP2 y) OP1 z
` [PATCH 8/8] factorize SHIFT(x, s) OP SHIFT(y, s) into SHIFT((x OP y), s)

[PATCH] fix trivial_phi()
 2020-11-26 20:35 UTC 

[PATCH] symaddr: give a type to OP_SYMADDR
 2020-11-22 17:50 UTC 

[PATCH 0/2] cleanup REPEAT_SYMBOL_CLEANUP & kill_insn()
 2020-11-21 22:46 UTC  (3+ messages)
` [PATCH 1/2] remove unneeded REPEAT_SYMBOL_CLEANUP
` [PATCH 2/2] simplify kill_insn() of unops and unop-ish instructions

[PATCH 0/4] simplification of computed goto
 2020-11-21 22:07 UTC  (8+ messages)
` [PATCH 1/4] add testcases for COMPUTEDGOTO simplification
` [PATCH 2/4] simplify OP_COMPUTEDGOTO with unique and known target
` [PATCH 3/4] simplify CGOTO(SEL(x, L1, L2)) into CBR x, L1, L2
` [PATCH 4/4] add a new instruction for label-as-value

[PATCH] fix kill_insn(OP_SETVAL)
 2020-11-21 17:16 UTC 

[PATCH net-next v2] net: add annotation for sock_{lock,unlock}_fast
 2020-11-20 18:43 UTC  (2+ messages)

Re: typeof and operands in named address spaces
 2020-11-19  8:11 UTC  (10+ messages)
        ` [PATCH] casts should drop qualifiers

[PATCH] simplify unrestricted postop
 2020-11-18 22:46 UTC 

[PATCH 0/5] fix qualifier dropping
 2020-11-18 21:11 UTC  (6+ messages)
` [PATCH 1/5] unqual: add testcases
` [PATCH 2/5] unqual: unqualify_type() should check for null ctypes
` [PATCH 3/5] unqual: comma expressions should drop qualifiers
` [PATCH 4/5] unqual: statement "
` [PATCH 5/5] unqual: pre- & post-increment/decrement should *not* "

[PATCH net-next] net: add annotation for sock_{lock,unlock}_fast
 2020-11-17 17:36 UTC  (5+ messages)

[PATCH] linearize: remove unneeded forward declarations
 2020-11-17 17:27 UTC 

[PATCH 0/2] simplify CBR-CBR on the same condition
 2020-11-17  1:10 UTC  (3+ messages)
` [PATCH 1/2] rebuild dominance tree during CFG cleanup
` [PATCH 2/2] simplify CBR-CBR on the same condition

[PATCH 0/8] cfg: early CFG simplification
 2020-11-17  0:42 UTC  (13+ messages)
` [PATCH 1/8] testcase: avoid UNDEF
` [PATCH 2/8] cfg: add testcase for phi-adjusting during BB merge
` [PATCH 3/8] cfg: extract merge_bb() from pack_basic_blocks()
` [PATCH 4/8] cfg: adjust phi-sources when merging BBs
` [PATCH 5/8] cfg: adjust phi-nodes "
` [PATCH 6/8] cfg: add missing REPEAT_CFG_CLEANUP
` [PATCH 7/8] cfg: call simplify_memops() unconditionally
` [PATCH 8/8] cfg: early CFG simplification

Corporate and Personal Loan/
 2020-11-10 14:11 UTC 

Corporate and Personal Loan *
 2020-11-15 16:44 UTC 

[PATCH 0/4] doc: one patch and three improvements
 2020-11-14 10:23 UTC  (5+ messages)
` [PATCH 1/4] doc: fix extracted autodoc when short description ends with a ?
` [PATCH 2/4] doc: add some doc to flowgraph.h
` [PATCH 3/4] doc: add header for optimization related documentation
` [PATCH 4/4] doc: add header for flow simplification "

[PATCH] add missing REPEAT_CFG_CLEANUP
 2020-11-14  9:46 UTC 

[PATCH] simplify OP_COMPUTEDGOTO with known target
 2020-11-14  8:22 UTC 

[PATCH] doc: Sphinx's option ':noindex:' have been rename into ':noindexentry:'
 2020-11-13  6:56 UTC 

[PATCH] doc: add some doc about using NULL or VOID in ptrlists
 2020-11-13  6:56 UTC 

[PATCH 0/2] adjust phi-sources when merging BBs
 2020-11-11 23:52 UTC  (3+ messages)
` [PATCH 1/2] add testcase for phi-adjusting during BB merge
` [PATCH 2/2] adjust phi-sources when merging BBs

[PATCH] linearize: fix a couple of 'selfcheck' warnings
 2020-11-12  0:06 UTC  (2+ messages)

Corporate and Personal Loan *
 2020-11-11  8:32 UTC 

[PATCH] fix linear_isdigit()'s itype
 2020-11-09 22:49 UTC 

'context imbalance' warnings
 2020-11-09 22:13 UTC  (4+ messages)

[PATCH 00/16] simplify & canonicalize compares
 2020-11-08  1:21 UTC  (17+ messages)
` [PATCH 01/16] cmp: adapt testcase for compares' canonicalization
` [PATCH 02/16] cmp: add testcases for the simplification of compares
` [PATCH 03/16] cmp: add signed/unsigned to opcode table
` [PATCH 04/16] cmp: move some code in a separate function: simplify_compare_constant()
` [PATCH 05/16] cmp: use a few helpers for the simplification of compares
` [PATCH 06/16] cmp: canonicalize unsigned (x {<,>=} C) --> (x {<=,>} C-1)
` [PATCH 07/16] cmp: simplify unsigned (x {<=,>} UMAX) into {1,0}
` [PATCH 08/16] cmp: canonicalize unsigned compare with UMAX or UMAX-1
` [PATCH 09/16] cmp: canonicalize unsigned (x {<=,>} SMAX)
` [PATCH 10/16] cmp: simplify sext(x) cmp C --> x cmp C
  ` [PATCH 11/16] cmp: simplify zext(x) "
  ` [PATCH 12/16] cmp: simplify sext(x) cmps {SMAX,SMIN}
  ` [PATCH 13/16] cmp: canonicalize sext(x) cmpu C (with C >= SMAX)
  ` [PATCH 14/16] cmp: simplify zext(x) cmps C
  ` [PATCH 15/16] cmp: simplify zext(x) cmpu C
  ` [PATCH 16/16] cmp: simplify compares and sign/zero extend

"warning: context imbalance" in kernel/bpf/hashtab.c
 2020-11-08  0:52 UTC  (18+ messages)

[PATCH 0/5] simplify SEL(SEL, ...), ...)
 2020-11-07 19:12 UTC  (8+ messages)
` [PATCH 1/5] select: add some testcases for select simplification
` [PATCH 2/5] select: simplify SEL(SEL(x, C, 0), y, z) --> SEL(x, y, z) and its dual
` [PATCH 3/5] select: simplify SEL(SEL(x, C, 0), C, 0) --> SEL(x, C, 0) == cond
` [PATCH 4/5] select: simplify SEL(SEL(x, C1, C2), y, z) --> y (with C1, C2 != 0)
` [PATCH 5/5] select: simplify handling of constant cond or src1 == src2

[PATCH] simplify SEL(x == y, x, y) and friends
 2020-11-07 13:39 UTC 

[PATCH] add debug helpers: show_insn_bb() & show_insn_entry()
 2020-11-07 13:08 UTC 

[PATCH] do not call simplify_instruction() if already removed
 2020-11-07 12:57 UTC 

[PATCH 0/2] testsuite: add new tags: check-output-{match,returns}
 2020-10-31 22:08 UTC  (5+ messages)
` [PATCH 1/2] testsuite: add a new tag: check-output-match
` [PATCH 2/2] testsuite: add a new tag: check-output-returns

[PATCH] linearize __builtin_isdigit()
 2020-10-30 16:36 UTC 

[PATCH] fix usage count in linearize_fma()
 2020-10-30 15:36 UTC 

[PATCH] fix init_linearized_builtins()
 2020-10-30 15:36 UTC 

[PATCH 0/2] give an explicit type to operands of comparisons
 2020-10-29 22:59 UTC  (3+ messages)
` [PATCH 1/2] eval_insn: add testcases for incorrect type in OP_SET_*
` [PATCH 2/2] eval_insn: give an explicit type to operands of comparisons

Sparse improvements & regressions for Linux v5.9-rc1 -> v5.10-rc1
 2020-10-27 21:03 UTC 

[PATCH] handle more graciously labels with no statement
 2020-10-26 23:39 UTC  (6+ messages)

[PATCH] warn on all missing parameter types
 2020-10-25 17:40 UTC 

[PATCH] replace nbr_users() by multi_users()
 2020-10-25 13:59 UTC 

[PATCH] add testcase for missing inline definition
 2020-10-25 13:58 UTC 

[PATCH 0/2] fix testing if a OP_CALL's function is pure
 2020-10-25 13:09 UTC  (3+ messages)
` [PATCH 1/2] add helper first_symbol()
` [PATCH 2/2] fix testing if a OP_CALL's function is pure

[PATCH] kill dead instructions before any other simplifications
 2020-10-25 12:52 UTC 

[PATCH] OP_CALL should use the full function type
 2020-10-25 12:31 UTC 

[PATCH] linearize: OP_INLINE do not use the function symbol
 2020-10-24 22:47 UTC 

[PATCH 0/2] simplify and canonicalize unsigned compares
 2020-10-23 19:08 UTC  (5+ messages)
` [PATCH 1/2] simplify unsigned compares against 0
` [PATCH 2/2] canonicalize unsigned compares against 0 or 1

[PATCH 0/9] basic unop simplifications
 2020-10-23 16:39 UTC  (10+ messages)
` [PATCH 1/9] unop: add testcases for "
` [PATCH 2/9] unop: prepare simplify_unop() to handle more cases
` [PATCH 3/9] unop: simplify -(x + C) --> -C - x
` [PATCH 4/9] unop: simplify -(x - y) --> y "
` [PATCH 5/9] unop: simplify -(~x) --> x + 1
` [PATCH 6/9] unop: simplify ~(x + C) --> ~C - x
` [PATCH 7/9] unop: simplify ~(C - x) --> x + ~C
` [PATCH 8/9] unop: simplify ~(x ^ C) --> x ^ ~C
` [PATCH 9/9] unop: simplify ~(-x) --> x - 1

[PATCH] cleanup linearize_cond_branch()
 2020-10-23 16:00 UTC 

[PATCH] llvm: fix crash with llvm-11 / use real phi-nodes
 2020-10-22 22:53 UTC 

[PATCH 00/22] essential OP_ADD & OP_SUB simplifications
 2020-10-20 21:10 UTC  (3+ messages)
` [PATCH 21/22] sub: simplify (x - y) + y --> x
` [PATCH 22/22] sub: simplify x + (y - x) --> y


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).