linux-sparse.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-02-14 20:42:47 to 2021-07-29 21:21:06 UTC [more...]

[PATCH 0/5] small fixes for the symbolic checker
 2021-07-29 21:20 UTC  (6+ messages)
` [PATCH 1/5] scheck: better diagnostic for unsupported instructions
` [PATCH 2/5] scheck: ignore OP_NOP & friends
` [PATCH 3/5] scheck: constants are untyped
` [PATCH 4/5] scheck: mkvar() with target or input type
` [PATCH 5/5] scheck: fix type of operands in casts

[PATCH] fix missing itype in SEL(x, 0/1, 1/0) --> (x ==/!= 0)
 2021-07-29 21:14 UTC 

new sparse release?
 2021-07-27 12:48 UTC  (3+ messages)

check idea: include sparse as a library in C++
 2021-07-26 18:28 UTC  (2+ messages)

Project
 2021-07-13 20:31 UTC 

Projects
 2021-07-12 18:49 UTC 

Servicio de la flota
 2021-07-08  7:31 UTC 

Get back to me
 2021-07-05 19:02 UTC 

Proposal
 2021-06-30  8:14 UTC 

Projects
 2021-06-09 12:09 UTC 

Proposal
 2021-06-09 12:10 UTC 

Servicio de la flota
 2021-06-02  8:00 UTC 

Personal
 2021-05-10 14:06 UTC 

[tglx-devel:x86/l1dflush 7/9] arch/x86/mm/tlb.c:354:13: sparse: sparse: incorrect type in initializer (different address spaces)
 2021-04-27 19:54 UTC  (4+ messages)

check idea: warn when mixing signedness in ?: operator (got bitten by this recently)
 2021-04-21 13:46 UTC  (7+ messages)

Servicio de la flota
 2021-04-21  7:31 UTC 

[PATCH] TRUNC(x) {==,!=} C --> AND(x,M) {==,!=} C
 2021-04-18 19:41 UTC 

[PATCH] canonicalize ((x & M) == M) --> ((x & M) != 0) when M is a power-of-2
 2021-04-18 18:46 UTC 

[SPARSE 0/4] fix/improve canonicalization of signed compares
 2021-04-18 15:32 UTC  (5+ messages)
` [SPARSE 1/4] canonicalize constant signed compares toward zero
` [SPARSE 2/4] add testcases for AND(x > 0, x <= C) --> x u<= C
` [SPARSE 3/4] add helper is_positive()
` [SPARSE 4/4] simplify AND(x >= 0, x < C) --> (unsigned)x < C

[PATCH 0/3] remove early simplification of casts during evaluation
 2021-04-18 11:56 UTC  (4+ messages)
` [PATCH 1/3] add testcases for simplification of casts
` [PATCH 2/3] simplify TRUNC(NOT(x)) --> NOT(TRUNC(x))
` [PATCH 3/3] remove early simplification of casts during evaluation

[PATCH 00/10] simplify and canonicalize signed compares
 2021-04-17 18:20 UTC  (3+ messages)

[PATCH] no needs to use MARK_CURRENT_DELETED() for multi-jumps
 2021-04-17 17:46 UTC  (4+ messages)

[PATCH v2 0/8] scheck: add a symbolic checker
 2021-04-13 16:42 UTC  (11+ messages)
` [PATCH v2 1/8] export declare_builtins()
` [PATCH v2 2/8] builtin: define a symbol_op for a generic op acting on integer
` [PATCH v2 3/8] .gitignore is a bit too greedy
` [PATCH v2 4/8] scheck: add a symbolic checker
` [PATCH v2 5/8] scheck: assert_eq()
` [PATCH v2 6/8] scheck: allow multiple assertions
` [PATCH v2 7/8] scheck: assert_const()
` [PATCH v2 8/8] scheck: support pre-conditions via __assume()

[PATCH 0/8] scheck: add a symbolic checker for sparse
 2021-04-11 22:05 UTC  (11+ messages)
` [PATCH 1/8] export declare_builtins()
` [PATCH 2/8] builtin: define a symbol_op for a generic op acting on integer
` [PATCH 3/8] .gitignore is a bit too greedy
` [PATCH 4/8] scheck: add a symbolic checker
` [PATCH 5/8] scheck: assert_eq()
` [PATCH 6/8] scheck: allow multiple assertions
` [PATCH 7/8] scheck: assert_const()
` [PATCH 8/8] scheck: support pre-conditions via __assume()

[PATCH 0/5] kill more dead stores
 2021-04-10 22:30 UTC  (6+ messages)
` [PATCH 1/5] add testcases for stores simplifications
` [PATCH 2/5] extract try_to_kill_store() from kill_dominated_stores()
` [PATCH 3/5] volatile stores are never dead
` [PATCH 4/5] kill parent's dead stores too
` [PATCH 5/5] kill redundant stores (local)

[PATCH] add some notes about pseudos being typeless
 2021-04-10 19:02 UTC 

[PATCH] linear: only allocate call instructions when needed
 2021-04-10 15:16 UTC 

[PATCH] fix null-pointer crash with with ident same as one of the attributes
 2021-04-04 19:37 UTC 

[PATCH 0/4] fix 2 problems with phi-sources
 2021-04-02 20:25 UTC  (5+ messages)
` [PATCH 1/4] additional testcase for remove_merging_phisrc()
` [PATCH 2/4] correctly count phi arguments
` [PATCH 3/4] better check validity of phi-sources
` [PATCH 4/4] fix remove_merging_phisrc()

Bidding invitation
 2021-03-31  7:16 UTC 

Servicio de la flota
 2021-03-29  7:55 UTC 

[PATCH 00/11] pragma once: treewide conversion
 2021-03-23 10:03 UTC  (12+ messages)

[PATCH 0/6] memops: small cleanups
 2021-03-21 17:08 UTC  (7+ messages)
` [PATCH 1/6] memops: dominates()s first arg is redundant
` [PATCH 2/6] memops: find_dominating_parents()s generation "
` [PATCH 3/6] memops: remove obsolete comment
` [PATCH 4/6] memops: do not mess up with phisource's source ident
` [PATCH 5/6] memops: avoid using first_pseudo()
` [PATCH 6/6] memops: we can kill addresses unconditionally

[PATCH 0/6] use an helper to add an instruction to a BB
 2021-03-21 16:16 UTC  (7+ messages)
` [PATCH 1/6] add insert_last_instruction()
` [PATCH 2/6] replace add_instruction_to_end() by insert_last_instruction()
` [PATCH 3/6] let insert_select() use insert_last_instruction()
` [PATCH 4/6] let insert_phis() "
` [PATCH 5/6] let find_dominating_parents() "
` [PATCH 6/6] let ssa_rename_phi() "

[PATCH] testsuite: add option '-r' to 'test-suite format'
 2021-03-21 12:54 UTC 

[PATCH 00/13] remove phi-sources from removed branches
 2021-03-21 12:35 UTC  (14+ messages)
` [PATCH 01/13] Revert "simplify CBR-CBR on the same condition"
` [PATCH 02/13] add testcases to check if phi-sources from removed targets are removed too
` [PATCH 03/13] remove insert_branch() redundant arg
` [PATCH 04/13] simplify remove_parent()
` [PATCH 05/13] fold remove_parent() into insert_branch()
` [PATCH 06/13] let insert_branch() reuse the terminating instruction
` [PATCH 07/13] move insert_branch() to flow.c
` [PATCH 08/13] let insert_branch() return a status
` [PATCH 09/13] rename insert_branch() to convert_to_jump()
` [PATCH 10/13] add remove_phisources()
` [PATCH 11/13] fix phisources during CBR-BR conversion
` [PATCH 12/13] use convert_to_jump() when converting a CBR with same targets
` [PATCH 13/13] fix phisources during SWITCH-BR conversion

[for-stable-4.19 PATCH v2 0/2] Backport patches to fix KASAN+LKDTM with recent clang on ARM64
 2021-03-20 10:57 UTC  (3+ messages)
` [for-stable-4.19 PATCH v2 1/2] vmlinux.lds.h: Create section for protection against instrumentation

[for-stable-4.19 PATCH 0/2] Backport patches to fix KASAN+LKDTM with recent clang on ARM64
 2021-03-19 22:48 UTC  (7+ messages)
` [for-stable-4.19 PATCH 1/2] vmlinux.lds.h: Create section for protection against instrumentation

[PATCH 0/9] simplify CMP(AND(x,M), C) and CMP(OR(x,M), C)
 2021-03-10 21:49 UTC  (10+ messages)
` [PATCH 1/9] change testing of signed compares against SMIN or SMAX
` [PATCH 2/9] add testcases for constant compares against AND/OR
` [PATCH 3/9] simplify (x & M) cmps C
` [PATCH 4/9] simplify (x & M) cmpu C
` [PATCH 5/9] simplify (x & M) cmps 0
` [PATCH 6/9] simplify (x & M) {==,!=} C
` [PATCH 7/9] simplify (x | "
` [PATCH 8/9] simplify (x | M) cmps C
` [PATCH 9/9] simplify (x | M) cmpu C

[PATCH 0/4] fix SSA conversion of mismatched memops
 2021-03-09 23:42 UTC  (5+ messages)
` [PATCH 1/4] ssa: add some testcases for "
` [PATCH 2/4] ssa: the sparse set is not needed
` [PATCH 3/4] ssa: avoid SSA conversion of packed bitfields
` [PATCH 4/4] ssa: fix conversion with mismatched size or offset

[PATCH 0/6] small changes to ptrlist API
 2021-03-06 22:05 UTC  (15+ messages)
` [PATCH 1/6] ptrlist: ~fix TYPEOF()
` [PATCH 2/6] ptrlist: change TYPEOF() into PTRLIST_TYPE()
` [PATCH 3/6] ptrlist: add pop_ptr_list()
` [PATCH 4/6] ptrlist: use ptr_list_nth() instead of linearize_ptr_list()
` [PATCH 5/6] ptrlist: make linearize_ptr_list() generic
` [PATCH 6/6] ptrlist: change return value of linearize_ptr_list()/ptr_list_to_array()

[PATCH] phi-sources can only have a single user (or none)
 2021-03-06 21:17 UTC  (2+ messages)

Servicio de la flota
 2021-03-03  8:31 UTC 

[PATCH] pre-proc: do some path normalization
 2021-03-01  0:44 UTC 

[PATCH 0/4] small reorganization of OP_SLICE
 2021-02-28 21:40 UTC  (9+ messages)
` [PATCH 1/4] slice: remove unneeded len from OP_SLICE
` [PATCH 2/4] slice: remove unneeded nr_nrbits from EXPR_SLICE
` [PATCH 3/4] slice: OP_SLICE needs the source's type: make it a kind of unop
` [PATCH 4/4] slice: display the source's size, like for unops

[PATCH] linearize.h: fix some 'selfcheck' warnings
 2021-02-28 21:33 UTC  (2+ messages)

[PATCH] asm-out0: fix a test failure on 32-bit systems
 2021-02-28 21:31 UTC  (2+ messages)

[PATCH] fix eval of the assignment of a non-restricted value to a restricted variable
 2021-02-25 22:05 UTC 

[PATCH 0/5] teach memory simplification about ASM instructions
 2021-02-21 22:34 UTC  (6+ messages)
` [PATCH 1/5] reorg dominates()
` [PATCH 2/5] asm-mem: add testcase for missing reload after asm memops
` [PATCH 3/5] asm-mem: does it clobber memory?
` [PATCH 4/5] asm-mem: does it output to memory?
` [PATCH 5/5] asm-mem: teach dominates() about OP_ASM

[PATCH 0/3] output *memory* operands need their address as *input*
 2021-02-21 22:28 UTC  (4+ messages)
` [PATCH 1/3] asm: add testcase for problem with output addresses
` [PATCH 2/3] asm: factor out add_asm_rule() from add_asm_{in,out}put()
` [PATCH 3/3] asm: output *memory* operands need their address as *input*

[PATCH] expand __builtin_object_size()
 2021-02-21 22:17 UTC 

[PATCH v2 2/4] usb: typec: tps6598x: Add trace event for status register
 2021-02-15 11:32 UTC  (5+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).