linux-staging.lists.linux.dev archive mirror
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Greg KH <gregkh@linuxfoundation.org>,
	Michael Straube <straube.linux@gmail.com>
Cc: Larry.Finger@lwfinger.net, phil@philpotter.co.uk,
	martin@kaiser.cx,  fmdefrancesco@gmail.com,
	linux-staging@lists.linux.dev,  linux-kernel@vger.kernel.org
Subject: Re: [PATCH] staging: r8188eu: refactor rtw_is_cckrates{only}_included()
Date: Tue, 17 Aug 2021 11:36:09 -0700	[thread overview]
Message-ID: <11a09af791c5453175a6bdac1c51bd9fcb0685bd.camel@perches.com> (raw)
In-Reply-To: <YRv4po3sLcH9VLuo@kroah.com>

On Tue, 2021-08-17 at 19:57 +0200, Greg KH wrote:
> On Mon, Aug 16, 2021 at 09:31:25PM +0200, Michael Straube wrote:
> > Refactor functions rtw_is_cckrates_included() and
> > rtw_is_cckratesonly_included(). Add new helper function rtw_is_cckrate()
> > that allows to make the code more compact. Improves readability and
> > slightly reduces object file size. Change the return type to bool to
> > reflect that the functions return boolean values.
[]
> > diff --git a/drivers/staging/r8188eu/core/rtw_ieee80211.c b/drivers/staging/r8188eu/core/rtw_ieee80211.c
[]
> > +bool rtw_is_cckratesonly_included(u8 *rate)
> >  {
> > -	u32 i = 0;
> > +	u8 r;
> >  
> > 
> > -	while (rate[i] != 0) {
> > -		if  ((((rate[i]) & 0x7f) != 2) && (((rate[i]) & 0x7f) != 4) &&
> > -		     (((rate[i]) & 0x7f) != 11)  && (((rate[i]) & 0x7f) != 22))
> > +	while ((r = *rate++)) {
> 
> Ick, no.
> 
> While it might be fun to play with pointers like this, trying to
> determine the precidence issues involved with reading from, and then
> incrementing the pointer like this is crazy.
> 
> The original was obvious as to how it was walking through the array.

It's sad to believe *ptr++ is not obvious to you as it's very commonly
used in the kernel sources (over 10,000 instances).



  reply	other threads:[~2021-08-17 21:03 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-16 19:31 [PATCH] staging: r8188eu: refactor rtw_is_cckrates{only}_included() Michael Straube
2021-08-16 20:09 ` Fabio M. De Francesco
2021-08-17 17:57 ` Greg KH
2021-08-17 18:36   ` Joe Perches [this message]
2021-08-17 18:49     ` Greg KH
2021-08-17 18:59       ` Joe Perches
2021-08-18  6:23       ` Fabio M. De Francesco
2021-08-18  6:33         ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=11a09af791c5453175a6bdac1c51bd9fcb0685bd.camel@perches.com \
    --to=joe@perches.com \
    --cc=Larry.Finger@lwfinger.net \
    --cc=fmdefrancesco@gmail.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-staging@lists.linux.dev \
    --cc=martin@kaiser.cx \
    --cc=phil@philpotter.co.uk \
    --cc=straube.linux@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).