linux-trace-devel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] kernelshark: Rename tracefs_get_tracing_dir() to the new  tracefs_tracing_dir()
@ 2020-12-21 19:24 Steven Rostedt
  2021-01-04 17:03 ` Yordan Karadzhov (VMware)
  0 siblings, 1 reply; 2+ messages in thread
From: Steven Rostedt @ 2020-12-21 19:24 UTC (permalink / raw)
  To: Linux Trace Devel; +Cc: Tzvetomir Stoyanov, Yordan Karadzhov

From: "Steven Rostedt (VMware)" <rostedt@goodmis.org>

libtracefs is renaming tracefs_get_tracing_dir() to tracefs_tracing_dir() as
there is no "tracefs_put_tracing_dir()" for this function. Since libtracefs
has not been officially released, it is fine to break API, as it is with
kernelshark v2.0 has not yet been official released that uses the old API.

Signen-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
---
 src/KsCaptureDialog.cpp | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/src/KsCaptureDialog.cpp b/src/KsCaptureDialog.cpp
index 63fd5d6..7253ab6 100644
--- a/src/KsCaptureDialog.cpp
+++ b/src/KsCaptureDialog.cpp
@@ -26,7 +26,7 @@ extern "C" {
 
 static inline tep_handle *local_events()
 {
-	return tracefs_local_events(tracefs_get_tracing_dir());
+	return tracefs_local_events(tracefs_tracing_dir());
 }
 
 /**
@@ -204,7 +204,7 @@ QStringList KsCaptureControl::_getPlugins()
 	QStringList pluginList;
 	char **all_plugins;
 
-	all_plugins = tracefs_tracers(tracefs_get_tracing_dir());
+	all_plugins = tracefs_tracers(tracefs_tracing_dir());
 
 	if (!all_plugins)
 		return pluginList;
-- 
2.25.4


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] kernelshark: Rename tracefs_get_tracing_dir() to the new tracefs_tracing_dir()
  2020-12-21 19:24 [PATCH] kernelshark: Rename tracefs_get_tracing_dir() to the new tracefs_tracing_dir() Steven Rostedt
@ 2021-01-04 17:03 ` Yordan Karadzhov (VMware)
  0 siblings, 0 replies; 2+ messages in thread
From: Yordan Karadzhov (VMware) @ 2021-01-04 17:03 UTC (permalink / raw)
  To: Steven Rostedt, Linux Trace Devel; +Cc: Tzvetomir Stoyanov



On 21.12.20 г. 21:24 ч., Steven Rostedt wrote:
> From: "Steven Rostedt (VMware)" <rostedt@goodmis.org>
> 
> libtracefs is renaming tracefs_get_tracing_dir() to tracefs_tracing_dir() as
> there is no "tracefs_put_tracing_dir()" for this function. Since libtracefs
> has not been officially released, it is fine to break API, as it is with
> kernelshark v2.0 has not yet been official released that uses the old API.
> 
> Signen-off-by: Steven Rostedt (VMware) <rostedt@goodmis.org>
> ---
>   src/KsCaptureDialog.cpp | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/src/KsCaptureDialog.cpp b/src/KsCaptureDialog.cpp
> index 63fd5d6..7253ab6 100644
> --- a/src/KsCaptureDialog.cpp
> +++ b/src/KsCaptureDialog.cpp
> @@ -26,7 +26,7 @@ extern "C" {
>   
>   static inline tep_handle *local_events()
>   {
> -	return tracefs_local_events(tracefs_get_tracing_dir());
> +	return tracefs_local_events(tracefs_tracing_dir());
>   }
>   
>   /**
> @@ -204,7 +204,7 @@ QStringList KsCaptureControl::_getPlugins()
>   	QStringList pluginList;
>   	char **all_plugins;
>   
> -	all_plugins = tracefs_tracers(tracefs_get_tracing_dir());
> +	all_plugins = tracefs_tracers(tracefs_tracing_dir());
>   
>   	if (!all_plugins)
>   		return pluginList;
> 

Thanks Steven!
I applied this one on my side before all KS 2.0 patches.

Reviewed-by: Yordan Karadzhov (VMware) <y.karadz@gmail.com>

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-01-04 17:04 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-12-21 19:24 [PATCH] kernelshark: Rename tracefs_get_tracing_dir() to the new tracefs_tracing_dir() Steven Rostedt
2021-01-04 17:03 ` Yordan Karadzhov (VMware)

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).