linux-usb.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Greg KH <gregkh@linuxfoundation.org>
To: Pawel Laszczak <pawell@cadence.com>
Cc: peter.chen@nxp.com, linux-usb@vger.kernel.org,
	linux-kernel@vger.kernel.org, balbi@kernel.org,
	colin.king@canonical.com, rogerq@ti.com, kurahul@cadence.com,
	nsekhar@ti.com
Subject: Re: [PATCH v2 00/10] Introduced new Cadence USBSSP DRD Driver.
Date: Fri, 6 Nov 2020 14:41:36 +0100	[thread overview]
Message-ID: <20201106134136.GA3316286@kroah.com> (raw)
In-Reply-To: <20201106114300.1245-1-pawell@cadence.com>

On Fri, Nov 06, 2020 at 12:42:50PM +0100, Pawel Laszczak wrote:
> This patch introduce new Cadence USBSS DRD driver to linux kernel.
> 
> The Cadence USBSS DRD Controller is a highly configurable IP Core which
> can be instantiated as Dual-Role Device (DRD), Peripheral Only and
> Host Only (XHCI)configurations.
> 
> The current driver has been validated with FPGA burned. We have support
> for PCIe bus, which is used on FPGA prototyping.
> 
> The host side of USBSS-DRD controller is compliance with XHCI
> specification, so it works with standard XHCI Linux driver.
> 
> The device side of USBSS DRD controller is compliant with XHCI.
> The architecture for device side is almost the same as for host side,
> and most of the XHCI specification can be used to understand how
> this controller operates.
> 
> This controller and driver support Full Speed, Hight Speed, Supper Speed
> and Supper Speed Plus USB protocol.
> 
> The prefix cdnsp used in driver has chosen by analogy to cdn3 driver.
> The last letter of this acronym means PLUS. The formal name of controller
> is USBSSP but it's to generic so I've decided to use CDNSP.
> 
> The patch 1: adds support for DRD CDNSP.
> The patch 2: separates common code that can be reusable by cdnsp driver.
> The patch 3: moves reusable code to separate module.
> The patch 4: changes prefixes in reusable code from cdns3 to common cdns.
> The patch 5: adopts gadget_dev pointer in cdns structure to make possible 
>              use it in both drivers.
> The patches 6-8: add the main part of driver and has been intentionally
>              split into 3 part. In my opinion such division should not
>              affect understanding and reviewing the driver, and cause that
>              main patch (7/8) is little smaller. Patch 6 introduces main
>              header file for driver, 7 is the main part that implements all
>              functionality of driver and 8 introduces tracepoints.
> The patch 9: Adds cdns3 prefixes to files related with USBSS driver.
> the patch 10: Adds USBSSP DRD IP driver entry to MAINTAINERS file.
> 
> Changlog from v1:
> - updated common code to latest cdns3 driver
> - moved cdnsp driver files to cdns3 as sugested by Peter Chan
> - removed duplicate code from cdnsp_ep0_set_config function
> - added cdns3 prefixes to file related with USBSS driver
> - updated MAINTAINERS file
> - fixed issue with U1
> - fixed issue with L1
> - some less improtant changes sugested by Chunfeng Yun

After a quick review, I don't see anything wrong with this series, nice
work.

It does feel odd you need to split things into a "common" and then 2
other modules, but I guess it makes sense.  Worst case, over time, you
merge them back together after everyone just ends up enabling both of
them :)

Felipe, want me to take these directly, or should they go through your
tree after you review them?  I never remember with this driver whose it
goes through.

thanks,

greg k-h

  parent reply	other threads:[~2020-11-06 13:40 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-06 11:42 [PATCH v2 00/10] Introduced new Cadence USBSSP DRD Driver Pawel Laszczak
2020-11-06 11:42 ` [PATCH v2 01/10] usb: cdns3: Add support for DRD CDNSP Pawel Laszczak
2020-11-10  9:04   ` Peter Chen
2020-11-06 11:42 ` [PATCH v2 02/10] usb: cdns3: Split core.c into cdns3-plat and core.c file Pawel Laszczak
2020-11-06 11:42 ` [PATCH v2 03/10] usb: cdns3: Moves reusable code to separate module Pawel Laszczak
2020-11-10  9:09   ` Peter Chen
2020-11-10  9:20     ` Pawel Laszczak
2020-11-10 11:21       ` Peter Chen
2020-11-10 11:39         ` gregkh
2020-11-10 11:42           ` Pawel Laszczak
2020-11-06 11:42 ` [PATCH v2 04/10] usb: cdns3: Refactoring names in reusable code Pawel Laszczak
2020-11-06 11:42 ` [PATCH v2 05/10] usb: cdns3: Changed type of gadget_dev in cdns structure Pawel Laszczak
2020-11-06 11:42 ` [PATCH v2 06/10] usb: cdnsp: Device side header file for CDNSP driver Pawel Laszczak
2020-11-11  2:33   ` Peter Chen
2020-11-17 14:54     ` Pawel Laszczak
2020-11-06 11:42 ` [PATCH v2 07/10] usb: cdnsp: cdns3 Add main part of Cadence USBSSP DRD Driver Pawel Laszczak
2020-11-11  3:25   ` Peter Chen
2020-11-18  9:50     ` Pawel Laszczak
2020-11-06 11:42 ` [PATCH v2 08/10] usb: cdnsp: Add tracepoints for CDNSP driver Pawel Laszczak
2020-11-11  3:27   ` Peter Chen
2020-11-06 11:42 ` [PATCH v2 09/10] usb: cdns3: Change file names for cdns3 driver Pawel Laszczak
2020-11-11  3:28   ` Peter Chen
2020-11-06 11:43 ` [PATCH v2 10/10] MAINTAINERS: add Cadence USBSSP DRD IP driver entry Pawel Laszczak
2020-11-06 13:41 ` Greg KH [this message]
2020-11-09  9:32   ` [PATCH v2 00/10] Introduced new Cadence USBSSP DRD Driver Pawel Laszczak

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20201106134136.GA3316286@kroah.com \
    --to=gregkh@linuxfoundation.org \
    --cc=balbi@kernel.org \
    --cc=colin.king@canonical.com \
    --cc=kurahul@cadence.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=nsekhar@ti.com \
    --cc=pawell@cadence.com \
    --cc=peter.chen@nxp.com \
    --cc=rogerq@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).