linux-usb.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Anirudh Rayabharam <mail@anirudhrb.com>
To: Shuah Khan <skhan@linuxfoundation.org>
Cc: Greg KH <gregkh@linuxfoundation.org>,
	valentina.manea.m@gmail.com, shuah@kernel.org,
	syzbot+74d6ef051d3d2eacf428@syzkaller.appspotmail.com,
	linux-kernel-mentees@lists.linuxfoundation.org,
	linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3 1/2] usbip: give back URBs for unsent unlink requests during cleanup
Date: Thu, 19 Aug 2021 23:39:05 +0530	[thread overview]
Message-ID: <YR6eQUpoe9cORXGu@anirudhrb.com> (raw)
In-Reply-To: <cb36604b-37f1-c12e-3ebb-cdafd7798dc1@linuxfoundation.org>

On Wed, Aug 18, 2021 at 12:36:11PM -0600, Shuah Khan wrote:
> On 8/17/21 11:39 PM, Greg KH wrote:
> > On Tue, Aug 17, 2021 at 05:16:51PM -0600, Shuah Khan wrote:
> > > On 8/13/21 12:25 PM, Anirudh Rayabharam wrote:
> > > > In vhci_device_unlink_cleanup(), the URBs for unsent unlink requests are
> > > > not given back. This sometimes causes usb_kill_urb to wait indefinitely
> > > > for that urb to be given back. syzbot has reported a hung task issue [1]
> > > > for this.
> > > > 
> > > > To fix this, give back the urbs corresponding to unsent unlink requests
> > > > (unlink_tx list) similar to how urbs corresponding to unanswered unlink
> > > > requests (unlink_rx list) are given back.
> > > > 
> > > > [1]: https://syzkaller.appspot.com/bug?id=08f12df95ae7da69814e64eb5515d5a85ed06b76
> > > > 
> > > > Reported-by: syzbot+74d6ef051d3d2eacf428@syzkaller.appspotmail.com
> > > > Tested-by: syzbot+74d6ef051d3d2eacf428@syzkaller.appspotmail.com
> > > > Signed-off-by: Anirudh Rayabharam <mail@anirudhrb.com>
> > > > ---
> > > >    drivers/usb/usbip/vhci_hcd.c | 26 ++++++++++++++++++++++++++
> > > >    1 file changed, 26 insertions(+)
> > > > 
> > > > diff --git a/drivers/usb/usbip/vhci_hcd.c b/drivers/usb/usbip/vhci_hcd.c
> > > > index 4ba6bcdaa8e9..6f3f374d4bbc 100644
> > > > --- a/drivers/usb/usbip/vhci_hcd.c
> > > > +++ b/drivers/usb/usbip/vhci_hcd.c
> > > > @@ -957,8 +957,34 @@ static void vhci_device_unlink_cleanup(struct vhci_device *vdev)
> > > >    	spin_lock(&vdev->priv_lock);
> > > >    	list_for_each_entry_safe(unlink, tmp, &vdev->unlink_tx, list) {
> > > > +		struct urb *urb;
> > > > +
> > > > +		/* give back URB of unsent unlink request */
> > > >    		pr_info("unlink cleanup tx %lu\n", unlink->unlink_seqnum);
> > > 
> > > I know this is an exiting one.
> > > Let's make this pr_debug or remove it all together.
> > > 
> > > > +
> > > > +		urb = pickup_urb_and_free_priv(vdev, unlink->unlink_seqnum);
> > > > +		if (!urb) {
> > > > +			pr_info("the urb (seqnum %lu) was already given back\n",
> > > > +				unlink->unlink_seqnum);
> > > 
> > > Let's make this pr_debug or remove it all together.
> > 
> > As you have a struct device for all of these, please use dev_dbg() and
> > friends, not pr_*(), for all of these.
> > 
> 
> Yes. Makes perfect sense.

Perhaps we should use usbip_dbg_vhci_hc() instead of dev_dbg()? It is
one of the custom macros defined by the usbip driver for printing debug
logs.

Thanks,

	Anirudh

  reply	other threads:[~2021-08-19 18:09 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-13 18:25 [PATCH v3 0/2] Fix syzkaller bug: hung task in hub_port_init Anirudh Rayabharam
2021-08-13 18:25 ` [PATCH v3 1/2] usbip: give back URBs for unsent unlink requests during cleanup Anirudh Rayabharam
2021-08-17 23:16   ` Shuah Khan
2021-08-18  5:39     ` Greg KH
2021-08-18 18:36       ` Shuah Khan
2021-08-19 18:09         ` Anirudh Rayabharam [this message]
2021-08-19 18:49           ` Shuah Khan
2021-08-13 18:25 ` [PATCH v3 2/2] usbip: eliminate duplicate code in vhci_device_unlink_cleanup Anirudh Rayabharam

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YR6eQUpoe9cORXGu@anirudhrb.com \
    --to=mail@anirudhrb.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel-mentees@lists.linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=shuah@kernel.org \
    --cc=skhan@linuxfoundation.org \
    --cc=syzbot+74d6ef051d3d2eacf428@syzkaller.appspotmail.com \
    --cc=valentina.manea.m@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).