From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-8.3 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, INCLUDES_PATCH,MAILING_LIST_MULTI,SIGNED_OFF_BY,SPF_HELO_NONE,SPF_PASS, USER_AGENT_SANE_2 autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 0B369C2BA83 for ; Wed, 12 Feb 2020 11:52:48 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [209.132.180.67]) by mail.kernel.org (Postfix) with ESMTP id D15312082F for ; Wed, 12 Feb 2020 11:52:47 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1727264AbgBLLwr (ORCPT ); Wed, 12 Feb 2020 06:52:47 -0500 Received: from mx2.suse.de ([195.135.220.15]:57220 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1726775AbgBLLwr (ORCPT ); Wed, 12 Feb 2020 06:52:47 -0500 X-Virus-Scanned: by amavisd-new at test-mx.suse.de Received: from relay2.suse.de (unknown [195.135.220.254]) by mx2.suse.de (Postfix) with ESMTP id 1768FB15E; Wed, 12 Feb 2020 11:52:46 +0000 (UTC) Date: Wed, 12 Feb 2020 12:52:44 +0100 From: Jean Delvare To: Mika Westerberg Cc: "Rafael J. Wysocki" , Len Brown , linux-acpi@vger.kernel.org, Wim Van Sebroeck , Guenter Roeck , linux-watchdog@vger.kernel.org, Tom Abraham Subject: Re: [PATCH 1/3] ACPICA: Introduce ACPI_ACCESS_BIT_WIDTH() macro Message-ID: <20200212125244.2b61202e@endymion> In-Reply-To: <20200212110540.83559-1-mika.westerberg@linux.intel.com> References: <20200211180331.11dbe525@endymion> <20200212110540.83559-1-mika.westerberg@linux.intel.com> Organization: SUSE Linux X-Mailer: Claws Mail 3.17.4 (GTK+ 2.24.32; x86_64-suse-linux-gnu) MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII Content-Transfer-Encoding: 7bit Sender: linux-watchdog-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-watchdog@vger.kernel.org On Wed, 12 Feb 2020 14:05:38 +0300, Mika Westerberg wrote: > Sometimes it is useful to find the access_width field value in bytes and > not in bits so add a helper that can be used for this purpose. s/ACPI_ACCESS_BIT_WIDTH/ACPI_ACCESS_BYTE_WIDTH/ in the subject. > > Suggested-by: Jean Delvare > Signed-off-by: Mika Westerberg > --- > include/acpi/actypes.h | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/include/acpi/actypes.h b/include/acpi/actypes.h > index a2583c2bc054..77d40b02f62a 100644 > --- a/include/acpi/actypes.h > +++ b/include/acpi/actypes.h > @@ -537,6 +537,7 @@ typedef u64 acpi_integer; > * struct acpi_resource_generic_register. > */ > #define ACPI_ACCESS_BIT_WIDTH(size) (1 << ((size) + 2)) > +#define ACPI_ACCESS_BYTE_WIDTH(size) (ACPI_ACCESS_BIT_WIDTH(size) / 8) One of the points of having this macro being to avoid needless math, I'd rather do: #define ACPI_ACCESS_BYTE_WIDTH(size) (1 << ((size) - 1)) Some compilers might be able to optimize it, but maybe not all, and I see little point in giving the compiler more work anyway when it can be easily avoided. You may also want to replace "bit" by "bit or byte in the comment right before the macros. > > /******************************************************************************* > * Reviewed-by: Jean Delvare -- Jean Delvare SUSE L3 Support