linux-wireless.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] ath5k: use swap() to make code cleaner
@ 2021-11-04  6:23 davidcomponentone
  2021-11-04  9:38 ` Jiri Slaby
  0 siblings, 1 reply; 5+ messages in thread
From: davidcomponentone @ 2021-11-04  6:23 UTC (permalink / raw)
  To: jirislaby
  Cc: davidcomponentone, mickflemm, mcgrof, kvalo, davem, kuba,
	linux-wireless, netdev, linux-kernel, Yang Guang, Zeal Robot

From: Yang Guang <yang.guang5@zte.com.cn>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Reported-by: Zeal Robot <zealci@zte.com.cn>
Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
---
 drivers/net/wireless/ath/ath5k/phy.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
index 00f9e347d414..08dc12611f8d 100644
--- a/drivers/net/wireless/ath/ath5k/phy.c
+++ b/drivers/net/wireless/ath/ath5k/phy.c
@@ -1562,16 +1562,13 @@ static s16
 ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
 {
 	s16 sort[ATH5K_NF_CAL_HIST_MAX];
-	s16 tmp;
 	int i, j;
 
 	memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
 	for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
 		for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
 			if (sort[j] > sort[j - 1]) {
-				tmp = sort[j];
-				sort[j] = sort[j - 1];
-				sort[j - 1] = tmp;
+				swap(sort[j], sort[j - 1]);
 			}
 		}
 	}
-- 
2.30.2


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] ath5k: use swap() to make code cleaner
  2021-11-04  6:23 [PATCH] ath5k: use swap() to make code cleaner davidcomponentone
@ 2021-11-04  9:38 ` Jiri Slaby
  0 siblings, 0 replies; 5+ messages in thread
From: Jiri Slaby @ 2021-11-04  9:38 UTC (permalink / raw)
  To: davidcomponentone
  Cc: mickflemm, mcgrof, kvalo, davem, kuba, linux-wireless, netdev,
	linux-kernel, Yang Guang, Zeal Robot

On 04. 11. 21, 7:23, davidcomponentone@gmail.com wrote:
> From: Yang Guang <yang.guang5@zte.com.cn>
> 
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.

Why not just use sort() instead of the double loop?

> Reported-by: Zeal Robot <zealci@zte.com.cn>
> Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
> ---
>   drivers/net/wireless/ath/ath5k/phy.c | 5 +----
>   1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
> index 00f9e347d414..08dc12611f8d 100644
> --- a/drivers/net/wireless/ath/ath5k/phy.c
> +++ b/drivers/net/wireless/ath/ath5k/phy.c
> @@ -1562,16 +1562,13 @@ static s16
>   ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
>   {
>   	s16 sort[ATH5K_NF_CAL_HIST_MAX];
> -	s16 tmp;
>   	int i, j;
>   
>   	memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
>   	for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
>   		for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
>   			if (sort[j] > sort[j - 1]) {
> -				tmp = sort[j];
> -				sort[j] = sort[j - 1];
> -				sort[j - 1] = tmp;
> +				swap(sort[j], sort[j - 1]);
>   			}
>   		}
>   	}
> 


-- 
js
suse labs

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] ath5k: use swap() to make code cleaner
  2022-02-15  0:51 davidcomponentone
  2022-02-15  1:55 ` Luis Chamberlain
@ 2022-02-15  5:39 ` Jiri Slaby
  1 sibling, 0 replies; 5+ messages in thread
From: Jiri Slaby @ 2022-02-15  5:39 UTC (permalink / raw)
  To: davidcomponentone
  Cc: mickflemm, mcgrof, kvalo, davem, kuba, linux-wireless, netdev,
	linux-kernel, Yang Guang, Zeal Robot

On 15. 02. 22, 1:51, davidcomponentone@gmail.com wrote:
> From: Yang Guang <yang.guang5@zte.com.cn>
> 
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.

Why don't you include that file then?

> Reported-by: Zeal Robot <zealci@zte.com.cn>
> Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
> Signed-off-by: David Yang <davidcomponentone@gmail.com>
> ---
>   drivers/net/wireless/ath/ath5k/phy.c | 5 +----
>   1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
> index 00f9e347d414..7fa7ba4952db 100644
> --- a/drivers/net/wireless/ath/ath5k/phy.c
> +++ b/drivers/net/wireless/ath/ath5k/phy.c
> @@ -1562,16 +1562,13 @@ static s16
>   ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
>   {
>   	s16 sort[ATH5K_NF_CAL_HIST_MAX];
> -	s16 tmp;
>   	int i, j;
>   
>   	memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
>   	for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
>   		for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
>   			if (sort[j] > sort[j - 1]) {
> -				tmp = sort[j];
> -				sort[j] = sort[j - 1];
> -				sort[j - 1] = tmp;
> +				sort(sort[j], sort[j - 1]);
>   			}
>   		}
>   	}


-- 
js
suse labs

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] ath5k: use swap() to make code cleaner
  2022-02-15  0:51 davidcomponentone
@ 2022-02-15  1:55 ` Luis Chamberlain
  2022-02-15  5:39 ` Jiri Slaby
  1 sibling, 0 replies; 5+ messages in thread
From: Luis Chamberlain @ 2022-02-15  1:55 UTC (permalink / raw)
  To: davidcomponentone
  Cc: jirislaby, mickflemm, kvalo, davem, kuba, linux-wireless, netdev,
	linux-kernel, Yang Guang, Zeal Robot

On Tue, Feb 15, 2022 at 08:51:50AM +0800, davidcomponentone@gmail.com wrote:
> From: Yang Guang <yang.guang5@zte.com.cn>
> 
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
> 
> Reported-by: Zeal Robot <zealci@zte.com.cn>
> Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
> Signed-off-by: David Yang <davidcomponentone@gmail.com>
> ---
>  drivers/net/wireless/ath/ath5k/phy.c | 5 +----
>  1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
> index 00f9e347d414..7fa7ba4952db 100644
> --- a/drivers/net/wireless/ath/ath5k/phy.c
> +++ b/drivers/net/wireless/ath/ath5k/phy.c
> @@ -1562,16 +1562,13 @@ static s16
>  ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
>  {
>  	s16 sort[ATH5K_NF_CAL_HIST_MAX];
> -	s16 tmp;
>  	int i, j;
>  
>  	memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
>  	for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
>  		for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
>  			if (sort[j] > sort[j - 1]) {
> -				tmp = sort[j];
> -				sort[j] = sort[j - 1];
> -				sort[j - 1] = tmp;
> +				sort(sort[j], sort[j - 1]);
>  			}
> -- 


I see only sort, not swap above. 

  Luis

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH] ath5k: use swap() to make code cleaner
@ 2022-02-15  0:51 davidcomponentone
  2022-02-15  1:55 ` Luis Chamberlain
  2022-02-15  5:39 ` Jiri Slaby
  0 siblings, 2 replies; 5+ messages in thread
From: davidcomponentone @ 2022-02-15  0:51 UTC (permalink / raw)
  To: jirislaby
  Cc: davidcomponentone, mickflemm, mcgrof, kvalo, davem, kuba,
	linux-wireless, netdev, linux-kernel, Yang Guang, Zeal Robot

From: Yang Guang <yang.guang5@zte.com.cn>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Reported-by: Zeal Robot <zealci@zte.com.cn>
Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
Signed-off-by: David Yang <davidcomponentone@gmail.com>
---
 drivers/net/wireless/ath/ath5k/phy.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/net/wireless/ath/ath5k/phy.c b/drivers/net/wireless/ath/ath5k/phy.c
index 00f9e347d414..7fa7ba4952db 100644
--- a/drivers/net/wireless/ath/ath5k/phy.c
+++ b/drivers/net/wireless/ath/ath5k/phy.c
@@ -1562,16 +1562,13 @@ static s16
 ath5k_hw_get_median_noise_floor(struct ath5k_hw *ah)
 {
 	s16 sort[ATH5K_NF_CAL_HIST_MAX];
-	s16 tmp;
 	int i, j;
 
 	memcpy(sort, ah->ah_nfcal_hist.nfval, sizeof(sort));
 	for (i = 0; i < ATH5K_NF_CAL_HIST_MAX - 1; i++) {
 		for (j = 1; j < ATH5K_NF_CAL_HIST_MAX - i; j++) {
 			if (sort[j] > sort[j - 1]) {
-				tmp = sort[j];
-				sort[j] = sort[j - 1];
-				sort[j - 1] = tmp;
+				sort(sort[j], sort[j - 1]);
 			}
 		}
 	}
-- 
2.30.2


^ permalink raw reply related	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2022-02-15  5:39 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-11-04  6:23 [PATCH] ath5k: use swap() to make code cleaner davidcomponentone
2021-11-04  9:38 ` Jiri Slaby
2022-02-15  0:51 davidcomponentone
2022-02-15  1:55 ` Luis Chamberlain
2022-02-15  5:39 ` Jiri Slaby

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).