linux-wireless.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/4] ath10k: sdio: improve power consumption
@ 2020-04-16 11:50 Kalle Valo
  2020-04-16 11:50 ` [PATCH v2 1/4] ath10k: rename ath10k_hif_swap_mailbox() to ath10k_hif_start_post() Kalle Valo
                   ` (3 more replies)
  0 siblings, 4 replies; 6+ messages in thread
From: Kalle Valo @ 2020-04-16 11:50 UTC (permalink / raw)
  To: ath10k; +Cc: linux-wireless

Hi,

here's a patchset for improving power consumption on SDIO with some refactoring
and some small cleanups afterwards.

v2:

* rename ath10k_hif_swap_mailbox() to make it usable for this

* small cleanups found while doing the refactoring

* compile tested only

Kalle Valo (3):
  ath10k: rename ath10k_hif_swap_mailbox() to ath10k_hif_start_post()
  ath10k: sdio: remove _hif_ prefix from functions not part of hif
    interface
  ath10k: hif: make send_complete_check op optional

Wen Gong (1):
  ath10k: improve power save performance for sdio

 drivers/net/wireless/ath/ath10k/core.c |   2 +-
 drivers/net/wireless/ath/ath10k/hif.h  |  11 ++-
 drivers/net/wireless/ath/ath10k/sdio.c | 168 +++++++++++++++++++++++----------
 drivers/net/wireless/ath/ath10k/sdio.h |  16 ++++
 drivers/net/wireless/ath/ath10k/usb.c  |  12 ---
 5 files changed, 139 insertions(+), 70 deletions(-)

-- 
2.7.4

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2020-04-21 12:04 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-04-16 11:50 [PATCH v2 0/4] ath10k: sdio: improve power consumption Kalle Valo
2020-04-16 11:50 ` [PATCH v2 1/4] ath10k: rename ath10k_hif_swap_mailbox() to ath10k_hif_start_post() Kalle Valo
2020-04-21 12:04   ` Kalle Valo
2020-04-16 11:50 ` [PATCH v2 2/4] ath10k: improve power save performance for sdio Kalle Valo
2020-04-16 11:50 ` [PATCH v2 3/4] ath10k: sdio: remove _hif_ prefix from functions not part of hif interface Kalle Valo
2020-04-16 11:50 ` [PATCH v2 4/4] ath10k: hif: make send_complete_check op optional Kalle Valo

This is a public inbox, see mirroring instructions
on how to clone and mirror all data and code used for this inbox