linux-wireless.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Kalle Valo <kvalo@adurom.com>
To: linux-wireless@vger.kernel.org
Subject: [PATCH v2 08/27] mac80211: rename ieee80211_fragment_entry to mac80211_fragment_entry
Date: Tue, 14 Jun 2011 01:35:38 +0300	[thread overview]
Message-ID: <20110613223538.10517.64883.stgit@localhost6.localdomain6> (raw)
In-Reply-To: <20110613223029.10517.52197.stgit@localhost6.localdomain6>

Signed-off-by: Kalle Valo <kvalo@adurom.com>
---
 net/mac80211/mac80211_i.h |    4 ++--
 net/mac80211/rx.c         |   10 +++++-----
 2 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/net/mac80211/mac80211_i.h b/net/mac80211/mac80211_i.h
index d35b195..fa766b2 100644
--- a/net/mac80211/mac80211_i.h
+++ b/net/mac80211/mac80211_i.h
@@ -62,7 +62,7 @@ struct mac80211_local;
 #define IEEE80211_DEFAULT_MAX_SP_LEN		\
 	IEEE80211_WMM_IE_STA_QOSINFO_SP_ALL
 
-struct ieee80211_fragment_entry {
+struct mac80211_fragment_entry {
 	unsigned long first_frag_time;
 	unsigned int seq;
 	unsigned int rx_queue;
@@ -565,7 +565,7 @@ struct ieee80211_sub_if_data {
 	bool old_idle;
 
 	/* Fragment table for host-based reassembly */
-	struct ieee80211_fragment_entry	fragments[IEEE80211_FRAGMENT_MAX];
+	struct mac80211_fragment_entry	fragments[IEEE80211_FRAGMENT_MAX];
 	unsigned int fragment_next;
 
 	struct ieee80211_key __rcu *keys[NUM_DEFAULT_KEYS + NUM_DEFAULT_MGMT_KEYS];
diff --git a/net/mac80211/rx.c b/net/mac80211/rx.c
index 22d066d..d49fa8b 100644
--- a/net/mac80211/rx.c
+++ b/net/mac80211/rx.c
@@ -1254,12 +1254,12 @@ ieee80211_rx_h_sta_process(struct ieee80211_rx_data *rx)
 	return RX_CONTINUE;
 } /* ieee80211_rx_h_sta_process */
 
-static inline struct ieee80211_fragment_entry *
+static inline struct mac80211_fragment_entry *
 ieee80211_reassemble_add(struct ieee80211_sub_if_data *sdata,
 			 unsigned int frag, unsigned int seq, int rx_queue,
 			 struct sk_buff **skb)
 {
-	struct ieee80211_fragment_entry *entry;
+	struct mac80211_fragment_entry *entry;
 	int idx;
 
 	idx = sdata->fragment_next;
@@ -1293,12 +1293,12 @@ ieee80211_reassemble_add(struct ieee80211_sub_if_data *sdata,
 	return entry;
 }
 
-static inline struct ieee80211_fragment_entry *
+static inline struct mac80211_fragment_entry *
 ieee80211_reassemble_find(struct ieee80211_sub_if_data *sdata,
 			  unsigned int frag, unsigned int seq,
 			  int rx_queue, struct ieee80211_hdr *hdr)
 {
-	struct ieee80211_fragment_entry *entry;
+	struct mac80211_fragment_entry *entry;
 	int i, idx;
 
 	idx = sdata->fragment_next;
@@ -1343,7 +1343,7 @@ ieee80211_rx_h_defragment(struct ieee80211_rx_data *rx)
 	u16 sc;
 	__le16 fc;
 	unsigned int frag, seq;
-	struct ieee80211_fragment_entry *entry;
+	struct mac80211_fragment_entry *entry;
 	struct sk_buff *skb;
 	struct ieee80211_rx_status *status;
 


  parent reply	other threads:[~2011-06-13 22:35 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-06-13 22:34 [PATCH v2 00/27] mac80211: create mac80211_ prefix Kalle Valo
2011-06-13 22:34 ` [PATCH v2 01/27] iwlegacy: fix stop/wake queue hacks Kalle Valo
2011-06-13 22:34 ` [PATCH v2 02/27] iwlwifi: " Kalle Valo
2011-06-13 22:34 ` [PATCH v2 03/27] zd1211rw: include mac80211.h from zd_chip.h Kalle Valo
2011-06-13 22:35 ` [PATCH v2 04/27] rtlwifi: include mac80211.h from core.h Kalle Valo
2011-06-13 22:35 ` [PATCH v2 05/27] mac80211: switch mac80211.h to use mac80211 prefix Kalle Valo
2011-06-13 22:35 ` [PATCH v2 06/27] mac80211: rename ieee80211_i.h to mac80211_i.h Kalle Valo
2011-06-13 22:35 ` [PATCH v2 07/27] mac80211: rename ieee80211_local to mac80211_local Kalle Valo
2011-06-13 22:35 ` Kalle Valo [this message]
2011-06-13 22:35 ` [PATCH v2 09/27] mac80211: rename ieee80211_bss to mac80211_bss Kalle Valo
2011-06-13 22:36 ` [PATCH v2 10/27] mac80211: rename ieee80211_tx_data to mac80211_tx_data Kalle Valo
2011-06-13 22:36 ` [PATCH v2 11/27] mac80211: rename ieee80211_packet_rx_flags to mac80211_packet_rx_flags Kalle Valo
2011-06-13 22:36 ` [PATCH v2 12/27] mac80211: rename ieee80211_rx_flags to mac80211_i_rx_flags Kalle Valo
2011-06-13 22:36 ` [PATCH v2 13/27] mac80211: rename ieee80211_rx_data to mac80211_rx_data Kalle Valo
2011-06-13 22:36 ` [PATCH v2 14/27] mac80211: rename ieee80211_if_ap to mac80211_if_ap Kalle Valo
2011-06-13 22:36 ` [PATCH v2 15/27] mac80211: change ieee80211_if_wds and _vlan to use mac80211 prefix Kalle Valo
2011-06-13 22:37 ` [PATCH v2 16/27] mac80211: rename ieee80211_work_type to mac80211_work_type Kalle Valo
2011-06-13 22:37 ` [PATCH v2 17/27] mac80211: rename ieee80211_work to mac80211_work Kalle Valo
2011-06-13 22:37 ` [PATCH v2 18/27] mac80211: rename ieee80211_sta_flags to mac80211_sta_flags Kalle Valo
2011-06-13 22:37 ` [PATCH v2 19/27] mac80211: rename ieee80211_if_managed to mac80211_if_managed Kalle Valo
2011-06-13 22:37 ` [PATCH v2 20/27] mac80211: rename ieee80211_if_ibss to mac80211_if_ibss Kalle Valo
2011-06-13 22:37 ` [PATCH v2 21/27] mac80211: rename ieee80211_if_mesh to mac80211_if_mesh Kalle Valo
2011-06-13 22:37 ` [PATCH v2 22/27] mac80211: rename ieee80211_sub_if_data_flags to mac80211_sub_if_data_flags Kalle Valo
2011-06-13 22:38 ` [PATCH v2 23/27] mac80211: rename ieee80211_sdata_state_bits to mac80211_sdata_state_bits Kalle Valo
2011-06-13 22:38 ` [PATCH v2 24/27] mac80211: ieee80211_sub_if_data to mac80211_sub_if_data Kalle Valo
2011-06-13 22:38 ` [PATCH v2 25/27] mac80211: use mac80211 prefix with rx and tx msg flags Kalle Valo
2011-06-13 22:38 ` [PATCH v2 26/27] mac80211: change queue stop reasons to use mac80211 prefix Kalle Valo
2011-06-13 22:38 ` [PATCH v2 27/27] mac80211: use mac80211_hw Kalle Valo
2011-06-16 15:34 ` [PATCH v2 00/27] mac80211: create mac80211_ prefix Johannes Berg
2011-06-17 11:11   ` Kalle Valo
2011-06-20 19:24     ` John W. Linville
2011-06-20 19:55       ` Kalle Valo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20110613223538.10517.64883.stgit@localhost6.localdomain6 \
    --to=kvalo@adurom.com \
    --cc=linux-wireless@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).