linux-wireless.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Larry Finger <Larry.Finger@lwfinger.net>
To: Lee Jones <lee.jones@linaro.org>, kvalo@codeaurora.org
Cc: linux-kernel@vger.kernel.org, Ping-Ke Shih <pkshih@realtek.com>,
	"David S. Miller" <davem@davemloft.net>,
	Jakub Kicinski <kuba@kernel.org>,
	linux-wireless@vger.kernel.org, netdev@vger.kernel.org
Subject: Re: [PATCH 05/41] rtl8192cu: trx: Demote clear abuse of kernel-doc format
Date: Mon, 2 Nov 2020 10:50:43 -0600	[thread overview]
Message-ID: <be7ae9a4-a9ec-8670-208b-44f9117e0f04@lwfinger.net> (raw)
In-Reply-To: <20201102112410.1049272-6-lee.jones@linaro.org>

On 11/2/20 5:23 AM, Lee Jones wrote:
> Fixes the following W=1 kernel build warning(s):
> 
>   drivers/net/wireless/realtek/rtlwifi/rtl8192cu/trx.c:455: warning: Function parameter or member 'txdesc' not described in '_rtl_tx_desc_checksum'
> 
> Cc: Ping-Ke Shih <pkshih@realtek.com>
> Cc: Kalle Valo <kvalo@codeaurora.org>
> Cc: "David S. Miller" <davem@davemloft.net>
> Cc: Jakub Kicinski <kuba@kernel.org>
> Cc: Larry Finger <Larry.Finger@lwfinger.net>
> Cc: linux-wireless@vger.kernel.org
> Cc: netdev@vger.kernel.org
> Signed-off-by: Lee Jones <lee.jones@linaro.org>
> ---
>   drivers/net/wireless/realtek/rtlwifi/rtl8192cu/trx.c | 2 +-
>   1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/net/wireless/realtek/rtlwifi/rtl8192cu/trx.c b/drivers/net/wireless/realtek/rtlwifi/rtl8192cu/trx.c
> index 1ad0cf37f60bb..87f959d5d861d 100644
> --- a/drivers/net/wireless/realtek/rtlwifi/rtl8192cu/trx.c
> +++ b/drivers/net/wireless/realtek/rtlwifi/rtl8192cu/trx.c
> @@ -448,7 +448,7 @@ static void _rtl_fill_usb_tx_desc(__le32 *txdesc)
>   	set_tx_desc_first_seg(txdesc, 1);
>   }
>   
> -/**
> +/*
>    *	For HW recovery information
>    */
>   static void _rtl_tx_desc_checksum(__le32 *txdesc)
> 

Did you check this patch with checkpatch.pl? I think you substituted one warning 
for another. The wireless-testing trees previously did not accept a bare "/*", 
which is why "/**" was present.

This particular instance should have
/* For HW recovery information */
as the comment.

Larry



  reply	other threads:[~2020-11-02 16:50 UTC|newest]

Thread overview: 61+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <20201102112410.1049272-1-lee.jones@linaro.org>
2020-11-02 11:23 ` [PATCH 01/41] wil6210: wmi: Correct misnamed function parameter 'ptr_' Lee Jones
2020-11-07  8:10   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 02/41] rsi_91x_usb: Fix some basic kernel-doc issues Lee Jones
2020-11-07 16:03   ` [02/41] rsi: " Kalle Valo
2020-11-02 11:23 ` [PATCH 03/41] rtl8192cu: mac: Fix some missing/ill-documented function parameters Lee Jones
2020-11-07 16:15   ` [03/41] rtlwifi: " Kalle Valo
2020-11-02 11:23 ` [PATCH 04/41] rsi_91x_usb_ops: Source file headers are not good candidates for kernel-doc Lee Jones
2020-11-02 11:23 ` [PATCH 05/41] rtl8192cu: trx: Demote clear abuse of kernel-doc format Lee Jones
2020-11-02 16:50   ` Larry Finger [this message]
2020-11-03  8:51     ` Lee Jones
2020-11-02 11:23 ` [PATCH 06/41] brcmfmac: bcmsdh: Fix description for function parameter 'pktlist' Lee Jones
2020-11-07 16:04   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 07/41] brcmfmac: pcie: Provide description for missing function parameter 'devinfo' Lee Jones
2020-11-02 11:23 ` [PATCH 08/41] iwlwifi: mvm: rs: Demote non-conformant function documentation headers Lee Jones
2020-11-02 11:23 ` [PATCH 09/41] wl1251: cmd: Rename 'len' to 'buf_len' in the documentation Lee Jones
2020-11-07 16:06   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 10/41] ath9k: ar9330_1p1_initvals: Remove unused const variable 'ar9331_common_tx_gain_offset1_1' Lee Jones
2020-11-07  8:08   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 11/41] ath9k: ar9340_initvals: Remove unused const variable 'ar9340Modes_ub124_tx_gain_table_1p0' Lee Jones
2020-11-02 11:23 ` [PATCH 12/41] ath9k: ar9485_initvals: Remove unused const variable 'ar9485_fast_clock_1_1_baseband_postamble' Lee Jones
2020-11-02 11:23 ` [PATCH 13/41] ath9k: ar9003_2p2_initvals: Remove unused const variables Lee Jones
2020-11-02 11:23 ` [PATCH 14/41] prism54: isl_ioctl: Fix one function header and demote another Lee Jones
2020-11-02 11:23 ` [PATCH 15/41] iwlwifi: iwl-eeprom-read: Demote one nonconformant function header Lee Jones
2020-11-02 11:23 ` [PATCH 16/41] iwlwifi: iwl-eeprom-parse: Fix 'struct iwl_eeprom_enhanced_txpwr's header Lee Jones
2020-11-02 11:23 ` [PATCH 17/41] intersil: hostap_hw: Prevent incompatible function type cast Lee Jones
2020-11-07 16:01   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 18/41] brcm80211: fweh: Add missing description for 'gfp' Lee Jones
2020-11-02 11:23 ` [PATCH 19/41] ath: regd: Provide description for ath_reg_apply_ir_flags's 'reg' param Lee Jones
2020-11-07  8:07   ` Kalle Valo
2020-11-02 11:23 ` [PATCH 20/41] ath9k: ar5008_phy: Demote half completed function headers Lee Jones
2020-11-02 11:23 ` [PATCH 21/41] ath: dfs_pattern_detector: Fix some function kernel-doc headers Lee Jones
2020-11-02 11:23 ` [PATCH 22/41] ath: dfs_pri_detector: Demote zero/half completed " Lee Jones
2020-11-02 11:23 ` [PATCH 23/41] iwlwifi: iwl-phy-db: Add missing struct member description for 'trans' Lee Jones
2020-11-02 11:23 ` [PATCH 24/41] wl3501_cs: Fix misspelling and provide missing documentation Lee Jones
2020-11-02 11:23 ` [PATCH 25/41] rtlwifi: halbtc8723b2ant: Remove a bunch of set but unused variables Lee Jones
2020-11-02 11:23 ` [PATCH 26/41] rtlwifi: phy: Remove set but unused variable 'bbvalue' Lee Jones
2020-11-02 11:23 ` [PATCH 27/41] rtlwifi: halbtc8821a1ant: Remove set but unused variable 'wifi_rssi_state' Lee Jones
2020-11-02 11:23 ` [PATCH 28/41] rtl8723be: phy: Remove set but unused variable 'lc_cal' Lee Jones
2020-11-02 11:23 ` [PATCH 29/41] rtl8188ee: phy: Remove set but unused variable 'reg_ea4' Lee Jones
2020-11-02 11:23 ` [PATCH 30/41] rtlwifi: halbtc8821a2ant: Remove a bunch of unused variables Lee Jones
2020-11-02 11:24 ` [PATCH 31/41] mwifiex: pcie: Remove a couple of unchecked 'ret's Lee Jones
2020-11-02 11:24 ` [PATCH 32/41] rtl8723be: trx: Remove set but unused variable 'cck_highpwr' Lee Jones
2020-11-02 11:24 ` [PATCH 33/41] rtlwifi: rtl8821ae: phy: Remove a couple of unused variables Lee Jones
2020-11-02 11:24 ` [PATCH 34/41] rtl8821ae: phy: Place braces around empty if() body Lee Jones
2020-11-02 11:24 ` [PATCH 35/41] wlcore: spi: Demote a non-compliant function header, fix another Lee Jones
2020-11-02 11:24 ` [PATCH 36/41] rtw8822b: Return type is not const Lee Jones
2020-11-07 16:10   ` [36/41] rtw88: " Kalle Valo
2020-11-02 11:24 ` [PATCH 37/41] iwlwifi: fw: dbg: Fix misspelling of 'reg_data' in function header Lee Jones
2020-11-02 11:24 ` [PATCH 38/41] realtek: rtw8822c: Remove unused variable 'corr_val' Lee Jones
2020-11-07 16:11   ` [38/41] rtw88: " Kalle Valo
2020-11-02 11:24 ` [PATCH 39/41] ath9k: dynack: Demote non-compliant function header Lee Jones
2020-11-02 11:24 ` [PATCH 40/41] iwlwifi: fw: acpi: Demote non-conformant function headers Lee Jones
2020-11-02 11:24 ` [PATCH 41/41] realtek: rtw88: pci: Add prototypes for .probe, .remove and .shutdown Lee Jones
2020-11-03  0:06   ` Brian Norris
2020-11-03  8:44     ` Lee Jones
2020-11-07 16:28       ` Kalle Valo
2020-11-07 18:42         ` Lee Jones
2020-11-02 15:42 ` [PATCH 00/41] [Set 4] Rid W=1 warnings in Wireless Kalle Valo
2020-11-06 13:28   ` Lee Jones
2020-11-06 13:35     ` Kalle Valo
2020-11-06 14:35       ` Lee Jones

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=be7ae9a4-a9ec-8670-208b-44f9117e0f04@lwfinger.net \
    --to=larry.finger@lwfinger.net \
    --cc=davem@davemloft.net \
    --cc=kuba@kernel.org \
    --cc=kvalo@codeaurora.org \
    --cc=lee.jones@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=pkshih@realtek.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).