linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Darrick J. Wong" <darrick.wong@oracle.com>
To: Christoph Hellwig <hch@lst.de>
Cc: linux-xfs@vger.kernel.org
Subject: Re: [PATCH 2/3] xfs: rename xfs_defer_join to xfs_defer_join_inode
Date: Wed, 16 Aug 2017 10:21:30 -0700	[thread overview]
Message-ID: <20170816172130.GA4796@magnolia> (raw)
In-Reply-To: <20170813144216.11192-3-hch@lst.de>

On Sun, Aug 13, 2017 at 04:42:15PM +0200, Christoph Hellwig wrote:
> Signed-off-by: Christoph Hellwig <hch@lst.de>
> ---
>  fs/xfs/libxfs/xfs_bmap.c  | 2 +-
>  fs/xfs/libxfs/xfs_defer.c | 4 ++--
>  fs/xfs/libxfs/xfs_defer.h | 2 +-
>  3 files changed, 4 insertions(+), 4 deletions(-)
> 
> diff --git a/fs/xfs/libxfs/xfs_bmap.c b/fs/xfs/libxfs/xfs_bmap.c
> index c09c16b1ad3b..24eba36ef818 100644
> --- a/fs/xfs/libxfs/xfs_bmap.c
> +++ b/fs/xfs/libxfs/xfs_bmap.c
> @@ -6452,7 +6452,7 @@ __xfs_bmap_add(
>  	bi->bi_whichfork = whichfork;
>  	bi->bi_bmap = *bmap;
>  
> -	error = xfs_defer_join(dfops, bi->bi_owner);
> +	error = xfs_defer_join_inode(dfops, bi->bi_owner);

/me wonders if this should be named xfs_defer_ijoin to be more
consistent with xfs_trans_ijoin, or if we should rename the other one to
xfs_trans_join_inode instead?

Other than that,
Reviewed-by: Darrick J. Wong <darrick.wong@oracle.com>

--D

>  	if (error) {
>  		kmem_free(bi);
>  		return error;
> diff --git a/fs/xfs/libxfs/xfs_defer.c b/fs/xfs/libxfs/xfs_defer.c
> index 87169bf56a09..043844f00f6e 100644
> --- a/fs/xfs/libxfs/xfs_defer.c
> +++ b/fs/xfs/libxfs/xfs_defer.c
> @@ -281,7 +281,7 @@ xfs_defer_has_unfinished_work(
>   * to xfs_defer_finish().
>   */
>  int
> -xfs_defer_join(
> +xfs_defer_join_inode(
>  	struct xfs_defer_ops		*dop,
>  	struct xfs_inode		*ip)
>  {
> @@ -324,7 +324,7 @@ xfs_defer_finish(
>  
>  	trace_xfs_defer_finish((*tp)->t_mountp, dop);
>  
> -	xfs_defer_join(dop, ip);
> +	xfs_defer_join_inode(dop, ip);
>  
>  	/* Until we run out of pending work to finish... */
>  	while (xfs_defer_has_unfinished_work(dop)) {
> diff --git a/fs/xfs/libxfs/xfs_defer.h b/fs/xfs/libxfs/xfs_defer.h
> index f6e93ef0bffe..4632c798ea2b 100644
> --- a/fs/xfs/libxfs/xfs_defer.h
> +++ b/fs/xfs/libxfs/xfs_defer.h
> @@ -77,7 +77,7 @@ int xfs_defer_finish(struct xfs_trans **tp, struct xfs_defer_ops *dop,
>  void xfs_defer_cancel(struct xfs_defer_ops *dop);
>  void xfs_defer_init(struct xfs_defer_ops *dop, xfs_fsblock_t *fbp);
>  bool xfs_defer_has_unfinished_work(struct xfs_defer_ops *dop);
> -int xfs_defer_join(struct xfs_defer_ops *dop, struct xfs_inode *ip);
> +int xfs_defer_join_inode(struct xfs_defer_ops *dop, struct xfs_inode *ip);
>  
>  /* Description of a deferred type. */
>  struct xfs_defer_op_type {
> -- 
> 2.11.0
> 
> --
> To unsubscribe from this list: send the line "unsubscribe linux-xfs" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

  parent reply	other threads:[~2017-08-16 17:21 UTC|newest]

Thread overview: 10+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-08-13 14:42 explicitly join inodes to deferred operations Christoph Hellwig
2017-08-13 14:42 ` [PATCH 1/3] xfs: refactor xfs_trans_roll Christoph Hellwig
2017-08-15  1:36   ` Dave Chinner
2017-08-13 14:42 ` [PATCH 2/3] xfs: rename xfs_defer_join to xfs_defer_join_inode Christoph Hellwig
2017-08-15  1:37   ` Dave Chinner
2017-08-16 17:21   ` Darrick J. Wong [this message]
2017-08-17  7:44     ` Christoph Hellwig
2017-08-17 16:22       ` Darrick J. Wong
2017-08-13 14:42 ` [PATCH 3/3] xfs: remove the ip argument to xfs_defer_finish Christoph Hellwig
2017-08-16 17:23   ` Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20170816172130.GA4796@magnolia \
    --to=darrick.wong@oracle.com \
    --cc=hch@lst.de \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).