linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@lst.de>
To: linux-xfs@vger.kernel.org
Cc: Allison Collins <allison.henderson@oracle.com>
Subject: [PATCH 04/33] xfs: fix misuse of the XFS_ATTR_INCOMPLETE flag
Date: Thu, 12 Dec 2019 11:54:04 +0100	[thread overview]
Message-ID: <20191212105433.1692-5-hch@lst.de> (raw)
In-Reply-To: <20191212105433.1692-1-hch@lst.de>

XFS_ATTR_INCOMPLETE is a flag in the on-disk attribute format, and thus
in a different namespace as the ATTR_* flags in xfs_da_args.flags.
Switch to using a XFS_DA_OP_INCOMPLETE flag in op_flags instead.  Without
this users might be able to inject this flag into operations using the
attr by handle ioctl.

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 fs/xfs/libxfs/xfs_attr.c      | 2 +-
 fs/xfs/libxfs/xfs_attr_leaf.c | 4 ++--
 fs/xfs/libxfs/xfs_da_btree.h  | 4 +++-
 fs/xfs/libxfs/xfs_da_format.h | 2 --
 4 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/fs/xfs/libxfs/xfs_attr.c b/fs/xfs/libxfs/xfs_attr.c
index 0d7fcc983b3d..2368a1bfe7e8 100644
--- a/fs/xfs/libxfs/xfs_attr.c
+++ b/fs/xfs/libxfs/xfs_attr.c
@@ -1007,7 +1007,7 @@ xfs_attr_node_addname(
 		 * The INCOMPLETE flag means that we will find the "old"
 		 * attr, not the "new" one.
 		 */
-		args->flags |= XFS_ATTR_INCOMPLETE;
+		args->op_flags |= XFS_DA_OP_INCOMPLETE;
 		state = xfs_da_state_alloc();
 		state->args = args;
 		state->mp = mp;
diff --git a/fs/xfs/libxfs/xfs_attr_leaf.c b/fs/xfs/libxfs/xfs_attr_leaf.c
index 08d4b10ae2d5..fed537a4353d 100644
--- a/fs/xfs/libxfs/xfs_attr_leaf.c
+++ b/fs/xfs/libxfs/xfs_attr_leaf.c
@@ -2403,8 +2403,8 @@ xfs_attr3_leaf_lookup_int(
 		 * If we are looking for INCOMPLETE entries, show only those.
 		 * If we are looking for complete entries, show only those.
 		 */
-		if ((args->flags & XFS_ATTR_INCOMPLETE) !=
-		    (entry->flags & XFS_ATTR_INCOMPLETE)) {
+		if (!!(args->op_flags & XFS_DA_OP_INCOMPLETE) !=
+		    !!(entry->flags & XFS_ATTR_INCOMPLETE)) {
 			continue;
 		}
 		if (entry->flags & XFS_ATTR_LOCAL) {
diff --git a/fs/xfs/libxfs/xfs_da_btree.h b/fs/xfs/libxfs/xfs_da_btree.h
index e16610d1c14f..0f4fbb0889ff 100644
--- a/fs/xfs/libxfs/xfs_da_btree.h
+++ b/fs/xfs/libxfs/xfs_da_btree.h
@@ -89,6 +89,7 @@ typedef struct xfs_da_args {
 #define XFS_DA_OP_OKNOENT	0x0008	/* lookup/add op, ENOENT ok, else die */
 #define XFS_DA_OP_CILOOKUP	0x0010	/* lookup to return CI name if found */
 #define XFS_DA_OP_ALLOCVAL	0x0020	/* lookup to alloc buffer if found  */
+#define XFS_DA_OP_INCOMPLETE	0x0040	/* lookup INCOMPLETE attr keys */
 
 #define XFS_DA_OP_FLAGS \
 	{ XFS_DA_OP_JUSTCHECK,	"JUSTCHECK" }, \
@@ -96,7 +97,8 @@ typedef struct xfs_da_args {
 	{ XFS_DA_OP_ADDNAME,	"ADDNAME" }, \
 	{ XFS_DA_OP_OKNOENT,	"OKNOENT" }, \
 	{ XFS_DA_OP_CILOOKUP,	"CILOOKUP" }, \
-	{ XFS_DA_OP_ALLOCVAL,	"ALLOCVAL" }
+	{ XFS_DA_OP_ALLOCVAL,	"ALLOCVAL" }, \
+	{ XFS_DA_OP_INCOMPLETE,	"INCOMPLETE" }
 
 /*
  * Storage for holding state during Btree searches and split/join ops.
diff --git a/fs/xfs/libxfs/xfs_da_format.h b/fs/xfs/libxfs/xfs_da_format.h
index 3dee33043e09..05615d1f4113 100644
--- a/fs/xfs/libxfs/xfs_da_format.h
+++ b/fs/xfs/libxfs/xfs_da_format.h
@@ -683,8 +683,6 @@ struct xfs_attr3_leafblock {
 
 /*
  * Flags used in the leaf_entry[i].flags field.
- * NOTE: the INCOMPLETE bit must not collide with the flags bits specified
- * on the system call, they are "or"ed together for various operations.
  */
 #define	XFS_ATTR_LOCAL_BIT	0	/* attr is stored locally */
 #define	XFS_ATTR_ROOT_BIT	1	/* limit access to trusted attrs */
-- 
2.20.1


  parent reply	other threads:[~2019-12-12 10:54 UTC|newest]

Thread overview: 43+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-12-12 10:54 clean up the attr interface Christoph Hellwig
2019-12-12 10:54 ` [PATCH 01/33] xfs: clear kernel only flags in XFS_IOC_ATTRMULTI_BY_HANDLE Christoph Hellwig
2019-12-18 21:26   ` Darrick J. Wong
2019-12-24 11:56     ` Christoph Hellwig
2019-12-12 10:54 ` [PATCH 02/33] xfs: reject invalid flags combinations " Christoph Hellwig
2019-12-18 21:29   ` Darrick J. Wong
2019-12-24 11:56     ` Christoph Hellwig
2019-12-12 10:54 ` [PATCH 03/33] xfs: also remove cached ACLs when removing the underlying attr Christoph Hellwig
2019-12-18 21:31   ` Darrick J. Wong
2019-12-24 11:57     ` Christoph Hellwig
2019-12-12 10:54 ` Christoph Hellwig [this message]
2019-12-18 21:33   ` [PATCH 04/33] xfs: fix misuse of the XFS_ATTR_INCOMPLETE flag Darrick J. Wong
2019-12-12 10:54 ` [PATCH 05/33] xfs: remove the ATTR_INCOMPLETE flag Christoph Hellwig
2019-12-18 21:43   ` Darrick J. Wong
2019-12-24 11:59     ` Christoph Hellwig
2019-12-12 10:54 ` [PATCH 06/33] xfs: merge xfs_attr_remove into xfs_attr_set Christoph Hellwig
2019-12-12 10:54 ` [PATCH 07/33] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set Christoph Hellwig
2019-12-12 10:54 ` [PATCH 08/33] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE Christoph Hellwig
2019-12-12 10:54 ` [PATCH 09/33] xfs: factour out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op Christoph Hellwig
2019-12-12 10:54 ` [PATCH 10/33] xfs: remove the name == NULL check from xfs_attr_args_init Christoph Hellwig
2019-12-12 10:54 ` [PATCH 11/33] xfs: remove the MAXNAMELEN " Christoph Hellwig
2019-12-12 10:54 ` [PATCH 12/33] xfs: move struct xfs_da_args to xfs_types.h Christoph Hellwig
2019-12-12 10:54 ` [PATCH 13/33] xfs: turn xfs_da_args.value into a void pointer Christoph Hellwig
2019-12-12 10:54 ` [PATCH 14/33] xfs: pass an initialized xfs_da_args structure to xfs_attr_set Christoph Hellwig
2019-12-12 10:54 ` [PATCH 15/33] xfs: pass an initialized xfs_da_args to xfs_attr_get Christoph Hellwig
2019-12-12 10:54 ` [PATCH 16/33] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked Christoph Hellwig
2019-12-12 10:54 ` [PATCH 17/33] xfs: remove ATTR_KERNOVAL Christoph Hellwig
2019-12-12 10:54 ` [PATCH 18/33] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL Christoph Hellwig
2019-12-12 10:54 ` [PATCH 19/33] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME Christoph Hellwig
2019-12-12 10:54 ` [PATCH 20/33] xfs: factor out a xfs_attr_match helper Christoph Hellwig
2019-12-12 10:54 ` [PATCH 21/33] xfs: cleanup xfs_attr_list_context Christoph Hellwig
2019-12-12 10:54 ` [PATCH 22/33] xfs: remove the unused ATTR_ENTRY macro Christoph Hellwig
2019-12-12 10:54 ` [PATCH 23/33] xfs: replace ATTR_ENTBASESIZE with offsetoff Christoph Hellwig
2019-12-12 10:54 ` [PATCH 24/33] xfs: move the legacy xfs_attr_list to xfs_ioctl.c Christoph Hellwig
2019-12-12 10:54 ` [PATCH 25/33] xfs: rename xfs_attr_list_int to xfs_attr_list Christoph Hellwig
2019-12-12 10:54 ` [PATCH 26/33] xfs: lift common check into xfs_ioc_attr_list Christoph Hellwig
2019-12-12 10:54 ` [PATCH 27/33] xfs: lift buffer allocation " Christoph Hellwig
2019-12-12 10:54 ` [PATCH 28/33] xfs: lift cursor copy in/out " Christoph Hellwig
2019-12-12 10:54 ` [PATCH 29/33] xfs: improve xfs_forget_acl Christoph Hellwig
2019-12-12 10:54 ` [PATCH 30/33] xfs: clean up the ATTR_REPLACE checks Christoph Hellwig
2019-12-12 10:54 ` [PATCH 31/33] xfs: clean up the attr flag confusion Christoph Hellwig
2019-12-12 10:54 ` [PATCH 32/33] xfs: remove XFS_DA_OP_INCOMPLETE Christoph Hellwig
2019-12-12 10:54 ` [PATCH 33/33] xfs: embedded the attrlist cursor into struct xfs_attr_list_context Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20191212105433.1692-5-hch@lst.de \
    --to=hch@lst.de \
    --cc=allison.henderson@oracle.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).