linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ira Weiny <ira.weiny@intel.com>
To: Jan Kara <jack@suse.cz>
Cc: linux-kernel@vger.kernel.org,
	"Darrick J. Wong" <darrick.wong@oracle.com>,
	Dan Williams <dan.j.williams@intel.com>,
	Dave Chinner <david@fromorbit.com>,
	Christoph Hellwig <hch@lst.de>,
	"Theodore Y. Ts'o" <tytso@mit.edu>,
	Jeff Moyer <jmoyer@redhat.com>,
	linux-ext4@vger.kernel.org, linux-xfs@vger.kernel.org,
	linux-fsdevel@vger.kernel.org
Subject: Re: [PATCH V8 09/11] fs: Introduce DCACHE_DONTCACHE
Date: Wed, 15 Apr 2020 21:55:11 -0700	[thread overview]
Message-ID: <20200416045511.GI2309605@iweiny-DESK2.sc.intel.com> (raw)
In-Reply-To: <20200415090153.GF501@quack2.suse.cz>

On Wed, Apr 15, 2020 at 11:01:53AM +0200, Jan Kara wrote:
> On Tue 14-04-20 23:45:21, ira.weiny@intel.com wrote:
> > From: Ira Weiny <ira.weiny@intel.com>
> > 
> > DCACHE_DONTCACHE indicates a dentry should not be cached on final
> > dput().
> > 
> > Also add a helper function which will flag I_DONTCACHE as well ad
> > DCACHE_DONTCACHE on all dentries point to a specified inode.
> 
> I think this sentence needs more work :). Like: Also add a helper function
> which will mark the inode with I_DONTCACHE flag and also mark all dentries
> pointing to a specified inode as DCACHE_DONTCACHE.
> 
> > 
> > Signed-off-by: Ira Weiny <ira.weiny@intel.com>
> > 
> > ---
> > Changes from V7:
> > 	new patch
> > ---
> >  fs/dcache.c            |  4 ++++
> >  fs/inode.c             | 15 +++++++++++++++
> >  include/linux/dcache.h |  2 ++
> >  include/linux/fs.h     |  1 +
> >  4 files changed, 22 insertions(+)
> 
> ...
> 
> > diff --git a/fs/inode.c b/fs/inode.c
> > index 93d9252a00ab..b8b1917a324e 100644
> > --- a/fs/inode.c
> > +++ b/fs/inode.c
> > @@ -1526,6 +1526,21 @@ int generic_delete_inode(struct inode *inode)
> >  }
> >  EXPORT_SYMBOL(generic_delete_inode);
> >  
> > +void flag_inode_dontcache(struct inode *inode)
> 
> mark_inode_dontcache?

That works.

> 
> > +{
> > +	struct dentry *dent;
> 
> This is really nitpicking but dentry variables are usually called 'de' or
> 'dentry' :)

Easy change.  done.

> 
> > +
> > +	rcu_read_lock();
> 
> I don't think this list is safe to traverse under RCU. E.g.
> dentry_unlink_inode() does hlist_del_init(&dentry->d_u.d_alias). Usually,
> we traverse this list under inode->i_lock protection AFAICS.

Ah...  not sure where I got that.  I thought I found this locked with rcu
somewhere but I obviously got confused.  And I did not even use the rcu version
of the list iterator...  :-(

I'll clean it up, thanks for the review,
Ira

> 
> 								Honza
> 
> > +	hlist_for_each_entry(dent, &inode->i_dentry, d_u.d_alias) {
> > +		spin_lock(&dent->d_lock);
> > +		dent->d_flags |= DCACHE_DONTCACHE;
> > +		spin_unlock(&dent->d_lock);
> > +	}
> > +	rcu_read_unlock();
> > +	inode->i_state |= I_DONTCACHE;
> > +}
> > +EXPORT_SYMBOL(flag_inode_dontcache);
> > +
> >  /*
> >   * Called when we're dropping the last reference
> >   * to an inode.
> -- 
> Jan Kara <jack@suse.com>
> SUSE Labs, CR

  reply	other threads:[~2020-04-16  4:55 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-15  6:45 [PATCH V8 00/11] Enable per-file/per-directory DAX operations V8 ira.weiny
2020-04-15  6:45 ` [PATCH V8 01/11] fs/xfs: Remove unnecessary initialization of i_rwsem ira.weiny
2020-04-15 15:12   ` Darrick J. Wong
2020-04-15  6:45 ` [PATCH V8 02/11] fs: Remove unneeded IS_DAX() check in io_is_direct() ira.weiny
2020-04-15  6:45 ` [PATCH V8 03/11] fs/stat: Define DAX statx attribute ira.weiny
2020-04-15  6:45 ` [PATCH V8 04/11] fs/xfs: Change XFS_MOUNT_DAX to XFS_MOUNT_DAX_ALWAYS ira.weiny
2020-04-15 15:11   ` Darrick J. Wong
2020-04-20  2:15   ` Dave Chinner
2020-04-20 17:50     ` Ira Weiny
2020-04-15  6:45 ` [PATCH V8 05/11] fs/xfs: Make DAX mount option a tri-state ira.weiny
2020-04-15 15:16   ` Darrick J. Wong
2020-04-16  4:15     ` Ira Weiny
2020-04-15  6:45 ` [PATCH V8 06/11] fs/xfs: Create function xfs_inode_enable_dax() ira.weiny
2020-04-15 15:17   ` Darrick J. Wong
2020-04-15  6:45 ` [PATCH V8 07/11] fs/xfs: Combine xfs_diflags_to_linux() and xfs_diflags_to_iflags() ira.weiny
2020-04-15  6:45 ` [PATCH V8 08/11] fs: Define I_DONTCACNE in VFS layer ira.weiny
2020-04-15  8:52   ` Jan Kara
2020-04-15 15:18     ` Darrick J. Wong
2020-04-16  4:28       ` Ira Weiny
2020-04-16  4:28     ` Ira Weiny
2020-04-15  6:45 ` [PATCH V8 09/11] fs: Introduce DCACHE_DONTCACHE ira.weiny
2020-04-15  9:01   ` Jan Kara
2020-04-16  4:55     ` Ira Weiny [this message]
2020-04-15  6:45 ` [PATCH V8 10/11] fs/xfs: Change xfs_ioctl_setattr_dax_invalidate() ira.weiny
2020-04-15 15:21   ` Darrick J. Wong
2020-04-16  5:00     ` Ira Weiny
2020-04-20  2:31   ` Dave Chinner
2020-04-20 18:36     ` Ira Weiny
2020-04-21  0:19       ` Dave Chinner
2020-04-15  6:45 ` [PATCH V8 11/11] Documentation/dax: Update Usage section ira.weiny
2020-04-15 15:29   ` Darrick J. Wong
2020-04-16  5:36     ` Ira Weiny

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200416045511.GI2309605@iweiny-DESK2.sc.intel.com \
    --to=ira.weiny@intel.com \
    --cc=dan.j.williams@intel.com \
    --cc=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=hch@lst.de \
    --cc=jack@suse.cz \
    --cc=jmoyer@redhat.com \
    --cc=linux-ext4@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=tytso@mit.edu \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).