linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Dave Chinner <david@fromorbit.com>
To: "Darrick J. Wong" <darrick.wong@oracle.com>
Cc: Allison Collins <allison.henderson@oracle.com>,
	linux-xfs@vger.kernel.org
Subject: Re: [PATCH v11 01/25] xfs: Add xfs_has_attr and subroutines
Date: Fri, 24 Jul 2020 12:24:36 +1000	[thread overview]
Message-ID: <20200724022436.GM2005@dread.disaster.area> (raw)
In-Reply-To: <20200721232613.GZ7625@magnolia>

On Tue, Jul 21, 2020 at 04:26:13PM -0700, Darrick J. Wong wrote:
> On Mon, Jul 20, 2020 at 05:15:42PM -0700, Allison Collins wrote:
> > This patch adds a new functions to check for the existence of an
> > attribute. Subroutines are also added to handle the cases of leaf
> > blocks, nodes or shortform. Common code that appears in existing attr
> > add and remove functions have been factored out to help reduce the
> > appearance of duplicated code.  We will need these routines later for
> > delayed attributes since delayed operations cannot return error codes.
> > 
> > Signed-off-by: Allison Collins <allison.henderson@oracle.com>
> > Reviewed-by: Chandan Rajendra <chandanrlinux@gmail.com>
> > Reviewed-by: Brian Foster <bfoster@redhat.com>
> 
> Looks good enough for now... I still dislike generating ENOATTR/EEXIST
> deep in the folds of the attr code but that's probably a bigger thing to
> be wrangled with later.  (And tbh I've thought about this & haven't come
> up with a better idea anyway :P)

Yes, I agree it is hard to read, but I do think there's a cleaner
way of doing this. Take, for example, xfs_attr_leaf_try_add(). It
looks like this:

        /*
         * Look up the given attribute in the leaf block.  Figure out if
         * the given flags produce an error or call for an atomic rename.
         */
        retval = xfs_attr_leaf_hasname(args, &bp);
        if (retval != -ENOATTR && retval != -EEXIST)
                return retval;
        if (retval == -ENOATTR && (args->attr_flags & XATTR_REPLACE))
                goto out_brelse;
        if (retval == -EEXIST) {
                if (args->attr_flags & XATTR_CREATE)
                        goto out_brelse;

                trace_xfs_attr_leaf_replace(args);

                /* save the attribute state for later removal*/
                args->op_flags |= XFS_DA_OP_RENAME;     /* an atomic rename */
                xfs_attr_save_rmt_blk(args);

                /*
                 * clear the remote attr state now that it is saved so that the
                 * values reflect the state of the attribute we are about to
                 * add, not the attribute we just found and will remove later.
                 */
                args->rmtblkno = 0;
                args->rmtblkcnt = 0;
                args->rmtvaluelen = 0;
        }

        /*
         * Add the attribute to the leaf block
         */
        return xfs_attr3_leaf_add(bp, args);

out_brelse:
        xfs_trans_brelse(args->trans, bp);
        return retval;
}


I agree, the error handling is messy and really hard to follow.
But if we write it like this:

        /*
         * Look up the given attribute in the leaf block.  Figure out if
         * the given flags produce an error or call for an atomic rename.
         */
        retval = xfs_attr_leaf_hasname(args, &bp);
        switch (retval) {
        case -ENOATTR:
                if (args->attr_flags & XATTR_REPLACE)
                        goto out_brelse;
                break;
        case -EEXIST:
                if (args->attr_flags & XATTR_CREATE)
                        goto out_brelse;

                trace_xfs_attr_leaf_replace(args);

                /* save the attribute state for later removal*/
                args->op_flags |= XFS_DA_OP_RENAME;     /* an atomic rename */
                xfs_attr_save_rmt_blk(args);

                /*
                 * clear the remote attr state now that it is saved so that the
                 * values reflect the state of the attribute we are about to
                 * add, not the attribute we just found and will remove later.
                 */
                args->rmtblkno = 0;
                args->rmtblkcnt = 0;
                args->rmtvaluelen = 0;
                break;
	case 0:
		break;
        default:
                return retval;
        }

        /*
         * Add the attribute to the leaf block
         */
        return xfs_attr3_leaf_add(bp, args);

out_brelse:
        xfs_trans_brelse(args->trans, bp);
        return retval;
}

The logic is *much* cleaner and it is not overly verbose, either.
This sort of change could be done at the end of the series, too,
rather than requiring a rebase of everything....

Cheers,

Dave.
-- 
Dave Chinner
david@fromorbit.com

  reply	other threads:[~2020-07-24  2:24 UTC|newest]

Thread overview: 48+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-21  0:15 [PATCH v11 00/25] xfs: Delay Ready Attributes Allison Collins
2020-07-21  0:15 ` [PATCH v11 01/25] xfs: Add xfs_has_attr and subroutines Allison Collins
2020-07-21 23:26   ` Darrick J. Wong
2020-07-24  2:24     ` Dave Chinner [this message]
2020-07-25  2:49       ` Allison Collins
2020-07-21  0:15 ` [PATCH v11 02/25] xfs: Check for -ENOATTR or -EEXIST Allison Collins
2020-07-21  0:15 ` [PATCH v11 03/25] xfs: Factor out new helper functions xfs_attr_rmtval_set Allison Collins
2020-07-21  0:15 ` [PATCH v11 04/25] xfs: Pull up trans handling in xfs_attr3_leaf_flipflags Allison Collins
2020-07-21  0:15 ` [PATCH v11 05/25] xfs: Split apart xfs_attr_leaf_addname Allison Collins
2020-07-21 23:19   ` Darrick J. Wong
2020-07-25  0:07     ` Allison Collins
2020-07-21  0:15 ` [PATCH v11 06/25] xfs: Refactor xfs_attr_try_sf_addname Allison Collins
2020-07-21  0:15 ` [PATCH v11 07/25] xfs: Pull up trans roll from xfs_attr3_leaf_setflag Allison Collins
2020-07-21  0:15 ` [PATCH v11 08/25] xfs: Factor out xfs_attr_rmtval_invalidate Allison Collins
2020-07-21  0:15 ` [PATCH v11 09/25] xfs: Pull up trans roll in xfs_attr3_leaf_clearflag Allison Collins
2020-07-21  0:15 ` [PATCH v11 10/25] xfs: Refactor xfs_attr_rmtval_remove Allison Collins
2020-07-21 23:31   ` Darrick J. Wong
2020-07-22  0:24     ` Darrick J. Wong
2020-07-25  0:08       ` Allison Collins
2020-07-25  0:46         ` Darrick J. Wong
2020-07-25  0:07     ` Allison Collins
2020-07-21  0:15 ` [PATCH v11 11/25] xfs: Pull up xfs_attr_rmtval_invalidate Allison Collins
2020-07-21  0:15 ` [PATCH v11 12/25] xfs: Add helper function xfs_attr_node_shrink Allison Collins
2020-07-21  0:15 ` [PATCH v11 13/25] xfs: Remove unneeded xfs_trans_roll_inode calls Allison Collins
2020-07-21 23:34   ` Darrick J. Wong
2020-07-25  0:08     ` Allison Collins
2020-07-21  0:15 ` [PATCH v11 14/25] xfs: Remove xfs_trans_roll in xfs_attr_node_removename Allison Collins
2020-07-21 23:38   ` Darrick J. Wong
2020-07-25  0:08     ` Allison Collins
2020-07-21  0:15 ` [PATCH v11 15/25] xfs: Add helpers xfs_attr_is_shortform and xfs_attr_set_shortform Allison Collins
2020-07-21  0:15 ` [PATCH v11 16/25] xfs: Add helper function xfs_attr_leaf_mark_incomplete Allison Collins
2020-07-21  0:15 ` [PATCH v11 17/25] xfs: Add remote block helper functions Allison Collins
2020-07-21  0:15 ` [PATCH v11 18/25] xfs: Add helper function xfs_attr_node_removename_setup Allison Collins
2020-07-21  0:16 ` [PATCH v11 19/25] xfs: Add helper function xfs_attr_node_removename_rmt Allison Collins
2020-07-21  0:16 ` [PATCH v11 20/25] xfs: Simplify xfs_attr_leaf_addname Allison Collins
2020-07-21 23:39   ` Darrick J. Wong
2020-07-25  0:07     ` Allison Collins
2020-07-21  0:16 ` [PATCH v11 21/25] xfs: Simplify xfs_attr_node_addname Allison Collins
2020-07-21 23:41   ` Darrick J. Wong
2020-07-25  0:08     ` Allison Collins
2020-07-21  0:16 ` [PATCH v11 22/25] xfs: Lift -ENOSPC handler from xfs_attr_leaf_addname Allison Collins
2020-07-21  0:16 ` [PATCH v11 23/25] xfs: Add delay ready attr remove routines Allison Collins
2020-07-21  0:16 ` [PATCH v11 24/25] xfs: Add delay ready attr set routines Allison Collins
2020-07-21  0:16 ` [PATCH v11 25/25] xfs: Rename __xfs_attr_rmtval_remove Allison Collins
2020-07-24  3:41 ` [PATCH v11 00/25] xfs: Delay Ready Attributes Dave Chinner
2020-07-24  5:35   ` Dave Chinner
2020-07-25  2:50     ` Allison Collins
2020-07-25  2:49   ` Allison Collins

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200724022436.GM2005@dread.disaster.area \
    --to=david@fromorbit.com \
    --cc=allison.henderson@oracle.com \
    --cc=darrick.wong@oracle.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).