linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@infradead.org>
To: "Matthew Wilcox (Oracle)" <willy@infradead.org>
Cc: linux-xfs@vger.kernel.org, linux-fsdevel@vger.kernel.org,
	"Darrick J . Wong" <darrick.wong@oracle.com>,
	linux-nvdimm@lists.01.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 6/9] iomap: Convert read_count to byte count
Date: Thu, 27 Aug 2020 09:35:52 +0100	[thread overview]
Message-ID: <20200827083552.GC11067@infradead.org> (raw)
In-Reply-To: <20200824145511.10500-7-willy@infradead.org>

> @@ -269,20 +263,17 @@ iomap_readpage_actor(struct inode *inode, loff_t pos, loff_t length, void *data,
>  	if (ctx->bio && bio_end_sector(ctx->bio) == sector)
>  		is_contig = true;
>  
> -
>  	/*
> -	 * If we start a new segment we need to increase the read count, and we
> -	 * need to do so before submitting any previous full bio to make sure
> -	 * that we don't prematurely unlock the page.
> +	 * We need to increase the read count before submitting any
> +	 * previous bio to make sure that we don't prematurely unlock
> +	 * the page.
>  	 */
>  	if (iop)
> -		atomic_inc(&iop->read_count);
> +		atomic_add(plen, &iop->read_count);
> +
> +	if (is_contig &&
> +	    __bio_try_merge_page(ctx->bio, page, plen, poff, &same_page))
> +		goto done;
>  
>  	if (!ctx->bio || !is_contig || bio_full(ctx->bio, plen)) {

I think we can simplify this a bit by reordering the checks:

 	if (iop)
		atomic_add(plen, &iop->read_count);

  	if (ctx->bio && bio_end_sector(ctx->bio) == sector)
		if (__bio_try_merge_page(ctx->bio, page, plen, poff,
				&same_page))
			goto done;
		is_contig = true;
	}

	if (!is_contig || bio_full(ctx->bio, plen)) {
		// the existing case to allocate a new bio
	}

Also I think read_count should be renamed to be more descriptive,
something like read_bytes_pending?  Same for the write side.

  parent reply	other threads:[~2020-08-27  8:35 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-08-24 14:55 [PATCH 0/9] THP iomap patches for 5.10 Matthew Wilcox (Oracle)
2020-08-24 14:55 ` [PATCH 1/9] iomap: Fix misplaced page flushing Matthew Wilcox (Oracle)
2020-08-24 23:51   ` Dave Chinner
2020-08-25 20:47   ` Darrick J. Wong
2020-08-27  8:24   ` Christoph Hellwig
2020-08-24 14:55 ` [PATCH 2/9] fs: Introduce i_blocks_per_page Matthew Wilcox (Oracle)
2020-08-24 23:55   ` Dave Chinner
2020-08-25 20:49   ` Darrick J. Wong
2020-08-25 22:21     ` Dave Chinner
2020-08-24 14:55 ` [PATCH 3/9] iomap: Use kzalloc to allocate iomap_page Matthew Wilcox (Oracle)
2020-08-24 23:56   ` Dave Chinner
2020-08-25 20:49   ` Darrick J. Wong
2020-08-24 14:55 ` [PATCH 4/9] iomap: Use bitmap ops to set uptodate bits Matthew Wilcox (Oracle)
2020-08-24 23:56   ` Dave Chinner
2020-08-25 20:50   ` Darrick J. Wong
2020-08-24 14:55 ` [PATCH 5/9] iomap: Support arbitrarily many blocks per page Matthew Wilcox (Oracle)
2020-08-24 23:59   ` Dave Chinner
2020-08-25  0:22     ` Matthew Wilcox
2020-08-25 21:02   ` Darrick J. Wong
2020-08-26  2:26     ` Matthew Wilcox
2020-08-26  3:32       ` Darrick J. Wong
2020-08-27  8:26   ` Christoph Hellwig
2020-08-24 14:55 ` [PATCH 6/9] iomap: Convert read_count to byte count Matthew Wilcox (Oracle)
2020-08-25  0:09   ` Dave Chinner
2020-08-25 22:14     ` Darrick J. Wong
2020-08-27  8:35   ` Christoph Hellwig [this message]
2020-08-24 14:55 ` [PATCH 7/9] iomap: Convert write_count " Matthew Wilcox (Oracle)
2020-08-27  8:36   ` Christoph Hellwig
2020-08-24 14:55 ` [PATCH 8/9] iomap: Convert iomap_write_end types Matthew Wilcox (Oracle)
2020-08-25  0:12   ` Dave Chinner
2020-08-25  1:06     ` Matthew Wilcox
2020-08-25  1:33       ` Dave Chinner
2020-08-27  8:41   ` Christoph Hellwig
2020-08-24 14:55 ` [PATCH 9/9] iomap: Change calling convention for zeroing Matthew Wilcox (Oracle)
2020-08-25  0:27   ` Dave Chinner
2020-08-25  3:26     ` Matthew Wilcox
2020-08-25  3:35       ` Andreas Dilger
2020-08-25  4:27         ` Dave Chinner
2020-08-25 12:40           ` Matthew Wilcox
2020-08-25 22:05             ` Dave Chinner
2020-08-25 22:23   ` Darrick J. Wong
2020-08-27  8:39     ` Christoph Hellwig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200827083552.GC11067@infradead.org \
    --to=hch@infradead.org \
    --cc=darrick.wong@oracle.com \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).