linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Chandan Rajendra <chandan@linux.ibm.com>
To: "Darrick J. Wong" <darrick.wong@oracle.com>, david@fromorbit.com
Cc: Chandan Rajendra <chandanrlinux@gmail.com>, linux-xfs@vger.kernel.org
Subject: Re: [PATCH 1/2] xfs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize
Date: Tue, 14 Jan 2020 16:09:52 +0530	[thread overview]
Message-ID: <2377606.TiqrJJHKO2@localhost.localdomain> (raw)
In-Reply-To: <20200113200843.GK8247@magnolia>

On Tuesday, January 14, 2020 1:38 AM Darrick J. Wong wrote: 
> On Fri, Jan 10, 2020 at 09:59:52AM +0530, Chandan Rajendra wrote:
> > This commit changes xfs_attr_leaf_newentsize() to explicitly accept name and
> > value length instead of a pointer to struct xfs_da_args. The next commit will
> > need to invoke xfs_attr_leaf_newentsize() from functions that do not have
> > a struct xfs_da_args to pass in.
> > 
> > Signed-off-by: Chandan Rajendra <chandanrlinux@gmail.com>
> 
> Mechanically this looks reasonable, but does this intersect in any way
> with Allison's delayed attrs patchset?

I don't think so since the patch is only open coding the arguments and the
next one fixes an incorrect log reservation calculation.

> 
> > ---
> >  fs/xfs/libxfs/xfs_attr.c      |  3 ++-
> >  fs/xfs/libxfs/xfs_attr_leaf.c | 33 +++++++++++++++++++++++----------
> >  fs/xfs/libxfs/xfs_attr_leaf.h |  3 ++-
> >  3 files changed, 27 insertions(+), 12 deletions(-)
> > 
> > diff --git a/fs/xfs/libxfs/xfs_attr.c b/fs/xfs/libxfs/xfs_attr.c
> > index 0d7fcc983b3d..1eae1db74f6c 100644
> > --- a/fs/xfs/libxfs/xfs_attr.c
> > +++ b/fs/xfs/libxfs/xfs_attr.c
> > @@ -199,7 +199,8 @@ xfs_attr_calc_size(
> >  	 * Determine space new attribute will use, and if it would be
> >  	 * "local" or "remote" (note: local != inline).
> >  	 */
> > -	size = xfs_attr_leaf_newentsize(args, local);
> > +	size = xfs_attr_leaf_newentsize(mp, args->namelen, args->valuelen,
> > +					local);
> >  	nblks = XFS_DAENTER_SPACE_RES(mp, XFS_ATTR_FORK);
> >  	if (*local) {
> >  		if (size > (args->geo->blksize / 2)) {
> > diff --git a/fs/xfs/libxfs/xfs_attr_leaf.c b/fs/xfs/libxfs/xfs_attr_leaf.c
> > index 08d4b10ae2d5..71024d4aa562 100644
> > --- a/fs/xfs/libxfs/xfs_attr_leaf.c
> > +++ b/fs/xfs/libxfs/xfs_attr_leaf.c
> > @@ -1338,7 +1338,8 @@ xfs_attr3_leaf_add(
> >  	leaf = bp->b_addr;
> >  	xfs_attr3_leaf_hdr_from_disk(args->geo, &ichdr, leaf);
> >  	ASSERT(args->index >= 0 && args->index <= ichdr.count);
> > -	entsize = xfs_attr_leaf_newentsize(args, NULL);
> > +	entsize = xfs_attr_leaf_newentsize(args->dp->i_mount, args->namelen,
> > +					args->valuelen, NULL);
> >  
> >  	/*
> >  	 * Search through freemap for first-fit on new name length.
> > @@ -1440,11 +1441,14 @@ xfs_attr3_leaf_add_work(
> >  	ASSERT(ichdr->freemap[mapindex].base < args->geo->blksize);
> >  	ASSERT((ichdr->freemap[mapindex].base & 0x3) == 0);
> >  	ASSERT(ichdr->freemap[mapindex].size >=
> > -		xfs_attr_leaf_newentsize(args, NULL));
> > +		xfs_attr_leaf_newentsize(mp, args->namelen,
> > +					args->valuelen, NULL));
> >  	ASSERT(ichdr->freemap[mapindex].size < args->geo->blksize);
> >  	ASSERT((ichdr->freemap[mapindex].size & 0x3) == 0);
> >  
> > -	ichdr->freemap[mapindex].size -= xfs_attr_leaf_newentsize(args, &tmp);
> > +	ichdr->freemap[mapindex].size -=
> > +		xfs_attr_leaf_newentsize(mp, args->namelen, args->valuelen,
> > +					&tmp);
> 
> Also these lines (long_lvalue op evenlonger_rvalue) are getting pretty
> gross and hard to read, can we please use some convenience variables?
> 
> 	entsize = xfs_attr_leaf_newentsize(mp, args->namelen, args->valuelen,
> 			&tmp);
> 	ichdr->freemap[mapindex].size -= entsize;
> 
> is a little easier to read than parsing through three levels of
> indentation for one statement.

Sure, I will make the relevant changes.

> 
> Also vaguely wondering about the necessity of opencoding the args, but
> let's go argue about that in the next patch.
> 
> --D
> 
> >  
> >  	entry->nameidx = cpu_to_be16(ichdr->freemap[mapindex].base +
> >  				     ichdr->freemap[mapindex].size);
> > @@ -1831,6 +1835,7 @@ xfs_attr3_leaf_figure_balance(
> >  	struct xfs_attr_leafblock	*leaf1 = blk1->bp->b_addr;
> >  	struct xfs_attr_leafblock	*leaf2 = blk2->bp->b_addr;
> >  	struct xfs_attr_leaf_entry	*entry;
> > +	struct xfs_da_args		*args;
> >  	int				count;
> >  	int				max;
> >  	int				index;
> > @@ -1840,6 +1845,7 @@ xfs_attr3_leaf_figure_balance(
> >  	int				foundit = 0;
> >  	int				tmp;
> >  
> > +	args = state->args;
> >  	/*
> >  	 * Examine entries until we reduce the absolute difference in
> >  	 * byte usage between the two blocks to a minimum.
> > @@ -1847,7 +1853,8 @@ xfs_attr3_leaf_figure_balance(
> >  	max = ichdr1->count + ichdr2->count;
> >  	half = (max + 1) * sizeof(*entry);
> >  	half += ichdr1->usedbytes + ichdr2->usedbytes +
> > -			xfs_attr_leaf_newentsize(state->args, NULL);
> > +		xfs_attr_leaf_newentsize(state->mp, args->namelen,
> > +					args->valuelen, NULL);
> >  	half /= 2;
> >  	lastdelta = state->args->geo->blksize;
> >  	entry = xfs_attr3_leaf_entryp(leaf1);
> > @@ -1859,7 +1866,10 @@ xfs_attr3_leaf_figure_balance(
> >  		 */
> >  		if (count == blk1->index) {
> >  			tmp = totallen + sizeof(*entry) +
> > -				xfs_attr_leaf_newentsize(state->args, NULL);
> > +				xfs_attr_leaf_newentsize(state->mp,
> > +							args->namelen,
> > +							args->valuelen,
> > +							NULL);
> >  			if (XFS_ATTR_ABS(half - tmp) > lastdelta)
> >  				break;
> >  			lastdelta = XFS_ATTR_ABS(half - tmp);
> > @@ -1895,7 +1905,8 @@ xfs_attr3_leaf_figure_balance(
> >  	totallen -= count * sizeof(*entry);
> >  	if (foundit) {
> >  		totallen -= sizeof(*entry) +
> > -				xfs_attr_leaf_newentsize(state->args, NULL);
> > +			xfs_attr_leaf_newentsize(state->mp, args->namelen,
> > +						args->valuelen, NULL);
> >  	}
> >  
> >  	*countarg = count;
> > @@ -2687,20 +2698,22 @@ xfs_attr_leaf_entsize(xfs_attr_leafblock_t *leaf, int index)
> >   */
> >  int
> >  xfs_attr_leaf_newentsize(
> > -	struct xfs_da_args	*args,
> > +	struct xfs_mount	*mp,
> > +	int			namelen,
> > +	int			valuelen,
> >  	int			*local)
> >  {
> >  	int			size;
> >  
> > -	size = xfs_attr_leaf_entsize_local(args->namelen, args->valuelen);
> > -	if (size < xfs_attr_leaf_entsize_local_max(args->geo->blksize)) {
> > +	size = xfs_attr_leaf_entsize_local(namelen, valuelen);
> > +	if (size < xfs_attr_leaf_entsize_local_max(mp->m_attr_geo->blksize)) {
> >  		if (local)
> >  			*local = 1;
> >  		return size;
> >  	}
> >  	if (local)
> >  		*local = 0;
> > -	return xfs_attr_leaf_entsize_remote(args->namelen);
> > +	return xfs_attr_leaf_entsize_remote(namelen);
> >  }
> >  
> >  
> > diff --git a/fs/xfs/libxfs/xfs_attr_leaf.h b/fs/xfs/libxfs/xfs_attr_leaf.h
> > index f4a188e28b7b..0ce1f9301157 100644
> > --- a/fs/xfs/libxfs/xfs_attr_leaf.h
> > +++ b/fs/xfs/libxfs/xfs_attr_leaf.h
> > @@ -106,7 +106,8 @@ void	xfs_attr3_leaf_unbalance(struct xfs_da_state *state,
> >  xfs_dahash_t	xfs_attr_leaf_lasthash(struct xfs_buf *bp, int *count);
> >  int	xfs_attr_leaf_order(struct xfs_buf *leaf1_bp,
> >  				   struct xfs_buf *leaf2_bp);
> > -int	xfs_attr_leaf_newentsize(struct xfs_da_args *args, int *local);
> > +int	xfs_attr_leaf_newentsize(struct xfs_mount *mp, int namelen,
> > +			int valuelen, int *local);
> >  int	xfs_attr3_leaf_read(struct xfs_trans *tp, struct xfs_inode *dp,
> >  			xfs_dablk_t bno, struct xfs_buf **bpp);
> >  void	xfs_attr3_leaf_hdr_from_disk(struct xfs_da_geometry *geo,
> 

-- 
chandan




      parent reply	other threads:[~2020-01-14 10:37 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-10  4:29 [PATCH 1/2] xfs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize Chandan Rajendra
2020-01-10  4:29 ` [PATCH 2/2] xfs: Fix log reservation calculation for xattr insert operation Chandan Rajendra
2020-01-13 21:26   ` Darrick J. Wong
2020-01-14 10:40     ` Chandan Rajendra
     [not found] ` <20200113200843.GK8247@magnolia>
2020-01-14 10:39   ` Chandan Rajendra [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=2377606.TiqrJJHKO2@localhost.localdomain \
    --to=chandan@linux.ibm.com \
    --cc=chandanrlinux@gmail.com \
    --cc=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=linux-xfs@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).