linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-01-09 13:35:04 to 2020-01-15 02:39:11 UTC [more...]

[RFC v2 0/9] Replacing the readpages a_op
 2020-01-15  2:38 UTC  (8+ messages)
` [PATCH v2 2/9] readahead: Ignore return value of ->readpages
` [PATCH v2 3/9] XArray: Add xarray_for_each_range
` [PATCH v2 5/9] mm: Add readahead address space operation
` [PATCH v2 6/9] iomap,xfs: Convert from readpages to readahead
` [PATCH v2 7/9] cifs: "
` [PATCH v2 8/9] mm: Remove add_to_page_cache_locked
` [PATCH v2 9/9] mm: Unify all add_to_page_cache variants

[RFC PATCH V2 00/12] Enable per-file/directory DAX operations V2
 2020-01-15  0:57 UTC  (28+ messages)
` [RFC PATCH V2 01/12] fs/stat: Define DAX statx attribute
` [RFC PATCH V2 02/12] fs/xfs: Isolate the physical DAX flag from effective
` [RFC PATCH V2 03/12] fs/xfs: Separate functionality of xfs_inode_supports_dax()
` [RFC PATCH V2 04/12] fs/xfs: Clean up DAX support check
` [RFC PATCH V2 05/12] fs: remove unneeded IS_DAX() check
` [RFC PATCH V2 06/12] fs/xfs: Check if the inode supports DAX under lock
` [RFC PATCH V2 07/12] fs: Add locking for a dynamic inode 'mode'
` [RFC PATCH V2 08/12] fs/xfs: Add lock/unlock mode to xfs
` [RFC PATCH V2 09/12] fs: Prevent mode change if file is mmap'ed
` [RFC PATCH V2 10/12] fs/xfs: Fix truncate up
` [RFC PATCH V2 11/12] fs/xfs: Clean up locking in dax invalidate
` [RFC PATCH V2 12/12] fs/xfs: Allow toggle of effective DAX flag

[PATCH] xfs: Add __packed to xfs_dir2_sf_entry_t definition
 2020-01-15  0:43 UTC  (3+ messages)

[PATCH v3 0/6] xfs: fix buf log item memory corruption on non-amd64
 2020-01-14 23:02 UTC  (12+ messages)
` [PATCH 1/6] xfs: refactor remote attr value buffer invalidation
` [PATCH 2/6] xfs: fix memory corruption during "
` [PATCH 3/6] xfs: clean up xfs_buf_item_get_format return value
` [PATCH 4/6] xfs: complain if anyone tries to create a too-large buffer log item
` [PATCH 5/6] xfs: make struct xfs_buf_log_format have a consistent size
` [PATCH 6/6] xfs: check log iovec size to make sure it's plausibly a buffer log format

Problems with determining data presence by examining extents?
 2020-01-14 22:49 UTC  (2+ messages)

RFC: hold i_rwsem until aio completes
 2020-01-14 21:50 UTC  (20+ messages)
` [PATCH 01/12] mm: fix a comment in sys_swapon
` [PATCH 02/12] locking/rwsem: Exit early when held by an anonymous owner
` [PATCH 03/12] xfs: fix IOCB_NOWAIT handling in xfs_file_dio_aio_read
` [PATCH 04/12] gfs2: move setting current->backing_dev_info
` [PATCH 05/12] gfs2: fix O_SYNC write handling
` [PATCH 06/12] iomap: pass a flags value to iomap_dio_rw
` [PATCH 07/12] iomap: allow holding i_rwsem until aio completion
` [PATCH 08/12] ext4: hold i_rwsem until AIO completes
` [PATCH 09/12] gfs2: "
` [PATCH 10/12] xfs: "
` [PATCH 11/12] xfs: don't set IOMAP_DIO_SYNCHRONOUS for unaligned I/O
` [PATCH 12/12] iomap: remove the inode_dio_begin/end calls

Making linkat() able to overwrite the target
 2020-01-14 19:37 UTC  (4+ messages)

[PATCH v6 0/2] New zonefs file system
 2020-01-14 18:24 UTC  (7+ messages)
` [PATCH v6 1/2] fs: "
` [PATCH v6 2/2] zonefs: Add documentation

[PATCH 0/2] Allow deduplication of the eof block when it is safe to do so
 2020-01-14 14:36 UTC  (9+ messages)
` [PATCH 1/2] fs: allow deduplication of eof block into the end of the destination file

[PATCH 1/2] xfs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize
 2020-01-14 10:40 UTC  (5+ messages)
` [PATCH 2/2] xfs: Fix log reservation calculation for xattr insert operation

XFS reflink vs ThinLVM
 2020-01-14  8:45 UTC  (12+ messages)

clean up the attr interface v2
 2020-01-14  8:10 UTC  (30+ messages)
` [PATCH 01/29] xfs: remove the ATTR_INCOMPLETE flag
` [PATCH 02/29] xfs: merge xfs_attr_remove into xfs_attr_set
` [PATCH 03/29] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set
` [PATCH 04/29] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE
` [PATCH 05/29] xfs: factor out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op
` [PATCH 06/29] xfs: remove the name == NULL check from xfs_attr_args_init
` [PATCH 07/29] xfs: remove the MAXNAMELEN "
` [PATCH 08/29] xfs: move struct xfs_da_args to xfs_types.h
` [PATCH 09/29] xfs: turn xfs_da_args.value into a void pointer
` [PATCH 10/29] xfs: pass an initialized xfs_da_args structure to xfs_attr_set
` [PATCH 11/29] xfs: pass an initialized xfs_da_args to xfs_attr_get
` [PATCH 12/29] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked
` [PATCH 13/29] xfs: remove ATTR_KERNOVAL
` [PATCH 14/29] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL
` [PATCH 15/29] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME
` [PATCH 16/29] xfs: factor out a xfs_attr_match helper
` [PATCH 17/29] xfs: cleanup xfs_attr_list_context
` [PATCH 18/29] xfs: remove the unused ATTR_ENTRY macro
` [PATCH 19/29] xfs: replace ATTR_ENTBASESIZE with offsetoff
` [PATCH 20/29] xfs: move the legacy xfs_attr_list to xfs_ioctl.c
` [PATCH 21/29] xfs: rename xfs_attr_list_int to xfs_attr_list
` [PATCH 22/29] xfs: lift common checks into xfs_ioc_attr_list
` [PATCH 23/29] xfs: lift buffer allocation "
` [PATCH 24/29] xfs: lift cursor copy in/out "
` [PATCH 25/29] xfs: improve xfs_forget_acl
` [PATCH 26/29] xfs: clean up the ATTR_REPLACE checks
` [PATCH 27/29] xfs: clean up the attr flag confusion
` [PATCH 28/29] xfs: remove XFS_DA_OP_INCOMPLETE
` [PATCH 29/29] xfs: embedded the attrlist cursor into struct xfs_attr_list_context

[PATCH v2] xfstests: xfs mount option sanity test
 2020-01-14  6:44 UTC  (13+ messages)

[RFC 0/8] Replacing the readpages a_op
 2020-01-14  1:07 UTC  (25+ messages)
` [PATCH 1/8] pagevec: Add an iterator
` [PATCH 2/8] mm: Fix the return type of __do_page_cache_readahead
` [PATCH 3/8] mm: Use a pagevec for readahead
` [PATCH 4/8] mm/fs: Add a_ops->readahead
` [PATCH 5/8] iomap,xfs: Convert from readpages to readahead
` [PATCH 6/8] cifs: "
` [PATCH 7/8] mm: Remove add_to_page_cache_locked
` [PATCH 8/8] mm: Unify all add_to_page_cache variants

[PATCH v2 0/5] xfs: fix buf log item memory corruption on non-amd64
 2020-01-14  0:59 UTC  (14+ messages)
` [PATCH 1/5] xfs: refactor remote attr value buffer invalidation
` [PATCH 2/5] xfs: fix memory corruption during "
` [PATCH 3/5] xfs: clean up xfs_buf_item_get_format return value
` [PATCH 4/5] xfs: complain if anyone tries to create a too-large buffer log item
` [PATCH 5/5] xfs: make struct xfs_buf_log_format have a consistent size

[PATCH] xfs: Fix xfs_dir2_sf_entry_t size check
 2020-01-13 17:26 UTC  (12+ messages)

Investment opportunity
 2020-01-12  5:00 UTC 

[RFC PATCH] generic/XXX: Add generic/XXX
 2020-01-11  2:18 UTC 

[PATCH v3 0/3] xfs: fix maxbytes problems on 32-bit systems
 2020-01-10 11:52 UTC  (6+ messages)
` [PATCH 1/3] xfs: introduce XFS_MAX_FILEOFF
` [PATCH 2/3] xfs: truncate should remove all blocks, not just to the end of the page cache
` [PATCH 3/3] xfs: fix s_maxbytes computation on 32-bit kernels

[PATCH 1/2] xfsprogs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize
 2020-01-10  4:30 UTC  (2+ messages)
` [PATCH 2/2] xfsprogs: Fix log reservation calculation for xattr insert operation

[PATCH] xfs/126: fix that corrupt xattr might fail with a small probability
 2020-01-09 16:46 UTC  (4+ messages)

[PATCH v4] fs: Fix page_mkwrite off-by-one errors
 2020-01-09 13:34 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).