linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-02-19 18:46:27 to 2020-02-21 05:21:56 UTC [more...]

XFS reports lchmod failure, but changes file system contents
 2020-02-21  5:21 UTC  (10+ messages)

reduce dmesg spam v2
 2020-02-21  4:41 UTC  (6+ messages)
` [PATCH 1/2] xfs: ratelimit xfs_buf_ioerror_alert messages
` [PATCH 2/2] xfs: ratelimit xfs_discard_page messages

[PATCH v3] xfs: add agf freeblocks verify in xfs_agf_verify
 2020-02-21  4:47 UTC 

[PATCH v7 00/23] Change readahead API
 2020-02-21  4:30 UTC  (49+ messages)
` [PATCH v7 01/24] mm: Move readahead prototypes from mm.h
` [PATCH v7 02/24] mm: Return void from various readahead functions
` [PATCH v7 03/24] mm: Ignore return value of ->readpages
` [PATCH v7 04/24] mm: Move readahead nr_pages check into read_pages
` [PATCH v7 05/24] mm: Use readahead_control to pass arguments
` [PATCH v7 06/24] mm: Rename various 'offset' parameters to 'index'
` [PATCH v7 07/24] mm: rename readahead loop variable to 'i'
` [PATCH v7 08/24] mm: Remove 'page_offset' from readahead loop
` [PATCH v7 09/24] mm: Put readahead pages in cache earlier
` [PATCH v7 10/24] mm: Add readahead address space operation
` [PATCH v7 11/24] mm: Move end_index check out of readahead loop
` [PATCH v7 12/24] mm: Add page_cache_readahead_unbounded
` [PATCH v7 13/24] fs: Convert mpage_readpages to mpage_readahead
` [PATCH v7 14/24] btrfs: Convert from readpages to readahead
` [PATCH v7 15/24] erofs: Convert uncompressed files "
` [PATCH v7 16/24] erofs: Convert compressed "
` [PATCH v7 17/24] ext4: Convert "
` [PATCH v7 18/24] ext4: Pass the inode to ext4_mpage_readpages
` [PATCH v7 19/24] f2fs: Convert from readpages to readahead
` [PATCH v7 20/24] fuse: "
` [PATCH v7 21/24] iomap: Restructure iomap_readpages_actor
` [PATCH v7 22/24] iomap: Convert from readpages to readahead
` [PATCH v7 23/24] mm: Document why we don't set PageReadahead
` [PATCH v7 24/24] mm: Use memalloc_nofs_save in readahead path

[PATCH] fs: fix a data race in i_size_write/i_size_read
 2020-02-21  4:19 UTC  (2+ messages)

[PATCH V4 00/13] Enable per-file/per-directory DAX operations V4
 2020-02-21  1:42 UTC  (17+ messages)
` [PATCH V4 01/13] fs/xfs: Remove unnecessary initialization of i_rwsem
` [PATCH V4 02/13] fs/xfs: Clarify lockdep dependency for xfs_isilocked()
` [PATCH V4 03/13] fs: Remove unneeded IS_DAX() check
` [PATCH V4 04/13] fs/stat: Define DAX statx attribute
` [PATCH V4 05/13] fs/xfs: Isolate the physical DAX flag from enabled
` [PATCH V4 06/13] fs/xfs: Create function xfs_inode_enable_dax()
` [PATCH V4 07/13] fs: Add locking for a dynamic address space operations state
` [PATCH V4 08/13] fs: Prevent DAX state change if file is mmap'ed
` [PATCH V4 09/13] fs/xfs: Add write aops lock to xfs layer
` [PATCH V4 10/13] fs/xfs: Clean up locking in dax invalidate
` [PATCH V4 11/13] fs/xfs: Allow toggle of effective DAX flag
` [PATCH V4 12/13] fs/xfs: Remove xfs_diflags_to_linux()
` [PATCH V4 13/13] Documentation/dax: Update Usage section

remove the di_uid/di_gid fields from the XFS icdinode
 2020-02-21  1:26 UTC  (7+ messages)
` [PATCH 1/3] xfs: ensure that the inode uid/gid match values match the icdinode ones
` [PATCH 2/3] xfs: remove the icdinode di_uid/di_gid members
` [PATCH 3/3] xfs: remove the kuid/kgid conversion wrappers

[PATCH v2 0/8] xfsprogs: actually check that writes succeeded
 2020-02-21  1:17 UTC  (24+ messages)
` [PATCH 1/8] libxfs: libxfs_buf_delwri_submit should write buffers immediately
` [PATCH 2/8] libxfs: complain when write IOs fail
` [PATCH 3/8] libxfs: return flush failures
` [PATCH 4/8] libxfs: enable tools to check that metadata updates have been committed
` [PATCH 5/8] xfs_db: "
` [PATCH 6/8] mkfs: "
` [PATCH 7/8] xfs_repair: "
` [PATCH 8/8] libfrog: always fsync when flushing a device

Modern uses of CONFIG_XFS_RT
 2020-02-20 22:06 UTC  (13+ messages)

[Lsf-pc] [LSF/MM/BPF TOPIC] Atomic Writes
 2020-02-20 21:30 UTC  (3+ messages)

[PATCH V2 0/3] fstests: fixes for 64k pages and dax
 2020-02-20 21:21 UTC  (5+ messages)
` [PATCH V2 1/3] dax/dm: disable testing on devices that don't support dax
` [PATCH V2 2/3] t_mmap_collision: fix hard-coded page size
` [PATCH V2 3/3] xfs/300: modify test to work on any fs block size

[PATCH v2] xfs_io/encrypt: support passing a keyring key to add_enckey
 2020-02-20 18:42 UTC  (3+ messages)

[PATCH v5 1/4] xfs: Refactor xfs_isilocked()
 2020-02-20 17:27 UTC  (12+ messages)

[PATCH v3 00/12] Enable per-file/directory DAX operations V3
 2020-02-20 17:00 UTC  (14+ messages)

[PATCH 0/1] selinux: Add xfs quota command types
 2020-02-20 16:08 UTC  (6+ messages)
` [PATCH 1/1] "

[PATCH v2] xfs: fix iclog release error check race with shutdown
 2020-02-20 16:02 UTC  (12+ messages)

[PATCH v2] xfs: add agf freeblocks verify in xfs_agf_verify
 2020-02-20 15:56 UTC  (3+ messages)

reduce dmesg spam
 2020-02-20 14:12 UTC  (4+ messages)
` [PATCH 1/2] xfs: ratelimit xfs_buf_ioerror_alert
` [PATCH 2/2] xfs: ratelimit xfs_discard_page alert messages

[PATCH] xfs/030: fix test for external log device
 2020-02-20 13:42 UTC  (3+ messages)

[PATCH 1/2] generic: per-type quota timers set/get test
 2020-02-20  5:05 UTC  (4+ messages)

[PATCH] xfs: test that default grace periods init on first mount
 2020-02-20  4:50 UTC  (2+ messages)

[RFC PATCH] xfs: make sure our default quota warning limits and grace periods survive quotacheck
 2020-02-20  4:31 UTC  (3+ messages)

[PATCH 00/14] xfsprogs: make buffer functions return error codes
 2020-02-20  1:53 UTC  (16+ messages)
` [PATCH 01/14] libxfs: make __cache_lookup return an error code
` [PATCH 02/14] libxfs: make libxfs_getbuf_flags "
` [PATCH 03/14] libxfs: make libxfs_buf_get_map "
` [PATCH 04/14] libxfs: refactor libxfs_readbuf out of existence
` [PATCH 05/14] libxfs: make libxfs_buf_read_map return an error code
` [PATCH 06/14] xfs: make xfs_buf_read_map "
` [PATCH 07/14] xfs: make xfs_buf_get "
` [PATCH 08/14] xfs: make xfs_buf_get_uncached "
` [PATCH 09/14] xfs: make xfs_buf_read "
` [PATCH 10/14] xfs: make xfs_trans_get_buf_map "
` [PATCH 11/14] xfs: make xfs_trans_get_buf "
` [PATCH 12/14] xfs: remove the xfs_btree_get_buf[ls] functions
` [PATCH 13/14] xfs: make xfs_*read_agf return EAGAIN to ALLOC_FLAG_TRYLOCK callers
` [PATCH 14/14] xfs: remove unnecessary null pointer checks from _read_agf callers

[PATCH 00/18] xfsprogs: refactor buffer function names
 2020-02-20  1:44 UTC  (19+ messages)
` [PATCH 01/18] libxfs: clean up readbuf flags
` [PATCH 02/18] libxfs: clean up writebuf flags
` [PATCH 03/18] libxfs: remove LIBXFS_EXIT_ON_FAILURE
` [PATCH 04/18] libxfs: replace libxfs_putbuf with libxfs_buf_relse
` [PATCH 05/18] libxfs: replace libxfs_getbuf with libxfs_buf_get
` [PATCH 06/18] libxfs: replace libxfs_readbuf with libxfs_buf_read
` [PATCH 07/18] libxfs: make libxfs_bwrite do what libxfs_writebufr does
` [PATCH 08/18] libxfs: make libxfs_readbuf_verify return an error code
` [PATCH 09/18] libxfs: make libxfs_readbufr stash the error value in b_error
` [PATCH 10/18] libxfs: introduce libxfs_buf_read_uncached
` [PATCH 11/18] libxlog: use uncached buffers instead of open-coding them
` [PATCH 12/18] libxfs: use uncached buffers for initial mkfs writes
` [PATCH 13/18] libxfs: straighten out libxfs_writebuf confusion
` [PATCH 14/18] libxfs: remove libxfs_writebuf_int
` [PATCH 15/18] libxfs: hide libxfs_{get,put}bufr
` [PATCH 16/18] libxfs: hide libxfs_getbuf_flags
` [PATCH 17/18] libxfs: rename libxfs_readbuf_map to libxfs_buf_read_map
` [PATCH 18/18] libxfs: rename libxfs_getbuf_map to libxfs_buf_get_map

[PATCH v13 0/2] New zonefs file system
 2020-02-20  1:15 UTC  (5+ messages)
` [PATCH v13 2/2] zonefs: Add documentation

[PATCH] xfs: remove the di_version field from struct icdinode
 2020-02-19 21:47 UTC  (7+ messages)

[PATCH v6 00/19] Change readahead API
 2020-02-19 20:24 UTC  (7+ messages)
` [PATCH v6 07/19] mm: Put readahead pages in cache earlier


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).