linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-02-24 22:50:43 to 2020-02-25 23:10:14 UTC [more...]

clean up the attr interface v6
 2020-02-25 23:09 UTC  (3+ messages)
` [PATCH 02/30] xfs: remove the ATTR_INCOMPLETE flag
` [PATCH 04/30] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set

[PATCH V4 00/13] Enable per-file/per-directory DAX operations V4
 2020-02-25 22:59 UTC  (15+ messages)
` [PATCH V4 07/13] fs: Add locking for a dynamic address space operations state
` [PATCH V4 09/13] fs/xfs: Add write aops lock to xfs layer

[PATCH v7 00/19] xfs: Delayed Ready Attrs
 2020-02-25 22:27 UTC  (53+ messages)
` [PATCH v7 01/19] xfs: Replace attribute parameters with struct xfs_name
` [PATCH v7 02/19] xfs: Embed struct xfs_name in xfs_da_args
` [PATCH v7 03/19] xfs: Add xfs_has_attr and subroutines
` [PATCH v7 05/19] xfs: Factor out new helper functions xfs_attr_rmtval_set
` [PATCH v7 07/19] xfs: Factor out xfs_attr_leaf_addname helper
` [PATCH v7 12/19] xfs: Add helper function xfs_attr_rmtval_unmap
` [PATCH v7 13/19] xfs: Add delay ready attr remove routines
` [PATCH v7 15/19] xfs: Add helper function xfs_attr_node_shrink
` [PATCH v7 16/19] xfs: Simplify xfs_attr_set_iter
` [PATCH v7 17/19] xfs: Add helper function xfs_attr_leaf_mark_incomplete

[PATCH v2] xfs: fix an undefined behaviour in _da3_path_shift
 2020-02-25 22:05 UTC  (4+ messages)

[PATCH v8 00/25] Change readahead API
 2020-02-25 21:48 UTC  (26+ messages)
` [PATCH v8 01/25] mm: Move readahead prototypes from mm.h
` [PATCH v8 02/25] mm: Return void from various readahead functions
` [PATCH v8 03/25] mm: Ignore return value of ->readpages
` [PATCH v8 04/25] mm: Move readahead nr_pages check into read_pages
` [PATCH v8 05/25] mm: Add new readahead_control API
` [PATCH v8 06/25] mm: Use readahead_control to pass arguments
` [PATCH v8 07/25] mm: Rename various 'offset' parameters to 'index'
` [PATCH v8 08/25] mm: rename readahead loop variable to 'i'
` [PATCH v8 09/25] mm: Remove 'page_offset' from readahead loop
` [PATCH v8 10/25] mm: Put readahead pages in cache earlier
` [PATCH v8 11/25] mm: Add readahead address space operation
` [PATCH v8 12/25] mm: Move end_index check out of readahead loop
` [PATCH v8 13/25] mm: Add page_cache_readahead_unbounded
` [PATCH v8 14/25] mm: Document why we don't set PageReadahead
` [PATCH v8 15/25] mm: Use memalloc_nofs_save in readahead path
` [PATCH v8 16/25] fs: Convert mpage_readpages to mpage_readahead
` [PATCH v8 17/25] btrfs: Convert from readpages to readahead
` [PATCH v8 18/25] erofs: Convert uncompressed files "
` [PATCH v8 19/25] erofs: Convert compressed "
` [PATCH v8 20/25] ext4: Convert "
` [PATCH v8 21/25] ext4: Pass the inode to ext4_mpage_readpages
` [PATCH v8 22/25] f2fs: Convert from readpages to readahead
` [PATCH v8 23/25] f2fs: Pass the inode to f2fs_mpage_readpages
` [PATCH v8 24/25] fuse: Convert from readpages to readahead
` [PATCH v8 25/25] iomap: "

[PATCH 0/1] selinux: Add xfs quota command types
 2020-02-25 21:35 UTC  (9+ messages)

[PATCH] xfs: fix data races in inode->i_*time
 2020-02-25 20:46 UTC  (4+ messages)

clean up the attr interface v6
 2020-02-25 19:51 UTC  (4+ messages)
` [PATCH 01/30] xfs: reject invalid flags combinations in XFS_IOC_ATTRLIST_BY_HANDLE
` [PATCH 02/30] xfs: remove the ATTR_INCOMPLETE flag

[PATCH 0/2] libfrog: various small fixes
 2020-02-25 19:40 UTC  (6+ messages)
` [PATCH 2/2] libfrog: move topology.[ch] to libxfs

[PATCH v2 00/25] xfsprogs: refactor buffer function names
 2020-02-25 19:26 UTC  (49+ messages)
` [PATCH 01/25] libxfs: open-code "exit on buffer read failure" in upper level callers
  ` [PATCH v2 "
` [PATCH 02/25] libxfs: remove LIBXFS_EXIT_ON_FAILURE
` [PATCH 03/25] libxfs: remove LIBXFS_B_EXIT
` [PATCH 04/25] libxfs: replace libxfs_putbuf with libxfs_buf_relse
` [PATCH 05/25] libxfs: replace libxfs_getbuf with libxfs_buf_get
` [PATCH 06/25] libxfs: replace libxfs_readbuf with libxfs_buf_read
` [PATCH 07/25] libxfs: rename libxfs_writebufr to libxfs_bwrite
` [PATCH 08/25] libxfs: make libxfs_readbuf_verify return an error code
` [PATCH 09/25] libxfs: make libxfs_readbufr stash the error value in b_error
` [PATCH 10/25] libxfs: introduce libxfs_buf_read_uncached
` [PATCH 11/25] xfs_db: use uncached buffer reads to get the superblock
` [PATCH 12/25] xfs_copy: "
` [PATCH 13/25] libxfs: move log functions for convenience
` [PATCH 14/25] libxfs: convert libxfs_log_clear to use uncached buffers
` [PATCH 15/25] libxlog: use uncached buffers instead of open-coding them
` [PATCH 16/25] libxfs: use uncached buffers for initial mkfs writes
` [PATCH 17/25] libxfs: straighten out libxfs_writebuf naming confusion
` [PATCH 18/25] libxfs: remove unused flags parameter to libxfs_buf_mark_dirty
` [PATCH 19/25] libxfs: remove libxfs_writebuf_int
` [PATCH 20/25] libxfs: remove dangerous casting between xfs_buf and cache_node
` [PATCH 21/25] libxfs: remove dangerous casting between cache_node and xfs_buf
` [PATCH 22/25] libxfs: remove the libxfs_{get,put}bufr APIs
` [PATCH 23/25] libxfs: hide libxfs_getbuf_flags
` [PATCH 24/25] libxfs: rename libxfs_readbuf_map to libxfs_buf_read_map
` [PATCH 25/25] libxfs: rename libxfs_getbuf_map to libxfs_buf_get_map

[PATCH v3 0/7] xfsprogs: actually check that writes succeeded
 2020-02-25 19:24 UTC  (17+ messages)
` [PATCH 1/7] libxfs: libxfs_buf_delwri_submit should write buffers immediately
` [PATCH 2/7] libxfs: complain when write IOs fail
` [PATCH 3/7] libxfs: return flush failures
` [PATCH 4/7] libxfs: flush all dirty buffers and report errors when unmounting filesystem
` [PATCH 5/7] mkfs: check that metadata updates have been committed
` [PATCH 6/7] xfs_repair: "
  ` [PATCH v2 "
` [PATCH 7/7] libfrog: always fsync when flushing a device

[PATCH, RFC] libxfs: use FALLOC_FL_ZERO_RANGE in libxfs_device_zero
 2020-02-25 19:16 UTC  (4+ messages)
` [PATCH V4] "

[PATCH] xfs: fix an undefined behaviour in _da3_path_shift
 2020-02-25 19:08 UTC  (6+ messages)

[PATCH v2 00/14] xfsprogs: make buffer functions return error codes
 2020-02-25 18:59 UTC  (17+ messages)
` [PATCH 01/14] libxfs: make __cache_lookup return an error code
` [PATCH 02/14] libxfs: make libxfs_getbuf_flags "
` [PATCH 03/14] libxfs: make libxfs_buf_get_map "
` [PATCH 04/14] libxfs: refactor libxfs_readbuf out of existence
` [PATCH 05/14] libxfs: make libxfs_buf_read_map return an error code
` [PATCH 06/14] xfs: make xfs_buf_read_map "
` [PATCH 07/14] xfs: make xfs_buf_get "
` [PATCH 08/14] xfs: make xfs_buf_get_uncached "
` [PATCH 09/14] xfs: make xfs_buf_read "
` [PATCH 10/14] xfs: make xfs_trans_get_buf_map "
` [PATCH 11/14] xfs: make xfs_trans_get_buf "
` [PATCH 12/14] xfs: remove the xfs_btree_get_buf[ls] functions
` [PATCH 13/14] xfs: make xfs_*read_agf return EAGAIN to ALLOC_FLAG_TRYLOCK callers
` [PATCH 14/14] xfs: remove unnecessary null pointer checks from _read_agf callers

[PATCH 0/2] libxfs: minor cleanups of destructors
 2020-02-25 18:48 UTC  (12+ messages)
` [PATCH 1/2] libxfs: zero the struct xfs_mount when unmounting the filesystem
` [PATCH 2/2] libxfs: clean up libxfs_destroy

[PATCH] xfs: mark ARM OABI as incompatible in Kconfig
 2020-02-25 17:56 UTC  (4+ messages)

agfl and related cleanups
 2020-02-25 17:24 UTC  (9+ messages)
` [PATCH 1/6] xfs: remove the agfl_bno member from struct xfs_agfl

[PATCH V4 RESEND 0/7] Fix log reservation calculation for xattr insert operation
 2020-02-25 17:19 UTC  (15+ messages)
` [PATCH V4 RESEND 1/7] xfs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize
` [PATCH V4 RESEND 2/7] xfs: xfs_attr_calc_size: Use local variables to track individual space components
` [PATCH V4 RESEND 3/7] xfs: xfs_attr_calc_size: Calculate Bmbt blks only once
` [PATCH V4 RESEND 4/7] xfs: Introduce struct xfs_attr_set_resv
` [PATCH V4 RESEND 5/7] xfs: xfs_attr_calc_size: Explicitly pass mp, namelen and valuelen args
` [PATCH V4 RESEND 6/7] xfs: Make xfs_attr_calc_size() non-static
` [PATCH V4 RESEND 7/7] xfs: Fix log reservation calculation for xattr insert operation

[PATCH 03/30] xfs: Add missing annotation to xfs_ail_check()
 2020-02-25 15:44 UTC  (2+ messages)

[PATCH v7 00/23] Change readahead API
 2020-02-25  1:49 UTC  (6+ messages)
` [PATCH v7 21/24] iomap: Restructure iomap_readpages_actor


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).