linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-02-26 17:01:24 to 2020-02-29 11:21:32 UTC [more...]

[PATCH v3] xfs: add agf freeblocks verify in xfs_agf_verify
 2020-02-29 11:21 UTC  (3+ messages)

[RFC v5 PATCH 0/9] xfs: automatic relogging experiment
 2020-02-29  5:35 UTC  (38+ messages)
` [RFC v5 PATCH 1/9] xfs: set t_task at wait time instead of alloc time
` [RFC v5 PATCH 2/9] xfs: introduce ->tr_relog transaction
` [RFC v5 PATCH 3/9] xfs: automatic relogging reservation management
` [RFC v5 PATCH 4/9] xfs: automatic relogging item management
` [RFC v5 PATCH 5/9] xfs: automatic log item relog mechanism
` [RFC v5 PATCH 6/9] xfs: automatically relog the quotaoff start intent
` [RFC v5 PATCH 7/9] xfs: buffer relogging support prototype
` [RFC v5 PATCH 8/9] xfs: create an error tag for random relog reservation
` [RFC v5 PATCH 9/9] xfs: relog random buffers based on errortag

[PATCH 0/3] xfs: fix errors in attr/directory scrubbers
 2020-02-29  1:49 UTC  (4+ messages)
` [PATCH 1/3] xfs: mark dir corrupt when lookup-by-hash fails
` [PATCH 2/3] xfs: mark extended attr "
` [PATCH 3/3] xfs: scrub should mark dir corrupt if entry points to unallocated inode

[PATCH 0/4] xfs: fix errors in directory verifiers
 2020-02-29  1:49 UTC  (5+ messages)
` [PATCH 1/4] xfs: fix buffer state when we reject a corrupt dir free block
` [PATCH 2/4] xfs: check owner of dir3 free blocks
` [PATCH 3/4] xfs: check owner of dir3 data blocks
` [PATCH 4/4] xfs: check owner of dir3 blocks

[PATCH v3 00/26] xfsprogs: refactor buffer function names
 2020-02-28 23:39 UTC  (27+ messages)
` [PATCH 01/26] libxfs: open-code "exit on buffer read failure" in upper level callers
` [PATCH 02/26] libxfs: remove LIBXFS_EXIT_ON_FAILURE
` [PATCH 03/26] libxfs: remove LIBXFS_B_EXIT
` [PATCH 04/26] libxfs: replace libxfs_putbuf with libxfs_buf_relse
` [PATCH 05/26] libxfs: replace libxfs_getbuf with libxfs_buf_get
` [PATCH 06/26] libxfs: replace libxfs_readbuf with libxfs_buf_read
` [PATCH 07/26] libxfs: rename libxfs_writebufr to libxfs_bwrite
` [PATCH 08/26] libxfs: make libxfs_readbuf_verify return an error code
` [PATCH 09/26] libxfs: make libxfs_readbufr stash the error value in b_error
` [PATCH 10/26] libxfs: introduce libxfs_buf_read_uncached
` [PATCH 11/26] xfs_db: use uncached buffer reads to get the superblock
` [PATCH 12/26] xfs_copy: "
` [PATCH 13/26] libxfs: move log functions for convenience
` [PATCH 14/26] libxfs: convert libxfs_log_clear to use uncached buffers
` [PATCH 15/26] libxlog: use uncached buffers instead of open-coding them
` [PATCH 16/26] libxfs: use uncached buffers for initial mkfs writes
` [PATCH 17/26] libxfs: straighten out libxfs_writebuf naming confusion
` [PATCH 18/26] libxfs: remove unused flags parameter to libxfs_buf_mark_dirty
` [PATCH 19/26] libxfs: remove libxfs_writebuf_int
` [PATCH 20/26] libxfs: remove dangerous casting between xfs_buf and cache_node
` [PATCH 21/26] libxfs: remove dangerous casting between cache_node and xfs_buf
` [PATCH 22/26] libxfs: remove the libxfs_{get,put}bufr APIs
` [PATCH 23/26] libxfs: hide libxfs_getbuf_flags
` [PATCH 24/26] libxfs: rename libxfs_readbuf_map to libxfs_buf_read_map
` [PATCH 25/26] libxfs: rename libxfs_getbuf_map to libxfs_buf_get_map
` [PATCH 26/26] libxfs: convert buffer priority get/set macros to functions

[PATCH v4 0/7] xfsprogs: actually check that writes succeeded
 2020-02-28 23:36 UTC  (8+ messages)
` [PATCH 1/7] libxfs: libxfs_buf_delwri_submit should write buffers immediately
` [PATCH 2/7] libxfs: complain when write IOs fail
` [PATCH 3/7] libxfs: return flush failures
` [PATCH 4/7] libxfs: flush all dirty buffers and report errors when unmounting filesystem
` [PATCH 5/7] mkfs: check that metadata updates have been committed
` [PATCH 6/7] xfs_repair: "
` [PATCH 7/7] libfrog: always fsync when flushing a device

[PATCH v7 00/19] xfs: Delayed Ready Attrs
 2020-02-28 18:14 UTC  (29+ messages)
` [PATCH v7 06/19] xfs: Factor out trans handling in xfs_attr3_leaf_flipflags
` [PATCH v7 07/19] xfs: Factor out xfs_attr_leaf_addname helper
` [PATCH v7 08/19] xfs: Refactor xfs_attr_try_sf_addname
` [PATCH v7 09/19] xfs: Factor out trans roll from xfs_attr3_leaf_setflag
` [PATCH v7 10/19] xfs: Factor out xfs_attr_rmtval_invalidate
` [PATCH v7 11/19] xfs: Factor out trans roll in xfs_attr3_leaf_clearflag
` [PATCH v7 13/19] xfs: Add delay ready attr remove routines
` [PATCH v7 16/19] xfs: Simplify xfs_attr_set_iter

[PATCH v6 0/4] xfs: Remove wrappers for some semaphores
 2020-02-28 17:10 UTC  (6+ messages)
` [PATCH v6 1/4] xfs: Refactor xfs_isilocked()
` [PATCH v6 2/4] xfs: clean up whitespace in xfs_isilocked() calls
` [PATCH v6 3/4] xfs: xfs_isilocked() can only check a single lock type
` [PATCH v6 4/4] xfs: replace mrlock_t with rw_semaphores

[ANNOUNCE] xfsprogs for-next updated to fbbb184b
 2020-02-28 16:42 UTC  (3+ messages)

[PATCH] fstests: fix up filters & expected output for latest xfs_repair
 2020-02-28 15:17 UTC  (3+ messages)

[PATCH v8 00/25] Change readahead API
 2020-02-28 14:08 UTC  (15+ messages)
` [PATCH v8 05/25] mm: Add new readahead_control API
` [PATCH v8 07/25] mm: Rename various 'offset' parameters to 'index'
` [PATCH v8 14/25] mm: Document why we don't set PageReadahead
` [PATCH v8 17/25] btrfs: Convert from readpages to readahead
` [PATCH v8 25/25] iomap: "

BUG: unable to handle kernel paging request in xfs_sb_read_verify
 2020-02-28  8:01 UTC  (2+ messages)

[PATCH RFC 0/3] fs: online filesystem uuid operations
 2020-02-27 21:33 UTC  (4+ messages)
` [PATCH 1/3] vfs: create ioctls to query and set the filesystem uuids
` [PATCH 2/3] xfs: allow online filesystem uuid queries
` [PATCH 3/3] ext4: "

[PATCH] xfs_repair: join realtime inodes to transaction only once
 2020-02-27 21:00 UTC  (2+ messages)

[PATCH] xfs_scrub: fix reporting of EINVAL for online repairs
 2020-02-27 20:28 UTC  (2+ messages)

[PATCH V4 00/13] Enable per-file/per-directory DAX operations V4
 2020-02-27 17:52 UTC  (24+ messages)
` [PATCH V4 01/13] fs/xfs: Remove unnecessary initialization of i_rwsem
` [PATCH V4 07/13] fs: Add locking for a dynamic address space operations state
` [PATCH V4 09/13] fs/xfs: Add write aops lock to xfs layer

[PATCH V5 00/12] Enable per-file/per-directory DAX operations V5
 2020-02-27 17:25 UTC  (14+ messages)
` [PATCH V5 01/12] fs/xfs: Remove unnecessary initialization of i_rwsem
` [PATCH V5 02/12] fs: Remove unneeded IS_DAX() check
` [PATCH V5 03/12] fs/stat: Define DAX statx attribute
` [PATCH V5 04/12] fs/xfs: Isolate the physical DAX flag from enabled
` [PATCH V5 05/12] fs/xfs: Create function xfs_inode_enable_dax()
` [PATCH V5 06/12] fs: Add locking for a dynamic address space operations state
` [PATCH V5 07/12] fs: Prevent DAX state change if file is mmap'ed
` [PATCH V5 08/12] fs/xfs: Hold off aops users while changing DAX state
` [PATCH V5 09/12] fs/xfs: Clean up locking in dax invalidate
` [PATCH V5 10/12] fs/xfs: Allow toggle of effective DAX flag
` [PATCH V5 11/12] fs/xfs: Remove xfs_diflags_to_linux()
` [PATCH V5 12/12] Documentation/dax: Update Usage section

[PATCH 0/3] xfs: prepare repair for bulk loading
 2020-02-27 15:51 UTC  (7+ messages)
` [PATCH 2/3] xfs: implement block reservation accounting for btrees we're staging

[PATCH V4 RESEND 0/7] Fix log reservation calculation for xattr insert operation
 2020-02-27 13:38 UTC  (14+ messages)
` [PATCH V4 RESEND 1/7] xfs: Pass xattr name and value length explicitly to xfs_attr_leaf_newentsize
` [PATCH V4 RESEND 7/7] xfs: Fix log reservation calculation for xattr insert operation
` [PATCH V4 RESEND 3/7] xfs: xfs_attr_calc_size: Calculate Bmbt blks only once

[PATCH] xfs/XXX: Add xfs/XXX
 2020-02-27  5:38 UTC 

clean up the attr interface v7
 2020-02-26 21:40 UTC  (37+ messages)
` [PATCH 01/32] xfs: reject invalid flags combinations in XFS_IOC_ATTRLIST_BY_HANDLE
` [PATCH 02/32] xfs: remove the ATTR_INCOMPLETE flag
` [PATCH 03/32] xfs: merge xfs_attr_remove into xfs_attr_set
` [PATCH 04/32] xfs: merge xfs_attrmulti_attr_remove into xfs_attrmulti_attr_set
` [PATCH 05/32] xfs: use strndup_user in XFS_IOC_ATTRMULTI_BY_HANDLE
` [PATCH 06/32] xfs: factor out a helper for a single XFS_IOC_ATTRMULTI_BY_HANDLE op
` [PATCH 07/32] xfs: remove the name == NULL check from xfs_attr_args_init
` [PATCH 08/32] xfs: remove the MAXNAMELEN "
` [PATCH 09/32] xfs: turn xfs_da_args.value into a void pointer
` [PATCH 10/32] xfs: pass an initialized xfs_da_args structure to xfs_attr_set
` [PATCH 11/32] xfs: pass an initialized xfs_da_args to xfs_attr_get
` [PATCH 12/32] xfs: remove the xfs_inode argument to xfs_attr_get_ilocked
` [PATCH 13/32] xfs: remove ATTR_KERNOVAL
` [PATCH 14/32] xfs: remove ATTR_ALLOC and XFS_DA_OP_ALLOCVAL
` [PATCH 15/32] xfs: replace ATTR_KERNOTIME with XFS_DA_OP_NOTIME
` [PATCH 16/32] xfs: factor out a xfs_attr_match helper
` [PATCH 17/32] xfs: cleanup struct xfs_attr_list_context
` [PATCH 18/32] xfs: remove the unused ATTR_ENTRY macro
` [PATCH 19/32] xfs: open code ATTR_ENTSIZE
` [PATCH 20/32] xfs: move the legacy xfs_attr_list to xfs_ioctl.c
` [PATCH 21/32] xfs: rename xfs_attr_list_int to xfs_attr_list
` [PATCH 22/32] xfs: lift common checks into xfs_ioc_attr_list
` [PATCH 23/32] xfs: lift buffer allocation "
` [PATCH 24/32] xfs: lift cursor copy in/out "
` [PATCH 25/32] xfs: improve xfs_forget_acl
` [PATCH 26/32] xfs: clean up the ATTR_REPLACE checks
` [PATCH 27/32] xfs: clean up the attr flag confusion
` [PATCH 28/32] xfs: remove XFS_DA_OP_INCOMPLETE
` [PATCH 29/32] xfs: embedded the attrlist cursor into struct xfs_attr_list_context
` [PATCH 30/32] xfs: clean up bufsize alignment in xfs_ioc_attr_list
` [PATCH 31/32] xfs: only allocate the buffer size actually needed in __xfs_set_acl
` [PATCH 32/32] xfs: switch xfs_attrmulti_attr_get to lazy attr buffer allocation

[PATCH 0/2] xfs: don't take addresses of packed structures
 2020-02-26 18:45 UTC  (7+ messages)
` [PATCH 2/2] xfs: don't take addresses of packed xfs_rmap_key
  ` [PATCH 2/2 V2] xfs: don't take addresses of packed xfs_rmap_key member
    ` [PATCH 2/2 V3] "

[PATCH v4 0/7] xfs_repair: do not trash valid root dirs
 2020-02-26 17:55 UTC  (11+ messages)
` [PATCH 3/7] xfs_repair: enforce that inode btree chunks can't point to AG headers
` [PATCH 7/7] xfs_repair: try to correct sb_unit value from secondaries


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).