linux-xfs.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-07-15 18:29:42 to 2020-07-21 14:59:21 UTC [more...]

[PATCH v5 00/11] xfs: separate dquot type from flags
 2020-07-21 14:59 UTC  (40+ messages)
` [PATCH 01/11] xfs: drop the type parameter from xfs_dquot_verify
` [PATCH 02/11] xfs: rename XFS_DQ_{USER,GROUP,PROJ} to XFS_DQTYPE_*
` [PATCH 03/11] xfs: refactor testing if a particular dquot is being enforced
` [PATCH 04/11] xfs: remove the XFS_QM_IS[UGP]DQ macros
` [PATCH 05/11] xfs: refactor quota type testing
` [PATCH 06/11] xfs: always use xfs_dquot_type when extracting type from a dquot
` [PATCH 07/11] xfs: remove unnecessary quota type masking
` [PATCH 08/11] xfs: replace a few open-coded XFS_DQTYPE_REC_MASK uses
` [PATCH 09/11] xfs: create xfs_dqtype_t to represent quota types
` [PATCH 10/11] xfs: improve ondisk dquot flags checking
  ` [PATCH v2 "
` [PATCH 11/11] xfs: rename the ondisk dquot d_flags to d_type

RFC: iomap write invalidation
 2020-07-21 14:53 UTC  (3+ messages)

[PATCH 0/4] xfsprogs: remove custom dir2 sf fork verifier from repair
 2020-07-21  0:57 UTC  (21+ messages)
` [PATCH 1/4] repair: set the in-core inode parent in phase 3
` [PATCH 2/4] repair: don't double check dir2 sf parent in phase 4
` [PATCH 3/4] repair: use fs root ino for dummy parent value instead of zero
  ` [PATCH v2] repair: use fs rootino "
` [PATCH 4/4] repair: remove custom dir2 sf fork verifier from phase6

[PATCH v4 0/7] add support for direct I/O with fscrypt using blk-crypto
 2020-07-21  0:56 UTC  (10+ messages)
` [PATCH v4 1/7] fscrypt: Add functions for direct I/O support
` [PATCH v4 2/7] direct-io: add support for fscrypt using blk-crypto
` [PATCH v4 3/7] iomap: support direct I/O with "
` [PATCH v4 4/7] ext4: "
` [PATCH v4 5/7] f2fs: "
` [PATCH v4 6/7] fscrypt: document inline encryption support
` [PATCH v4 7/7] fscrypt: update documentation for direct I/O support

[PATCH v11 00/25] xfs: Delay Ready Attributes
 2020-07-21  0:16 UTC  (26+ messages)
` [PATCH v11 01/25] xfs: Add xfs_has_attr and subroutines
` [PATCH v11 02/25] xfs: Check for -ENOATTR or -EEXIST
` [PATCH v11 03/25] xfs: Factor out new helper functions xfs_attr_rmtval_set
` [PATCH v11 04/25] xfs: Pull up trans handling in xfs_attr3_leaf_flipflags
` [PATCH v11 05/25] xfs: Split apart xfs_attr_leaf_addname
` [PATCH v11 06/25] xfs: Refactor xfs_attr_try_sf_addname
` [PATCH v11 07/25] xfs: Pull up trans roll from xfs_attr3_leaf_setflag
` [PATCH v11 08/25] xfs: Factor out xfs_attr_rmtval_invalidate
` [PATCH v11 09/25] xfs: Pull up trans roll in xfs_attr3_leaf_clearflag
` [PATCH v11 10/25] xfs: Refactor xfs_attr_rmtval_remove
` [PATCH v11 11/25] xfs: Pull up xfs_attr_rmtval_invalidate
` [PATCH v11 12/25] xfs: Add helper function xfs_attr_node_shrink
` [PATCH v11 13/25] xfs: Remove unneeded xfs_trans_roll_inode calls
` [PATCH v11 14/25] xfs: Remove xfs_trans_roll in xfs_attr_node_removename
` [PATCH v11 15/25] xfs: Add helpers xfs_attr_is_shortform and xfs_attr_set_shortform
` [PATCH v11 16/25] xfs: Add helper function xfs_attr_leaf_mark_incomplete
` [PATCH v11 17/25] xfs: Add remote block helper functions
` [PATCH v11 18/25] xfs: Add helper function xfs_attr_node_removename_setup
` [PATCH v11 19/25] xfs: Add helper function xfs_attr_node_removename_rmt
` [PATCH v11 20/25] xfs: Simplify xfs_attr_leaf_addname
` [PATCH v11 21/25] xfs: Simplify xfs_attr_node_addname
` [PATCH v11 22/25] xfs: Lift -ENOSPC handler from xfs_attr_leaf_addname
` [PATCH v11 23/25] xfs: Add delay ready attr remove routines
` [PATCH v11 24/25] xfs: Add delay ready attr set routines
` [PATCH v11 25/25] xfs: Rename __xfs_attr_rmtval_remove

[PATCH v3 0/7] add support for direct I/O with fscrypt using blk-crypto
 2020-07-20 20:14 UTC  (12+ messages)
` [PATCH v3 1/7] fscrypt: Add functions for direct I/O support
` [PATCH v3 2/7] direct-io: add support for fscrypt using blk-crypto
` [PATCH v3 3/7] iomap: support direct I/O with "
` [PATCH v3 4/7] ext4: "
` [PATCH v3 5/7] f2fs: "
` [PATCH v3 6/7] fscrypt: document inline encryption support
` [PATCH v3 7/7] fscrypt: update documentation for direct I/O support

[PATCH v6] xfs: Fix false positive lockdep warning with sb_internal & fs_reclaim
 2020-07-20 15:46 UTC  (5+ messages)

[PATCH v4 00/26] xfs: remove xfs_disk_quot from incore dquot
 2020-07-20  5:38 UTC  (15+ messages)
` [PATCH 05/26] xfs: split the incore dquot type into a separate field
` [PATCH 06/26] xfs: refactor quotacheck flags usage
` [PATCH 07/26] xfs: rename dquot incore state flags
` [PATCH 09/26] xfs: make XFS_DQUOT_CLUSTER_SIZE_FSB part of the ondisk format
` [PATCH 10/26] xfs: stop using q_core.d_flags in the quota code
` [PATCH 24/26] xfs: assume the default quota limits are always set in xfs_qm_adjust_dqlimits
` [PATCH 25/26] xfs: actually bump warning counts when we send warnings

[PATCH 00/10] xfs: automatic relogging
 2020-07-20  3:58 UTC  (10+ messages)

[PATCH] xfs: xfs_btree_staging.h: delete duplicated words
 2020-07-20  1:21 UTC  (2+ messages)

[PATCH v11 00/26] xfsprogs: Delay Ready Attributes
 2020-07-18  4:33 UTC  (27+ messages)
` [PATCH v11 01/26] xfs: random buffer write failure errortag
` [PATCH v11 02/26] xfsprogs: Add xfs_has_attr and subroutines
` [PATCH v11 03/26] xfsprogs: Check for -ENOATTR or -EEXIST
` [PATCH v11 04/26] xfsprogs: Factor out new helper functions xfs_attr_rmtval_set
` [PATCH v11 05/26] xfsprogs: Pull up trans handling in xfs_attr3_leaf_flipflags
` [PATCH v11 06/26] xfsprogs: Split apart xfs_attr_leaf_addname
` [PATCH v11 07/26] xfsprogs: Refactor xfs_attr_try_sf_addname
` [PATCH v11 08/26] xfsprogs: Pull up trans roll from xfs_attr3_leaf_setflag
` [PATCH v11 09/26] xfsprogs: Factor out xfs_attr_rmtval_invalidate
` [PATCH v11 10/26] xfsprogs: Pull up trans roll in xfs_attr3_leaf_clearflag
` [PATCH v11 11/26] xfsprogs: Refactor xfs_attr_rmtval_remove
` [PATCH v11 12/26] xfsprogs: Pull up xfs_attr_rmtval_invalidate
` [PATCH v11 13/26] xfsprogs: Add helper function xfs_attr_node_shrink
` [PATCH v11 14/26] xfsprogs: Remove unneeded xfs_trans_roll_inode calls
` [PATCH v11 15/26] xfsprogs: Remove xfs_trans_roll in xfs_attr_node_removename
` [PATCH v11 16/26] xfsprogs: Add helpers xfs_attr_is_shortform and xfs_attr_set_shortform
` [PATCH v11 17/26] xfsprogs: Add helper function xfs_attr_leaf_mark_incomplete
` [PATCH v11 18/26] xfsprogs: Add remote block helper functions
` [PATCH v11 19/26] xfsprogs: Add helper function xfs_attr_node_removename_setup
` [PATCH v11 20/26] xfsprogs: Add helper function xfs_attr_node_removename_rmt
` [PATCH v11 21/26] xfsprogs: Simplify xfs_attr_leaf_addname
` [PATCH v11 22/26] xfsprogs: Simplify xfs_attr_node_addname
` [PATCH v11 23/26] xfsprogs: Lift -ENOSPC handler from xfs_attr_leaf_addname
` [PATCH v11 24/26] xfsprogs: Add delay ready attr remove routines
` [PATCH v11 25/26] xfsprogs: Add delay ready attr set routines
` [PATCH v11 26/26] xfsprogs: Rename __xfs_attr_rmtval_remove

[PATCH v2] fs/direct-io: fix one-time init of ->s_dio_done_wq
 2020-07-18  0:42 UTC  (5+ messages)

[PATCH 0/3] xfsprogs: xfs_quota error message and state reporting improvement
 2020-07-17 21:13 UTC  (9+ messages)
` [PATCH 1/3] xfsprogs: xfs_quota command error message improvement
` [PATCH 2/3] xfs_quota: display warning limits when printing quota type information
` [PATCH 3/3] xfsprogs: xfs_quota state command should report ugp grace times
  ` [PATCH v2 "

[PATCH] xfs: fix inode allocation block res calculation precedence
 2020-07-17 20:07 UTC  (10+ messages)
` [PATCH 2/2] xfs: replace ialloc space res macro with inline helper

[PATCH] fs/direct-io: avoid data race on ->s_dio_done_wq
 2020-07-17  1:36 UTC  (12+ messages)

[PATCH v2 0/7] add support for direct I/O with fscrypt using blk-crypto
 2020-07-17  1:35 UTC  (8+ messages)
` [PATCH v2 1/7] fscrypt: Add functions for direct I/O support
` [PATCH v2 2/7] direct-io: add support for fscrypt using blk-crypto
` [PATCH v2 3/7] iomap: support direct I/O with "
` [PATCH v2 4/7] ext4: "
` [PATCH v2 5/7] f2fs: "
` [PATCH v2 6/7] fscrypt: document inline encryption support
` [PATCH v2 7/7] fscrypt: update documentation for direct I/O support

[PATCH] xfs: drain the buf delwri queue before xfsaild idles
 2020-07-16 14:39 UTC  (5+ messages)
` [PATCH v2] "

[PATCH v3 00/26] xfs: remove xfs_disk_quot from incore dquot
 2020-07-16  2:17 UTC  (9+ messages)
` [PATCH 05/26] xfs: split the incore dquot type into a separate field

[PATCH] repair: simplify bmap_next_offset
 2020-07-15 23:55 UTC  (2+ messages)

[ANNOUNCE] xfsprogs v5.7.0-rc1 released
 2020-07-15 20:12 UTC 

[PATCH] xfs: preserve inode versioning across remounts
 2020-07-15 19:04 UTC  (3+ messages)

[PATCH 0/3] xfs: preparation for syncing with 5.8
 2020-07-15 18:44 UTC  (5+ messages)
` [PATCH 1/3] xfs_db: stop misusing an onstack inode
` [PATCH 2/3] xfs_repair: never zero a shortform '..' entry

[PATCH v2.2 0/4] xfs_repair: check quota counters
 2020-07-15 18:30 UTC  (5+ messages)
` [PATCH 3/4] xfs_repair: check quota values if quota was loaded
` [PATCH 4/4] xfs_repair: skip mount time quotacheck if our quotacheck was ok


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).