linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Kyle Moffett <Kyle.D.Moffett@boeing.com>
To: Benjamin Herrenschmidt <benh@kernel.crashing.org>
Cc: linuxppc-dev <linuxppc-dev@lists.ozlabs.org>,
	Kyle Moffett <Kyle.D.Moffett@boeing.com>
Subject: [PATCH 07/10] powerpc/mpic: Don't open-code dcr_resource_start
Date: Tue, 29 Nov 2011 13:58:34 -0500	[thread overview]
Message-ID: <1322593117-29938-8-git-send-email-Kyle.D.Moffett@boeing.com> (raw)
In-Reply-To: <1322593117-29938-1-git-send-email-Kyle.D.Moffett@boeing.com>

Don't open-code the OpenFirmware "dcr-reg" property lookup trying to map
DCR resources.  This makes the code a bit easier to read.

Signed-off-by: Kyle Moffett <Kyle.D.Moffett@boeing.com>
---
 arch/powerpc/sysdev/mpic.c |    7 ++-----
 1 files changed, 2 insertions(+), 5 deletions(-)

diff --git a/arch/powerpc/sysdev/mpic.c b/arch/powerpc/sysdev/mpic.c
index e0216ff..6916ba5 100644
--- a/arch/powerpc/sysdev/mpic.c
+++ b/arch/powerpc/sysdev/mpic.c
@@ -319,11 +319,8 @@ static void _mpic_map_dcr(struct mpic *mpic, struct device_node *node,
 			  struct mpic_reg_bank *rb,
 			  unsigned int offset, unsigned int size)
 {
-	const u32 *dbasep;
-
-	dbasep = of_get_property(node, "dcr-reg", NULL);
-
-	rb->dhost = dcr_map(node, *dbasep + offset, size);
+	phys_addr_t phys_addr = dcr_resource_start(node);
+	rb->dhost = dcr_map(mpic->node, phys_addr + offset, size);
 	BUG_ON(!DCR_MAP_OK(rb->dhost));
 }
 
-- 
1.7.2.5

  parent reply	other threads:[~2011-11-29 18:59 UTC|newest]

Thread overview: 32+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-11-29 18:58 [PATCH 00/10] powerpc/mpic: General cleanup patch series Kyle Moffett
2011-11-29 18:58 ` [PATCH 01/10] powerpc/85xx: Move mpc85xx_smp_init() decl to a new "smp.h" Kyle Moffett
2011-11-29 18:58 ` [PATCH 02/10] powerpc: Consolidate mpic_alloc() OF address translation Kyle Moffett
2011-12-01  1:04   ` Paul Mackerras
2011-11-29 18:58 ` [PATCH 03/10] powerpc/mpic: Assume a device-node was passed in mpic_alloc() Kyle Moffett
2011-11-29 18:58 ` [PATCH 04/10] powerpc/mpic: Save computed phys_addr for board-specific code Kyle Moffett
2011-11-29 18:58 ` [PATCH 05/10] powerpc/mpic: Search for open-pic device-tree node if NULL Kyle Moffett
2011-11-29 18:58 ` [PATCH 06/10] powerpc/mpic: Invert the meaning of MPIC_PRIMARY Kyle Moffett
2011-11-29 18:58 ` Kyle Moffett [this message]
2011-12-01  6:58   ` [PATCH 07/10] powerpc/mpic: Don't open-code dcr_resource_start Michael Ellerman
2011-11-29 18:58 ` [PATCH 08/10] powerpc/mpic: Put "pic-no-reset" test back into the MPIC code Kyle Moffett
2011-11-29 18:58 ` [PATCH 09/10] powerpc/mpic: Cache the device-tree node in "struct mpic" Kyle Moffett
2011-11-29 18:58 ` [PATCH 10/10] powerpc/mpic: Add in-core support for cascaded MPICs Kyle Moffett
2011-12-01  6:59   ` Michael Ellerman
2011-12-02  1:48     ` Moffett, Kyle D
2011-12-02  3:04       ` Benjamin Herrenschmidt
2011-12-02 16:27         ` [PATCH v3 00/10] powerpc/mpic: General cleanup patch series Kyle Moffett
2011-12-02 16:27         ` [PATCH v3 01/10] powerpc/85xx: Move mpc85xx_smp_init() decl to a new "smp.h" Kyle Moffett
2011-12-02 16:27         ` [PATCH v3 02/10] powerpc: Consolidate mpic_alloc() OF address translation Kyle Moffett
2011-12-03 15:53           ` Kumar Gala
2011-12-05 18:41             ` Moffett, Kyle D
2011-12-05 19:22               ` Kumar Gala
2011-12-02 16:28         ` [PATCH v3 03/10] powerpc/mpic: Assume a device-node was passed in mpic_alloc() Kyle Moffett
2011-12-02 16:28         ` [PATCH v3 04/10] powerpc/mpic: Save computed phys_addr for board-specific code Kyle Moffett
2011-12-02 16:28         ` [PATCH v3 05/10] powerpc/mpic: Search for open-pic device-tree node if NULL Kyle Moffett
2011-12-03 16:05           ` Kumar Gala
2011-12-02 16:28         ` [PATCH v3 06/10] powerpc/mpic: Invert the meaning of MPIC_PRIMARY Kyle Moffett
2011-12-02 16:28         ` [PATCH v3 07/10] powerpc/mpic: Don't open-code dcr_resource_start Kyle Moffett
2011-12-02 16:28         ` [PATCH v3 08/10] powerpc/mpic: Put "pic-no-reset" test back into the MPIC code Kyle Moffett
2011-12-02 16:28         ` [PATCH v3 09/10] powerpc/mpic: Cache the device-tree node in "struct mpic" Kyle Moffett
2011-12-02 16:28         ` [PATCH v3 10/10] powerpc/mpic: Add in-core support for cascaded MPICs Kyle Moffett
2011-11-30  4:40 ` [PATCH 00/10] powerpc/mpic: General cleanup patch series Benjamin Herrenschmidt

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1322593117-29938-8-git-send-email-Kyle.D.Moffett@boeing.com \
    --to=kyle.d.moffett@boeing.com \
    --cc=benh@kernel.crashing.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).