linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Michael Ellerman <mpe@ellerman.id.au>
To: Stewart Smith <stewart@linux.vnet.ibm.com>
Cc: linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 00/18] sync opal.h with firmware
Date: Tue, 10 Feb 2015 14:59:04 +1100	[thread overview]
Message-ID: <1423540744.19657.12.camel@ellerman.id.au> (raw)
In-Reply-To: <1423535220-6322-1-git-send-email-stewart@linux.vnet.ibm.com>

On Tue, 2015-02-10 at 13:26 +1100, Stewart Smith wrote:
> This patch series takes a careful step-by-step process to sync the
> opal.h header file (definition of interface to OPAL firmware) with
> opal.h in firmware.
> 
> Each patch is designed to be as obvious as possible so that it's
> easy for someone else to prove that I haven't messed it up anywhere.
> 
> In the process of doing this, I fixed a few things in firmware too,
> so this matches skiboot at 4681ed9, which is a little after the most
> recent skiboot release (4.1.1).
> 
> The biggest change is moving the function prototypes for API calls
> out to opal-api.h.

Hi Stewart,

I'm going to be a total pain, and suggest that this is the wrong approach :)

I was on board until patch 15, where you have to add an #ifdef SKIBOOT to guard
an include, and you have to remove an include on the Linux side.

I think the better solution would be to pull all the common parts out into a
new file, opal-api.h. That file would define the API between Linux & Skiboot,
and absolutely nothing else.

Both Linux and Skiboot would continue to have an opal.h, which would include
opal-api.h, and then anything else needed on either side to make a functioning
opal.h - eg. other includes & definitions (SG_ENTRIES_PER_NODE).

It would also have the advantage that because opal-api.h is a new file, we can
get it synced from the beginning and not worry about all the whitespace &
rearranging patches. ie. there'd just be one patch on both sides to add the new
file and move definitions into it from opal.h.

If you don't violently disagree I'll do a patch for that and we can see how it
looks?

cheers

  parent reply	other threads:[~2015-02-10  3:59 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-02-10  2:26 [PATCH 00/18] sync opal.h with firmware Stewart Smith
2015-02-10  2:26 ` [PATCH 01/18] powerpc/powernv: sync OPAL API tokens with skiboot Stewart Smith
2015-02-10  2:26 ` [PATCH 02/18] powerpc/powernv: synchronize OPAL calls and return codes with firmware Stewart Smith
2015-02-10  2:26 ` [PATCH 03/18] powerpc/powernv: s/OPAL_PCI_SET_PHB_CXL_MODE/OPAL_PCI_SET_PHB_CAPI_MODE/ to match firmware Stewart Smith
2015-02-10  3:39   ` Benjamin Herrenschmidt
2015-02-10  2:26 ` [PATCH 04/18] powerpc/powernv: relocate struct opal_sg_entry in opal.h to same place it is in firmware Stewart Smith
2015-02-10  2:26 ` [PATCH 05/18] powerpc/powernv: synchronize opal.h whitespace with firmware Stewart Smith
2015-02-10  2:26 ` [PATCH 06/18] powerpc/powernv: move OPAL_DUMP_REGION defines in opal.h to same place as in firmware opal.h Stewart Smith
2015-02-10  2:26 ` [PATCH 07/18] powerpc/powernv: make whitespace for OPAL_PM_* defines match firmware Stewart Smith
2015-02-10  2:26 ` [PATCH 08/18] powerpc/powernv: Move OpalSysparamPerm, OpalMessageType in opal.h to " Stewart Smith
2015-02-10  2:26 ` [PATCH 09/18] powerpc/powernv: match enum OpalMessageType with firmware Stewart Smith
2015-02-10  2:26 ` [PATCH 10/18] powerpc/powernv: move OPAL API prototypes to opal-api.h Stewart Smith
2015-02-10  2:26 ` [PATCH 11/18] powerpc/powernv: make whitespace in enum OpalSysparamPerm match firmware Stewart Smith
2015-02-10  2:26 ` [PATCH 12/18] powerpc/powernv: add CAPI and EPOW parts to opal.h Stewart Smith
2015-02-10  2:26 ` [PATCH 13/18] powerpc/powernv: add remaining missing enums " Stewart Smith
2015-02-10  2:26 ` [PATCH 14/18] powerpc/powernv: sync comments and whitespace in opal.h with firmware Stewart Smith
2015-02-10  2:26 ` [PATCH 15/18] powerpc/powernv: sync #includes " Stewart Smith
2015-02-10  2:26 ` [PATCH 16/18] powerpc/powernv: move SG_ENTRIES_PER_NODE to linux-specific opal-api.h Stewart Smith
2015-02-10  2:26 ` [PATCH 17/18] powerpc/powernv: s/u8/uint8_t/ to match firmware in opal.h Stewart Smith
2015-02-10  2:27 ` [PATCH 18/18] powerpc/powernv: s/OpalM64EnableAction/OpalM64Action/ and __be64 annotation Stewart Smith
2015-02-10  3:59 ` Michael Ellerman [this message]
2015-02-10  5:10   ` [PATCH 00/18] sync opal.h with firmware Stewart Smith

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1423540744.19657.12.camel@ellerman.id.au \
    --to=mpe@ellerman.id.au \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=stewart@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).