linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Christophe Leroy <christophe.leroy@csgroup.eu>
To: Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Andrew Morton <akpm@linux-foundation.org>,
	"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
	Helge Deller <deller@gmx.de>, Arnd Bergmann <arnd@arndb.de>,
	Kees Cook <keescook@chromium.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-arch@vger.kernel.org, linux-ia64@vger.kernel.org,
	linux-parisc@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-mm@kvack.org, Nicholas Piggin <npiggin@gmail.com>,
	linuxppc-dev@lists.ozlabs.org, Daniel Axtens <dja@axtens.net>
Subject: [PATCH v3 02/12] powerpc: Use 'struct func_desc' instead of 'struct ppc64_opd_entry'
Date: Sun, 17 Oct 2021 14:38:15 +0200	[thread overview]
Message-ID: <4a912da3c89569bf5bff897d2588538e74198f35.1634457599.git.christophe.leroy@csgroup.eu> (raw)
In-Reply-To: <cover.1634457599.git.christophe.leroy@csgroup.eu>

'struct ppc64_opd_entry' is somehow redundant with 'struct func_desc',
the later is more correct/complete as it includes the third
field which is unused.

So use 'struct func_desc' instead of 'struct ppc64_opd_entry'

Reviewed-by: Kees Cook <keescook@chromium.org>
Reviewed-by: Daniel Axtens <dja@axtens.net>
Reviewed-by: Nicholas Piggin <npiggin@gmail.com>
Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
---
 arch/powerpc/include/asm/sections.h |  4 ++--
 arch/powerpc/kernel/module_64.c     | 10 +++++-----
 2 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/arch/powerpc/include/asm/sections.h b/arch/powerpc/include/asm/sections.h
index 6e4af4492a14..abd2e5213197 100644
--- a/arch/powerpc/include/asm/sections.h
+++ b/arch/powerpc/include/asm/sections.h
@@ -74,10 +74,10 @@ static inline int overlaps_kernel_text(unsigned long start, unsigned long end)
 #undef dereference_function_descriptor
 static inline void *dereference_function_descriptor(void *ptr)
 {
-	struct ppc64_opd_entry *desc = ptr;
+	struct func_desc *desc = ptr;
 	void *p;
 
-	if (!get_kernel_nofault(p, (void *)&desc->funcaddr))
+	if (!get_kernel_nofault(p, (void *)&desc->addr))
 		ptr = p;
 	return ptr;
 }
diff --git a/arch/powerpc/kernel/module_64.c b/arch/powerpc/kernel/module_64.c
index 6baa676e7cb6..a89da0ee25e2 100644
--- a/arch/powerpc/kernel/module_64.c
+++ b/arch/powerpc/kernel/module_64.c
@@ -64,19 +64,19 @@ static unsigned int local_entry_offset(const Elf64_Sym *sym)
 #else
 
 /* An address is address of the OPD entry, which contains address of fn. */
-typedef struct ppc64_opd_entry func_desc_t;
+typedef struct func_desc func_desc_t;
 
 static func_desc_t func_desc(unsigned long addr)
 {
-	return *(struct ppc64_opd_entry *)addr;
+	return *(struct func_desc *)addr;
 }
 static unsigned long func_addr(unsigned long addr)
 {
-	return func_desc(addr).funcaddr;
+	return func_desc(addr).addr;
 }
 static unsigned long stub_func_addr(func_desc_t func)
 {
-	return func.funcaddr;
+	return func.addr;
 }
 static unsigned int local_entry_offset(const Elf64_Sym *sym)
 {
@@ -187,7 +187,7 @@ static int relacmp(const void *_x, const void *_y)
 static unsigned long get_stubs_size(const Elf64_Ehdr *hdr,
 				    const Elf64_Shdr *sechdrs)
 {
-	/* One extra reloc so it's always 0-funcaddr terminated */
+	/* One extra reloc so it's always 0-addr terminated */
 	unsigned long relocs = 1;
 	unsigned i;
 
-- 
2.31.1


  parent reply	other threads:[~2021-10-17 12:41 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-10-17 12:38 [PATCH v3 00/12] Fix LKDTM for PPC64/IA64/PARISC Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 01/12] powerpc: Move and rename func_descr_t Christophe Leroy
2021-10-18  5:58   ` Nicholas Piggin
2022-02-11  0:51   ` Kees Cook
2021-10-17 12:38 ` Christophe Leroy [this message]
2021-10-17 12:38 ` [PATCH v3 03/12] powerpc: Remove 'struct ppc64_opd_entry' Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 04/12] powerpc: Prepare func_desc_t for refactorisation Christophe Leroy
2021-10-18  6:27   ` Nicholas Piggin
2021-10-18  7:08     ` Christophe Leroy
2022-02-11  0:54   ` Kees Cook
2022-02-11  7:39     ` Segher Boessenkool
2022-02-14 10:30     ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 05/12] ia64: Rename 'ip' to 'addr' in 'struct fdesc' Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 06/12] asm-generic: Define CONFIG_HAVE_FUNCTION_DESCRIPTORS Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 07/12] asm-generic: Define 'func_desc_t' to commonly describe function descriptors Christophe Leroy
2021-10-18  6:29   ` Nicholas Piggin
2021-10-18  7:07     ` Christophe Leroy
2021-10-18  9:16       ` Nicholas Piggin
2021-10-17 12:38 ` [PATCH v3 08/12] asm-generic: Refactor dereference_[kernel]_function_descriptor() Christophe Leroy
2022-02-10 10:30   ` Michael Ellerman
2022-02-11  0:56     ` Kees Cook
2022-02-14 10:32       ` Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 09/12] lkdtm: Force do_nothing() out of line Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 10/12] lkdtm: Really write into kernel text in WRITE_KERN Christophe Leroy
2021-10-17 12:38 ` [PATCH v3 11/12] lkdtm: Fix execute_[user]_location() Christophe Leroy
2021-12-17 11:49   ` Christophe Leroy
2021-12-17 17:12     ` Helge Deller
2022-01-19 19:28     ` Christophe Leroy
2022-01-19 22:00       ` Kees Cook
2022-02-11  1:01   ` Kees Cook
2021-10-17 12:38 ` [PATCH v3 12/12] lkdtm: Add a test for function descriptors protection Christophe Leroy
2022-02-11  1:09   ` Kees Cook
2022-02-14 10:34     ` Christophe Leroy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=4a912da3c89569bf5bff897d2588538e74198f35.1634457599.git.christophe.leroy@csgroup.eu \
    --to=christophe.leroy@csgroup.eu \
    --cc=James.Bottomley@HansenPartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=benh@kernel.crashing.org \
    --cc=deller@gmx.de \
    --cc=dja@axtens.net \
    --cc=gregkh@linuxfoundation.org \
    --cc=keescook@chromium.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-ia64@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    --cc=npiggin@gmail.com \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).