linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Hari Bathini <hbathini@linux.ibm.com>
To: "Oliver O'Halloran" <oohall@gmail.com>,
	linuxppc-dev <linuxppc-dev@ozlabs.org>
Cc: Ananth N Mavinakayanahalli <ananth@linux.ibm.com>,
	Mahesh J Salgaonkar <mahesh@linux.ibm.com>,
	Vasant Hegde <hegdevasant@linux.ibm.com>,
	Nicholas Piggin <npiggin@gmail.com>,
	Stewart Smith <stewart@linux.ibm.com>,
	Daniel Axtens <dja@axtens.net>
Subject: Re: [PATCH v3 03/16] pseries/fadump: move out platform specific support from generic code
Date: Wed, 3 Jul 2019 23:18:52 +0530	[thread overview]
Message-ID: <72e2c26a-3944-bfdb-6bb1-b4f2318e2951@linux.ibm.com> (raw)
In-Reply-To: <8a779e216bb088b33b022cd026bdb647e05aa338.camel@gmail.com>

[-- Attachment #1: Type: text/plain, Size: 2400 bytes --]


On 03/07/19 9:34 AM, Oliver O'Halloran wrote:
> On Wed, 2019-06-26 at 02:16 +0530, Hari Bathini wrote:
>> Introduce callbacks for platform specific operations like register,
>> unregister, invalidate & such, and move pseries specific code into
>> platform code.
> Please don't move around large blocks of code *and* change the code in
> a single patch. It makes reviewing the changes extremely tedious since
> the changes are mixed in with hundreds of lines of nothing.

Right, Oliver.
I am already working on splitting up few other patches for ease of reviewing.
Thought of keeping this patch this way though as it doesn't add any new logic
but moves the code around. Will ensure I split this one up too for the sake
of sanity.

>> Signed-off-by: Hari Bathini <hbathini@linux.ibm.com>
>> ---
>>  arch/powerpc/include/asm/fadump.h            |   75 ----
>>  arch/powerpc/kernel/fadump-common.h          |   38 ++
>>  arch/powerpc/kernel/fadump.c                 |  500 ++-----------------------
>>  arch/powerpc/platforms/pseries/Makefile      |    1 
>>  arch/powerpc/platforms/pseries/rtas-fadump.c |  529 ++++++++++++++++++++++++++
>>  arch/powerpc/platforms/pseries/rtas-fadump.h |   96 +++++
>>  6 files changed, 700 insertions(+), 539 deletions(-)
>>  create mode 100644 arch/powerpc/platforms/pseries/rtas-fadump.c
>>  create mode 100644 arch/powerpc/platforms/pseries/rtas-fadump.h
>>
>> +static struct fadump_ops pseries_fadump_ops = {
>> +	.init_fadump_mem_struct	= pseries_init_fadump_mem_struct,
>> +	.register_fadump	= pseries_register_fadump,
> I realise you are just translating the existing interface, but why is
> init_fadump_mem_struct() done as a seperate step and not as a part of
> the registration function? The struct doesn't seem to be necessary
> until the actual registration happens.

Yeah. But registration is a user choice and can happen multiple times within
a single boot (for example, due to hotplug operations) but the structure
contents remain the same. So, it is initialized once early on...

>
>> +	.unregister_fadump	= pseries_unregister_fadump,
>> +	.invalidate_fadump	= pseries_invalidate_fadump,
>> +	.process_fadump		= pseries_process_fadump,
>> +	.fadump_region_show	= pseries_fadump_region_show,
>> +	.crash_fadump		= pseries_crash_fadump,
> Rename this to fadump_trigger or something, it's not clear what it
> does.

Sure.
Thanks for the review!

- Hari


[-- Attachment #2: Type: text/html, Size: 3962 bytes --]

  reply	other threads:[~2019-07-03 21:28 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-06-25 20:45 [PATCH v3 00/16] Add FADump support on PowerNV platform Hari Bathini
2019-06-25 20:45 ` [PATCH v3 01/16] powerpc/fadump: move internal fadump code to a new file Hari Bathini
2019-06-28  4:55   ` Stewart Smith
2019-06-28  5:51     ` Hari Bathini
2019-07-03  3:30   ` Oliver O'Halloran
2019-07-03 17:36     ` Hari Bathini
2019-06-25 20:45 ` [PATCH v3 02/16] powerpc/fadump: Improve fadump documentation Hari Bathini
2019-06-25 20:46 ` [PATCH v3 03/16] pseries/fadump: move out platform specific support from generic code Hari Bathini
2019-07-03  4:04   ` Oliver O'Halloran
2019-07-03 17:48     ` Hari Bathini [this message]
2019-06-25 20:46 ` [PATCH v3 04/16] powerpc/fadump: use FADump instead of fadump for how it is pronounced Hari Bathini
2019-06-25 20:46 ` [PATCH v3 05/16] powerpc/fadump: enable fadump support on OPAL based POWER platform Hari Bathini
2019-06-25 20:46 ` [PATCH v3 06/16] powerpc/fadump: Update documentation about OPAL platform support Hari Bathini
2019-06-25 20:46 ` [PATCH v3 07/16] powerpc/fadump: consider reserved ranges while reserving memory Hari Bathini
2019-06-25 20:46 ` [PATCH v3 08/16] powerpc/fadump: consider reserved ranges while releasing memory Hari Bathini
2019-06-25 20:46 ` [PATCH v3 09/16] powernv/fadump: process architected register state data provided by firmware Hari Bathini
2019-06-25 20:47 ` [PATCH v3 10/16] powernv/fadump: add support to preserve crash data on FADUMP disabled kernel Hari Bathini
2019-06-25 20:47 ` [PATCH v3 11/16] powerpc/fadump: update documentation about CONFIG_PRESERVE_FA_DUMP Hari Bathini
2019-06-25 20:47 ` [PATCH v3 12/16] powerpc/powernv: export /sys/firmware/opal/core for analysing opal crashes Hari Bathini
2019-06-25 20:47 ` [PATCH v3 13/16] powernv/fadump: Skip processing /proc/vmcore when only OPAL core exists Hari Bathini
2019-06-25 20:47 ` [PATCH v3 14/16] powernv/opalcore: provide an option to invalidate /sys/firmware/opal/core file Hari Bathini
2019-06-25 20:47 ` [PATCH v3 15/16] powernv/fadump: consider f/w load area Hari Bathini
2019-06-25 20:48 ` [PATCH v3 16/16] powernv/fadump: update documentation about option to release opalcore Hari Bathini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=72e2c26a-3944-bfdb-6bb1-b4f2318e2951@linux.ibm.com \
    --to=hbathini@linux.ibm.com \
    --cc=ananth@linux.ibm.com \
    --cc=dja@axtens.net \
    --cc=hegdevasant@linux.ibm.com \
    --cc=linuxppc-dev@ozlabs.org \
    --cc=mahesh@linux.ibm.com \
    --cc=npiggin@gmail.com \
    --cc=oohall@gmail.com \
    --cc=stewart@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).