linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Kumar Gala <galak@kernel.crashing.org>
To: Jia Hongtao-B38951 <B38951@freescale.com>
Cc: Wood Scott-B07421 <B07421@freescale.com>,
	"linuxppc-dev@lists.ozlabs.org" <linuxppc-dev@lists.ozlabs.org>,
	Li Yang-R58472 <r58472@freescale.com>
Subject: Re: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie initialization code
Date: Fri, 27 Jul 2012 07:47:28 -0500	[thread overview]
Message-ID: <73450B27-5496-499C-B7D1-13B797FE7650@kernel.crashing.org> (raw)
In-Reply-To: <412C8208B4A0464FA894C5F0C278CD5D01A2883B@039-SN1MPN1-002.039d.mgd.msft.net>


On Jul 27, 2012, at 3:35 AM, Jia Hongtao-B38951 wrote:

>=20
>=20
>> -----Original Message-----
>> From: Kumar Gala [mailto:galak@kernel.crashing.org]
>> Sent: Friday, July 27, 2012 2:15 AM
>> To: Jia Hongtao-B38951
>> Cc: linuxppc-dev@lists.ozlabs.org; Wood Scott-B07421; Li Yang-R58472
>> Subject: Re: [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie
>> initialization code
>>=20
>>=20
>> On Jul 26, 2012, at 7:30 AM, Jia Hongtao wrote:
>>=20
>>> We unified the Freescale pci/pcie initialization by changing the
>> fsl_pci
>>> to a platform driver. In previous PCI code architecture the
>> initialization
>>> routine is called at board_setup_arch stage. Now the initialization =
is
>> done
>>> in probe function which is architectural better. Also It's =
convenient
>> for
>>> adding PM support for PCI controller in later patch.
>>>=20
>>> One issue introduced by this architecture is the timing of =
swiotlb_init.
>>> During PCI initialization the need of swiotlb is determined and this
>> should
>>> be done before swiotlb_init. So a new function to determine swiotlb =
by
>>> parsing pci ranges is made. This function is called at =
board_setup_arch
>>> stage which is earlier than swiotlb_init.
>>>=20
>>> Signed-off-by: Jia Hongtao <B38951@freescale.com>
>>> Signed-off-by: Li Yang <leoli@freescale.com>
>>> ---
>>> Changed for V3:
>>> - Rebase the patch set on the latest tree
>>> - merge PCI unify and swiotlb patch into one
>>>=20
>>> arch/powerpc/sysdev/fsl_pci.c |  155 =
++++++++++++++++++++++++++++++++--
>> -------
>>> arch/powerpc/sysdev/fsl_pci.h |    9 +--
>>> 2 files changed, 125 insertions(+), 39 deletions(-)
>>=20
>> I'd like the SWIOTLB refactoring as a separate patch.  Additionally, =
the
>> order of patches should be as follows:
>>=20
>> 1. refactor PCI node parsing code
>> 2. add pci_determine_swiotlb (should rename to =
fsl_pci_determine_swiotlb)
>> 3. Determine primary bus by looking for ISA node
>> 4. convert all boards over to fsl_pci_init
>> 5. convert fsl pci to platform driver (edac and other fixes should be
>> merged in here)
>> 6. PM support
>>=20
>> - k
>=20
> Should I convert all boards over to fsl_pci_init first and then =
convert them
> over to platform driver again or just convert them direct to platform =
driver?

Yes do the fsl_pci_init conversion first.  The reason is we should NOT =
break functionality from one patch to another.

- k=

  reply	other threads:[~2012-07-27 12:47 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-07-26 12:30 [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie initialization code Jia Hongtao
2012-07-26 12:30 ` [PATCH V3 2/5] powerpc/fsl-pci: Determine primary bus by looking for ISA node Jia Hongtao
2012-07-26 18:21   ` Kumar Gala
2012-07-27  2:16     ` Jia Hongtao-B38951
2012-07-27  2:56     ` Jia Hongtao-B38951
2012-07-26 12:30 ` [PATCH V3 3/5] powerpc/mpc85xx: convert to unified PCI init Jia Hongtao
2012-07-26 17:46   ` Kumar Gala
2012-07-26 17:47   ` Kumar Gala
2012-07-26 12:30 ` [PATCH V3 4/5] powerpc/fsl-pci: Add pci inbound/outbound PM support Jia Hongtao
2012-07-26 12:30 ` [PATCH V3 5/5] Edac/85xx: Register mpc85xx_pci_err_driver by fsl_pci_driver Jia Hongtao
2012-07-26 17:52 ` [PATCH V3 1/5] powerpc/fsl-pci: Unify pci/pcie initialization code Kumar Gala
2012-07-27 10:10   ` Jia Hongtao-B38951
2012-07-27 20:24     ` Scott Wood
2012-07-27 21:17       ` Kumar Gala
2012-07-30  8:26         ` Jia Hongtao-B38951
2012-07-30 14:46           ` Kumar Gala
2012-07-31  6:36             ` Jia Hongtao-B38951
2012-07-31  7:21             ` Li Yang
2012-07-31 13:37               ` Kumar Gala
2012-08-01  2:24                 ` Jia Hongtao-B38951
2012-07-26 18:14 ` Kumar Gala
2012-07-27  8:35   ` Jia Hongtao-B38951
2012-07-27 12:47     ` Kumar Gala [this message]
2012-07-30  8:07       ` Jia Hongtao-B38951
2012-07-30 14:46         ` Kumar Gala
2012-07-31  2:22           ` Jia Hongtao-B38951
2012-08-01 17:42   ` Joakim Tjernlund

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=73450B27-5496-499C-B7D1-13B797FE7650@kernel.crashing.org \
    --to=galak@kernel.crashing.org \
    --cc=B07421@freescale.com \
    --cc=B38951@freescale.com \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=r58472@freescale.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).