linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
 messages from 2021-01-27 20:52:31 to 2021-02-01 01:25:59 UTC [more...]

linux-next: build failure on power pc
 2021-02-01  1:24 UTC  (5+ messages)
` [PATCH] powerpc: fix AKEBONO build failures

[PATCH v7 00/42] powerpc: interrupt wrappers
 2021-01-31 12:30 UTC  (44+ messages)
` [PATCH v7 01/42] powerpc/64s: interrupt exit improve bounding of interrupt recursion
` [PATCH v7 02/42] KVM: PPC: Book3S HV: Context tracking exit guest context before enabling irqs
` [PATCH v7 03/42] powerpc/32s: move DABR match out of handle_page_fault
` [PATCH v7 04/42] powerpc/64s: "
` [PATCH v7 05/42] powerpc/64s: move the hash fault handling logic to C
` [PATCH v7 06/42] powerpc: remove arguments from fault handler functions
` [PATCH v7 07/42] powerpc/fsl_booke/32: CacheLockingException remove args
` [PATCH v7 08/42] powerpc: do_break get registers from regs
` [PATCH v7 09/42] powerpc: DebugException remove args
` [PATCH v7 10/42] powerpc/32: transfer can avoid saving r4/r5 over trace call
` [PATCH v7 11/42] powerpc: bad_page_fault get registers from regs
` [PATCH v7 12/42] powerpc/64s: add do_bad_page_fault_segv handler
` [PATCH v7 13/42] powerpc: rearrange do_page_fault error case to be inside exception_enter
` [PATCH v7 14/42] powerpc/64s: move bad_page_fault handling to C
` [PATCH v7 15/42] powerpc/64s: split do_hash_fault
` [PATCH v7 16/42] powerpc/mm: Remove stale do_page_fault comment referring to SLB faults
` [PATCH v7 17/42] powerpc/64s: slb comment update
` [PATCH v7 18/42] powerpc/traps: add NOKPROBE_SYMBOL for sreset and mce
` [PATCH v7 19/42] powerpc/perf: move perf irq/nmi handling details into traps.c
` [PATCH v7 20/42] powerpc/time: move timer_broadcast_interrupt prototype to asm/time.h
` [PATCH v7 21/42] powerpc: add and use unknown_async_exception
` [PATCH v7 22/42] powerpc/cell: tidy up pervasive declarations
` [PATCH v7 23/42] powerpc: introduce die_mce
` [PATCH v7 24/42] powerpc/mce: ensure machine check handler always tests RI
` [PATCH v7 25/42] powerpc: improve handling of unrecoverable system reset
` [PATCH v7 26/42] powerpc: interrupt handler wrapper functions
` [PATCH v7 27/42] powerpc: add interrupt wrapper entry / exit stub functions
` [PATCH v7 28/42] powerpc: convert interrupt handlers to use wrappers
` [PATCH v7 29/42] powerpc: add interrupt_cond_local_irq_enable helper
` [PATCH v7 30/42] powerpc/64: context tracking remove _TIF_NOHZ
` [PATCH v7 31/42] powerpc/64s/hash: improve context tracking of hash faults
` [PATCH v7 32/42] powerpc/64: context tracking move to interrupt wrappers
` [PATCH v7 33/42] powerpc/64: add context tracking to asynchronous interrupts
` [PATCH v7 34/42] powerpc: handle irq_enter/irq_exit in interrupt handler wrappers
` [PATCH v7 35/42] powerpc/64s: move context tracking exit to interrupt exit path
` [PATCH v7 36/42] powerpc/64s: reconcile interrupts in C
` [PATCH v7 37/42] powerpc/64: move account_stolen_time into its own function
` [PATCH v7 38/42] powerpc/64: entry cpu time accounting in C
` [PATCH v7 39/42] powerpc: move NMI entry/exit code into wrapper
` [PATCH v7 40/42] powerpc/64s: move NMI soft-mask handling to C
` [PATCH v7 41/42] powerpc/64s: runlatch interrupt handling in C
` [PATCH v7 42/42] powerpc/64s: power4 nap fixup "

[GIT PULL] Please pull powerpc/linux.git powerpc-5.11-6 tag
 2021-01-31 19:38 UTC 

[RFC 00/20] TLB batching consolidation and enhancements
 2021-01-31  8:14 UTC  (7+ messages)
` [RFC 11/20] mm/tlb: remove arch-specific tlb_start/end_vma()

[PATCH] cxl: Simplify bool conversion
 2021-01-29  9:34 UTC  (2+ messages)

[PATCH 1/2] powerpc/Kconfig: Fix unmet direct dependency on NET
 2021-01-30 22:55 UTC 

[PATCH v2] tpm: ibmvtpm: fix error return code in tpm_ibmvtpm_probe()
 2021-01-30 21:14 UTC  (4+ messages)

[PATCH] powerpc/fault: fix wrong KUAP fault for IO_URING
 2021-01-30 13:54 UTC  (14+ messages)

[PATCH] powerpc64/idle: Fix SP offsets when saving GPRs
 2021-01-30 13:44 UTC  (3+ messages)

[PATCH] powerpc: remove unneeded semicolons
 2021-01-30  1:31 UTC  (3+ messages)

module loader dead code removal and cleanups v2
 2021-01-29 21:29 UTC  (21+ messages)
` [PATCH 01/13] powerpc/powernv: remove get_cxl_module
` [PATCH 02/13] drm: remove drm_fb_helper_modinit
` [PATCH 03/13] module: unexport find_module and module_mutex
` [PATCH 04/13] module: use RCU to synchronize find_module
` [PATCH 05/13] kallsyms: refactor {,module_}kallsyms_on_each_symbol
` [PATCH 06/13] kallsyms: only build {, module_}kallsyms_on_each_symbol when required
` [PATCH 07/13] module: mark module_mutex static
` [PATCH 08/13] module: remove each_symbol_in_section
` [PATCH 09/13] module: merge each_symbol_section into find_symbol
` [PATCH 10/13] module: pass struct find_symbol_args to find_symbol
` [PATCH 11/13] module: move struct symsearch to module.c
` [PATCH 12/13] module: remove EXPORT_SYMBOL_GPL_FUTURE
` [PATCH 13/13] module: remove EXPORT_UNUSED_SYMBOL*

[PATCH] vio: make remove callback return void
 2021-01-29 19:08 UTC  (5+ messages)

[PATCH AUTOSEL 4.4 2/2] scsi: ibmvfc: Set default timeout to avoid crash during migration
 2021-01-29 15:39 UTC 

[PATCH AUTOSEL 4.9 3/4] scsi: ibmvfc: Set default timeout to avoid crash during migration
 2021-01-29 15:38 UTC 

[PATCH AUTOSEL 4.14 6/8] scsi: ibmvfc: Set default timeout to avoid crash during migration
 2021-01-29 15:38 UTC 

[PATCH AUTOSEL 4.19 08/12] scsi: ibmvfc: Set default timeout to avoid crash during migration
 2021-01-29 15:38 UTC  (2+ messages)
` [PATCH AUTOSEL 4.19 09/12] selftests/powerpc: Only test lwm/stmw on big endian

[PATCH AUTOSEL 5.4 10/19] scsi: ibmvfc: Set default timeout to avoid crash during migration
 2021-01-29 15:38 UTC  (2+ messages)
` [PATCH AUTOSEL 5.4 14/19] selftests/powerpc: Only test lwm/stmw on big endian

[PATCH AUTOSEL 5.10 18/41] scsi: ibmvfc: Set default timeout to avoid crash during migration
 2021-01-29 15:36 UTC  (2+ messages)
` [PATCH AUTOSEL 5.10 28/41] selftests/powerpc: Only test lwm/stmw on big endian

[PATCH 1/2] powerpc/vdso: fix unnecessary rebuilds of vgettimeofday.o
 2021-01-29 11:41 UTC  (5+ messages)
` [PATCH 2/2] powerpc/vdso64: remove meaningless vgettimeofday.o build rule

[PATCH 0/3] sched: Task priority related cleanups
 2021-01-29 10:55 UTC  (5+ messages)
` [PATCH 1/3] sched: Remove MAX_USER_RT_PRIO
` [PATCH 2/3] sched: Remove USER_PRIO, TASK_USER_PRIO and MAX_USER_PRIO
` [PATCH 3/3] sched/core: Update task_prio() function header

[PATCH v2] powerpc/sstep: Fix array out of bound warning
 2021-01-29 10:04 UTC  (2+ messages)

[PATCH] powerpc/sstep: Fix array out of bound warning
 2021-01-29  7:18 UTC  (3+ messages)

[PATCH 1/2] crypto: talitos - Work around SEC6 ERRATA (AES-CTR mode data size error)
 2021-01-29  5:10 UTC  (2+ messages)

[PATCH net v2] ibmvnic: device remove has higher precedence over reset
 2021-01-29  4:34 UTC 

[PATCH 00/27] arch: syscalls: unifiy all syscalltbl.sh into scripts/syscalltbl.sh
 2021-01-28 18:53 UTC  (35+ messages)
` [PATCH 01/27] scripts: add generic syscalltbl.sh
` [PATCH 02/27] x86/syscalls: fix -Wmissing-prototypes warnings from COND_SYSCALL()
` [PATCH 03/27] x86/build: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 04/27] x86/entry/x32: rename __x32_compat_sys_* to __x64_compat_sys_*
` [PATCH 05/27] x86/syscalls: switch to generic syscalltbl.sh
` [PATCH 06/27] ARM: syscalls: "
` [PATCH 07/27] alpha: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 08/27] alpha: syscalls: switch to generic syscalltbl.sh
` [PATCH 09/27] ia64: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 10/27] ia64: syscalls: switch to generic syscalltbl.sh
` [PATCH 11/27] m68k: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 12/27] m68k: syscalls: switch to generic syscalltbl.sh
` [PATCH 13/27] microblaze: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 14/27] microblaze: syscalls: switch to generic syscalltbl.sh
` [PATCH 15/27] mips: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 16/27] mips: syscalls: switch to generic syscalltbl.sh
` [PATCH 17/27] parisc: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 18/27] parisc: syscalls: switch to generic syscalltbl.sh
` [PATCH 19/27] sh: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 20/27] sh: syscalls: switch to generic syscalltbl.sh
` [PATCH 21/27] sparc: remove wrong comment from arch/sparc/include/asm/Kbuild
` [PATCH 22/27] sparc: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 23/27] sparc: syscalls: switch to generic syscalltbl.sh
` [PATCH 24/27] powerpc: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 25/27] powerpc: syscalls: switch to generic syscalltbl.sh
` [PATCH 26/27] xtensa: add missing FORCE and fix 'targets' to make if_changed work
` [PATCH 27/27] xtensa: syscalls: switch to generic syscalltbl.sh

module loader dead code removal and cleanusp
 2021-01-28 16:24 UTC  (8+ messages)
` [PATCH 03/13] livepatch: refactor klp_init_object
` [PATCH 13/13] module: remove EXPORY_UNUSED_SYMBOL*

[PATCH v4 00/10] Improve signal performance on PPC64 with KUAP
 2021-01-28 12:05 UTC  (13+ messages)
` [PATCH v4 01/10] powerpc/uaccess: Add unsafe_copy_from_user
` [PATCH v4 02/10] powerpc/signal: Add unsafe_copy_{vsx, fpr}_from_user()
` [PATCH v4 03/10] powerpc/signal64: Move non-inline functions out of setup_sigcontext()
` [PATCH v4 04/10] powerpc: Reference param in MSR_TM_ACTIVE() macro
` [PATCH v4 05/10] powerpc/signal64: Remove TM ifdefery in middle of if/else block
` [PATCH v4 06/10] powerpc/signal64: Replace setup_sigcontext() w/ unsafe_setup_sigcontext()
` [PATCH v4 07/10] powerpc/signal64: Replace restore_sigcontext() w/ unsafe_restore_sigcontext()
` [PATCH v4 08/10] powerpc/signal64: Rewrite handle_rt_signal64() to minimise uaccess switches
` [PATCH v4 09/10] powerpc/signal64: Rewrite rt_sigreturn() "
` [PATCH v4 10/10] powerpc/signal64: Use __get_user() to copy sigset_t

[PATCH] ASoC: fsl_spdif: Utilize the defined parameter to clear code
 2021-01-28 11:27 UTC 

[PATCH v5 1/2] powerpc/mce: Reduce the size of event arrays
 2021-01-28 10:41 UTC  (2+ messages)
` [PATCH v5 2/2] powerpc/mce: Remove per cpu variables from MCE handlers

[PATCH] PCI: dwc: layerscape: convert to builtin_platform_driver()
 2021-01-28 10:35 UTC  (19+ messages)

[PATCH v4 1/2] powerpc/mce: Reduce the size of event arrays
 2021-01-28  9:27 UTC  (4+ messages)
` [PATCH v4 2/2] powerpc/mce: Remove per cpu variables from MCE handlers

[PATCH v6 00/39] powerpc: interrupt wrappers
 2021-01-28  9:25 UTC  (6+ messages)
` [PATCH v6 05/39] powerpc: remove arguments from fault handler functions
` [PATCH v6 08/39] powerpc: rearrange do_page_fault error case to be inside exception_enter

[PATCH 2/3] kbuild: LD_VERSION redenomination
 2021-01-28  6:38 UTC  (2+ messages)

[PATCH] powerpc64: Workaround sigtramp vdso return call
 2021-01-28  5:38 UTC 

[PATCH v15 00/10] Carry forward IMA measurement log on kexec on ARM64
 2021-01-28  4:57 UTC  (18+ messages)
` [PATCH v15 09/10] arm64: Call kmalloc() to allocate DTB buffer
` [PATCH v15 10/10] arm64: Add IMA log information in kimage used for kexec

[PATCH 1/2] PCI/AER: Disable AER interrupt during suspend
 2021-01-28  4:09 UTC  (3+ messages)

[PATCH v11 00/13] huge vmalloc mappings
 2021-01-28  3:13 UTC  (5+ messages)
` [PATCH v11 01/13] mm/vmalloc: fix HUGE_VMAP regression by enabling huge pages in vmalloc_to_page
` [PATCH v11 04/13] mm/ioremap: rename ioremap_*_range to vmap_*_range

[PATCH v3 00/32] powerpc/64: interrupts and syscalls series
 2021-01-28  0:09 UTC  (4+ messages)
` [PATCH v3 28/32] powerpc/64s: interrupt implement exit logic in C

[PATCH v4 00/23] powerpc/32: Implement C syscall entry/exit
 2021-01-27 23:50 UTC  (5+ messages)
` [PATCH v4 11/23] powerpc/syscall: Rename syscall_64.c into syscall.c


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).