LinuxPPC-Dev Archive on lore.kernel.org
 help / color / Atom feed
* [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl, ls1028a-pcie"
@ 2019-09-02  3:43 Xiaowei Bao
  2019-09-02  3:43 ` [PATCH v6 2/3] arm64: dts: ls1028a: Add PCIe controller DT nodes Xiaowei Bao
                   ` (3 more replies)
  0 siblings, 4 replies; 13+ messages in thread
From: Xiaowei Bao @ 2019-09-02  3:43 UTC (permalink / raw)
  To: robh+dt, mark.rutland, shawnguo, leoyang.li, minghuan.Lian,
	mingkai.hu, roy.zang, lorenzo.pieralisi, linux-pci, devicetree,
	linux-kernel, linux-arm-kernel, linuxppc-dev
  Cc: bhelgaas, Hou Zhiqiang, Xiaowei Bao

Add the PCIe compatible string for LS1028A

Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
Reviewed-by: Rob Herring <robh@kernel.org>
---
v2:
 - No change.
v3:
 - No change.
v4:
 - No change.
v5:
 - No change.
v6:
 - No change.

 Documentation/devicetree/bindings/pci/layerscape-pci.txt | 1 +
 1 file changed, 1 insertion(+)

diff --git a/Documentation/devicetree/bindings/pci/layerscape-pci.txt b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
index e20ceaa..99a386e 100644
--- a/Documentation/devicetree/bindings/pci/layerscape-pci.txt
+++ b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
@@ -21,6 +21,7 @@ Required properties:
         "fsl,ls1046a-pcie"
         "fsl,ls1043a-pcie"
         "fsl,ls1012a-pcie"
+        "fsl,ls1028a-pcie"
   EP mode:
 	"fsl,ls1046a-pcie-ep", "fsl,ls-pcie-ep"
 - reg: base addresses and lengths of the PCIe controller register blocks.
-- 
2.9.5


^ permalink raw reply	[flat|nested] 13+ messages in thread

* [PATCH v6 2/3] arm64: dts: ls1028a: Add PCIe controller DT nodes
  2019-09-02  3:43 [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl, ls1028a-pcie" Xiaowei Bao
@ 2019-09-02  3:43 ` Xiaowei Bao
  2019-09-02  3:43 ` [PATCH v6 3/3] PCI: layerscape: Add LS1028a support Xiaowei Bao
                   ` (2 subsequent siblings)
  3 siblings, 0 replies; 13+ messages in thread
From: Xiaowei Bao @ 2019-09-02  3:43 UTC (permalink / raw)
  To: robh+dt, mark.rutland, shawnguo, leoyang.li, minghuan.Lian,
	mingkai.hu, roy.zang, lorenzo.pieralisi, linux-pci, devicetree,
	linux-kernel, linux-arm-kernel, linuxppc-dev
  Cc: bhelgaas, Hou Zhiqiang, Xiaowei Bao

LS1028a implements 2 PCIe 3.0 controllers.

Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
---
v2:
 - Fix up the legacy INTx allocate failed issue.
v3:
 - No change.
v4:
 - Remove the num-lanes property.
v5:
 - Add the num-viewport property.
v6:
 - move num-viewport to 8.

 arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi | 52 ++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
index 72b9a75..c043b1d 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1028a.dtsi
@@ -625,6 +625,58 @@
 			};
 		};
 
+		pcie@3400000 {
+			compatible = "fsl,ls1028a-pcie";
+			reg = <0x00 0x03400000 0x0 0x00100000   /* controller registers */
+			       0x80 0x00000000 0x0 0x00002000>; /* configuration space */
+			reg-names = "regs", "config";
+			interrupts = <GIC_SPI 108 IRQ_TYPE_LEVEL_HIGH>, /* PME interrupt */
+				     <GIC_SPI 109 IRQ_TYPE_LEVEL_HIGH>; /* aer interrupt */
+			interrupt-names = "pme", "aer";
+			#address-cells = <3>;
+			#size-cells = <2>;
+			device_type = "pci";
+			dma-coherent;
+			num-viewport = <8>;
+			bus-range = <0x0 0xff>;
+			ranges = <0x81000000 0x0 0x00000000 0x80 0x00010000 0x0 0x00010000   /* downstream I/O */
+				  0x82000000 0x0 0x40000000 0x80 0x40000000 0x0 0x40000000>; /* non-prefetchable memory */
+			msi-parent = <&its>;
+			#interrupt-cells = <1>;
+			interrupt-map-mask = <0 0 0 7>;
+			interrupt-map = <0000 0 0 1 &gic 0 0 GIC_SPI 109 IRQ_TYPE_LEVEL_HIGH>,
+					<0000 0 0 2 &gic 0 0 GIC_SPI 110 IRQ_TYPE_LEVEL_HIGH>,
+					<0000 0 0 3 &gic 0 0 GIC_SPI 111 IRQ_TYPE_LEVEL_HIGH>,
+					<0000 0 0 4 &gic 0 0 GIC_SPI 112 IRQ_TYPE_LEVEL_HIGH>;
+			status = "disabled";
+		};
+
+		pcie@3500000 {
+			compatible = "fsl,ls1028a-pcie";
+			reg = <0x00 0x03500000 0x0 0x00100000   /* controller registers */
+			       0x88 0x00000000 0x0 0x00002000>; /* configuration space */
+			reg-names = "regs", "config";
+			interrupts = <GIC_SPI 113 IRQ_TYPE_LEVEL_HIGH>,
+				     <GIC_SPI 114 IRQ_TYPE_LEVEL_HIGH>;
+			interrupt-names = "pme", "aer";
+			#address-cells = <3>;
+			#size-cells = <2>;
+			device_type = "pci";
+			dma-coherent;
+			num-viewport = <8>;
+			bus-range = <0x0 0xff>;
+			ranges = <0x81000000 0x0 0x00000000 0x88 0x00010000 0x0 0x00010000   /* downstream I/O */
+				  0x82000000 0x0 0x40000000 0x88 0x40000000 0x0 0x40000000>; /* non-prefetchable memory */
+			msi-parent = <&its>;
+			#interrupt-cells = <1>;
+			interrupt-map-mask = <0 0 0 7>;
+			interrupt-map = <0000 0 0 1 &gic 0 0 GIC_SPI 114 IRQ_TYPE_LEVEL_HIGH>,
+					<0000 0 0 2 &gic 0 0 GIC_SPI 115 IRQ_TYPE_LEVEL_HIGH>,
+					<0000 0 0 3 &gic 0 0 GIC_SPI 116 IRQ_TYPE_LEVEL_HIGH>,
+					<0000 0 0 4 &gic 0 0 GIC_SPI 117 IRQ_TYPE_LEVEL_HIGH>;
+			status = "disabled";
+		};
+
 		pcie@1f0000000 { /* Integrated Endpoint Root Complex */
 			compatible = "pci-host-ecam-generic";
 			reg = <0x01 0xf0000000 0x0 0x100000>;
-- 
2.9.5


^ permalink raw reply	[flat|nested] 13+ messages in thread

* [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
  2019-09-02  3:43 [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl, ls1028a-pcie" Xiaowei Bao
  2019-09-02  3:43 ` [PATCH v6 2/3] arm64: dts: ls1028a: Add PCIe controller DT nodes Xiaowei Bao
@ 2019-09-02  3:43 ` Xiaowei Bao
  2019-10-03  9:10   ` Shawn Guo
                     ` (2 more replies)
  2019-11-05 11:05 ` [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl,ls1028a-pcie" Andrew Murray
  2019-11-06 16:09 ` Lorenzo Pieralisi
  3 siblings, 3 replies; 13+ messages in thread
From: Xiaowei Bao @ 2019-09-02  3:43 UTC (permalink / raw)
  To: robh+dt, mark.rutland, shawnguo, leoyang.li, minghuan.Lian,
	mingkai.hu, roy.zang, lorenzo.pieralisi, linux-pci, devicetree,
	linux-kernel, linux-arm-kernel, linuxppc-dev
  Cc: bhelgaas, Hou Zhiqiang, Xiaowei Bao

Add support for the LS1028a PCIe controller.

Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
---
v2:
 - No change.
v3:
 - Reuse the ls2088 driver data structurt.
v4:
 - No change.
v5:
 - No change.
v6:
 - No change.

 drivers/pci/controller/dwc/pci-layerscape.c | 1 +
 1 file changed, 1 insertion(+)

diff --git a/drivers/pci/controller/dwc/pci-layerscape.c b/drivers/pci/controller/dwc/pci-layerscape.c
index 3a5fa26..f24f79a 100644
--- a/drivers/pci/controller/dwc/pci-layerscape.c
+++ b/drivers/pci/controller/dwc/pci-layerscape.c
@@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata ls2088_drvdata = {
 static const struct of_device_id ls_pcie_of_match[] = {
 	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
 	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
+	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },
 	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
 	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
 	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
-- 
2.9.5


^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
  2019-09-02  3:43 ` [PATCH v6 3/3] PCI: layerscape: Add LS1028a support Xiaowei Bao
@ 2019-10-03  9:10   ` Shawn Guo
  2019-10-08  7:11     ` Xiaowei Bao
  2019-11-05 11:04   ` Andrew Murray
  2019-11-05 12:32   ` Lorenzo Pieralisi
  2 siblings, 1 reply; 13+ messages in thread
From: Shawn Guo @ 2019-10-03  9:10 UTC (permalink / raw)
  To: Xiaowei Bao
  Cc: mark.rutland, roy.zang, lorenzo.pieralisi, devicetree, linux-pci,
	Hou Zhiqiang, linux-kernel, leoyang.li, minghuan.Lian, robh+dt,
	linux-arm-kernel, bhelgaas, linuxppc-dev, mingkai.hu

On Mon, Sep 02, 2019 at 11:43:19AM +0800, Xiaowei Bao wrote:
> Add support for the LS1028a PCIe controller.
> 
> Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> ---
> v2:
>  - No change.
> v3:
>  - Reuse the ls2088 driver data structurt.
> v4:
>  - No change.
> v5:
>  - No change.
> v6:
>  - No change.
> 
>  drivers/pci/controller/dwc/pci-layerscape.c | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/drivers/pci/controller/dwc/pci-layerscape.c b/drivers/pci/controller/dwc/pci-layerscape.c
> index 3a5fa26..f24f79a 100644
> --- a/drivers/pci/controller/dwc/pci-layerscape.c
> +++ b/drivers/pci/controller/dwc/pci-layerscape.c
> @@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata ls2088_drvdata = {
>  static const struct of_device_id ls_pcie_of_match[] = {
>  	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
>  	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
> +	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },

I think you can save this driver change by using "fsl,ls2088a-pcie" as
compatible fallback like below.

  compatible = "fsl,ls1028a-pcie", "fsl,ls2088a-pcie";

Shawn

>  	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
>  	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
>  	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
> -- 
> 2.9.5
> 

^ permalink raw reply	[flat|nested] 13+ messages in thread

* RE: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
  2019-10-03  9:10   ` Shawn Guo
@ 2019-10-08  7:11     ` Xiaowei Bao
  0 siblings, 0 replies; 13+ messages in thread
From: Xiaowei Bao @ 2019-10-08  7:11 UTC (permalink / raw)
  To: Shawn Guo
  Cc: mark.rutland, Roy Zang, lorenzo.pieralisi, devicetree, linux-pci,
	Z.q. Hou, linux-kernel, Leo Li, M.h. Lian, robh+dt,
	linux-arm-kernel, bhelgaas, linuxppc-dev, Mingkai Hu



> -----Original Message-----
> From: Shawn Guo <shawnguo@kernel.org>
> Sent: 2019年10月3日 17:11
> To: Xiaowei Bao <xiaowei.bao@nxp.com>
> Cc: robh+dt@kernel.org; mark.rutland@arm.com; Leo Li
> <leoyang.li@nxp.com>; M.h. Lian <minghuan.lian@nxp.com>; Mingkai Hu
> <mingkai.hu@nxp.com>; Roy Zang <roy.zang@nxp.com>;
> lorenzo.pieralisi@arm.com; linux-pci@vger.kernel.org;
> devicetree@vger.kernel.org; linux-kernel@vger.kernel.org;
> linux-arm-kernel@lists.infradead.org; linuxppc-dev@lists.ozlabs.org;
> bhelgaas@google.com; Z.q. Hou <zhiqiang.hou@nxp.com>
> Subject: Re: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
> 
> On Mon, Sep 02, 2019 at 11:43:19AM +0800, Xiaowei Bao wrote:
> > Add support for the LS1028a PCIe controller.
> >
> > Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> > Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> > ---
> > v2:
> >  - No change.
> > v3:
> >  - Reuse the ls2088 driver data structurt.
> > v4:
> >  - No change.
> > v5:
> >  - No change.
> > v6:
> >  - No change.
> >
> >  drivers/pci/controller/dwc/pci-layerscape.c | 1 +
> >  1 file changed, 1 insertion(+)
> >
> > diff --git a/drivers/pci/controller/dwc/pci-layerscape.c
> > b/drivers/pci/controller/dwc/pci-layerscape.c
> > index 3a5fa26..f24f79a 100644
> > --- a/drivers/pci/controller/dwc/pci-layerscape.c
> > +++ b/drivers/pci/controller/dwc/pci-layerscape.c
> > @@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata ls2088_drvdata
> > = {  static const struct of_device_id ls_pcie_of_match[] = {
> >  	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
> >  	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
> > +	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },
> 
> I think you can save this driver change by using "fsl,ls2088a-pcie" as
> compatible fallback like below.
> 
>   compatible = "fsl,ls1028a-pcie", "fsl,ls2088a-pcie";

Yes, it is ok to do so, but according to the previous code, I think add a new compatible " fsl,ls1028a-pcie " to driver is better.

Thanks 
Xiaowei

> 
> Shawn
> 
> >  	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
> >  	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
> >  	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
> > --
> > 2.9.5
> >

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
  2019-09-02  3:43 ` [PATCH v6 3/3] PCI: layerscape: Add LS1028a support Xiaowei Bao
  2019-10-03  9:10   ` Shawn Guo
@ 2019-11-05 11:04   ` Andrew Murray
  2019-11-05 12:32   ` Lorenzo Pieralisi
  2 siblings, 0 replies; 13+ messages in thread
From: Andrew Murray @ 2019-11-05 11:04 UTC (permalink / raw)
  To: Xiaowei Bao
  Cc: mark.rutland, roy.zang, lorenzo.pieralisi, devicetree, linux-pci,
	Hou Zhiqiang, linuxppc-dev, linux-kernel, leoyang.li,
	minghuan.Lian, robh+dt, linux-arm-kernel, bhelgaas, shawnguo,
	mingkai.hu

On Mon, Sep 02, 2019 at 11:43:19AM +0800, Xiaowei Bao wrote:
> Add support for the LS1028a PCIe controller.
> 
> Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> ---
> v2:
>  - No change.
> v3:
>  - Reuse the ls2088 driver data structurt.
> v4:
>  - No change.
> v5:
>  - No change.
> v6:
>  - No change.
> 
>  drivers/pci/controller/dwc/pci-layerscape.c | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/drivers/pci/controller/dwc/pci-layerscape.c b/drivers/pci/controller/dwc/pci-layerscape.c
> index 3a5fa26..f24f79a 100644
> --- a/drivers/pci/controller/dwc/pci-layerscape.c
> +++ b/drivers/pci/controller/dwc/pci-layerscape.c
> @@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata ls2088_drvdata = {
>  static const struct of_device_id ls_pcie_of_match[] = {
>  	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
>  	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
> +	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },
>  	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
>  	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
>  	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },

Reviewed-by: Andrew Murray <Andrew.Murray@arm.com>

> -- 
> 2.9.5
> 

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl,ls1028a-pcie"
  2019-09-02  3:43 [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl, ls1028a-pcie" Xiaowei Bao
  2019-09-02  3:43 ` [PATCH v6 2/3] arm64: dts: ls1028a: Add PCIe controller DT nodes Xiaowei Bao
  2019-09-02  3:43 ` [PATCH v6 3/3] PCI: layerscape: Add LS1028a support Xiaowei Bao
@ 2019-11-05 11:05 ` Andrew Murray
  2019-11-06 16:09 ` Lorenzo Pieralisi
  3 siblings, 0 replies; 13+ messages in thread
From: Andrew Murray @ 2019-11-05 11:05 UTC (permalink / raw)
  To: Xiaowei Bao
  Cc: mark.rutland, roy.zang, lorenzo.pieralisi, devicetree, linux-pci,
	Hou Zhiqiang, linuxppc-dev, linux-kernel, leoyang.li,
	minghuan.Lian, robh+dt, linux-arm-kernel, bhelgaas, shawnguo,
	mingkai.hu

On Mon, Sep 02, 2019 at 11:43:17AM +0800, Xiaowei Bao wrote:
> Add the PCIe compatible string for LS1028A
> 
> Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> Reviewed-by: Rob Herring <robh@kernel.org>
> ---

Reviewed-by: Andrew Murray <andrew.murray@arm.com>

> v2:
>  - No change.
> v3:
>  - No change.
> v4:
>  - No change.
> v5:
>  - No change.
> v6:
>  - No change.
> 
>  Documentation/devicetree/bindings/pci/layerscape-pci.txt | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/Documentation/devicetree/bindings/pci/layerscape-pci.txt b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> index e20ceaa..99a386e 100644
> --- a/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> +++ b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> @@ -21,6 +21,7 @@ Required properties:
>          "fsl,ls1046a-pcie"
>          "fsl,ls1043a-pcie"
>          "fsl,ls1012a-pcie"
> +        "fsl,ls1028a-pcie"
>    EP mode:
>  	"fsl,ls1046a-pcie-ep", "fsl,ls-pcie-ep"
>  - reg: base addresses and lengths of the PCIe controller register blocks.
> -- 
> 2.9.5
> 

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
  2019-09-02  3:43 ` [PATCH v6 3/3] PCI: layerscape: Add LS1028a support Xiaowei Bao
  2019-10-03  9:10   ` Shawn Guo
  2019-11-05 11:04   ` Andrew Murray
@ 2019-11-05 12:32   ` Lorenzo Pieralisi
  2019-11-06  3:35     ` Xiaowei Bao
  2 siblings, 1 reply; 13+ messages in thread
From: Lorenzo Pieralisi @ 2019-11-05 12:32 UTC (permalink / raw)
  To: Xiaowei Bao
  Cc: mark.rutland, roy.zang, devicetree, linux-pci, Hou Zhiqiang,
	linuxppc-dev, linux-kernel, leoyang.li, minghuan.Lian, robh+dt,
	linux-arm-kernel, bhelgaas, shawnguo, mingkai.hu

On Mon, Sep 02, 2019 at 11:43:19AM +0800, Xiaowei Bao wrote:
> Add support for the LS1028a PCIe controller.
> 
> Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> ---
> v2:
>  - No change.
> v3:
>  - Reuse the ls2088 driver data structurt.
> v4:
>  - No change.
> v5:
>  - No change.
> v6:
>  - No change.
> 
>  drivers/pci/controller/dwc/pci-layerscape.c | 1 +
>  1 file changed, 1 insertion(+)

I have not seen any comment on any layerscape driver patches
coming from the maintainers as listed in the MAINTAINERS
file (and CCed in this series).

I request maintainers ACK on these patches and I expect them
to start reviewing your code if they want to be still considered
maintainers for this driver.

The changes look OK minus Shawn's remark on compatible string
that was ignored.

Thanks,
Lorenzo

> diff --git a/drivers/pci/controller/dwc/pci-layerscape.c b/drivers/pci/controller/dwc/pci-layerscape.c
> index 3a5fa26..f24f79a 100644
> --- a/drivers/pci/controller/dwc/pci-layerscape.c
> +++ b/drivers/pci/controller/dwc/pci-layerscape.c
> @@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata ls2088_drvdata = {
>  static const struct of_device_id ls_pcie_of_match[] = {
>  	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
>  	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
> +	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },
>  	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
>  	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
>  	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
> -- 
> 2.9.5
> 

^ permalink raw reply	[flat|nested] 13+ messages in thread

* RE: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
  2019-11-05 12:32   ` Lorenzo Pieralisi
@ 2019-11-06  3:35     ` Xiaowei Bao
  2019-11-06  3:46       ` M.h. Lian
  0 siblings, 1 reply; 13+ messages in thread
From: Xiaowei Bao @ 2019-11-06  3:35 UTC (permalink / raw)
  To: Lorenzo Pieralisi
  Cc: mark.rutland, Roy Zang, devicetree, linux-pci, Z.q. Hou,
	linuxppc-dev, linux-kernel, Leo Li, M.h. Lian, robh+dt,
	linux-arm-kernel, bhelgaas, shawnguo, Mingkai Hu



> -----Original Message-----
> From: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>
> Sent: 2019年11月5日 20:33
> To: Xiaowei Bao <xiaowei.bao@nxp.com>
> Cc: robh+dt@kernel.org; mark.rutland@arm.com; shawnguo@kernel.org; Leo
> Li <leoyang.li@nxp.com>; M.h. Lian <minghuan.lian@nxp.com>; Mingkai Hu
> <mingkai.hu@nxp.com>; Roy Zang <roy.zang@nxp.com>;
> linux-pci@vger.kernel.org; devicetree@vger.kernel.org;
> linux-kernel@vger.kernel.org; linux-arm-kernel@lists.infradead.org;
> linuxppc-dev@lists.ozlabs.org; bhelgaas@google.com; Z.q. Hou
> <zhiqiang.hou@nxp.com>
> Subject: Re: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
> 
> On Mon, Sep 02, 2019 at 11:43:19AM +0800, Xiaowei Bao wrote:
> > Add support for the LS1028a PCIe controller.
> >
> > Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> > Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> > ---
> > v2:
> >  - No change.
> > v3:
> >  - Reuse the ls2088 driver data structurt.
> > v4:
> >  - No change.
> > v5:
> >  - No change.
> > v6:
> >  - No change.
> >
> >  drivers/pci/controller/dwc/pci-layerscape.c | 1 +
> >  1 file changed, 1 insertion(+)
> 
> I have not seen any comment on any layerscape driver patches coming from
> the maintainers as listed in the MAINTAINERS file (and CCed in this series).
> 
> I request maintainers ACK on these patches and I expect them to start
> reviewing your code if they want to be still considered maintainers for this
> driver.
> 
> The changes look OK minus Shawn's remark on compatible string that was
> ignored.

Hi Lorenzo,

Thanks for your comments.

In fact, the patches have reviewed in our internal mail list, after the review by Minghuan 
and Mingkai, I will send these patches to opensource, they will give the ACK when these
patches seems is OK and no comments on this.
   
Thanks 
Xiaowei

> 
> Thanks,
> Lorenzo
> 
> > diff --git a/drivers/pci/controller/dwc/pci-layerscape.c
> > b/drivers/pci/controller/dwc/pci-layerscape.c
> > index 3a5fa26..f24f79a 100644
> > --- a/drivers/pci/controller/dwc/pci-layerscape.c
> > +++ b/drivers/pci/controller/dwc/pci-layerscape.c
> > @@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata ls2088_drvdata
> > = {  static const struct of_device_id ls_pcie_of_match[] = {
> >  	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
> >  	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
> > +	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },
> >  	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
> >  	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
> >  	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
> > --
> > 2.9.5
> >

^ permalink raw reply	[flat|nested] 13+ messages in thread

* RE: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
  2019-11-06  3:35     ` Xiaowei Bao
@ 2019-11-06  3:46       ` M.h. Lian
  2019-11-06 15:01         ` Lorenzo Pieralisi
  0 siblings, 1 reply; 13+ messages in thread
From: M.h. Lian @ 2019-11-06  3:46 UTC (permalink / raw)
  To: Xiaowei Bao, Lorenzo Pieralisi
  Cc: mark.rutland, Roy Zang, devicetree, linux-pci, Z.q. Hou,
	linuxppc-dev, linux-kernel, Leo Li, robh+dt, linux-arm-kernel,
	bhelgaas, shawnguo, Mingkai Hu

Hi Lorenzo,

Sorry for the late reply.

Acked-by: Minghuan Lian <minghuan.Lian@nxp.com>

Thanks,
Minghuan

> -----Original Message-----
> From: Xiaowei Bao <xiaowei.bao@nxp.com>
> Sent: Wednesday, November 6, 2019 11:36 AM
> To: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>
> Cc: robh+dt@kernel.org; mark.rutland@arm.com; shawnguo@kernel.org;
> Leo Li <leoyang.li@nxp.com>; M.h. Lian <minghuan.lian@nxp.com>; Mingkai
> Hu <mingkai.hu@nxp.com>; Roy Zang <roy.zang@nxp.com>; linux-
> pci@vger.kernel.org; devicetree@vger.kernel.org; linux-
> kernel@vger.kernel.org; linux-arm-kernel@lists.infradead.org; linuxppc-
> dev@lists.ozlabs.org; bhelgaas@google.com; Z.q. Hou
> <zhiqiang.hou@nxp.com>
> Subject: RE: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
> 
> 
> 
> > -----Original Message-----
> > From: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>
> > Sent: 2019年11月5日 20:33
> > To: Xiaowei Bao <xiaowei.bao@nxp.com>
> > Cc: robh+dt@kernel.org; mark.rutland@arm.com; shawnguo@kernel.org;
> Leo
> > Li <leoyang.li@nxp.com>; M.h. Lian <minghuan.lian@nxp.com>; Mingkai
> Hu
> > <mingkai.hu@nxp.com>; Roy Zang <roy.zang@nxp.com>;
> > linux-pci@vger.kernel.org; devicetree@vger.kernel.org;
> > linux-kernel@vger.kernel.org; linux-arm-kernel@lists.infradead.org;
> > linuxppc-dev@lists.ozlabs.org; bhelgaas@google.com; Z.q. Hou
> > <zhiqiang.hou@nxp.com>
> > Subject: Re: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
> >
> > On Mon, Sep 02, 2019 at 11:43:19AM +0800, Xiaowei Bao wrote:
> > > Add support for the LS1028a PCIe controller.
> > >
> > > Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> > > Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> > > ---
> > > v2:
> > >  - No change.
> > > v3:
> > >  - Reuse the ls2088 driver data structurt.
> > > v4:
> > >  - No change.
> > > v5:
> > >  - No change.
> > > v6:
> > >  - No change.
> > >
> > >  drivers/pci/controller/dwc/pci-layerscape.c | 1 +
> > >  1 file changed, 1 insertion(+)
> >
> > I have not seen any comment on any layerscape driver patches coming
> > from the maintainers as listed in the MAINTAINERS file (and CCed in this
> series).
> >
> > I request maintainers ACK on these patches and I expect them to start
> > reviewing your code if they want to be still considered maintainers
> > for this driver.
> >
> > The changes look OK minus Shawn's remark on compatible string that was
> > ignored.
> 
> Hi Lorenzo,
> 
> Thanks for your comments.
> 
> In fact, the patches have reviewed in our internal mail list, after the review by
> Minghuan and Mingkai, I will send these patches to opensource, they will
> give the ACK when these patches seems is OK and no comments on this.
> 
> Thanks
> Xiaowei
> 
> >
> > Thanks,
> > Lorenzo
> >
> > > diff --git a/drivers/pci/controller/dwc/pci-layerscape.c
> > > b/drivers/pci/controller/dwc/pci-layerscape.c
> > > index 3a5fa26..f24f79a 100644
> > > --- a/drivers/pci/controller/dwc/pci-layerscape.c
> > > +++ b/drivers/pci/controller/dwc/pci-layerscape.c
> > > @@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata
> > > ls2088_drvdata = {  static const struct of_device_id ls_pcie_of_match[] = {
> > >  	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
> > >  	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
> > > +	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },
> > >  	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
> > >  	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
> > >  	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
> > > --
> > > 2.9.5
> > >

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
  2019-11-06  3:46       ` M.h. Lian
@ 2019-11-06 15:01         ` Lorenzo Pieralisi
  0 siblings, 0 replies; 13+ messages in thread
From: Lorenzo Pieralisi @ 2019-11-06 15:01 UTC (permalink / raw)
  To: M.h. Lian
  Cc: mark.rutland, Roy Zang, Xiaowei Bao, devicetree, linux-pci,
	Z.q. Hou, linuxppc-dev, linux-kernel, Leo Li, robh+dt,
	linux-arm-kernel, bhelgaas, shawnguo, Mingkai Hu

On Wed, Nov 06, 2019 at 03:46:17AM +0000, M.h. Lian wrote:
> Hi Lorenzo,
> 
> Sorry for the late reply.
> 
> Acked-by: Minghuan Lian <minghuan.Lian@nxp.com>

https://en.wikipedia.org/wiki/Posting_style#Top-posting

Never top-post on kernel mailing lists.

Thanks,
Lorenzo

> Thanks,
> Minghuan
> 
> > -----Original Message-----
> > From: Xiaowei Bao <xiaowei.bao@nxp.com>
> > Sent: Wednesday, November 6, 2019 11:36 AM
> > To: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>
> > Cc: robh+dt@kernel.org; mark.rutland@arm.com; shawnguo@kernel.org;
> > Leo Li <leoyang.li@nxp.com>; M.h. Lian <minghuan.lian@nxp.com>; Mingkai
> > Hu <mingkai.hu@nxp.com>; Roy Zang <roy.zang@nxp.com>; linux-
> > pci@vger.kernel.org; devicetree@vger.kernel.org; linux-
> > kernel@vger.kernel.org; linux-arm-kernel@lists.infradead.org; linuxppc-
> > dev@lists.ozlabs.org; bhelgaas@google.com; Z.q. Hou
> > <zhiqiang.hou@nxp.com>
> > Subject: RE: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
> > 
> > 
> > 
> > > -----Original Message-----
> > > From: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>
> > > Sent: 2019年11月5日 20:33
> > > To: Xiaowei Bao <xiaowei.bao@nxp.com>
> > > Cc: robh+dt@kernel.org; mark.rutland@arm.com; shawnguo@kernel.org;
> > Leo
> > > Li <leoyang.li@nxp.com>; M.h. Lian <minghuan.lian@nxp.com>; Mingkai
> > Hu
> > > <mingkai.hu@nxp.com>; Roy Zang <roy.zang@nxp.com>;
> > > linux-pci@vger.kernel.org; devicetree@vger.kernel.org;
> > > linux-kernel@vger.kernel.org; linux-arm-kernel@lists.infradead.org;
> > > linuxppc-dev@lists.ozlabs.org; bhelgaas@google.com; Z.q. Hou
> > > <zhiqiang.hou@nxp.com>
> > > Subject: Re: [PATCH v6 3/3] PCI: layerscape: Add LS1028a support
> > >
> > > On Mon, Sep 02, 2019 at 11:43:19AM +0800, Xiaowei Bao wrote:
> > > > Add support for the LS1028a PCIe controller.
> > > >
> > > > Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> > > > Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> > > > ---
> > > > v2:
> > > >  - No change.
> > > > v3:
> > > >  - Reuse the ls2088 driver data structurt.
> > > > v4:
> > > >  - No change.
> > > > v5:
> > > >  - No change.
> > > > v6:
> > > >  - No change.
> > > >
> > > >  drivers/pci/controller/dwc/pci-layerscape.c | 1 +
> > > >  1 file changed, 1 insertion(+)
> > >
> > > I have not seen any comment on any layerscape driver patches coming
> > > from the maintainers as listed in the MAINTAINERS file (and CCed in this
> > series).
> > >
> > > I request maintainers ACK on these patches and I expect them to start
> > > reviewing your code if they want to be still considered maintainers
> > > for this driver.
> > >
> > > The changes look OK minus Shawn's remark on compatible string that was
> > > ignored.
> > 
> > Hi Lorenzo,
> > 
> > Thanks for your comments.
> > 
> > In fact, the patches have reviewed in our internal mail list, after the review by
> > Minghuan and Mingkai, I will send these patches to opensource, they will
> > give the ACK when these patches seems is OK and no comments on this.
> > 
> > Thanks
> > Xiaowei
> > 
> > >
> > > Thanks,
> > > Lorenzo
> > >
> > > > diff --git a/drivers/pci/controller/dwc/pci-layerscape.c
> > > > b/drivers/pci/controller/dwc/pci-layerscape.c
> > > > index 3a5fa26..f24f79a 100644
> > > > --- a/drivers/pci/controller/dwc/pci-layerscape.c
> > > > +++ b/drivers/pci/controller/dwc/pci-layerscape.c
> > > > @@ -263,6 +263,7 @@ static const struct ls_pcie_drvdata
> > > > ls2088_drvdata = {  static const struct of_device_id ls_pcie_of_match[] = {
> > > >  	{ .compatible = "fsl,ls1012a-pcie", .data = &ls1046_drvdata },
> > > >  	{ .compatible = "fsl,ls1021a-pcie", .data = &ls1021_drvdata },
> > > > +	{ .compatible = "fsl,ls1028a-pcie", .data = &ls2088_drvdata },
> > > >  	{ .compatible = "fsl,ls1043a-pcie", .data = &ls1043_drvdata },
> > > >  	{ .compatible = "fsl,ls1046a-pcie", .data = &ls1046_drvdata },
> > > >  	{ .compatible = "fsl,ls2080a-pcie", .data = &ls2080_drvdata },
> > > > --
> > > > 2.9.5
> > > >

^ permalink raw reply	[flat|nested] 13+ messages in thread

* Re: [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl,ls1028a-pcie"
  2019-09-02  3:43 [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl, ls1028a-pcie" Xiaowei Bao
                   ` (2 preceding siblings ...)
  2019-11-05 11:05 ` [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl,ls1028a-pcie" Andrew Murray
@ 2019-11-06 16:09 ` Lorenzo Pieralisi
  2019-11-07  3:07   ` Xiaowei Bao
  3 siblings, 1 reply; 13+ messages in thread
From: Lorenzo Pieralisi @ 2019-11-06 16:09 UTC (permalink / raw)
  To: Xiaowei Bao
  Cc: mark.rutland, roy.zang, devicetree, linux-pci, Hou Zhiqiang,
	linuxppc-dev, linux-kernel, leoyang.li, minghuan.Lian, robh+dt,
	linux-arm-kernel, bhelgaas, shawnguo, mingkai.hu

On Mon, Sep 02, 2019 at 11:43:17AM +0800, Xiaowei Bao wrote:
> Add the PCIe compatible string for LS1028A

Sentences must be terminated with a period.

> Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> Reviewed-by: Rob Herring <robh@kernel.org>
> ---
> v2:
>  - No change.
> v3:
>  - No change.
> v4:
>  - No change.
> v5:
>  - No change.
> v6:
>  - No change.
> 
>  Documentation/devicetree/bindings/pci/layerscape-pci.txt | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/Documentation/devicetree/bindings/pci/layerscape-pci.txt b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> index e20ceaa..99a386e 100644
> --- a/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> +++ b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> @@ -21,6 +21,7 @@ Required properties:
>          "fsl,ls1046a-pcie"
>          "fsl,ls1043a-pcie"
>          "fsl,ls1012a-pcie"
> +        "fsl,ls1028a-pcie"
>    EP mode:
>  	"fsl,ls1046a-pcie-ep", "fsl,ls-pcie-ep"
>  - reg: base addresses and lengths of the PCIe controller register blocks.

I have applied this series to pci/layerscape, thanks.

Lorenzo

^ permalink raw reply	[flat|nested] 13+ messages in thread

* RE: [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl,ls1028a-pcie"
  2019-11-06 16:09 ` Lorenzo Pieralisi
@ 2019-11-07  3:07   ` Xiaowei Bao
  0 siblings, 0 replies; 13+ messages in thread
From: Xiaowei Bao @ 2019-11-07  3:07 UTC (permalink / raw)
  To: Lorenzo Pieralisi
  Cc: mark.rutland, Roy Zang, devicetree, linux-pci, Z.q. Hou,
	linuxppc-dev, linux-kernel, Leo Li, M.h. Lian, robh+dt,
	linux-arm-kernel, bhelgaas, shawnguo, Mingkai Hu



> -----Original Message-----
> From: Lorenzo Pieralisi <lorenzo.pieralisi@arm.com>
> Sent: 2019年11月7日 0:10
> To: Xiaowei Bao <xiaowei.bao@nxp.com>
> Cc: robh+dt@kernel.org; mark.rutland@arm.com; shawnguo@kernel.org; Leo
> Li <leoyang.li@nxp.com>; M.h. Lian <minghuan.lian@nxp.com>; Mingkai Hu
> <mingkai.hu@nxp.com>; Roy Zang <roy.zang@nxp.com>;
> linux-pci@vger.kernel.org; devicetree@vger.kernel.org;
> linux-kernel@vger.kernel.org; linux-arm-kernel@lists.infradead.org;
> linuxppc-dev@lists.ozlabs.org; bhelgaas@google.com; Z.q. Hou
> <zhiqiang.hou@nxp.com>
> Subject: Re: [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible
> strings "fsl,ls1028a-pcie"
> 
> On Mon, Sep 02, 2019 at 11:43:17AM +0800, Xiaowei Bao wrote:
> > Add the PCIe compatible string for LS1028A
> 
> Sentences must be terminated with a period.
> 
> > Signed-off-by: Xiaowei Bao <xiaowei.bao@nxp.com>
> > Signed-off-by: Hou Zhiqiang <Zhiqiang.Hou@nxp.com>
> > Reviewed-by: Rob Herring <robh@kernel.org>
> > ---
> > v2:
> >  - No change.
> > v3:
> >  - No change.
> > v4:
> >  - No change.
> > v5:
> >  - No change.
> > v6:
> >  - No change.
> >
> >  Documentation/devicetree/bindings/pci/layerscape-pci.txt | 1 +
> >  1 file changed, 1 insertion(+)
> >
> > diff --git a/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> > index e20ceaa..99a386e 100644
> > --- a/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> > +++ b/Documentation/devicetree/bindings/pci/layerscape-pci.txt
> > @@ -21,6 +21,7 @@ Required properties:
> >          "fsl,ls1046a-pcie"
> >          "fsl,ls1043a-pcie"
> >          "fsl,ls1012a-pcie"
> > +        "fsl,ls1028a-pcie"
> >    EP mode:
> >  	"fsl,ls1046a-pcie-ep", "fsl,ls-pcie-ep"
> >  - reg: base addresses and lengths of the PCIe controller register blocks.
> 
> I have applied this series to pci/layerscape, thanks.

Thank you for your corrections and comments, I will pay attention to the details
and quality of each patch in the future.

> 
> Lorenzo

^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, back to index

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-09-02  3:43 [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl, ls1028a-pcie" Xiaowei Bao
2019-09-02  3:43 ` [PATCH v6 2/3] arm64: dts: ls1028a: Add PCIe controller DT nodes Xiaowei Bao
2019-09-02  3:43 ` [PATCH v6 3/3] PCI: layerscape: Add LS1028a support Xiaowei Bao
2019-10-03  9:10   ` Shawn Guo
2019-10-08  7:11     ` Xiaowei Bao
2019-11-05 11:04   ` Andrew Murray
2019-11-05 12:32   ` Lorenzo Pieralisi
2019-11-06  3:35     ` Xiaowei Bao
2019-11-06  3:46       ` M.h. Lian
2019-11-06 15:01         ` Lorenzo Pieralisi
2019-11-05 11:05 ` [PATCH v6 1/3] dt-bindings: pci: layerscape-pci: add compatible strings "fsl,ls1028a-pcie" Andrew Murray
2019-11-06 16:09 ` Lorenzo Pieralisi
2019-11-07  3:07   ` Xiaowei Bao

LinuxPPC-Dev Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/linuxppc-dev/0 linuxppc-dev/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 linuxppc-dev linuxppc-dev/ https://lore.kernel.org/linuxppc-dev \
		linuxppc-dev@lists.ozlabs.org linuxppc-dev@ozlabs.org
	public-inbox-index linuxppc-dev

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.ozlabs.lists.linuxppc-dev


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git