From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-1.0 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SPF_PASS,URIBL_BLOCKED autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 9A173C43387 for ; Tue, 1 Jan 2019 01:12:37 +0000 (UTC) Received: from lists.ozlabs.org (lists.ozlabs.org [203.11.71.2]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by mail.kernel.org (Postfix) with ESMTPS id 1257D2070B for ; Tue, 1 Jan 2019 01:12:36 +0000 (UTC) DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 1257D2070B Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=telegraphics.com.au Authentication-Results: mail.kernel.org; spf=pass smtp.mailfrom=linuxppc-dev-bounces+linuxppc-dev=archiver.kernel.org@lists.ozlabs.org Received: from lists.ozlabs.org (lists.ozlabs.org [IPv6:2401:3900:2:1::3]) by lists.ozlabs.org (Postfix) with ESMTP id 43TGPZ68C4zDqHv for ; Tue, 1 Jan 2019 12:12:34 +1100 (AEDT) Authentication-Results: lists.ozlabs.org; dmarc=none (p=none dis=none) header.from=telegraphics.com.au Authentication-Results: lists.ozlabs.org; spf=none (mailfrom) smtp.mailfrom=telegraphics.com.au (client-ip=98.124.60.144; helo=kvm5.telegraphics.com.au; envelope-from=fthain@telegraphics.com.au; receiver=) Authentication-Results: lists.ozlabs.org; dmarc=none (p=none dis=none) header.from=telegraphics.com.au Received: from kvm5.telegraphics.com.au (kvm5.telegraphics.com.au [98.124.60.144]) by lists.ozlabs.org (Postfix) with ESMTP id 43TGMJ2MxVzDqDT for ; Tue, 1 Jan 2019 12:10:36 +1100 (AEDT) Received: from localhost (localhost.localdomain [127.0.0.1]) by kvm5.telegraphics.com.au (Postfix) with ESMTP id 2962D29C55; Mon, 31 Dec 2018 20:10:33 -0500 (EST) Date: Tue, 1 Jan 2019 12:10:11 +1100 (AEDT) From: Finn Thain To: Arnd Bergmann Subject: Re: [PATCH v8 20/25] powerpc, fbdev: Use arch_nvram_ops methods instead of nvram_read_byte() and nvram_write_byte() In-Reply-To: Message-ID: References: <7e8eb87ea829c03941c895c968df2ebd0f80512f.1545784679.git.fthain@telegraphics.com.au> <20181229180236.Horde.idY3gOIzkSWywjIrqlXJMA1@messagerie.si.c-s.fr> MIME-Version: 1.0 Content-Type: text/plain; charset=US-ASCII X-BeenThere: linuxppc-dev@lists.ozlabs.org X-Mailman-Version: 2.1.29 Precedence: list List-Id: Linux on PowerPC Developers Mail List List-Unsubscribe: , List-Archive: List-Post: List-Help: List-Subscribe: , Cc: Linux Fbdev development list , Bartlomiej Zolnierkiewicz , Greg Kroah-Hartman , Linux Kernel Mailing List , dri-devel , linux-m68k , Paul Mackerras , linuxppc-dev Errors-To: linuxppc-dev-bounces+linuxppc-dev=archiver.kernel.org@lists.ozlabs.org Sender: "Linuxppc-dev" On Mon, 31 Dec 2018, Arnd Bergmann wrote: > On Sun, Dec 30, 2018 at 12:43 AM Finn Thain wrote: > > > > > Is there some benefit, or is that just personal taste? > > > > Avoiding changes to call sites avoids code review, but I think 1) the > > thinkpad_acpi changes have already been reviewed and 2) the fbdev changes > > need review anyway. > > > > Your suggesion would add several new entities and one extra layer of > > indirection. > > > > I think indirection harms readability because now the reader now has to go > > and look up the meaning of the new entities. > > > > It's not the case that we need to choose between definitions of > > nvram_read_byte() at compile time, or stub them out: > > > > #ifdef CONFIG_FOO > > static inline unsigned char nvram_read_byte(int addr) > > { > > return arch_nvram_ops.read_byte(addr); > > } > > #else > > static inline unsigned char nvram_read_byte(int addr) { } > > #endif > > > > And I don't anticipate a need for a macro here either: > > > > #define nvram_read_byte(a) random_nvram_read_byte_impl(a) > > > > I think I've used the simplest solution. > > Having the indirection would help if the inline function can > encapsulate the NULL pointer check, like > > static inline unsigned char nvram_read_byte(loff_t addr) > { > char data; > > if (!IS_ENABLED(CONFIG_NVRAM)) > return 0xff; > > if (arch_nvram_ops.read_byte) > return arch_nvram_ops.read_byte(addr); > > if (arch_nvram_ops.read) > return arch_nvram_ops.read(char, 1, &addr); > > return 0xff; > } > The semantics of .read_byte and .read are subtly different. For CONFIG_X86 and CONFIG_ATARI, .read implies checksum validation and .read_byte does not. In particular, in the thinkpad_acpi case, checksum validation isn't used, but in the atari_scsi case, it is. So I like to see drivers explicitly call the method they want. I didn't want to obscure this distinction in a helper. --