linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Leonardo Bras <leobras.c@gmail.com>
To: Alexey Kardashevskiy <aik@ozlabs.ru>,
	Michael Ellerman <mpe@ellerman.id.au>,
	 Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	Christophe Leroy <christophe.leroy@c-s.fr>,
	 Joel Stanley <joel@jms.id.au>,
	Thiago Jung Bauermann <bauerman@linux.ibm.com>,
	Ram Pai <linuxram@us.ibm.com>,
	 Brian King <brking@linux.vnet.ibm.com>,
	Murilo Fossa Vicentini <muvic@linux.ibm.com>,
	David Dai <zdai@linux.vnet.ibm.com>
Cc: linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v1 06/10] powerpc/pseries/iommu: Add ddw_list_add() helper
Date: Fri, 28 Aug 2020 18:28:34 -0300	[thread overview]
Message-ID: <b9349897f3a9e8c247796708c0817f9bc93295fb.camel@gmail.com> (raw)
In-Reply-To: <54cfb977-6d30-47b8-b26b-f47efd10299f@ozlabs.ru>

On Fri, 2020-08-28 at 11:58 +1000, Alexey Kardashevskiy wrote:
> 
> On 28/08/2020 08:11, Leonardo Bras wrote:
> > On Mon, 2020-08-24 at 13:46 +1000, Alexey Kardashevskiy wrote:
> > > >  static int find_existing_ddw_windows(void)
> > > >  {
> > > >  	int len;
> > > > @@ -887,18 +905,11 @@ static int find_existing_ddw_windows(void)
> > > >  		if (!direct64)
> > > >  			continue;
> > > >  
> > > > -		window = kzalloc(sizeof(*window), GFP_KERNEL);
> > > > -		if (!window || len < sizeof(struct dynamic_dma_window_prop)) {
> > > > +		window = ddw_list_add(pdn, direct64);
> > > > +		if (!window || len < sizeof(*direct64)) {
> > > 
> > > Since you are touching this code, it looks like the "len <
> > > sizeof(*direct64)" part should go above to "if (!direct64)".
> > 
> > Sure, makes sense.
> > It will be fixed for v2.
> > 
> > > 
> > > 
> > > >  			kfree(window);
> > > >  			remove_ddw(pdn, true);
> > > > -			continue;
> > > >  		}
> > > > -
> > > > -		window->device = pdn;
> > > > -		window->prop = direct64;
> > > > -		spin_lock(&direct_window_list_lock);
> > > > -		list_add(&window->list, &direct_window_list);
> > > > -		spin_unlock(&direct_window_list_lock);
> > > >  	}
> > > >  
> > > >  	return 0;
> > > > @@ -1261,7 +1272,8 @@ static u64 enable_ddw(struct pci_dev *dev, struct device_node *pdn)
> > > >  	dev_dbg(&dev->dev, "created tce table LIOBN 0x%x for %pOF\n",
> > > >  		  create.liobn, dn);
> > > >  
> > > > -	window = kzalloc(sizeof(*window), GFP_KERNEL);
> > > > +	/* Add new window to existing DDW list */
> > > 
> > > The comment seems to duplicate what the ddw_list_add name already suggests.
> > 
> > Ok, I will remove it then.
> > 
> > > > +	window = ddw_list_add(pdn, ddwprop);
> > > >  	if (!window)
> > > >  		goto out_clear_window;
> > > >  
> > > > @@ -1280,16 +1292,14 @@ static u64 enable_ddw(struct pci_dev *dev, struct device_node *pdn)
> > > >  		goto out_free_window;
> > > >  	}
> > > >  
> > > > -	window->device = pdn;
> > > > -	window->prop = ddwprop;
> > > > -	spin_lock(&direct_window_list_lock);
> > > > -	list_add(&window->list, &direct_window_list);
> > > > -	spin_unlock(&direct_window_list_lock);
> > > 
> > > I'd leave these 3 lines here and in find_existing_ddw_windows() (which
> > > would make  ddw_list_add -> ddw_prop_alloc). In general you want to have
> > > less stuff to do on the failure path. kmalloc may fail and needs kfree
> > > but you can safely delay list_add (which cannot fail) and avoid having
> > > the lock help twice in the same function (one of them is hidden inside
> > > ddw_list_add).
> > > Not sure if this change is really needed after all. Thanks,
> > 
> > I understand this leads to better performance in case anything fails.
> > Also, I think list_add happening in the end is less error-prone (in
> > case the list is checked between list_add and a fail).
> 
> Performance was not in my mind at all.
> 
> I noticed you remove from a list with a lock help and it was not there
> before and there is a bunch on labels on the exit path and started
> looking for list_add() and if you do not double remove from the list.
> 
> 
> > But what if we put it at the end?
> > What is the chance of a kzalloc of 4 pointers (struct direct_window)
> > failing after walk_system_ram_range?
> 
> This is not about chances really, it is about readability. If let's say
> kmalloc failed, you just to the error exit label and simply call kfree()
> on that pointer, kfree will do nothing if it is NULL already, simple.
> list_del() does not have this simplicity.
> 
> 
> > Is it not worthy doing that for making enable_ddw() easier to
> > understand?
> 
> This is my goal here :)

Ok, it makes sense to me now. 
I tried creating list_add() to keep everything related to list-adding
into a single place, instead of splitting it around the other stuff,
but now I understand that the code may look more complex than it was
before, because of the failing path increasing in size.

For me it was strange creating a list entry end not list_add()ing it
right away, but maybe it's something worth to get used to, as it may
increase the failing path simplicity, since list_add() don't fail.

I will try to see if the ddw_list_add() routine would become a useful
ddw_list_entry(), but if not, I will remove this patch.

Alexey, Thank you for reviewing this series!
Best regards,

Leonardo


  reply	other threads:[~2020-08-28 21:30 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-08-17 23:40 [PATCH v1 00/10] DDW indirect mapping Leonardo Bras
2020-08-17 23:40 ` [PATCH v1 01/10] powerpc/pseries/iommu: Replace hard-coded page shift Leonardo Bras
2020-08-22  9:33   ` Alexey Kardashevskiy
2020-08-27 15:32     ` Leonardo Bras
2020-08-28  2:27       ` Alexey Kardashevskiy
2020-08-28 19:55         ` Leonardo Bras
2020-08-31  0:06           ` Alexey Kardashevskiy
2020-08-31  1:41             ` Oliver O'Halloran
2020-08-31  3:48               ` Alexey Kardashevskiy
2020-09-01 21:38                 ` Leonardo Bras
2020-09-03  4:26                   ` Alexey Kardashevskiy
2020-08-17 23:40 ` [PATCH v1 02/10] powerpc/kernel/iommu: Align size for IOMMU_PAGE_SIZE on iommu_*_coherent() Leonardo Bras
2020-08-22 10:07   ` Alexey Kardashevskiy
2020-08-27 16:51     ` Leonardo Bras
2020-08-28  1:40       ` Alexey Kardashevskiy
2020-08-28 20:41         ` Leonardo Bras
2020-08-31  0:47           ` Alexey Kardashevskiy
2020-09-01 22:34             ` Leonardo Bras
2020-09-03  4:41               ` Alexey Kardashevskiy
2020-09-04  6:04                 ` Leonardo Bras
2020-09-08  3:18                   ` Alexey Kardashevskiy
2020-08-17 23:40 ` [PATCH v1 03/10] powerpc/kernel/iommu: Use largepool as a last resort when !largealloc Leonardo Bras
2020-08-22 10:09   ` Alexey Kardashevskiy
2020-08-27 16:58     ` Leonardo Bras
2020-08-17 23:40 ` [PATCH v1 04/10] powerpc/kernel/iommu: Add new iommu_table_in_use() helper Leonardo Bras
2020-08-22 10:34   ` Alexey Kardashevskiy
2020-08-27 18:34     ` Leonardo Bras
2020-08-28  1:51       ` Alexey Kardashevskiy
2020-08-17 23:40 ` [PATCH v1 05/10] powerpc/pseries/iommu: Add iommu_pseries_alloc_table() helper Leonardo Bras
2020-08-24  0:38   ` Alexey Kardashevskiy
2020-08-27 21:23     ` Leonardo Bras
2020-08-17 23:40 ` [PATCH v1 06/10] powerpc/pseries/iommu: Add ddw_list_add() helper Leonardo Bras
2020-08-24  3:46   ` Alexey Kardashevskiy
2020-08-27 22:11     ` Leonardo Bras
2020-08-28  1:58       ` Alexey Kardashevskiy
2020-08-28 21:28         ` Leonardo Bras [this message]
2020-08-17 23:40 ` [PATCH v1 07/10] powerpc/pseries/iommu: Allow DDW windows starting at 0x00 Leonardo Bras
2020-08-24  3:44   ` Alexey Kardashevskiy
2020-08-28 14:04     ` Leonardo Bras
2020-08-31  0:50       ` Alexey Kardashevskiy
2020-08-17 23:40 ` [PATCH v1 08/10] powerpc/pseries/iommu: Add ddw_property_create() and refactor enable_ddw() Leonardo Bras
2020-08-24  5:07   ` Alexey Kardashevskiy
2020-08-28 15:25     ` Leonardo Bras
2020-08-31  4:34       ` Alexey Kardashevskiy
2020-09-02  5:27         ` Leonardo Bras
2020-08-17 23:40 ` [PATCH v1 09/10] powerpc/pseries/iommu: Make use of DDW even if it does not map the partition Leonardo Bras
2020-08-24  5:17   ` Alexey Kardashevskiy
2020-08-28 18:36     ` Leonardo Bras
2020-08-31  4:35       ` Alexey Kardashevskiy
2020-09-02  6:11         ` Leonardo Bras
2020-09-04  1:00           ` Alexey Kardashevskiy
2020-08-17 23:40 ` [PATCH v1 10/10] powerpc/pseries/iommu: Rename "direct window" to "dma window" Leonardo Bras

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=b9349897f3a9e8c247796708c0817f9bc93295fb.camel@gmail.com \
    --to=leobras.c@gmail.com \
    --cc=aik@ozlabs.ru \
    --cc=bauerman@linux.ibm.com \
    --cc=benh@kernel.crashing.org \
    --cc=brking@linux.vnet.ibm.com \
    --cc=christophe.leroy@c-s.fr \
    --cc=joel@jms.id.au \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=linuxram@us.ibm.com \
    --cc=mpe@ellerman.id.au \
    --cc=muvic@linux.ibm.com \
    --cc=paulus@samba.org \
    --cc=zdai@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).