linuxppc-dev.lists.ozlabs.org archive mirror
 help / color / mirror / Atom feed
From: Christophe Leroy <christophe.leroy@csgroup.eu>
To: Sathvika Vasireddy <sv@linux.ibm.com>,
	"linuxppc-dev@lists.ozlabs.org" <linuxppc-dev@lists.ozlabs.org>
Cc: "peterz@infradead.org" <peterz@infradead.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"rostedt@goodmis.org" <rostedt@goodmis.org>,
	"aik@ozlabs.ru" <aik@ozlabs.ru>,
	"mingo@redhat.com" <mingo@redhat.com>,
	"paulus@samba.org" <paulus@samba.org>,
	"jpoimboe@redhat.com" <jpoimboe@redhat.com>,
	"naveen.n.rao@linux.vnet.ibm.com"
	<naveen.n.rao@linux.vnet.ibm.com>,
	"mbenes@suse.cz" <mbenes@suse.cz>
Subject: Re: [RFC PATCH v3 03/12] objtool: Use target file class size instead of a compiled constant
Date: Fri, 8 Jul 2022 17:35:56 +0000	[thread overview]
Message-ID: <e51d2b09-3531-3c43-d9dd-7c518b9ebefc@csgroup.eu> (raw)
In-Reply-To: <20220624183238.388144-4-sv@linux.ibm.com>



Le 24/06/2022 à 20:32, Sathvika Vasireddy a écrit :
> From: Christophe Leroy <christophe.leroy@csgroup.eu>
> 
> In order to allow using objtool on cross-built kernels,
> determine size of long from elf data instead of using
> sizeof(long) at build time.
> 
> For the time being this covers only mcount.
> 
> Signed-off-by: Christophe Leroy <christophe.leroy@csgroup.eu>
> ---
>   tools/objtool/check.c               | 16 +++++++++-------
>   tools/objtool/elf.c                 |  8 ++++++--
>   tools/objtool/include/objtool/elf.h |  8 ++++++++
>   3 files changed, 23 insertions(+), 9 deletions(-)
> 
> diff --git a/tools/objtool/check.c b/tools/objtool/check.c
> index cef1dd54d505..fabc0ea88747 100644
> --- a/tools/objtool/check.c
> +++ b/tools/objtool/check.c
> @@ -802,9 +802,9 @@ static int create_ibt_endbr_seal_sections(struct objtool_file *file)
>   static int create_mcount_loc_sections(struct objtool_file *file)
>   {
>   	struct section *sec;
> -	unsigned long *loc;
>   	struct instruction *insn;
>   	int idx;
> +	int size = elf_class_size(file->elf);

Should be renamed addrsize as per Naveen comment.

>   
>   	sec = find_section_by_name(file->elf, "__mcount_loc");
>   	if (sec) {
> @@ -820,23 +820,25 @@ static int create_mcount_loc_sections(struct objtool_file *file)
>   	list_for_each_entry(insn, &file->mcount_loc_list, call_node)
>   		idx++;
>   
> -	sec = elf_create_section(file->elf, "__mcount_loc", 0, sizeof(unsigned long), idx);
> +	sec = elf_create_section(file->elf, "__mcount_loc", 0, size, idx);
>   	if (!sec)
>   		return -1;
>   
> +	sec->sh.sh_addralign = size;
> +
>   	idx = 0;
>   	list_for_each_entry(insn, &file->mcount_loc_list, call_node) {
> +		void *loc;
>   
> -		loc = (unsigned long *)sec->data->d_buf + idx;
> -		memset(loc, 0, sizeof(unsigned long));
> +		loc = sec->data->d_buf + idx;
> +		memset(loc, 0, size);
>   
> -		if (elf_add_reloc_to_insn(file->elf, sec,
> -					  idx * sizeof(unsigned long),
> +		if (elf_add_reloc_to_insn(file->elf, sec, idx,
>   					  R_X86_64_64,
>   					  insn->sec, insn->offset))
>   			return -1;
>   
> -		idx++;
> +		idx += size;
>   	}
>   
>   	return 0;
> diff --git a/tools/objtool/elf.c b/tools/objtool/elf.c
> index c25e957c1e52..63218f5799c2 100644
> --- a/tools/objtool/elf.c
> +++ b/tools/objtool/elf.c
> @@ -1124,6 +1124,7 @@ static struct section *elf_create_rela_reloc_section(struct elf *elf, struct sec
>   {
>   	char *relocname;
>   	struct section *sec;
> +	int size = elf_class_size(elf);

Should be renamed addrsize as per Naveen comment.

>   
>   	relocname = malloc(strlen(base->name) + strlen(".rela") + 1);
>   	if (!relocname) {
> @@ -1133,7 +1134,10 @@ static struct section *elf_create_rela_reloc_section(struct elf *elf, struct sec
>   	strcpy(relocname, ".rela");
>   	strcat(relocname, base->name);
>   
> -	sec = elf_create_section(elf, relocname, 0, sizeof(GElf_Rela), 0);
> +	if (size == sizeof(u32))
> +		sec = elf_create_section(elf, relocname, 0, sizeof(Elf32_Rela), 0);
> +	else
> +		sec = elf_create_section(elf, relocname, 0, sizeof(GElf_Rela), 0);
>   	free(relocname);
>   	if (!sec)
>   		return NULL;
> @@ -1142,7 +1146,7 @@ static struct section *elf_create_rela_reloc_section(struct elf *elf, struct sec
>   	sec->base = base;
>   
>   	sec->sh.sh_type = SHT_RELA;
> -	sec->sh.sh_addralign = 8;
> +	sec->sh.sh_addralign = size;
>   	sec->sh.sh_link = find_section_by_name(elf, ".symtab")->idx;
>   	sec->sh.sh_info = base->idx;
>   	sec->sh.sh_flags = SHF_INFO_LINK;
> diff --git a/tools/objtool/include/objtool/elf.h b/tools/objtool/include/objtool/elf.h
> index adebfbc2b518..c720c4476828 100644
> --- a/tools/objtool/include/objtool/elf.h
> +++ b/tools/objtool/include/objtool/elf.h
> @@ -141,6 +141,14 @@ static inline bool has_multiple_files(struct elf *elf)
>   	return elf->num_files > 1;
>   }
>   
> +static inline int elf_class_size(struct elf *elf)

Should be renamed elf_class_addrsize() as per Naveen comment.

> +{
> +	if (elf->ehdr.e_ident[EI_CLASS] == ELFCLASS32)
> +		return sizeof(u32);
> +	else
> +		return sizeof(u64);
> +}
> +
>   struct elf *elf_open_read(const char *name, int flags);
>   struct section *elf_create_section(struct elf *elf, const char *name, unsigned int sh_flags, size_t entsize, int nr);
>   

  reply	other threads:[~2022-07-08 17:37 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-06-24 18:32 [RFC PATCH v3 00/12] objtool: Enable and implement --mcount option on powerpc Sathvika Vasireddy
2022-06-24 18:32 ` [RFC PATCH v3 01/12] objtool: Fix SEGFAULT Sathvika Vasireddy
2022-07-08 15:10   ` Christophe Leroy
2022-06-24 18:32 ` [RFC PATCH v3 02/12] objtool: Use target file endianness instead of a compiled constant Sathvika Vasireddy
2022-06-24 18:32 ` [RFC PATCH v3 03/12] objtool: Use target file class size " Sathvika Vasireddy
2022-07-08 17:35   ` Christophe Leroy [this message]
2022-06-24 18:32 ` [RFC PATCH v3 04/12] objtool: Add --mnop as an option to --mcount Sathvika Vasireddy
2022-06-24 18:32 ` [RFC PATCH v3 05/12] powerpc: Skip objtool from running on VDSO files Sathvika Vasireddy
2022-06-24 18:32 ` [RFC PATCH v3 06/12] objtool: Read special sections with alts only when specific options are selected Sathvika Vasireddy
2022-06-24 18:32 ` [RFC PATCH v3 07/12] objtool: Use macros to define arch specific reloc types Sathvika Vasireddy
2022-07-04 11:14   ` Peter Zijlstra
2022-07-04 15:53     ` Christophe Leroy
2022-07-04 16:18       ` Peter Zijlstra
2022-06-24 18:32 ` [RFC PATCH v3 08/12] objtool: Add arch specific function arch_ftrace_match() Sathvika Vasireddy
2022-06-24 18:32 ` [RFC PATCH v3 09/12] objtool/powerpc: Enable objtool to be built on ppc Sathvika Vasireddy
2022-06-24 18:32 ` [RFC PATCH v3 10/12] objtool/powerpc: Add --mcount specific implementation Sathvika Vasireddy
2022-06-24 18:32 ` [RFC PATCH v3 11/12] powerpc: Remove unreachable() from WARN_ON() Sathvika Vasireddy
2022-06-25  6:46   ` Christophe Leroy
2022-06-27 15:21     ` Sathvika Vasireddy
2022-06-27 15:35     ` Sathvika Vasireddy
2022-06-27 15:46       ` Christophe Leroy
2022-06-29 18:30       ` Christophe Leroy
2022-06-30  8:05         ` Naveen N. Rao
2022-06-30  9:58           ` Christophe Leroy
2022-06-30 10:33             ` Christophe Leroy
2022-06-30 10:37             ` Naveen N. Rao
2022-06-30 15:58               ` Segher Boessenkool
2022-07-04 12:01                 ` Peter Zijlstra
2022-07-04 11:43               ` Peter Zijlstra
2022-07-01  2:13           ` Chen Zhongjin
2022-07-01  6:56             ` Sathvika Vasireddy
2022-07-01 11:40               ` [RFC PATCH v3 11/12] powerpc: Remove unreachable() from WARN_ON() (gcc issue ?) Christophe Leroy
2022-07-04 11:45         ` [RFC PATCH v3 11/12] powerpc: Remove unreachable() from WARN_ON() Peter Zijlstra
2022-07-04 12:34           ` Christophe Leroy
2022-07-05 15:48             ` Segher Boessenkool
2022-07-04 12:05     ` Peter Zijlstra
2022-07-04 12:44       ` Christophe Leroy
2022-07-04 14:19         ` Peter Zijlstra
2022-06-24 18:32 ` [RFC PATCH v3 12/12] objtool/powerpc: Fix unannotated intra-function call warnings Sathvika Vasireddy
2022-07-08 15:06 ` [RFC PATCH v3 00/12] objtool: Enable and implement --mcount option on powerpc Christophe Leroy
2022-07-08 15:42   ` Christophe Leroy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e51d2b09-3531-3c43-d9dd-7c518b9ebefc@csgroup.eu \
    --to=christophe.leroy@csgroup.eu \
    --cc=aik@ozlabs.ru \
    --cc=jpoimboe@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mbenes@suse.cz \
    --cc=mingo@redhat.com \
    --cc=naveen.n.rao@linux.vnet.ibm.com \
    --cc=paulus@samba.org \
    --cc=peterz@infradead.org \
    --cc=rostedt@goodmis.org \
    --cc=sv@linux.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).